Remarks:
Before starting the software, check that you have the latest version of the drivers for your graphic card. It may solve a lot of problems.

There is an FAQ in the documentation PDF (GrandDesigner.pdf)

V1.1.0:
Fixes:

- Export:
  - Improved color accuracy in 24bits and 48bits background export. Tonemapping is now correctly applied.
- Rendering:
  - Spikes at poles are now fixed.
- Interface:
  - Compatibility issues with Wacom tablets and 3DConnexion mouse is now fixed.
  - Some tooltips has been fixed with the right text (it was a bit messed up).
  - Clouds influence on roughness is now hidden in roughness layer mode.

New features:

- Rendering:
  - Improved rings rendering, shadows are transparent, allowing intensity variations. Surface acne is removed from the ring surface.
  - Banding effects in shadows has been reduced thanks to the introduction of noise.
  - Banding effect removed in bloom and soft gradients by adding dithering in the tone mapping pass.
  - Purkinje effect added in the post process.
  - A partial background can be generated, allowing a higher texture resolution focused on the screen. This allows very high quality backgrounds to be generated in one specific direction.
  - A secondary fill light can be defined to break the blackness of the dark side of the planet.
- Planet generator:
  - New exponentialy distributed noise types (use ramp to modify values distribution)
  - Advanced color correction of the albedo has been added (new tab).
  - A whole new layer of micro craters has been added (new tab), allowing the generation of small and numerous craters over the surface of planet. Many options are available like craters count, size, age, regularity, coloring ...
  - Improved craters and details coloring ... no more overlap of the two zones.
  - Two new blending modes for details (Alpha and reflect).
  - High frequencies enhancement section added in Relief base tab. This acts like a sharpen filter of the height map focused on the high frequencies.
- Secondary roads added in the cities generation (scale and intensity).
- Second layer of details added (new tab), allowing a richer, improved generation of planets. Each detail layer can have its own coloring parameters.
- Roughness can be modulated on both detail layers, craters and micro craters.
- Details (details & details2 layers) and micro craters can be injected in the water layer to allow rivers-like generation and richer self-emissive planets (lavas for instance).
- Details coloring can be balanced between height, slope and ambient occlusion.
- **Background generator:**
  - Distortion depth slider added, allowing fine tuning of the distortion effect.
  - Noise slider added in the nebulae raycast, breaking the banding effect.
  - Advanced nebulae rendering by adding a masking effect on the background. 4 blending mode has been added and many new sliders.
  - Latitude masking added, allowing horizontal nebulae (Milky Way like).
- **Animation:**
  - Revolution of planet can be done on any axis now and the revolution time can be adjusted.
- **Export/Import:**
  - Checkboxes to allow horizontal et vertical flips of the textures.
  - Input files can be sharpened by using negative blur values.
  - Height values can be exported in R8G8 or RSG5B5 formats.
  - Export of heat and moisture maps (PRO dlc only)
  - Clouds normal are exported.
  - Supersized screenshots quality has been dramatically improved with higher textures quality, artefacts removal, better rings and background rendering.
  - Supersized screenshots can go up to 14x viewport size (PRO dlc only)
  - Planet masks can be exported in supersized screenshots, allowing you to do offline compositing of several planets
  - Background can be exported with alpha channel now, using nebulae density as alpha or computing alpha from colors.
  - Planet tessellation has been improved when doing screenshots (or supersized screenshots).
- **Interface:**
  - F1 opens the help file now.
  - Stars layer rendering can be toggled.
  - Reorganization of the channels dropdown menus.
  - Post effects can be toggled individually.
  - A default camera, planet and light orientation can be stored with any planets. These scene presets can be stored and recalled at any time. These are used automatically on preset reload.
  - An invert ramp button has been added to the color ramp editor.
  - Some sliders range has been extended/fixed.
V1.0.8 (Incomitatum update):
Fixes:

- Export:
  - Snapshot with alpha was not returning completely translucent color as background. Fixed
  - Decimated planets had hard edges on the UV seam. Fixed

- Rendering:
  - Clouds shadows are now casted on cities.

- Interface:
  - The random range of the Weather/Global/Random scale has been increased to 50 and the slider is now a logarithmic one.
  - Integer slider is now editable like all other ones (Craters count)
  - The min/max range for the cities altitude has been improved.
  - Relief base input textures are now working properly, even if the textures are not in the media directory.

New features:

- Interface:
  - There is now a cloud offset allowing you to place the cloud layer where you want for snapshots.
  - There is now a gimbal lock which will force rotations of the planet and the background to occur only around the planet axis. It’s the new icon above the terrain preview window on the bottom of the screen.
  - The special effects presets/values are now kept between sessions.
  - Two new sliders allow the tuning of the smoothness of the min and max altitude for cities.

V1.0.7:
Fixes:

- Interface:
  - VRAM usage computation was wrong in 16K/high precision

New features:

- Interface:
  - Goldilock changed to CHZ (Circumstellar habitable zone)
  - The heat map is now displayed with slices, which is more readable.
  - The planet size and max altitude are now displayed as references. The planet radius is defined in the shaders parameters, like the displacement.
  - Dropdowns are now scrollable, allowing more presets available per file.
  - Some sliders have now a logarithmic scale to allow a finer tuning of the values (noise scale for instance).
The topology map (2D and 3D) on the bottom of the screen is now draggable (left-right and up-down) and the right mouse buttons allows the control of the zoom.

You can now do snapshots with alpha, but this is limited to viewport size. Go to Edit>Snapshot with alpha. You can also assign that role to the camera icon (Edit>Options>Output>Snapshot icon)

- **Export/Import:**
  - 8bits and 16bits greyscale export is now supported. Just change your preset in Edit>Options>Channels>Check the ‘grey’ checkboxes you want.
  - 16bits greyscale and 48 bits RGB can be imported as heightmaps in Relief>Relief base. This removes the slices/layers you have with 8bits greyscale/24bits RGB.

- **Planet generator:**
  - Internal accuracy of 32bits is available to everyone now, not only the Pro users as before. This will also help to get rid of slices/layers you can have even with 16bits greyscale heightmaps.
  - A moisture influence slider has been added to the desert to avoid having the desertic zones going too close to the coastlines.

---

**V1.0.6:**

**Fixes:**

- **Planet generator:**
  - Squares appearing in HD render due to some problem with the moisture propagation. Fixed.

- **Exporter:**
  - Export stuck at 75% fixed.

**New features:**

- **Interface:**
  - Turnaround button in the mixer which allows an easy full rotation movie of a planet.
  - Seeds modifier in the randomizer. You can now enforce the regeneration of similar planets by changing just the seeds.
  - Batch generation in the randomizer. You can create and export several variations of a planets directly in the randomizer. Very useful if you want to generate content quickly.
  - Display the value of the FOV (field of view) in the console when you change it.
  - Ask for confirmation if you want to generate a HD planet that is already HD.
  - New shortcuts: F8 = reset position, F5-F6-F7 = toggle between lightmodes.
- Light lock. You can enforce the background and/or the sun to stick with the planet thanks to new light modes (4th icon in the toolbar).
- Autosave: All your parameters are saved every 5 minutes. You can reload the last autosave in the menu File->Load autosave.

**Planet generator:**
- Adjust roughness from sediment and vegetation level.

**V1.0.5 (First non early access release):**

**Fixes:**

- **Interface:**
  - Cleanup of parameters (some parameters were not connected to any functionality).
  - Color editor now refresh correctly when loading preset or doing undo/redo.

- **Export:**
  - Fixed background export (was definitely not in the right range before). RGB output have a Reinhard tone mapping applied to compensate the limited range. 48 and 64 bpp are linear, not sRGB.

**New features:**

- **Interface:**
  - New animation/blending system added. It allow presets blending and also animation of camera, planet, skybox and any parameters you can think of.
  - Scale slider added to the temperature/moisture randomization.
  - Improved low/medium/high frequencies control in all noises.
  - Randomizer is back with a better interface and controls that make more sense.

- **Planet generator:**
  - New minimum and maximum blending mode added in the details tab.
  - Improved noise in desert/ice caps.

- **Background generator:**
  - The randomization of the colors of the stars can be done by localization in the sky and not only pure randomness.
  - Improved stars controls (bright stars added).

- **Rendering:**
  - New atmosphere shader, more realistic, more flexible, less restrictive.
  - Addition of flares ... it is restricted to 11 presets right now, but more options will follow.
  - Addition of special effects: chromatic aberrations and vignetting.
  - No more specular reflections in the shadows.
V1.0.4 beta:

Fixes:

- Interface:
  - Width and opacity of roads are now clearly split on two different sliders.
  - Some tooltips had the wrong text. Some menu entries updated.
  - Redesign of some icons.
  - Reset values is now resetting only the current category and not the whole set of parameters. You can still do that by using the ‘new’ icon
  - Fix the undo/redo that was not working with some global parameters
  - Layer buttons are remove when the planet is in HD or when in background or post effect mode.

- Planet generator:
  - Noise hash generation has been updated to reduce the visible repetition in the noise.
  - Growth by height has been added to the vegetation tab.

New features:

- Interface:
  - Detection of Intel GPU and advice to change the default GPU laptops
  - A new mini relief viewer has been added on the interface, with a 2D and a 3D mode. This simplify the understanding of what’s going on while editing the relief.
  - New color ramp viewer that actually show the effect of the level and position sliders (for toon-like renders).
  - Undo/redo icons are back
  - Colors can be introduced in hex values
  - Reset camera button

- Planet generator:
  - A curve/level editor has been added. This somewhat breaks the backward compatibility on some planets you may have saved, but with some tuning of the black/white points, you should be able to fix that.
  - An experimental feature has been added: you are now able to work only on a part of the planet, not the complete surface (in terrain, global, planet coverage). It is limited to section with a 2:1 ratio. You can also flatten it if it is small enough, allowing you to generate simple terrains.

- Export:
  - Meshes are now exported with the displacement baked in the vertices position.
  - Meshes can be decimated/simplified at the export. Be aware that this option will strongly slow down your export.
  - A dialog is opened when exporting allowing you to choose right before the export your texture preset, file format, mesh export options ...
V1.0.3 beta:
Fixes:

- Interface:
  - The scroll wheel and the drag of the panel are now working fine even where there is a label. So, the left side of the panel can be dragged and you can use the scroll wheel on it.

- Planet generator:
  - The roads are now correctly following the mask/constraints (underwater/temperature ...)

V1.0.2 beta:
Fixes:

- Interface:
  - Background was not updated when in isolation mode.
  - When cancelling a snapshot, the software was freezing.
  - The current layer is now correctly displayed (darkened), even when using shortcuts.

- Rendering:
  - Ring texture is now clamped (this avoids problems in the viewport on the inner/outer edges of the ring)

- Planet generator:
  - Cities and roads have a minimal height limit, relative to the water height (or 0).

- Export:
  - More consistent obj export of meshes (rings are exported only when active, background only when exporting background).

New features:

- Interface:
  - Presets for the navigation: Maya, Blender, Max and default – Grand Designer.
  - A new ‘reload preset’ button has been added.

- Planet generator:
  - The ring can be tilted now on one axis.
  - Cities and roads can be colored on the dark side too.
  - The generation of Cities and roads has been improved, some new parameters have been added. It’s not yet like I want, but it’s getting better.
  - Completely rewritten star generator.
    - It uses now spherical Fibonacci to place stars using multiple layers
    - You have control on the size of the stars
    - A random mask can modulate the density of stars

- Rendering:
- Mipmaps can be generated in the viewport. This is optional –on by default-, it uses more VRAM (33% more), but reduces greatly the generation/rendering time in HD and globally improves the rendering quality.

- **Export:**
  - The material (.MTL) is now exported alongside the mesh (OBJ). It has been tested in Maya, Photoshop and unity. Some programs, like unreal, are not importing the MTL files.

**V1.0.1 beta:**

**Fixes:**

- **Planet generator:**
  - The vertical strips bug has been fixed, it was due to a problem in the curvature computation.
  - The ambient occlusion was slightly off centered and assymetrical ... it is now fixed.

**New features:**

- **Interface:**
  - The amount of video memory used to generate the planet is displayed on the bottom of the interface.

**V1.0.0 beta:**

**Fixes:**

- **Bug reporter:**
  - The bug reporter has been redone and is now launching the mail application with a prefilled mail.

**New features:**

- **Rendering:**
  - Shader performance boost. The main shader has been improved to ensure better responsiveness of the software.
  - Ability to save the rendering of the viewport in 100%, 200%, 400% and 600% size.
  - Every textures is now sampled using bicubic sampler instead of bilinear, improving the global quality of the rendering.

- **Interface:**
  - Complete redesign of the interface, including menu and large icons.
  - Color picker added. Select a color and click-drag the eyedropper.
  - Adjustable light and planet rotation.
GPU load option has been added, you can tune how often the application is giving back the control to the OS while rendering.

Mouse key configuration added.

FOV tuning using mouse.

Export:

- Export the planet and ring mesh optionally when exporting the textures (Options->Output->Model export)

Planet generator:

- New management of ice caps and desert.
  - Heat map has been added. You can control the temperature at the poles, at the equator and how it spreads.
  - Moisture propagation system rewritten.
- AO level is tunable and the AO algorithm has been improved with fine tuning of high, medium and low frequencies.
- Sharpness has been added to sediment depot.
- Improved distortion algorithm, much faster than before.
- New hyperfractal noise generator.
- Rendering of cities and roads.
- Major optimization of the generator’s compute shaders.

Known issues:

- Planet generator:
  - Sometimes vertical strips appears on the Albedo of the texture, it’s not AO, not height/normal related ...

V0.0.7:

Fixes:

- Engine:
  - Progressive update of the clouds layer. The previous revisions was taking a lot of time to render some clouds under certain conditions and this solves the problem.

- Interface:
  - Main window was opening in the middle of desktop. You can now configure the place and size of the window when starting the application in the options.
  - Roughness of the water is now in the water tab and is now correctly exported (it was a constant before).
  - Reset of values was not working after loading a preset, it’s fixed now.
  - Channel water*water alpha is also available on standard version, not only pro. This allows the export of an emissive map for lava planets.
  - Mousewheel sensitivity is now saved correctly.
  - Color presets delete are saved directly now.
- Planet manipulation (drag/zoom ...) works only if the mouse is in the work/viewport area.
- Mousewheel speed increased in the scrollviews (was unusable before).

**Presets:**
- Old presets are fixed to take the new features into account. By default, you will keep your old preset files, if you want to get the new ones, go to SteamLibrary\steamapps\common\Grand Designer\Media\Presets and delete the .gdp, right-click on Grand Designer in your steam library, select properties, select the ‘Local files’ tab and click ‘Verify integrity of application cache …’, this will force the download of the new files.

**New features:**

- **Samples:**
  - New unity sample with
    - new custom materials, easier to tune
    - self emitting water
    - separate clouds layer
    - separate clouds layer with atmosphere
    - translucent rings
    - cutout rings (cast and receive shadows)
    - a scene containing many variations using one texture set
  - New unreal sample with
    - self emitting water
    - displacement
    - separate clouds layer
    - merged animated clouds layer
    - separate atmosphere layer
    - translucent rings
    - cutout rings (cast and receive shadows)
    - a scene containing many variations using one texture set

- **Engine:**
  - The heightmap is computed only when necessary and not for all parameters changes, which result in faster update.
  - Craters generation greatly improved:
    - Seed is now exposed, you can generate different distributions at will.
    - Craters blend more realistically with each other, no more ugly overlaps.
    - Crater’s height parameter has now a significant effect.
    - Some parameters has been added to add more variety in the generation and break the artificial look.
  - Improved vegetation system:
    - Select vegetation color according to moisture level and to desert level.
    - Allow the vegetation to grow outside the sediment.
    - Allow the usage of alpha in the vegetation color ramps.
    - Control the growth of vegetation according to slopes.
  - Improved ice caps:
Select color from slopes or from AO.
Control the influence of water and land height on ice spreading.

- Interface:
  - The rendering time is displayed in preview mode and in rendering mode.
  - Water sharpness parameter has been added.
  - Control of the curvature thickness added.
  - You can now import an external height map
    - This will be the first layer of your planet, and you can enrich it with extra layers of noise.
    - AO and normal generation can be improved thanks to jitter and blur parameters.
    - Bicubic filtering is used to compute the final heightmap, so the files can be in low definition.
    - All heightmaps are imported as 8bits per component so far.
    - There is a sample file in Media\HeightMaps called Moon.png
  - Much better and more realistic simulation of moisture level. Extra parameters has been exposed in the ‘Other’ tab and allow you to
    - Tune the moisture level at the poles and at the equator.
    - Tune the spreading of oceans moisture.
    - Randomize the moisture distribution.
  - Adjustment of 3D noise position, rotation and scale thanks to a new set of parameters in the ‘Global’ tab. This provides a very fine level adjustment for the noise and allows you to control the position of mainland on the planet.
  - High definition rendering:
    - The main interface is now locked to avoid any conflict and interruption of the rendering.
    - You can cancel the rendering at any time and don’t have to wait for it to finish.

v0.0.6:

Fixes:
- Interface:
  - Reset is now working with min-max sliders
  - Change default values for ice caps (was too random)
- Export:
  - Background export with TGA was broken - fixed
  - When exporting background, the default filename was the name of the planet preset - fixed
  - Ring texture had the wrong resolution - fixed
- Post effects:
  - Deactivate post effects when in solo/layer mode
- Planet generator:
  - Artefacts were appearing if you update a value and the planet was turning – fixed
- **Configuration:**
  - Fixed a bug that prevents some options to be saved correctly.

**New features:**

- **Interface:**
  - You can now toggle the complete interface on and off with the F11 key. This allows you to take screenshots/videos without the UI.
  - Addition of a reset button for the current edition mode.
  - Addition of a button that shows release notes.
  - Zoom speed is now tunable and the middle mouse button can be used to zoom too (the mouse wheel is kept as well).
  - Add manual input of values for sliders and min-max sliders (just click on the values to edit them – use return or enter to validate). Accuracy has been upgraded to 4 decimal numbers.

- **Export:**
  - Exports options for the background are now exposed. You can chose to export in RGB or RGBE, in 8bits per component or 16bits per component (pro only)

- **Post effects:**
  - Toggle all post effects with a single button
  - Addition of a sharpen post effect

- **Background generator:**
  - Addition of a sun tab to control visibility, sun scale, sun glow intensity, sun hue, sun saturation, light color and light intensity.