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GETTING STARTED
Welcome to Mixcraft 8, a powerful recording DAW software offering the tools and
performance power to create professional music and video projects... easily!
ABOUT THE MANUAL
This manual was written to provide a basic walkthrough of some of the steps that an
artist may encounter when using Mixcraft. This manual provides a range of
step-by-step instructions and explanations of features in the software. We’ll also throw
in some helpful tips from time to time.
We recommend viewing in Adobe Acrobat Viewer. If you don’t have already have it,
you can download it free from Adobe (a quick Google search will find the correct
installer for your system.)
Blue underlined text are links to other sections of this manual. You may want to jot
down the page you’re on prior to clicking these links as most PDF viewers don’t have a
“go back to where I was” function.
CHECKING FOR UPDATES
Acoustica periodically provides updates to software. You can easily obtain these
updates through Acoustica’s website,with an active Internet connection. To check for
updates, go to the Help menu at the top of the screen and choose Check For Update...
ADDITIONAL HELP
We’ve made a heck of an effort to include as much Mixcraft 8 information as possible
in this manual, but if you get stumped, contact Acoustica tech support online at
www.acoustica.com and click the Support link.
Mixcraft also has a lively online forum with tons of useful archived information and
support not only from the Acoustica tech support staff, but seasoned Mixcraft users as
well. Find it at www.acoustica.com, click Support, then Discussion Boards.
Welcome to the Acoustica family... we hope you’ll enjoy Mixcraft 8 and make some
great music (and video) along the way!
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MIXCRAFT 8 HOME STUDIO
LIMITATIONS
Mixcraft is available in three different versions: Mixcraft 8 Home Studio, Mixcraft 8
Recording Studio, and Mixcraft 8 Pro Studio. In order to bring Mixcraft 8 Home Studio
to you at such an affordable price point, it sacrifices some features compared with its
big brothers. Below is a summary of its reduced feature set:
Feature

Limits

System bit-depth compatibility

32-bit compatible only

Tracks

sixteen total audio and instrument tracks

Performance Panel

eight sets

Automation

pan and volume only

Sound Library

6500+ loops and sound effects

Virtual Instruments

Acoustica Instruments, Impulse, Messiah,
MiniMogueVA, VB3 Organ

Samplers

Alpha Sampler (Omni Sampler not included)

Effect Plug-ins

Acoustica Chorus, Acoustica Compressor,
Acoustica Delay, Acoustica Distortion,
Acoustica EQ, Acoustica Flanger, Acoustica
Reverb, Classic Auto-Filter, Classic Chorus,
Classic Compressor, Classic Delay, Classic
EQ, Classic Flanger, Classic Master Limiter,
Classic Phaser, Classic Reverb, EZQ Equalizer,
GTune Guitar Tuner, Voxengo Amp Simulator,
Voxengo Spectrum Analyzer

Submix, Send, and Output Tracks

no

Audio Mixdown Formats

MP3, WAV, WMA, OGG

Video Mixdown Formats

MP4, WMV, AVI

CD Burning

yes

MIDI/Audio FX Routing

no

ReWire Hosting

no

Import To Library

no
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IMPORTANT SOUND SETUP
INFORMATION
When Mixcraft is first launched, it’s important to ensure that the audio latency is set
optimally. Ideally, using a very low latency setting is best, as it results in little or no
audible delay when playing virtual instruments or recording using software monitoring.
Your computer’s processor speed and amount of RAM, as well as your audio system or
sound card all affect audio playback and recording performance. Optimally adjusting
your sound device will be a balancing act between latency versus gapping or breaks in
continuous sound. If you are recording audio using Mixcraft’s built-in monitoring or
playing virtual instruments, you’ll need to adjust your latency response properly.
CHOOSING AN AUDIO DRIVER TYPE

1. Click File> Preferences...
2. Click on the Sound Device tab.
3. Wave RT was introduced in Windows Vista and is part of every newer version of
Windows; this the default audio driver. If you have a slower computer, you may
need to increase the latency setting.
4. If you’re using Windows 7 or 8, you may be able to click WaveRT Exclusive Mode.
Depending on your computer’s speed and power, this mode will allow down to three
milliseconds of latency. In this mode, other programs will lose audio capability when
Mixcraft is running. You may need to restart other programs to get their audio back.
WaveRT exclusive mode is the best way to use every last ounce of computing power.
5. If you don’t have WaveRT, the next best option is ASIO. If it’s grayed out, go to your
sound device or sound card manufacturer’s website and install the latest drivers.
Click on the ASIO Device flip menu and choose the sound device or sound card
you wish to use. You can adjust the settings of the ASIO device by clicking “Open
Mixer.” Each ASIO driver is implemented differently; consult the manual or help for
your sound device in order to optimize the latency setting. Ensure that Default
Output (Playback) is set to the correct device so you’ll hear audio properly.
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6. If you don’t have Vista or an ASIO option enabled, select Wave. To reduce latency,
decrease the Number Of Buffers and reduce the Buffer Size. The Latency field will
update – this will entail a bit of trial and error as adjustments are made. Click OK,
then check the quality of audio playback. A setting of 100 milliseconds or less is
tolerable; lower settings of 20 milliseconds or less are preferred.
QUICK GLANCE CHART
Type

Windows Version

Notes

WaveRT

Windows 7,8
and Vista

The default option. Latency
down to 20 milliseconds.

WaveRT EXCLUSIVE

Windows 7,8

Takes over the computer’s
audio, but will work down to
three milliseconds of latency.
This option is available when
WaveRT is selected. Audio from
other programs and Windows
will not work at the same time
that you are in this mode.

ASIO

XP, Vista, Win 7,
Win 8

Best for playback and recording
synchronization. Must have a
supported ASIO driver for your
sound device.

Wave

XP, Vista, Win 7,
Win 8

Only use if absolutely necessary.

COMPUTER SPEED CONSIDERATION
If you have a slower computer and experience audible breaks in audio recording or
playback, you may need to increase the latency setting. Alternatively, you may need
to purchase a higher performance sound card or audio system designed with music
recording and playback in mind. Changing the latency will depend on what type of
audio driver is being used. See the Choosing An Audio Driver Type section above for
more information. Another effective speed enhancement is to defragment your hard
drive, or purchase a new hard drive. (Old hard drives can get slow with age.)
Notice the CPU meter on the lower right corner
of Mixcraft.This indicates the amount of CPU
resources used by Mixcraft compared to the
entire computer’s CPU usage.

9

Right On Track
You may notice that
Mixcraft won’t allow
you to drop the loop
on a track with a
little keyboard icon;
that’s because these
are MIDI tracks. Make
sure to drag audio
loops to audio tracks,
i.e. tracks with a little
speaker icon. Mixcraft
actually has a number
of different track
types optimized for
different purposes, but
while we’re in “quick
startville,” we’ll just
concern ourselves with
Audio Tracks, that play
digitized audio, and
MIDI Tracks, that play
note on/off messages.

QUICK START
We know what you’re thinking … “I don’t wanna read this big ol’ manual now, I wanna
rock!” (or thereabouts). Don’t worry, we’ve got ya covered. In this section, we’ll show
how to play audio clips from Mixcraft’s huge included library, record audio and MIDI
tracks, and add effects.
LOAD AND PLAY AN AUDIO CLIP
To launch Mixcraft, double-click the Mixcraft 8 icon on the desktop. We’ll begin by
dragging an audio clip of a bass line into the Main Window – that’s the big gray grid
where clips of audio, MIDI, and video playback.
Click the Library tab at the bottom of the arrange window, then click the Library popmenu and and select Loops. Now click the Sort By pop-up menu and select Song Kit.
You’ll see a list of song styles below; select 12-8 Blues. In the list of loops on the right,
you’ll see Bass 12 Bars. Click and drag this to bar 1 of Audio Track in the empty gray
grid beneath the word Start. While hovering a loop over the grid in the Track View
window, you’ll notice two tiny white triangles; this is called the Caret.

The Caret shows where clips will land when the mouse button is released. It also
indicates where playback or recording will begin. Once you’ve dropped the audio into
place, a dialog box will open and ask: “Use Best Sounding Project Tempo, Key & Time
Signature?” We’ll explain exactly what this means later on, but for now, click Yes.
Once you’ve dropped a loop into the main grid, it creates a “Clip.” Clips are the rectangular audio, MIDI, or video “building blocks” in the main grid that make up a project.
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The Main Grid window should look something like this:

Click the green play arrow button in the transport section to hear the bass clip play;
click a second time to stop playback, or press the space bar to start or stop playback.
If the clip begins playing somewhere in the middle, click the mouse near the number 1
in the timeline (the numbered line at the top of the Main Grid window). This will
relocate the Caret, thereby changing the playback start.

Jargon Alert:
The “>” Sign

Try dragging different types of loops into the Main Grid on separate audio tracks.
Mixcraft will automatically match tempo and key signature, making it super easy to
create music! If you run out of audio tracks, create more by clicking +Track>Insert
Audio track at the top of the Track List.

+Track>Insert
Audio, the “>” sign

If you’d like a section to loop during playback, drag the mouse in the
timeline at the top to create a purple highlight area, then click the Loop
button in the transport area. The button will turn green to show that loop
mode is active. Click it again to turn off looping. (Pressing the L button will
also toggle looping.)
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Throughout this
manual, when you
see something like

usually refers to a
sequence
of actions. Think about
it as a shorthand way
of us saying,
“click this>then this>
then this.”

RECORDING AN AUDIO TRACK
Select a blank audio track in the Track List at the left side of the screen. Existing blank
audio tracks will already be named Audio Track and have a little speaker icon beneath
the name (we told you this would be easy!). If there aren’t any blank audio tracks in the
Track List, create new ones by clicking the +Track button at the top of the Track List
and selecting Insert Audio Track.
Click on the audio track you’d like to record on; the track will highlight in green. Now
choose the recording input source by clicking the down arrow to the right of the Arm
button. Depending on your audio hardware, this list may appear differently, but the
idea is to select the hardware input you’ll be plugging a mic or instrument into. In the
example below, we’ve chosen the left channel (i.e. input 1) of a two-channel audio device.

If you’re recording a mono signal, click the sound device followed by Left or Right
depending on where you’ve plugged into the audio device. If you’re recording in stereo
with simultaneous left and right inputs, select Stereo. Pay close attention to this setting,
because it’s easy to accidentally record mono input sources (e.g., lead vocals, bass
guitar, etc.) as a stereo file if you’ve set this incorrectly. It won’t hurt anything, but
you’ll unnecessarily waste hard drive space.
After selecting the input, click the track’s Arm button. The Arm button will turn red,
letting you know Mixcraft is ready to record. Now send some audio through the input
to verify that the correct input was chosen. You should see the meters moving onscreen on the recording track.
When a track is armed, the volume slider turns
into a red recording input level adjuster. Move the
slider to adjust the recording input level. If peaks
send the meter into the red, back off the level. Ideally, the input signal should
nominally sit in the green-to-yellow area.
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Important Note: If you’re using an audio device with an ASIO driver (you can

check in File>Preferences>Sound Device), the volume slider will disappear when
the track is armed for recording. This is because ASIO recording drivers do not
support input level adjustment in software. To set the proper recording input
level, you’ll need to use either the input level on your audio hardware, or if it
doesn’t have one, you’ll most likely want to set the recording level using the
output level control on an external preamp or channel strip.
In order to record in time with a project’s tempo, you’ll most likely want to
record with a metronome. To turn on the metronome, click the metronome
button in the middle of the transport. It looks like, well, a metronome.

Check the Recording box. This means the metronome will click during recording.
Checking the Playback box makes it click during playback, but we can leave this off
for now. If it’s not already checked, check the Recording Count-In Measures box. Upon
pressing the Record button, this gives a “countdown” before recording begins. The
number selector lets you choose the length of the countdown – 1 bar usually provides
enough time. Hit OK when you’re done. Once you’ve configured the metronome,
you can quickly toggle it on and off by pressing the M key on the computer keyboard.
Almost there! Let Mixcraft know where to begin recording by positioning the Caret
in the grid. This can be done by either clicking in the timeline at the top of the main
window, or by clicking anywhere in the Main Grid. We recommend positioning the
Caret on an exact number in the timeline (e.g., 1, 2, 3). Setting the Snap To setting at
the top of the screen to Snap To Grid will simplify positioning the Caret.
Now it’s time to grab that microphone or guitar, and let it rip. If you want to monitor
the recording source during recording, click the little speaker icon (directly to the left of the
Mute button).
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Here we go. Click the red Record button in the transport (the one with the red dot),

wait four clicks for recording to begin and record something! When you’re done,
click the Record button again to stop (you’ll notice the red circle turns into a square
while recording), or just hit your computer’s space bar. It should look something like this:

Congratulations, you’ve made your first Mixcraft audio recording!
RECORDING A MIDI TRACK
Unlike an Audio Clip, which contains digital sound data, a MIDI Clip contains MIDI
notes. Think of a MIDI Clips as a sort of computerized player piano ... a MIDI Clip
primarily contains digital on/off messages saying, “hey computer instrument, play these
notes at this time, wouldja?”
There are a number of ways to create MIDI clips, but the most common way is to plug
in a USB MIDI controller keyboard, press the Record button, and tickle the ivories
(plastics?). If you have a USB MIDI controller, plug it into an available USB port on
your computer. If you don’t have a USB keyboard controller, you can input notes direct
from the computer’s keyboard using Musical Typing. This can be toggled on and off by
going to the View menu at the top and selecting Musical Typing, or by using the key
shortcut [CTRL]+[ALT]+K. Musical typing uses the computer’s QWERTY keyboard to
play musical notes. When activated, the layout shows the “mini music keyboard,”
octave, transpose, velocity, and other relevant parameters:

Now that we’re playing some kind of keyboard, we’ll select one of Mixcraft’s built-in
Virtual Instruments. A Virtual Instrument is like having keyboard instrument that lives
inside the computer. Handy, right?
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First, create a new virtual instrument track. Click the +Track button at the top left, and
select Insert Virtual Instrument Track. Now click the track’s piano keyboard icon. This
opens a dialog box where instruments can be selected:
There’s Already
A Piano, Man
New MIDI Tracks
default to an acoustic
piano sound, so you
really don’t need to
select an instrument
to play MIDI notes, but
we thought you might
want to know so you
wouldn’t be stuck with
all piano, all the time!

We’ll go with our old friend “Acoustic Piano,” but feel free to scroll through the list and
choose something saucy, like “Space Walk.” When you’ve made your selection, click on
the red X in the upper right corner.
Before we record a MIDI performance, let’s turn on Mixcraft’s metronome.
This lets you play in time with the project’s tempo. To turn on the
metronome, click the metronome button in the middle of the transport:
Check the Recording box. This
means the metronome will click
during recording. Checking the
Playback box makes it click during
playback, but we can leave this off
for now. If it’s not already checked,
check the Recording Count-In
Measures box.

Upon pressing the Record button, this gives a “countdown” before recording begins.
The number selector lets you choose the length of the countdown. Unless your
computer and MIDI keyboard are really far away from each other, choosing 1 bar
should give you plenty of time to get those fingers poised. Hit OK when you’re done.
Once you’ve configured when the metronome plays, you can quickly toggle it on and
off by pressing the M key on the computer keyboard.
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We’re almost there! Let Mixcraft know where to begin recording by positioning the
Caret in the grid. This can be done by either clicking in the timeline at the top of the
main window, or by clicking anywhere in the Main Grid. We recommend positioning
the Caret exactly on a number (e.g., 1, 2, 3). To simplify
positioning the Caret, make sure Snap To Grid is selected
in the Snap To menu at the top of the screen.
Make sure the track is armed for recording – if it’s not red, click on it. Now click the
red Record button in the transport (that’s the one with the red dot), wait four clicks for
recording to begin, and lay down the rock. When you’re done, click the Record button
again to stop (you’ll notice the red circle turns into a square while recording), or just
hit your computer’s space bar. You should have something like this:

To create more MIDI tracks, select empty tracks in the Track List on the left of the
screen and add more instruments as described above.
ADDING AN EFFECT TO AN AUDIO CLIP
OR VIRTUAL INSTRUMENT TRACK
Mixcraft includes a large suite of real-time audio effects that can be applied to audio
clips or virtual instruments. These are usually referred to as “plug-ins.”
To add a plug-in effect, click on an Audio Track or Virtual Instrument track (if it’s an
audio track, make sure it has associated audio clips in the grid). Now click the track’s
fx button.
The fx button will turn green and following dialog window opens. Click
<Select An Effect>. A drop-down menu will display a whole gaggle of effects;
choose one that sounds fun. For this example, we’lI choose Acoustica Delay.
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At this point, you could just click the X in the top-right corner and be off on your
delayin’ way, but most likely you’ll want to change the default settings. Mixcraft
plug-ins include factory preset settings – to try out the factory preset settings,
click on <Custom> in the Preset list.

To edit the plug-in settings, click the Edit button to view a plug-in’s user interface.
This opens up the Acoustica Delay interface and lets you set its parameters to your
liking. You can press the play button in the transport and hear the settings change in
real-time. (We recommend using Loop Mode for more convenient previewing.)
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REGISTRATION
Following installation, Mixcraft runs in trial mode for 14 days, so
you’ll want to register as soon as possible for full functionality. To
register your copy, click the Register! button on the toolbar or select Help> Enter
Registration Code… in the Main Window menus.

Type in or copy and paste the registration ID (usually your email address) in the Step 3
edit box and type or copy and paste the 20-character registration code (excluding
dashes) into the Step 4 edit box. (Do not enter any extra spaces.) Click the Register!
button and you’re done!
Thank you for choosing Mixcraft. Your support and patronage helps us to continually
improve Mixcraft. Enjoy! – The Acoustica Team
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MIXCRAFT REFERENCE
Think of this section as what you’ll come across when using Mixcraft. Later chapters
will explain how to accomplish tasks in Mixcraft in detail. Blue italicized texts indicate
clickable links that will jump to sections with further information.
MAIN WINDOW

This is where you’ll spend most of your time in Mixcraft. We’ll explain each of its
sections below.
MENUS

Basic menus for accessing many Mixcraft functions.
TRACK HEADER

Button shortcuts atop the Track List allowing creation of new tracks, enabling the
master track, and enabling the Performance Panel.
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MAIN WINDOW TOOLBAR
The Main Window Toolbar contains button shortcuts for many frequently used
functions and parameters. Here, we’ll go over its functions, buttons, and tools.

OPEN NEW PROJECT

Opens a new project.
LOAD PROJECT

Loads an existing project.
ADD FILE

Adds audio or MIDI files to a project on the currently selected track at the
current Caret position.
SAVE

Saves the current project.

Publish
The Publish function lets you render, upload, and promote music and video
projects directly to social media sites such as YouTube, Vimeo, Facebook,
Soundcloud, and Mixcloud. For more information, see “Publishing Mixcraft Projects
Online.”
BURN CD

Burns the current project to a CD. (Your computer must have an internal or
external CD burner. You knew that.)
MIXDOWN TO AUDIO FILE

Mixes the current project to a WAV or MP3 file.
UNDO

Cancels the last operation. The same as pressing [CTRL]+Z.
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REDO

Restores the last operation. The same as pressing [CTRL]+Y.
ZOOM IN

Widens the horizontal view of the Main Clip Grid (i.e. clips become larger).
ZOOM OUT

Shrinks the horizontal view of the Main Clip Grid (i.e. clips become smaller).
MIDI LEARN

Toggles MIDI Learn mode for hardware controller assignment (See “Using
Generic MIDI Controllers and Control Surfaces.”)
CLIP AUTOMATION VIEW

This pop-up shows the type of clip automation currently
displayed. For more information about clip automation,
see the “Clip Automation” section in “Automation and
Controller Mapping.”
PREFERENCES

Opens Mixcraft’s Preferences window.
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SNAP SETTING

The Snap setting acts as a quantize control for
placement of all elements in the Main Clip Grid
including the playhead, markers, and clips, as
well as moving, cutting, pasting, etc. Snap
simplifies the process of keeping clips and
markers exactly on bar and beat lines. To set
the Snap resolution, click on the Snap setting
drop-down and a select a time division setting.
The chraracters on the right side are shortcut
keys for quickly changing the Snap setting.
These work only from the numbers directly
above your computer’s QWERTY keyboard;
they won’t work from the 10-key numeric
keypad. The tilde (Off shortcut) is located
next to the number 1 key at the top of your
keyboard. Tilda Swinton, on the other hand,
is probably at the hairdresser in Beverly Hills
getting her hair bleached.

HOW THE SNAP SETTING AFFECTS THE MIXCRAFT CLIP GRID

You may have noticed that as Mixcraft’s horizontal view size is zoomed, the Main Clip
Grid increment lines become finer (closer zoom) or coarser (farther zoom). The Snap
To Grid setting conforms Snap to the light gray “sub” grid lines in the Main Clip Grid.
You may find Snap To Grid works best in most situations. Use the Snap To Grid
(Triplets) option if you’re working on music with a “three” feel.
REGISTER

Use this to register your copy of Mixcraft. The Register button
disappears once Mixcraft has been properly registered. (See the
“Registration” section.)
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TIMELINE

The Timeline indicates song position, represented either in minutes and seconds (Time
mode), or in bars numbers and divisions (Beats mode).The gray area above the ruler is
where in/out points, tempo, time signature, key, and song markers are displayed.
TRACKS

The Track displays important info and parameters for individual audio, MIDI,
and video tracks. In addition to standard audio and virtual tracks, Mixcraft includes a
number of other specialized tracks types for various tasks. For a full description of all
track types and how to use them, see “Tracks and Track Controls.”
TRACK LIST

This is what we call the entire list of all audio, MIDI, and video tracks comprising a
Mixcraft project.
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MAIN CLIP GRID

The playback and recording area where audio, MIDI, and video clips can be created
and moved. This is where (most) of the action happens, baby.
Tip: The Clip Grid area can be zoomed in and out by spinning your mouse wheel. (The
mouse wheel’s behavior can be changed in File>Preferences>Mouse Wheel.)
AUDIO/MIDI/VIDEO CLIPS
Clips are the “building blocks” of projects.
Depending on the clip type, they may contain audio,
MIDI, video, or text. Following are operations that
are common to all clip types. Learn more in the
“Using Clips and The Main Clip Grid” section.

PLAYHEAD

The playhead is a vertical line with a yellow “flag” at the top indicating the current
playback time, or where playback will occur when play or record is initiated. Clicking
anywhere in the Timeline moves the playhead to the click position.
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CARET
The Caret is a line and two triangles indicating the precise
point on the Main Clip Grid where edits happen, and
where playback or recording begins. The tiny triangles
indicate which track the Caret is on. The Caret location is
set by clicking in the Main Clip Grid. The Caret will obey
the current Snap Setting.
New sounds and recordings are added at the Caret position. After adding a new sound,
the Caret will move to the end of the sound. The Caret is also the point at which
selected sounds will be split. The Caret can be moved by clicking the mouse or by
using the keyboard direction arrows. The Caret is not susceptible to being eaten by
wascally wabbits.
TRANSPORT BAR

Standard tape deck-style controls for playback, recording, loop mode, and punch in/
out. The large middle display shows song tempo, time signature, song key, and the
current position of the playhead. To the right are the master level meter, volume slider,
and master effects bypass button.
TABS

These show additional project information and parameters. Tabs pop up and occupy
the bottom half of the screen when clicked.
If the Sound Tab is selected, the following editors are available:
Audio Clips

Loop Editor

Virtual Instruments Clips (MIDI)

Piano Roll
Step Edit
Score Edit
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STATUS BAR

This lonely area at the bottom of the window displays current CPU usage and whether
Mixcraft is saving, loading, or freezing something.
GUITAR TUNER

Each audio track features a built-in tuner. Though we refer to it as a “guitar tuner,” it
will work with any monophonic instrument signal (i.e. one-note-at-a-time). Those of
you using drifty, old analog synthesizers should find it quite handy!
To toggle the tuner on or off, simply click the track’s Arm button, then click the tuning
fork icon. The tuning fork icon will turn green, and the track’s volume slider/level
meter turns into a display for the tuner. When the tuner detects an audio signal, it
displays the closest note. When the signal is in tune the “tuning cursor” will appear in
the middle and highlight in white.
The tuner can also be turned on or off by right-clicking on the track and selecting
Guitar Tuner or clicking the main window menu Track>Guitar Tuner.
TIME/BEATS MODE
Toggles song position in the timeline and transport bar numeric
display between bar numbers and divisions or time shown in
minutes and seconds.
TRANSPORT
This is where you’ll find playback, recording, loop mode, and master volume.

Shortcut Key

Function

Control

Record
[R]

Click the recording button
to start recording.
Rewind To Start

[HOME] key

Resets the playback
indicator to the start of the
project.
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Shortcut Key

Function

Control

Rewind
[CTRL] + , (comma)

Rewinds the playback
indicator by a measure or
so.
Play

[SPACE] BAR

Starts playback at the
current playback indicator
position. Visible when
playback is stopped.
Stop

[SPACE] BAR

Stops playback at the
current playback indicator
position. Visible only
during playback.
Fast Forward

[CTRL] + . (period)

Fast forwards the playback
indicator by a measure or
so.
Fast Forward To End

[END] key

[L]

Resets the playback
indicator to the end of the
project.
Loop Mode
Toggles loop mode for
recording or playback.

[M]

Metronome
Toggle the playback,
recording, or countin metronomes. Press
[ALT]+P to toggle the
playback metronome or
[ALT]+O to toggle the
recording metronome

(No key shortcut)

Punch In/Out
Toggles punch in/out
recording.
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RECORDING TIMER

Mixcraft includes a Recording Timer. This allows recording for a specified duration.
To use the Recording Timer, select Mix>Use Recording Timer from the Main Window
menus and enter a number of minutes to record. (If you only want to record 30
seconds, enter 0.5)
To disable the recording timer, select Mix>Use Recording Timer again and uncheck it in
the menu.
PLAYBACK TIME READOUT/DISPLAY
This is the green readout that shows the
current playback indicator time or measure
and beat position. It also shows the current
tempo, time signature, and key.
PROJECT TEMPO, KEY AND TIME SIGNATURE
PROJECT TEMPO

All sounds that have a tempo and are set to Adjust To Project Tempo mode will conform
to the project tempo. For example, if a sound has a tempo of 200 bpm and the project
has a tempo of 100 bpm, the sound will playback two times as fast and be 1/2 the
normal duration. In addition to affecting any tempo-adjusted sounds, the project
tempo also determines the metronome rate.
PROJECT KEY

All sounds that have a key and are set to Adjust To Project Key mode will conform to
the set project key. For example, if a sound has a key of A and the project’s key is B, the
sound will playback two semitones or half steps higher than normal in order to be in
tune with the key of B.
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PROJECT TIME SIGNATURE

The time signature affects snap behavior if Snap is set to Snap To... a number of bars.
For example, if the time signature is 3/4 and the software is snapping to the measure,
it would mean that the software is snapping every three beats, instead of four beats for
4/4 time. The metronome will play based on the current time signature.
The numerator of the time signature indicates the number of beats per measure and the
denominator indicates what type of note receives a beat.
MASTER VOLUME
The master volume adjusts the level of the
entire mix. Move the slider left or right to set
the desired volume. Master Volume also has
an integrated master level VU meter.
Alternatively, you can right-click on the Transport and select Master Volume>Set Master
Volume followed by choosing a level % or specifying an exact value. This menu can also
be accessed by selecting Mix>Set Master Volume in the Main Windows menus.
LOOP MODE & PUNCH IN/OUT
Mixcraft can be set to play or record in loop mode. Punch In/Out lets you record at a
specific time section. These modes can work together or separately.
To loop a region, click the Loop mode button in the Transport, then drag the Loop Start
and Loop End markers in the Timeline to set a loop area.
Punch In/Out
Punch In/Out recording lets you place
markers that define where to start and end
recording. See “Punch In/Out” in the
“Recording Audio” chapter for more
information.
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METRONOME
Mixcraft’s metronome clicks at the project tempo. It can be set to click
during playback, recording, or both. To configure the metronome, click the
metronome button.
The metronome dialog opens:

PLAYBACK

Checking this box makes the metronome click during playback. Pressing the M key
will toggle it on and off.
RECORDING

Checking this box makes the metronome click during recording. Pressing [SHIFT]+M
key will toggle it on and off.
RECORDING COUNT-IN MEASURES

Upon pressing the Record button, this gives a “countdown” before recording begins.
The number selector lets you choose the length of the countdown length in measures.
METRONOME PREFERENCES

Metronome sounds and volume can be customized by selecting Preference>Metronome
in the Main Window menus.
PLAY EVERY X BEATS

The metronome can be configured to play on specific beats by creating a Marker
and specifying this in the Edit Marker window. See the “Markers” chapter for more
information on this.
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MUSICAL TYPING KEYBOARD

The Musical Typing Keyboard allows virtual instruments to be played using your
computer’s QWERTY keyboard. Enable it by clicking View>Musical Typing in the main
screen drop-down menus, or with the keyboard shortcut [CTRL]+[ALT]+K.
When activated, the Musical Typing Keyboard displays on onscreen a music keyboard
corresponding to the computer keyboard, as well as octave, transpose, velocity, and
other relevant parameters. Learn more about the Musical Typing Keyboard in the
“Musical Typing Keyboard (MTK)” chapter.
EFFECTS

Effects can be added to any track type (excluding video and text tracks). To add
effects to a track, click the FX button in a track header. Mixcraft features a large
array of effects including echo, delay, chorus, EQ, distortion, and more. Learn more in
the “Effects” section.
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TRACKS AND TRACK
CONTROLS

The Track List is at the left side of Mixcraft’s main interface window. Each track
contains controls for volume, panning, muting, soloing, and more. There are a number
of track types, each with its own purpose and variations in its controls. You can use as
many tracks simultaneously as you like (until your computer starts billowing smoke).
The exception is that a project can only have one Video and one Master track. First
we’ll go over some common controls for most track types, then we’ll get into specifics
for each track type.
HOW TO ADD TRACKS
There are several ways to add tracks:


Click the +Track button at the top of the track list and select a new track type.



Click Track>Add Track in the Main Window menus to add a track at the bottom
of the track list, or click Track>Insert Track to add a track above the currently
selected track.

		
		

 Tracks can be inserted by right-clicking within the track list and choosing Insert
		Track or added at the bottom by right-clicking in the blank area beneath existing
		 tracks and choosing Add Track.

BASIC TRACK CONTROLS
Below is a list of controls amd actions common to most track types.
VOLUME + INPUT/OUTPUT METER

Track volume is adjusted by the horizontal slider with
built-in level meter. Click down on the slider and move it left
or right to decrease or increase volume. Volume can be set from 0% to 200% (-Inf dB
to +6 dB).
To set an exact track volume, choose Track>Properties>Set Volume>Set Exact Value…
from the main window drop-down menu and enter the desired volume. This can also
be accessed by right-clicking on the track.
Tip: Hold down [ALT], [SHIFT], or [CTRL] and click-drag the slider for finer and more
accurate adjustment.
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The horizontal volume fader contains an integrated level meter. In standard playback
mode, this displays the output level as the track plays. If the track is in record arm
mode (Arm button will be red), the meter functions as an input level meter.
PAN

The track’s pan control is the small horizontal slider to the left of the
track volume control. Adjust the pan control by clicking and dragging it
to the left or right. Pan is adjustable from 100% left to 100% right. The pan controls
default to center position – this means that the sound is equally balanced between the
left and right channels. Track panning can also be set in the main window drop-down
menu Track>Properties>Set Pan>Set Exact Value … This menu is also accessible by
right-clicking a track.
Tip: For finer and more accurate pan adjustment, hold down [ALT], [SHIFT], or
[CTRL] while dragging the pan slider.
MUTE

Tracks can be temporarily silenced by clicking the track Mute button. Once
muted, the solo button turns green, and all clips on the track turn gray.
Tracks may also be muted using the shortcut [CTRL]+M, or by right-clicking the track
and selecting Properties>Mute. If multiple tracks are selected, all selected tracks are
muted simultaneously.
If multiple tracks are muted, [CTRL]-clicking an unmuted track unmutes all others and
mutes the clicked track (sort of a mute “solo” function). If multiple tracks are muted
and one of them is [CTRL]-clicked, all are unmuted.
SOLO

To hear a single track’s audio, click the Solo button. Multiple tracks may be
soloed. For example, to hear how the bass and guitar sound together without
drums, solo the bass and guitar tracks. Once soloed, the track’s solo button turns green
and all other tracks turn gray. If multiple tracks are selected, all selected tracks are
soloed simultaneously.
The currently selected track can also be soloed using the shortcut [CTRL]+L, or by
right-clicking the track and selecting Properties>Solo.
If multiple tracks are soloed, [CTRL]-clicking a non-soloed track disables solo on all
other tracks and soloes the clicked track. If multiple tracks are soloed and one of them
is [CTRL]-clicked, solo is disabled for all tracks.
ARM

Clicking the Arm button readies an audio or MIDI track for recording. (the
button turns bright red). If nothing else is armed, the currently selected track
will automatically be armed for the duration of the recording.
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Mute and Solo
Button [CTRL] + Click
Shortcuts
If multiple tracks are
soloed or muted, you
can unsolo or unmute
all tracks in project by
[CTRL] + clicking on a
solo or mute button.
Multiple tracks cannot
be Han Soloed.

More than one track can be armed for simultaneously recording to multiple audio or
MIDI tracks.
SELECTING A TRACK

Clicking on a track header will select it. The tracker header will change color; the
default color varies depending on the track type, but its color may be changed (see
“Track Color”).
MULTIPLE TRACK SELECTION

[CTRL]+click will select multiple tracks simultaneously, [SHIFT]+click selects all
tracks between any two selected tracks. Selecting multiple tracks is handy for moving
or deleting multiple tracks. Additionally, Volume, Pan, Mute, Solo, Arm and other
operations apply to all selected tracks.
Note: When multiple tracks are selected, Volume and Pan changes are relative. As an
example, changing a volume level on one track won’t cause all selected tracks to jump
to the same volume; instead, selected tracks maintain their volume settings relative to
each other but move up and down as a group. The same applies to Pan settings.
LINKING TRACKS

Multiple tracks can also be linked together; this gangs up the volume, pan, mute, solo
and send controls. It’s particularly useful if you have a group of similar tracks (like
drums, or multiple backing vocals). You may have as many separate groups of tracks
linked as you like. Linked tracks will display “chain” icons next to the track name, and
each Link group will have uniquely colored color bars at the far left of the track.
To link two or more tracks, select tracks as detailed in the previous section then choose
from the following Link options:
 Link Selected Tracks

Choose Track> Link>Link Selected Tracks from the main menus, or right-click
one of the selected tracks and and choose Link>Link Selected Tracks to link 		
currently selected tracks.
 Unlink All

This disables linking for all tracks in the current Link group (one track within the
group must currently be seleted before unlinking).
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 Unlink

This disables linking for only the selected track in the current Link group. Use this
to remove a single track from the Link group.
Note: Track linking is overriden for volume, pan, or send if automation locks are
enabled for these parameters.
TRACK TYPES
Here’s a brief summary of Mixcraft’s track types and their basic functionality, followed
by an in-depth explanation of each.
Track Type

Details

Audio

Record audio or remix loops.

Virtual Instrument/MIDI

Edit or record MIDI data.

Video

Add and edit video files or still images.

Video Text Track

Add and edit video static and scrolling text to videos.

Master

Shape the master volume and effects - this is where
effects are inserted into the main output bus.

Send

Share effects between multiple tracks.

Output

Additional output busses in addition to the Master
Track. These are used to route audio to physical
outputs with multiple-out audio hardware.

Rewire

Controls a third-party Rewire application.

Instrument Mix

Mix additional audio channels from virtual
instruments with multiple output busses; this is
automatically created when a virtual instrument with
multiple output channel is added.

AUDIO TRACK

Audio tracks are used to record and play back audio. Audio clips can be recorded by
the user or loaded from pre-existing libraries (such as Mixcraft’s super-duper included
library of samples, loops, and sound effects).
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To Insert or To Send Effects, That Is The Question

VIRTUAL INSTRUMENT/MIDI TRACK

Virtual instruments are used to play VSTi virtual
instruments. These are like having a keyboard instrument
within Mixcraft. They can be played and recorded using
a USB or MIDI keyboard controller (or your computer’s
QWERTY keyboard see “Musical Typing Keyboard”).
Mixcraft includes numerous virtual instruments, or
you can expand your palette by installing third-party
VSTi instruments. Virtual Instrument tracks are easily
distinguished from other types of tracks by the keyboard
icon next to the Mute button.
Virtual Instrument Tracks are also used to play external
MIDI instruments (even though they’re not technically
virtual instruments, because they exist in three-dimensional
reality... deep).
To load and play virtual instruments, check out the “Virtual
Instruments” chapter, or for the quick ‘n’ dirty lowdown,
Recording A MIDI Track in the “Quick Start” chapter.
VIDEO TRACK

A video track holds video clips and/or still images. A project
can only have one video track. For an in-depth explanation
of how to use video and video tracks, see “Video Tracks and
Editing.”
VIDEO TEXT TRACK

This is a specialized type of video track that (wait for it...)
lets you add various types of static and scrolling text to
video tracks. This is also covered in the “Video Tracks and
Editing” chapter.
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There are two ways to use effects in a mix environment:
insert effects, and send (or bus) effects. Both methods can
be used somewhat interchangeably, but each has its own
advantages largely dependent upon the type of effect, its
intended use, and, in the virtual DAW environment, use of
computer resources.
Insert Effects
When an effect is added to a track by clicking the fx
button, you’re using it as a channel insert. You can think
of an insert effect as being a part of an individual channel
strip. It also means that the wet-to-dry signal balance is
adjusted using the controls in the effect itself. Although
you can insert any type of effect, inserting is best suited to
gain and dynamics effects such as compressors, limiters,
EQs, distortion, etc., because their mix is typically set
“fully wet.” In other words, you don’t usually use a partial
amount of a compressed or distorted signal (although
some crafty engineers have been known to break this
rule). Conversely, time-domain effects such as chorus,
delay, and reverb are almost always mixed with the dry
signal – in other words, the dry signal is always at full
blast and the effected signal mixed with the dry signal at
a lesser volume.
Send Track Effects
One good way to think of a send effect is as one or more
channels being mixed together and then being sent to a
standalone effects unit. The dry mix remains unaffected,
and the effect gets added to final mix. Because of this,
the wet/dry mix control of a send effect should always
be set to 100% wet. (Otherwise you’d end up with the
dry signal from the main mix plus some dry signal from
the effect itself, making it it difficult to mix.) Perhaps the
biggest benefit of send effects is conservation of computer
processing resources; if you’re using a reverb plug-in that
demands a great deal of computer overhead, send tracks
allow you to send many mix channels to just one instance.
And if you’re using an effect to process many channels
of one “instrument” (e.g., a drum kit, several vocal tracks,
etc.), a send effect lets you add different amounts of the
effect for each channel by simply adjusting the amount of
each track’s send knob. Send tracks also offer tremendous
flexibility with regard to stereoization; for example, a dry
track could be panned to one side of the stereo image,
with the effected side panned to the other.

MASTER TRACK

A project has one Master Track. Think of this as the stereo master output the entire mix
gets routed through. Volume, panning, and effects can be added and automated for the
entire project.
To toggle the Master Track view, click the Master button at the top of
the Track List. The button will turn green and the Master Track will
display at the very bottom of the Track List. (The idea is that the Master Track is the
final processing stage.) You can also click Track>Show Master Track in the main page
drop-down menus.
SEND TRACK

Send Tracks are tracks containing an effect, or a chain of effects, and track automation.
Unlike inserting an effect into a standard audio channel, multiple audio channels can
be “sent” to a send track effect using the red channel send knobs in the Mixer tab. A
Send Track is also often referred to as an Aux Bus.
Benefits of using Send Tracks:


Share effects over multiple tracks.



Fine degree of control over dry vs. effect level and 		
dry vs. effects in the stereo field.

placement of

Use effects on a specific portion or section of a tracks 		
automation).

(via



If you’re not super clear on when or why to use Send Tracks, grab yourself a mug o’
Joe and carefully read the sidebar “To Insert or To Send Effects, That Is The Question”
on the previous page; send tracks are really useful and a key to achieving polished,
professional mixes.
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HOW TO ROUTE AUDIO TO A SEND TRACK

Add a Send Track to the project by clicking the +Track button and selecting Add Send
Track. You can also click Track>Add Track>Send Track in the main window menus.
In this example, we’ve renamed the Send Track, “Reverb (SEND 1).”

Click on the track you’d like to add reverb to. Display its track automation
by clicking the Automation button.
Click the Automation Type drop-down menu (by default it will say Track Volume), then
click beneath Sends to select the Send Track effect. In this example, the number 11 is
the track number of the Send Track, and Reverb (SEND) is the Send Track’s name.

Once the Send Track is selected, a knob appears. This sets the amount of signal sent to
the Send Track.

The send level can be set by clicking and dragging the knob up and down. (The mouse
cursor turns into up and down arrows.) You can also set a channels Send Track level
by clicking the Mixer tab at the bottom of the screen and rotating the channel’s Send
knob, but we’ll tell you all about the mixer later on. Keep in mind that numerous
tracks can be sent to the same Send Track. The amount of the track’s audio sent to
the Send Track can also be adjusted via track automation. (For more information, see
“Automation and Controller Mapping.”)
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Wait A Minute
Mr. Post Send
Mixcraft Send Tracks
default to Post-Fader
volume djustment.
This is a sensible
choice for most mix
situations, because it
means reducing the
volume of a track fader
proportionally reduces
the volume of the
Send Track. There are
situations where this
behavior isn’t optimal.
For example, if you’d
like a dry instrument to
be very quiet, but you’d
like the reverbed signal
very loud, Pre-Fader
adjustment is a better
choice.

SEND VOLUME TYPE

This lets you choose at the point in channel’s signal flow where audio is tapped to be
sent to the Send Track. To change the Send Volume Type, right-click on the channel’s
Send knob in the Mixer or on the Send knob displayed when track automation is
visible.

 Dry Adjustment

Audio is sent to the Send Track before the channel’s insert effects or volume fader.
Thus the signal sent to Send Track will have no channel insert effects applied and
the volume fader has no effect on the signal level sent to the Send Track. You’ll
see the word Dry appear next to the track Send knob as a reminder. (i.e. “My 		
channel faders are all down... why do I still hear these wacky effects?!?”)
 Pre-Fader Adjustment

The track’s audio is sent to the Send Track before the volume fader, thus the
volume fader has no effect on the signal level sent to the Send Track. You’ll 		
see the word Pre appear next to the track Send knob as a reminder.
 Post-Fader Adjustment

The track’s audio is sent to the Send Track after the channel volume fader. This
the default setting, and the desired setting in most cases. To find out why, see
the sidebar, “Wait A Minute Mr. Post Send.”
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Using Presets
Optimized For
Send Track Effects
When adding an effect
to a Send Track, we
recommend using a
preset designed for a
Send Track. (They’ll
have the word Send in
the title.) These presets
will already have the
wet/dry mix set to
100% wet in order to
avoid the problem of
having the dry signal’s
volume controlled by
the channel fader and
the effect’s dry signal
balance. If the clean
volume appears to
behave strangely
(“Why can’t I turn
this darn channel
down!%^&?”), click
fx in the Send Track,
then the Edit button
next to the effect.
Now adjust the dry
mix down to 0% and
the wet mix up to 100%.

AUDIO SIGNAL FLOW
Following is a diagram of how the audio signal flow works in Mixcraft. This should
help illustrate all the dry/pre/post business we bored you with before this.
1. Clips (with clip-level automation)

2. DRY-Fader Send
3. Track Insert Effects

3. Track Insert Effects

4. PRE-Fader Send

5. Track volume, pan, and three-band EQ

6. POST-Fader Send
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INSTRUMENT MIX OUTPUT “CHILD” TRACKS
Some virtual instruments have multiple output channels (most commonly virtual drum
kit-type instruments), allowing separate routing and processing of individual sounds.
When a multiple-output instrument is loaded, a + sign appears next to the small
keyboard icon.

If a track has multiple outputs, Mixcraft creates a child track for each output. This
enables independent control of volume, pan, and EQ settings, as well as using applying
independent insert and send effects for each of the instrument’s outputs. This is nice
when you’d like a massive reverb on a snare drum, but want to keep the kick drum dry,
for example.
To set up multiple outputs, click the channel’s keyboard instrument icon next to the
Mute button, then click the instrument’s Outputs>Config… button.

Use the checkboxes to enable individual outputs, or click the All or None button to
quickly enable or disable all outputs (or if you’re an all-or-none type).

Checking the Automatically add all instrument output tracks for Virtual Instruments
box at the bottom will always enable all available individual outs when new multipleout instruments are opened (you can also enable the Automatically add all instrument
output tracks for Virtual Instruments in File>Preferences>Plug-Ins in the main window).
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More About
Multiple-Out Virtual
Instruments
In addition to
configuring Mixcraft
to recognize multipleoutput virtual
instruments, you’ll
likely need to set
up the instrument
itself. Drum-based
multiple-output virtual
instruments typically
feature a built-in mixer
page with output
destination settings.
This is where you’ll
instruct the instrument
to send individual
sounds to Mixcraft’s
separate outputs.
Sampler-type virtual
instruments may not
have a page resembling
a traditional audio
mixer, but may feature
keymaps or groups
with output destination
settings. If you’re
unable to figure it out,
consult the virtual
instrument’s owner’s
manual. We’re big fans
of poking around ‘til
it works, but don’t tell
anyone, ok?

If you do not need all the mix output channels, unused outputs can be shut off by
unchecking outputs. Click the OK button when the outputs are configured as desired.

The + sign in a Multiple-Out Virtual Instrument track hides or displays the view of
child tracks. This won’t affect the audio configuration in any way, but it’s convenient if
you don’t want to fill the screen with tracks from a single multi-out virtual instrument.
SUBMIX TRACK

A SubMix track routes audio to an intermediate track before the Main Mix master
volume. This is very useful as a master volume control for a group of related tracks
such as a drum kit, or multiple tracks of backing vocals. SubMix tracks are also useful
if you’d like to send a group of tracks to one channel-insert-type effect. One common
use would be to send drums or multi-tracked layered backing vocals through a single
compressor instance to “glue” them together.
To create a SubMix Track, click the +Track button and select Add Submix Track. You can
also click Track>Add Track>SubMix Track in the main window menu or right-click in
the Track List area and use the Insert Track menu.
To add tracks to a SubMix Track, drag and drop the tracks onto the SubMix track.
(Make sure to grab tracks in the track list, not clips in the grid; when you move a track,
its clips move with it.) Once tracks are the child of a SubMix track, they can be freely
moved up and down in track list. Besides being directly beneath the SubMix track,
child tracks will indent slightly with a small black region on the left side for easy visible
identification. If the SubMix Track is moved in the the track list, all child tracks move
with it. Child tracks may be shown or hidden by clicking the +/- sign at the far left side
of the SubMix Track.
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Regardless of the show or hide state of child tracks, you’ll see a “ghost” waveform
approximating the sum of all the child track audio waveforms in the clip area next to
the SubMix track. This is particularly handy when SubMix child tracks are hidden.
Volume, panning, solo, mute, insert effects, and automation remain independently
adjustable for SubMix child tracks. Tracks may also be dragged and dropped out of the
SubMix track – drag the track up or down to a location out of the SubMix track and
the track becomes a standard track again.
NESTING SUBMIX TRACKS

SubMix tracks can be nested into other SubMix tracks. This is done exactly like
dragging tracks into a SubMix track. Nested SubMix tracks let you subdivide and
organize tracks with great precision. You might use a nested SubMix track for the toms
of a SubMixed drum kit, or perhaps multi-tracked individual harmony lines in a large
vocal production.
OUTPUT BUS TRACK
An Output Bus Track is typically used to route audio to physical audio outputs when
using audio hardware with multiple outputs, or the outputs of additional audio
interfaces attached to your computer.

To create an Output Bus Track, click the +Track button and select Add Output Bus
Track. You can also click Track>Add Track>Output Bus Track in the main window
menu or right-click in the Track List area and use the Insert Track menu.
ROUTING AUDIO TO AN OUTPUT BUS TRACK

Output routing for audio tracks must be set in the Mixer window.
We’ll talk more about mixer-window stuff in the “Audio Mixer”
chapter, but we’ll take a little detour into mixer land to explain
Output Bus Track routing.
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Click the Mixer tab at the bottom left of the
screen. At the top of each mixer channel, you’ll see
each audio channel’s output selector pop-up. The
bottom half shows the current routing; by default
this will be Main Mix. Clicking on the bottom half
opens a pop-up menu where you’ll select either
Main Mix or any Output Bus tracks you’ve added
to the project. Once selected, the current setting
for a track changes in the lower half of the output
selector pop-up. At the risk of stating the obvious, you can route as many channels as
desired to an Output Bus Track (it is a mixer, after all!).
ROUTING OUTPUT BUS TRACKS TO AUDIO HARDWARE OUTPUTS

If you’re using an audio device with multiple outputs, click on an Output Bus Track’s
Output drop-down menu beneath the level meter (it’ll say Default Playback Device).
Here, you’ll be able to select from your audio hardware’s available physical outputs.
The routing of tracks to physical outputs can also be configured in the Mixer tab; see
the “Audio Mixer” section.

There are many ways to use Output Bus Tracks to enhance a mix. For some swell
examples, check out “Appendix 3: Nifty Uses For Output Bus Tracks.
TRANSMIT MIDI CLOCK/SYNC
If you’re using Mixcraft in conjunction with a self-contained music workstation/
sequencer/beat box type device (like an Akai MPC workstation, a Korg Monotribe, or
maybe that crusty old Kawai drum machine you found in your uncle’s closet), Mixcraft
can be set to send MIDI clock data over a standard MIDI cable. This lets everybody
play together in lock-step. If you find yourself trying to hit the play button on two
devices at once (which never works!), you may need some MIDI clock transmission
action. Here’s how to configure Mixcraft to send MIDI clock data:
1. Open a new MIDI instrument track by clicking the +Track button at the top of the
track list, or click on an existing unused MIDI instrument track.
2. Click the track’s small piano keyboard to open the instrument window.
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3. In the Category list, click <External MIDI Devices>, then choose the name of your
MIDI interface in the Instrument Preset window.

4. In the Instruments window click the Edit button.

5. Check the Send MIDI Clock and Status Messages checkbox.

The pop-window at the top of the window lets
you specify which MIDI channels will receive
MIDI clock data (1-16, or all sixteen channels
simultaneously). When you’re done, click the
X’s in the upper-right window corners to close
the MIDI clock and MIDI instrument windows.
To send MIDI clock on multiple (but not all)
MIDI channels or to different ports on a multiport MIDI interface, you can create multiple
clock transmission “instruments” set to different
single MIDI channels or ports.
ADDING/MOVING/SIZING/DELETING TRACKS
Drag, right-click, or use key shortcuts to add, delete, move, and duplicate tracks.
MOVING TRACKS

Tracks can be moved by clicking and dragging them vertically within the Track List.
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RESIZING TRACKS

Tracks can be resized vertically. Track height can be
increased for easier editing, or decreased to fit
more tracks on the screen simultaneously. To resize
a track vertically, move the mouse to the bottom of
a track and drag up or down. When the mouse is
in the correct location for resizing, the cursor will
become an up/down cursor. Alternatively, you can click Track>Properties>Track Height
and choose a size of small, normal, large, or Super Big Gulp X-Treme™. Okay, maybe
not that last one.
RESIZE ALL TRACKS

You can resize all tracks at once by clicking on the View>All Tracks Height and
choosing a new size.
To resize all tracks to a specific size, hold down the [SHIFT] key, click on the bottom of
a track and drag up or down. All tracks will resize upon mouse release.
DELETING TRACKS

Click on a track to select it. Then click Track>Delete Track, or right-click on the track
and choose Delete Track. All sounds on the track will also be deleted.
CUSTOMIZING TRACK APPEARANCE

Change the color, icon, name or size of tracks.
NAME

The default name for newly created tracks will be “Audio Track,” for audio tracks, or
“Instrument Track,” for MIDI tracks. Tracks can be renamed by left-clicking the current
name and typing. Hit the Enter key or click on another area of the window to finish.
IMAGE

Each track can have its own icon beaneath the the track name for personalization as
well as organization. Choose from twenty stock images or import your own!
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To change the track image, double-click an existing track image or hover over the
track image and click the pop-up button. You can also select Track>Properties>Choose
Image… in the main window drop-down menus, or right-click on a track and select
Properties>Choose Image...
The Choose A Track Image window opens:

1. Select a new image and click OK.
2. Add Your Own Image Or Photo
3. Custom images can be added as well. The following image formats are supported:
		

JPG, BMP, PNG, GIF

To add a custom image, click Add My Own Image File…, navigate to the image to be
added, select the desired image, and click Open. The image will replace the existing
track image and be added to the list of thumbnail images. Note that added images will
be available for future Mixcraft projects, not just the current one.
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TRACK COLOR

Track colors can be individually set by selecting Track>Properties>Track Color in
the main window drop-down menus or (more easily) by right-clicking a track and
choosing Color. This affects the track’s highlight color and all clips on the track.

ADDITIONAL RIGHT-CLICK FUNCTIONS
We know it’s not real neighborly to stick these all the way at the end, but here are some
handy-dandy things you can do by right-clicking the track header.
MIX TO NEW AUDIO TRACK

Mixes all Virtual Instrument or audio clips on the selected track to a single, continuous
audio clip and places it on a newly created track beneath the current track. This has a
couple of practical uses:
 Convert MIDI Virtual Instrument To An Audio Wave

		
		

This is useful if you’re handing off files to another user who doesn’t have Virtual
Instruments you’ve used in a project.
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 Permanently Embedding Insert Effects Or Instruments In An Audio File

		
		

Again, this is useful if you’re handing off a project to another user who doesn’t
have effects plug-ins you’ve used.

 Long-Term Archiving

		
		
		
		

Instrument or effects plug-ins (especially those from software developers in
Uzbekistan) can become obsolete or incompatible with current operating 		
systems/format changes, etc. Converting to “pure” audio files can act as 		
insurance to guarantee projects remain playable for years to come.

DUPLICATE

Creates a copy of the track and all of its clips. This is a time-saver if you want to add
a second part using the same instrument, add a vocal double with the same plugin setup, etc. Also useful if you’d like to do some wild edits and want to retain an
unadulterated version.
FREEZE

Freeze is similar to Mix To New Audio Track; it creates a new audio file with
instruments or effects “burned in” to the file. Unlike Mix To New Audio Track, it does
not make a new track; the audio is created in the background and plays back on the
existing track. Because instruments and effects are part of the newly created audio
file, Mixcraft disables instrument and effects plugs upon playback, thus freeing up
computer processor resources. If you’re using an older or underpowered computer,
Freeze can be tremendously helpful (check out the CPU percentage meter while
playing back projects for reference). Conversely, if you’re using a rocketship computer,
you probably won’t need Freeze.
Frozen tracks can be unfrozen (i.e., converted back to standard tracks with instrument
and plug-ins active) by reselecting the Freeze command (which will say Unfreeze).
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USING CLIPS AND THE
MAIN CLIP GRID
Clips are the “building blocks” of projects. Depending on the clip type, they may
contain audio, MIDI, video, or text for video. In this section we’ll focus on audio and
MIDI clips. Video and video text clips are explained in “Video Tracks and Editing.”
OPERATIONS COMMON TO ALL CLIP TYPES
CLIP HEADER BUTTONS

At the top of every clip next to its name are three tiny buttons:
 Play

Clicking the Play button plays the clip one time.

 Mute

This silences the clip. The clip turns gray and [Muted] appear besides its name.
Click again to unmute it. You can also mute clips by highlighting them and 		
selecting Sound>Properties>Mute in the Main Screen menu.
 Duplicate

Creates copies of the clip immediately to the right.
HIDING THE CLIP HEADER BUTTONS

The Play, Mute, and Duplicate buttons can be hidden or displayed by right-clicking
and selecting Hide Clip Buttons or Show Clip Buttons, respectively. There is no current
provision for hiding or displaying beloved actor, Red Buttons.
MOVING/DELETING/LINKING/LOCKING CLIPS
 Moving Clips

Clips can be freely moved in the Main Clip Grid. To
move a clip, click its title bar and drag vertically or
horizontally while holding down the mouse button.
(The title bar is the top area of the clip where the name is displayed.)
You can also move a clip by using the keyboard. Highlight the clip or clips to be
moved, and press the arrow keys. The clip(s) will move based on the current 		
Snap setting.
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 Deleting Clips

Select a clip or group of clips and then select Edit>Delete from the Main Window,
or press the DELETE key.
 Deleting Parts Of Clips

If only a part of a clip is selected, only the selected part will be deleted. For 		
example, if you’ve recorded a singer and there is an extra audible breath,
select the unwanted area and delete it. Holding [SHIFT] while clicking will delete
the entire clip (or clips if you have regions of multiple clips currently selected).
 Linking Clips

Related clips can be linked together causing them to
move as a single unit. This is useful when moving
video clips with associated audio, multiple-mic drum
recordings, or layered background vocals.
To link clips together, select the clips and click Edit>Link Selected Clips in the
Main Window menus or by right-clicking one of the selected clips. To unlink
clips, simply click the two rings/X button on the clip, or choose the Edit>Unlink
Selected Clips. If there are multiple clips linked together, you can unlink just one by
choosing Edit>Unlink This Clip.
 Locking Clips

Clips can be locked to prevent them from being moved
or resized. To lock a clip(s), select it then click
Sound>Properties>Lock from the Main Window menus
(or by right-clicking the clip). Clips can be unlocked
the same way; simply click in the same menus to uncheck locking. Clips can also be
locked and unlocked using the Sound tab.
 Cropping and Trimming Clips

You can trim the start and end of any clip. Moving the mouse
to the right or left edge of a clip will change the cursor into a
left/right resize arrow. Hold the mouse down and drag to
resize or trim. For more precise adjustment, zoom the view in closer. The left or
right edge of will trim based on the current Snap setting. If a clip won’t trim to a
specific length, check the Snap setting; you may need to set the value to Off.
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 Crop From A Selection

A specific region can be cropped by making a selection over a clip, or a group of
clips, and selecting Edit>Crop from the Main Window menus or by right-clicking
and selecting Crop.
Before cropping:

After cropping:

 Looping Clips

To create additional loops of a clips, move the
mouse onto the left or right edge of the clip.
The cursor will turn into a left/right arrow.
Click and drag the right edge of the clip; when the length of the clip exceeds the
length of the Loop Start and Loop End points (defined in the Sound tab), a new
loop begins.
The indentations in the bottom of a clip indicate the loop start and
end points. Additional loop copies can be created by clicking the +1
Loop button to the immediate left of the clip’s name.
 Remove Space Between Clips

This eliminates silent gaps by moving clips together. It does not combine clips into
one big sound – it just scoots clips closer together. Select Edit>Remove Space
Between Clips from the Main Window Edit menu.
 Cutting/Copying/Pasting Clips

To cut and paste a clip, select a clip, or a portion of one, by dragging over it. Select
Cut from the Main Window Edit menu, then click in the Main Clip Grid to position
the Caret in the desired destination. Select Paste from the Edit menu to paste to the
Caret location.
Copying clips work exactly as above, just select Copy instead of Cut and the original
clip will remain. You can also Cut, Copy, or Paste by right-clicking the mouse.
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 Alt-Drag Copying

To duplicate selected clips, hold down the [ALT] key and click-drag copy of the clip
to a new location.
MERGING

To merge two or more audio or virtual instrument clips on the same track, select the
clips and then click Sound>Merge To New Clip in the Main Window menus.
Before a merge:

After the merge:

Reasons To Merge Clips


Multiple virtual instrument clips are on one track and you’d like to print out
sheet music for the entire track, but the notation view only displays one clip at a
time. Merging clips together allows notes to appear correctly in the notation view.



Multiple audio clips have been recorded with the same noisy air conditioner in
the background and you’d like to use noise reduction function to remove the A/C
noise all at once (as opposed to applying it to each clip individually.



The current project has hundreds of clips and the workspace is getting confusing
and slow. Merging the clips to one sound cuts down on resources for increased
computer speed and additionally, will unclutter the workspace

SELECTING CLIPS

A selection is an area of clip highlighted for editing.
 Drawing A Selection

Click and drag the cursor over a region to create a selection. The selection is
displayed as a transparent purple rectangle. Selections obey the Snap setting.
(“Transparent Purple Rectangle” would be a fabulous name for a psychedelic band.)
The selection drag may be started on the timeline, a clip, or a track body.
 Selecting An Individual Clip or Multiple Clips

To select an individual clip, click on its title bar. The
clip will have a white outline when selected.

To select multiple clips, hold down the [CTRL] key and click on the title bars of the
clips to be selected.
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 Selecting A Region of a Clip

To select part of a clip, click and drag in the bottom
section of a clip (beneath the
Title Bar). The cursor will change to an I-beam to
simplify selection.

Selection Shortcuts
Action

Shortcut

Description

Selecting All Clips
On A Lane

[CTRL]+[SHIFT]+[ALT]+A

Choose Track> Lanes >Select
All

Selecting All Clips
On A Track

[CTRL]+[SHIFT]+A

Choose Track>Select
All Clips On This Track.
Alternatively, double-click a
track header.

Selecting All Clips
In Project

[CTRL]+A

Choose Edit>Select All

Unselect Clips

[Esc]

Deselect any selected clips.

Select Next Clip

[Tab]

A quick way to select the
next clip.

Select Previous Clip

[SHIFT]+[Tab]

A quick way to select the
previous clip.

 Other Selection Operations

Once regions are selected, they may be cut, copied, and pasted. Here are some less
obvious operations that can be done with selected regions:






Boosting or reducing audio levels		
Creating fades		
Cropping clips		
Linking clips		
Merging clips






Normalizing clips
Removing space between clips
Setting Loop to Crop
Trimming silence
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INSERTING TIME INTO A PROJECT

Regions of time may be inserted into the project. This automatically repositions all
markers, automation, and clips. This is useful, for example, if you’re far into a project
and decide to add another chorus in the middle of the song.
To insert a region of time, create a selection in the
Timeline by click-dragging either in the Timeline, or
in an empty area of the Clip Grid. Select Edit>Insert
Selected Time in the Main Window menus, or by
right-clicking in the Timeline. The picture on the
right shows the resulting effect on the timeline and
clips. All other clips, markers, and automation to the
right of the insertion point advance in the project.
REMOVING TIME FROM A PROJECT

Removing works just like inserting time, only in reverse. It deletes markers,
automation, and clips in the removed section and repositions existing markers,
automation, and clips.
To remove a region of time, create a selection by clickdragging either in the Timeline, or in an empty area of the
Clip Grid. Select Edit>Delete Selected Time in the Main
Window menus, or by right-clicking in the Timeline. The
picture on the right shows the resulting effect on the
timeline and clips. All clips, markers, and automation in
the deleted region are removed, and remaining clips,
markers, and automation slide to the left.
AUDIO CLIPS
An audio clip is a clip containing an audio recording. Audio
clips always display a waveform in their lower section.
Existing audio can be added to Mixcraft, or new audio clips
can be created by recording audio into Mixcraft.
MP3, OGG, WMA, WAV or AIF format audio files can be loaded into Mixcraft. New
recordings will be saved as WAV or OGG files and stored in the current project folder.
ADDING AND LOADING AUDIO CLIPS

There are several ways to add audio clips to a project.
 Sound Menu

Click Sound>Add Sound File… from the Main Window menus. Navigate to
a folder, select the sound and click Open. The sound will be placed at the
current Caret location. Alternatively, use [CTRL]+H or click the Add Sound button
on the Main Window Toolbar. The Add Sound button has musical notes on a folder.
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 Double-Click An Empty Area of the Main Clip Grid

Double-clicking in an empty area to the right of an audio track in the Main Clip
opens a dialog for importing audio. The selected audio will be placed at the current
Caret location.
 Add a Sound From the Mixcraft’s Loop Library

Click the Library tab on the bottom of the Mixcraft window. Select a sound from
the library, position the Caret where you’d like the sound to go, then click the +
button next to the sound. Alternatively, you can drag the sound directly into the
Main Clip Grid.
 Drag In a Sound From Windows File Explorer

Open a Window’s File Explorer window and navigate to the sound or sounds to be
added. Select the sound(s) in Windows File Explorer and drag them into the Main
Clip Grid.
AUDIO CLIP PROPERTIES

These settings govern how Mixcraft displays and plays back individual audio clips.
 Channel

If a clip contains a mono audio file, the clip will display
one waveform.

If a clip contains a stereo audio file, the clip displays two
waveforms atop one another.

If the a track’s height is reduced to a small size, stereo clips will display a single
waveform, but don’t worry, it’s still playing back in stereo. (Track height can be
restored to normal size by selecting Track>Properties>Track Height>Normal 		
in the Main Window menus.)
To play back only the left or right channel of a stereo sound, highlight the audio clip
and select Sound>Properties>Channels>Left Channel or Right Channel. (Or Chanel
No5 if smelling nice is your thing.) To restore stereo playback, select select
Sound>Properties>Channels>Stereo.
If a stereo clip is set to play one channel only, Mixcraft addends [Left Channel]
or [Right Channel] to the clip name as a reminder.
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 Phase

The Phase setting allows inversion of either or
both channels in a stereo file. This is useful if
you’re experiencing frequency cancellation as a
result of poorly placed mics, and can also be used
to eliminate monophonic audio content, such as drums, bass, and lead vocals, in
complete mixes. Here are the Phase options for clips:
		 
		 
		 
		 

Sound menu>Properties>Phase>Normal
Sound menu>Properties>Phase>Invert Left Channel Only
Sound menu>Properties>Phase>Invert Right Channel Only
Sound menu>Properties>Phase>Invert Both Channels

 Normalize

Normalizing a sound locates its loudest peak, raises it up to “full scale” (i.e. loudest
level before clipping), and proportionately raises the volume of the rest of the clip.
To normalize a clip, highlight and select Sound>Properties>Normalize. Like
all Mixcraft, normalization is not “destructive,” so it doesn’t permanently alter the
sound stored on your hard drive. To disable normalization, simply go back to
Sound>Properties and uncheck Normalize.
Note: Normalizing essentially makes clips as loud as possible without clipping,
but does not alter dynamic balance like a compressor or limiter.
USING AN EXTERNAL WAVE EDITOR

Mixcraft will work in conjunction with external sound editing software to apply
permanent changes or edits to the sound. External Wave editing software can be useful
for functions not available in Mixcraft, such as editing out pops and clicks.
 Configuring An External Wave Editor

To configure an external Wave editor, select File>Preferences>General. Beneath
External Wave Editor, click the Browse… button, navigate to the Wave editing
software and click to select it.
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 Editing A Sound In An External Wave Editor

Right-click on a sound and choose Edit In External Editor... or choose
Sound>Edit In External Editor... from the menus in the Main Window.
You’ll have the option of editing the original sound or a copy of it. If the original
sound is edited, any changes made to it will be permanent. This is known as
“destructive editing”.
CROSSFADING BETWEEN CLIPS

Crossfading with Mixcraft is so easy that, for all
intents and purposes, it’s automatic. Simply
drag one sound over another and a crossfade is
instantly and visibly created. The length of the
crossfade corresponds to the size of the overlap
of neighboring clips.
REVERSING CLIP PLAYBACK

Audio clip playback can be reversed by highlighting a
clip and selecting Sound>Reverse in the Main Window
menus. (Or “unreversed” by reselecting
Sound>Reverse.) If clip automation has been applied,
remember that envelope points won’t move – they stay
in their original location. Reverse sound playback works especially well with long,
decaying sounds such as cymbal crashes or long piano chords (or if it’s 1978 and you’re
trying to freak your parents out).
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FLEXAUDIO™ TIME STRETCHING
FlexAudio™ allows easy time compression and

expansion by visually dragging the left or right edge
of a clip. While holding the [CTRL] key down, click
on the left or right edge and drag left or right.
The cursor turns into two hands when in FlexAudio™ mode. FlexAudio™
works on audio and MIDI clips. For finer control of clip lengths, set the
Snap value to Off.
VIRTUAL INSTRUMENT (MIDI) CLIPS
A Virtual Instrument Clip is made up of MIDI data and
instructs a synthesizer to play notes (as well as how to
play them).
The tiny horizontal lines inside a MIDI clip represent notes. These correspond roughly
to the length and pitch of the clip’s notes, offering some visual feedback as to its content.
ADDING/LOADING CLIPS
Virtual Instrument Clips can be added in several ways.
 Creating A Blank Virtual Instrument Clip

Blank Virtual Instrument tracks can be created by double-clicking a Virtual
Instrument Track or right-clicking a Virtual Instrument Track and clicking
Add Instrument Clip.
 Recording A Virtual Instrument Clip

Arm a Virtual Instrument Track and use a MIDI controller to record notes.
 Import a MIDI File

Right-click on a Virtual Instrument Track and select Add Sound File...
Select a MIDI file (.MID) and click Open.
Note: If the MIDI file contains more than one track, each track will be loaded
to a separate track and new tracks may be created.
MIDI files may also be loaded by selecting File>Open Project from the Main Window
menus and then selecting a MIDI file.
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Fast Talkin’ With
FlexAudio™
Ever made a 30- or
60-second ad that ran
a couple seconds long?
Try time-stretching it
with FlexAudio™. Ever
heard a lightning-fast
legal disclaimer at the
end of a commercial?
Create the by timestretching by about
75%. Turn off snapping
and FlexAudio™ it to
the desired length.

MIDI BASICS
MIDI is an acronym for Musical Instrument Digital Interface. It is a series of messages
that keyboards and synthesizers use to play notes or change the sounds of instruments.
A Virtual Instrument Track in Mixcraft contains Virtual Instrument Clips, which
contain MIDI data.
MIDI NOTES
When middle C is played on a music keyboard, it sends a short message that translates
to “play middle C.” When you let go of the key, a message is sent that translates to
“stop playing middle c.” In addition, the message contains other information, such as
the MIDI channel and key velocity. There are 16 MIDI channels which allow you to
route MIDI messages. The key velocity is a number from 1 to 127 which describes how
fast the key was depressed. A velocity of 1 would hardly be heard and a velocity of 127
would be full volume.
Each MIDI Note message contains the following information: note value (C0 – G10),
key velocity (1-127), and MIDI channel (1-16)
NOTE VALUE
This is the value of the note. There are 128 possible MIDI notes, ranging from a low of
C-1 to a high of G9.
KEY VELOCITY
This is how fast the key was pressed. Faster velocities usually correspond to louder
sounds or may trigger extra sounds, depending on the synthesizer and sound
programming.
MIDI CHANNEL
MIDI channels can be thought of like lanes on a freeway - each of its 16 channels
contains an independent MIDI data stream. In reality, MIDI messages are sent down the
cable one after the other (i.e. serially), but because the data is moving very quickly, it
behaves as if multiple channels are sent simultaneously (i.e. in parallel). MIDI channels
allow routing of specific channels to specific synthesizers, tracks, or both.
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MIDI CONTROLLERS
A controller is another type of MIDI message that controls other parameters. The most
commonly used controllers are Modulation and Pitch Wheel. A standard MIDI piano
keyboard has two wheels that correspond to modulation and pitch wheel (pitch bend).
 Modulation

This is also known as vibrato and will usually cause the pitch to oscillate around
the note. However, it depends on the synthesizer being used. Modulation has a
value of 0 to 127. (127 is the most extreme modulation)
 Pitch Wheel (Pitch Bend)

This controller usually bends the pitch up or down a half step in pitch. However,
it depends on the synthesizer being used. Pitch wheel or pitch bend has a value
from -8191 to 8192.
 Other Controllers

There are many other controllers allowing real-time variance of synth parameters.
These are assigned a number value of 0 to 127 (corresponding to the controller);
many are standardized. For example, MIDI controller #7 always controls volume.
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MIDI EDITING: CLIPS
Following are MIDI editing operations that can be performed by selecting one or more
clips and either right-clicking or selecting from the Main Window Sound menu. Unlike
the MIDI editors discussed later in this chapter, these operations can be performed
directly “from the clips” without opening a separate edit window.
Below is a summary of MIDI editing operations; after that are detailed explanations of
what each of them does and how to use it.
 Quantize

Moves notes closer to the beat.
 Humanize

Adjusts notes for a looser or tighter feel.
 Transpose

Moves notes up and down the scale.
 Velocities

Adjusts how hard notes are played (usually affecting volume or brightness).
 Offsets

Adjusts note start times.
 Durations

Adjusts note lengths.
 Soloize

Deletes extraneous notes in a performance intended to be one-note-at-a-time.
Regrettably, Soloize will not turn you into Van Halen (but we’re working on it).
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QUANTIZE
Quantization is the process of moving notes closer to a set note value or “grid,” in
order to tighten the timing of sloppy performances. To access the Quantize menu,
right-click on a MIDI clip or MIDI data in the Piano Roll Editor and select MIDI
Editing>Quantize...

 Note Type

Specifies the snap setting to quantize to.


		
		


		


		

If this is set to eighth-note but you’re actually quantizing a whole note, it will
not adjust the length of the note to an eighth-note, but rather align it to the
closest eighth-note.
If the Start Times box is checked, then the start times of each note will be
quantized to this note type.
If the Note Ends box is checked, then the end times of each note will be
quantized to this note type.

 Start Time

Click the checkbox next to Start Time and then choose a Note Type setting. Mixcraft
adjusts all notes to the closest beat or partial beat, based on the Note Type.
 Note Ends

Mixcraft adjusts the note endings to the closest beat or partial beat, based on the
Note Type.
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 Swing

If you want to quantize with swing, click Swing and choose an intensity %. Swing
will offset every note that is on an odd beat, depending on the quantize note start setting.
For example, if you had a recording of eighth notes, set the Note Type to eighth-notes
and then set swing to 30%; every other eighth-note would be offset by 30%.
Before: “Unswung” eighth notes.

After: Quantized eighth notes with a 35% swing. Swingin’, baby!

 All or Selection

Choose whether to quantize the selected notes or all the notes in the current virtual
instrument clip. (Only apples if a region is highlighted within the Piano Roll Editor.)
Before quantizing.

After quantizing Start Times and Note Ends to 1/8 Notes.

HUMANIZE
Humanizing is the process of adding a random and more “humanized” feel. When
entering MIDI data via the mouse and using snap, music can sound stiff and artificial;
Humanize lends a more natural feel.
Right-click on a MIDI clip or MIDI data in the Piano editor and select MIDI
Editing>Humanize...
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 Max Adjustment

The maximum note duration to humanize towards.
 Start Time

Specifies if we are humanizing the start time with options for Early, Late, or 		
Random timing.
 Duration

Specifies whether Humanize affects note durations with options for Early, Late
or Random timing.
 Note Velocities

Allows randomization of note velocities with following options:
 Randomize by

– A percentage of the original note value.

 Randomize in range – A new note velocity is randomly chosen in the range entered.
 All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual
instrument clip. (This applies only if a region of notes has been highlighted within
the Piano Roll Editor.)
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Before humanizing – velocities the same on every note:

After humanizing – randomized velocities:

TRANSPOSE
The Transpose dialog allows shifting of all notes or selected notes in a clip by octaves
or semitones. Right-click a MIDI clip or MIDI data in the Piano Roll and select MIDI
Editing>Transpose...

Choose Octave(s) or Semitone(s) from the Transpose By drop-down menu, then enter
the amount and click OK.
To transpose selected notes only, click the Selection radio button.
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VELOCITIES
The Velocities dialog allows adjustment of all or selected note velocities. A MIDI
velocity indicates how hard the note has been struck. The range is from 1 to 127.

Right-click a MIDI clip or MIDI data in the Piano editor and select MIDI
Editing>Velocities…
 Adjust By

Adjust velocities by a specific percentage.
 Force To

Specify a velocity to adjust all notes to. The valid range is from 1 to 127.
 All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual
instrument clip. (This applies only if a region of notes has been highlighted within
the Piano Editor.)
OFFSET NOTES
Offset Notes allows adjustment of all notes or the selected notes time offsets. Right-click
a MIDI clip or MIDI data in the Piano editor and select MIDI Editing>Offsets…
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 Offset Direction

Choose left or right.
 Offset Amount

Note values are:






Whole notes		
1/2 notes		
1/4 notes		
1/8 notes		
1/16 notes		







1/32 notes
1/64 notes
1/4 triplet notes
1/8 triplet notes
1/16 triplet notes

Choose the number of the note value chosen. For example, you could choose
to offset by three 1/8 notes.
 All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual
instrument clip. (This applies only if a region of notes has been highlighted within
the Piano editor.)
DURATIONS
Note Durations allows adjustment of all notes or selected note durations.
Right-click on a MIDI clip or MIDI data in the Piano Roll and select MIDI
Editing>Durations…

 Adjust By

Adjusts notes durations by a percentage.

68

 Force To

Note values are:






Whole notes		
1/2 notes		
1/4 notes		
1/8 notes		
1/16 notes		







1/32 notes
1/64 notes
1/4 triplet notes
1/8 triplet notes
1/16 triplet notes

 All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual
instrument clip. (This applies only if a region of notes has been highlighted within
the Piano Roll Editor.)
SOLOIZE
Soloize is a unique function that modifies the note data in a MIDI clip by forcing it to
play one note at a time.
Right-click on a MIDI clip or MIDI data in the Piano editor and select MIDI
Editing>Soloize…
For example, if you played a clarinet part and accidentally hit some overlapping notes,
you could use the Soloize feature.
Before soloizing:

After soloizing:
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DOUBLE
Duplicates the current clip and merges them, creating one large double-length clip.
Before doubling:

After doubling:
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MIDI EDITORS:
PIANO ROLL EDITOR
These editors allow precise creation and manipulation of MIDI note and controller
data. Depending on your particular needs, each is suited to different purposes. Since
they simultaneously update, you may freely switch between them.
Double–click on a MIDI clip in the Main Clip Grid to open
the Sound tab, then click Piano to open the Piano Roll editor.

The Piano Roll is named for its resemblance to the punched paper rolls used in old
player pianos. The Piano Roll editor features a graphical interface with pitches
indicated vertically with a piano keyboard reference. MIDI notes are displayed as blue
rectangular boxes with width indicating duration. MIDI notes are freely movable and
lengths can be edited by clicking and dragging the right side of a note. To open the
Piano Roll Editor, double-click a virtual instrument MIDI clip or right-click a MIDI and
select Edit. Clicking a key on the keyboard on the left will sound notes.
PIANO ROLL TOOL BAR
This how the Tool Bar appears when the Piano Roll Editor is selected:
There are three main editing tools available on the Piano Roll Editor toolbar:


Arrow Note Selection Tool

Used for note selection, moving, and editing note durations. It can be selected
with the keyboard shortcut Q.


Pencil Tool

Used for drawing new notes in the Piano Roll grid. It can be selected with the
keyboard shortcut W.


Eraser Tool

Clicking notes with the Eraser tool removes them from the grid. It can be
selected with the keyboard shortcut E.
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 Note Duration Buttons

These work in conjunction with the pencil tool when drawing in new notes in the
grid. Choose whole-note, half-note, quarter-note, eighth-note, sixteenth-note, and
thirty-second note values. You can also select the dotted and triplet node modifiers
for converting standard note values to dotted and triplet values, respectively.
 Default Velocity

Specifies the velocity for new notes drawn in with the Pencil tool.
 Snap Value

Determines the minimum note value that notes will snap to when creating new notes,
moving pre-existing notes, and moving loop markers. Dependent upon the current
zoom view level, Snap To Grid setting automatically changes the snap value to the
current grid size. This setting works well in most situations. If you’re working on a
track with a three-count based time signature, use the Snap To Grid (Triplets) settings.
 Selecting Notes

Click on a note to select it. Alternatively, select the Arrow tool and drag a selection.
All notes that fall within the selection rectangle are selected. Hold the [SHIFT]
or [CTRL] key to select multiple notes. Double-clicking a note on the piano roll
keyboard will select all notes of that value. Click anywhere beside a note (or 		
pressing the [ESC] key) will deselect it.
Notes may also be selected by duration and velocity by clicking the MIDI Editing
button on the Piano Roll editor toolbar and choosing Select By Duration... or
Select By Velocity...
These functions are useful for edits such as weeding out unwanted short or very
lightly played error notes.
[TAB] and [SHIFT]+[TAB] select the next note and the previous note, respectively.
Tab™ will quench your thirst without the extra calories of other leading soft drinks.
Note: After selecting a note, if new notes are added, they will take on the length,
duration, and velocity of the previously clicked on note.
 Moving and Copying Notes

In either arrow or pencil mode, select a note or notes and drag. Move the note or
notes by dragging up, down, left, or right. The piano roll will auto scroll if notes
are dragged beyond the current window view. Note destinations are based on the
Piano Roll’s current Snap setting. To maintain the note’s timing location, hold the
[SHIFT] key down while dragging up or down. Holding down the [ALT] key will
copy selected notes.
 Resizing Notes

Place the mouse on the left or right edge of a note. The cursor will become left/right
arrow, and notes can be resized by dragging horizontally. Resizing will be aligned
based on the Piano Roll’s current Snap setting.
72

Before resizing:

After resizing:

 Resizing Multiple Notes At A Time

If more than one note is selected, they may be simultaneously resized. This can
be convenient if you want all the notes to be staccato, for example.
 Editing Notes In Detail

Notes or groups of notes can also edited by right-clicking and selecting Edit...
The note edit dialog opens and allow you to edit specifics, including:
		 
		 
		 
		 
		 
		 

Start time (Measure, beat and fractional beat)
Duration (Measures, beats and fractional beats)
Note value (A0-G10)
Velocity ON (1-127)
MIDI Channel (1-16)
Velocity OFF ( 0-127)

ERASING/DELETING NOTES
Select the eraser tool and click unwanted notes. Notes can also be erased individually
by selecting them and using the [DELETE] key. D
ERASING/DELETING NOTES WITH THE SELECTION RECTANGLE
Drawing a selection rectangle over part of a note or multiple notes will delete only the
area of the notes in the selection region (this is handy for “evening up” the ends of
several notes simultaneously). Holding the [SHIFT] key while clicking will delete the
the entire note (or notes) regardless of what portion of them is currently selected.
SNAP
The Piano Roll has a dedicated Snap control, allowing editing and movement of
notes to exact measure and beat positions. All piano roll note sizing and movement
operations conform to the Snap value setting. If you’re unable to move or resize a note,
try turning off (or lowering the note value of) the Piano Roll Snap.
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COPY, CUT, PASTE AND CLIPBOARD OPERATIONS
Notes or groups of notes may be cut, copied, or pasted as with any other data. You can
use the keyboard shortcuts, or simply right-click on the Piano Roll editor and select
the appropriate operation. Once you copy, cut, or paste notes, the notes reside in the
clipboard. Notes may be pasted at the current Caret location.
ALT+DRAG QUICK COPY
Holding down the [ALT] key and dragging selected sounds copies the selected sounds
and moves them to the new position.
LOOPING CLIPS
As with Audio Clips, the Loop Start and Loop End points of MIDI Virtual Instrument
Clips can be set to make clips loop. Specifically, this means the area of the clip that
plays back can be smaller than the area containing MIDI notes. To move a loop point,
click and drag the Loop Start or Loop End point and drag.
In the image below, the loop begins at measure 1 and ends at measure 3. Let’s say we’d
like to modify the loop points to start at measure 2 and ends at measure 3. Here’s what
we being with:

Drag the Loop Start point to measure 2:

Once you’re satisfied with the loop, you can extend the clip in the Main Grid to loop it
as many times as desired.
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CONTROLLER INFORMATION
MIDI controller data can be edited at the bottom portion of the Piano Roll editor in the
Sound tab. One type of controller data is displayed; the currently displayed controller
data type can be selected by clicking the pop-up menu to the left. Controller numbers
currently containing data are displayed in bold font in the pop-up menu.
CHOOSE THE CONTROLLER TYPE
Click the drop-down menu on the left hand side to pick a specific controller – referring
to the image below, click on (1) Modulation Wheel toward the bottom left.
Choose from the following controller types:




Note-On Velocity		
Note-Off Velocity		
Program Change		





Channel Pressure
Pitch Wheel
Modulation

Click in the pop-up menu field and type in a controller number from 0 to 127. If the
clip contains controller information for a specific controller, the controller number
appears in bold in the pop-up list.
EDITING CONTROLLER DATA
There are two modes in the controller window:
 Drawing
 Erasing
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Select the eraser tool to erase controller data. Select either the arrow or pencil tool
to draw controller data.
In this example, we’ll modify the velocity of the notes so that it ramps up. Here’s how
it looks initially. Each line represents the velocity of a note in the Piano Roll above it:

Now we’ll click and drag the mouse to draw the following shape. The dark blue region
under the Piano Roll represents the area we’ve drawn. If more room is needed to edit
the controller data, simply click on the bar at the top of the controller area and drag it
vertically to resize the controller area.

EDITING VELOCITIES OF SELECTED NOTES
The velocity of selected notes can be
edited by holding down the [SHIFT]
key and drawing over the velocities.
This can be extremely useful in
situations where other notes start at
the same time, or in other situations
where it can be difficult to adjust the
velocity of one note without affecting
neighboring notes. Note that only
the velocities of the selected Ab
notes are being edited.
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PRECISE EDITING OF CONTROLLER INFORMATION
Right-clicking in the controller data field offers additional options.
Note: Right-clicking in the controller data field works does not work for note velocity.

 Add Controller

Right-click the mouse in an area with no controller data and select Add Controller
to insert controller data at an exact value. A dialog box opens and specific values
can be entered.
 Edit Controller

To edit existing controller data with increased precision, right-click it and select Edit
Controller… A dialog box opens and specific values can be entered.
For all controllers, besides Velocity, you can right-click to add, edit, or delete
controller information.
 Delete Controller

Removes all controller data of the current type for the current MIDI clip.
 Delete All Controllers

Removes controller data of all types for the current MIDI clip.

77

MIDI EDITORS: STEP EDITOR

Mixcraft’s Step Editor is a grid-based editor that should be familiar to users of classic
Japanese “X0X” drum machines, but it’s far more flexible with no limitations on the
number of instruments or available steps. It excels at creating and editing drum
patterns, but its built-in scale maps also allow fast creation of musical patterns. Once
the Step editor is configured, notes are added and deleted by simply clicking in grid
squares. This is fast, easy, and fun way to create drum parts or other pattern-based
music.
STEP EDITOR TOOL BAR
Here’s how the Tool Bar appears when the Step Editor is selected:

The tools and functionality are largely the same as the Piano Roll editor, with two
primary differences:
1. Because the Step editor grid inherently defines the note values, the toolbar musical
note values seen in the Piano and Score editors are hidden. Set the grid resolution by
clicking the Steps drop-down menu and choosing a note value (Sixteenth-note is a
good starting point).
2. The piano keyboard on the left of the window is replaced by a list of specific notes
called the Voice List.
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Arrow Tool

Notes can be selected by choosing the Arrow tool in the toolbar and clicking on
them. Use this to delete notes, drag to new locations, or to highlight notes for
velocity and other controller info adjustments (the vertical bar beneath the note 		
will turn red).


Pencil Tool

Notes can be added or removed by selecting the Pencil tool in the toolbar and
clicking in grid locations.


Eraser Tool

Use the Eraser tool to delete grid notes. Though note grid locations can be
“turned on and off” with the Pencil tool, the Eraser tool is handy for quickly
erasing many grid notes by click-dragging it over multiple grid locations.
VELOCITY

Sets the MIDI velocity of notes added to the grid. These can be edited later using the
Velocity (Note ON) vertical lines below.
MIDI EDITING

Provides the standard Mixcraft MIDI editing parameters for quantization, transposition,
etc., but by and large, most of the MIDI Editing options defeat the purpose of using the
Step editor. (You wouldn’t want to quantize to swung triplets if you had the Step Editor
grid set to sixteenth-notes, for example.)
STEPS

Defines the size of each step in the grid. For traditional “X0X”-style drum machine
programming, set this to sixteenth-notes.
SCALE/DRUM MAPS

Selects which voices (i.e. notes of the scale) are displayed in the Voice List in the
column at left. If set to Chromatic, MIDI notes are shown in conventional format, e.g.
A1, C3, etc. Selecting a custom Drum Map (aka “Voice List”) displays individual names
for each note. This is particularly useful when programming drums, as notes can have
descriptive names such as, “Bass Drum”, “Snare Drum”, or “Explosive Megametal Flame
Encircled Gong.”
The Scale select field automatically changes and updates the voice list when new
Acoustica Instrument drum kits are selected. For more information, see Configuring
The Voice List below.
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Super Quick Music
Creation with
Step Edit
Here’s one way to
rapidly created
semi-random musical
phrases with the Step
Editor: Click the Add/
Edit button, choose a
scale with the Select
Mode controls, then
click-drag the mouse
across an octave or
two of notes on the
Step Editor Notes
Chooser keyboard.
Click OK in the Step
Editor Notes Chooser
keyboard window. Set
the Steps drop-down
to sixteenth-notes
and select the Pencil
tool from the toolbar.
Now click random grid
positions, making sure
not to click two notes
vertically. This creates
semi-random melodies
within the note limits of
the selected scale.

COPY TO

The Copy To menu allows you to export patterns created in the Step editor.
 Copy To>Performance Panel
		 Exports the current Step editor pattern to the current track’s first available

		 Performance Panel set location. The exported region will be between the Loop
		Start and Loop End markers, so make sure these are in the desired locations
		 before exporting.
 Copy To>Performance Panel

		
		

Exports the current Step editor pattern to a new MIDI clip on the currently
selected track at the Caret location.

CONFIGURING THE VOICE LIST

The most unique aspect of the Step editor is that unlike most other MIDI editors,
Step editor does not display all MIDI notes. Not only can you choose which notes are
displayed, you’re free to rearrange their order in the list at the left of the editor. This
is very handy when working with drum parts, as the list can be set to display just the
notes you’ll be using.
The list of of notes is called the Voice List (to avoid confusion
with the MIDI notes in the grid). Notes are always displayed
top to bottom, i.e. highest notes at the top, lowest notes
appear at the bottom.

There are a couple of ways to add notes to the note list.
 If you’ve already recorded a MIDI clip, double-click the MIDI clip, and and click
		 the Step button in the toolbar. Mixcraft will automatically create a Voice List
		 with all notes used in the selected clip. These can be edited with the Step Editor
		
Voice Chooser keyboard by clicking the Add/Edit button.
(keep reading to find out how to use the Step Editor Voice
Chooser keyboard)


		
		
		
		

To create a custom Voice List from scratch, select an empty MIDI track in the
Track List, right-click in the Main Clip next to it and select Add Instrument Clip
to create an empty MIDI clip. Double-click the MIDI clip, and click the Step
button in the toolbar. To add MIDI notes, click the Add/Edit button. This opens
the handsomely rendered Step Editor Voice Chooser keyboard:
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USING THE STEP EDITOR VOICE CHOOSER

To add notes to the Voice List with Step Editor Voice Chooser keyboard, simply click
keys on the keyboard. Notes (i.e., voices) can be removed by right-clicking. The
keyboard keys will turn beige for newly selected notes; keyboard keys turn green if
there are notes in the grid already using the “voice”.
 Select Mode
		 This limits note selections to a specific key signature, scale, or mode. If notes

		
		

outside of the chosen key or scale are clicked, they won’t be added to the Voice
List. Scale and mode choices include:


Chromatic



Dorian



Major



Mixolydian



Minor



Harmonic Minor



Pentatonic Major



Blues



Pentatonic Minor

 Clear

		
		
		

This deletes all unused voices from the current Voice List. If there are notes
“played” on the grid (i.e. MIDI events played or drawn in), the “used” voices
cannot be deleted from the Voice List.

PREVIEWING NOTES IN THE VOICE LIST

Clicking the note name in the Voice List will sound the note.

CHANGING A NOTE IN THE VOICE LIST

To change an existing note in the Voice List, click the down
arrow next to the note name. A MIDI keyboard will open
on-screen; simply click a new note. All notes in this row of
the grid now play the newly selected note.
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VOICE LIST RIGHT-CLICK MENU

Extra functions are available by right-clicking a
note in the Voice List, or in the gray area
beneath it.

 Add Voice

		
		

This opens a keyboard and lets you add new voice(s) by clicking a key (or
multiple keys) on the displayed keyboard.

 Voice Chooser

		 This is the same as clicking the Add/Edit button. It opens the Step Editor Notes
		Chooser keyboard and allows voices to be added or deleted from the Voice List.
 Select Notes

		
		
		

Selects all notes played by the current voice in the grid. This is useful for moving
a voice’s notes to a different voice (by dragging), or for 				
quickly deleting all of a voice’s notes.

 Delete

		
		

Removes the voice from the Voice List and all notes for the voice on the grid.
Careful with this one!

 Remove Unused Steps

		

Deletes all voices with no notes on the grid.

If you’re using a drum virtual instrument, instead of notes, you can view the names
of individual drums in the left column. In the Sound tab, select a drum map from the
Map drop-down control. Mixcraft will choose the appropriate drum map if it is already
mapped.
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CREATING CUSTOM DRUM MAPS (ADVANCED)

To create drum maps with individual custom instrument names (per-note), go to the
%programdata%\Acoustica\Mixcraft\drum-maps7\ folder. (if you’re using Mixcraft
Home Studio, go to the %programdata%\Acoustica\MixcraftHS\drum-maps7\ ) Here
you’ll find text files representing Mixcraft’s included Drum Maps. The text format is as
follows:
[MIDI Note Number] [Drum Hit Name]
For example, if you had a virtual instrument called Big And Dumb Drums with a sound
called Mega Kick on MIDI note 54, you would add the following line:
54 Mega Kick
The file would be saved as Big And Dumb Drums.txt in the %programdata%\Acoustica\
Mixcraft\drum-maps7\ folder.
Once Mixcraft is restarted, the new Drum Map appears in the Scale/Drum Maps list.
The final step is to add a default mapping in order to automatically select the correct
Drum Map when the Big And Dumb Drums virtual instrument is selected.
Open the file called Default-Drum-Mapping.csv in either Excel, Open Office Calc, or
Google docs. The file is comma delimited for columns and quote (“) delimited for text.
Fill in the following fields and save the document:
 Map File

		

The name of the file you just created, ie: “Big And Dumb Drums.txt”.

 VST GUID

		 This is a special value uniquely identifying the VSTi. Open up your Log file after
		 having used the plug-in to get its VST GUID. Your log file will be located at
		%appdata%\Acoustica\Mixcraft.
		 The following example shows how to find the GUID for the Bass Synthesizer
		VSTi.
		
		

15:39:16 [635 mils] : VST: C:\Program Files (x86)\Acoustica Mixcraft 8\		
VST\3rdParty\Alien 303 Bass Synthesizer.dll”

		

15:39:16 [635 mils] : VST found in registry.

		

15:39:16 [635 mils] : {4A2F286F-0000-0000-0000-000000000000}
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VST Name
If there isn’t a GUID, use the exact name from the log file.
Preset #
This is the preset the drum patch resides on.
Comments
No need to keep those comments to yourself; put them here.

Once you’ve defined the above parameters, save the file and load the virtual
instrument.
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MIDI EDITORS:
SCORE EDITOR
Mixcraft allows editing, viewing, and printing in notation or sheet music form. Virtual
Instrument Clips may also be viewed in the Score Editor.

EDITING NOTES

Mixcraft allows note editing on the staff directly. By editing the size and position of the
piano bar, you can change the way the notation is displayed.
Here’s a typical quarter-note with its associated piano bar:

After clicking the piano bar, it turns blue.

To move a note, click and drag on the blue section. To resize a note, move the cursor
onto the left or right edge of the blue section and drag horizontally.
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To retain the note time offset and drag up or down, hold the [SHIFT] key down while
dragging.
SCORE TOOLBAR

This is how the Toolbar appears when the Score Editor is selected:

There are three main editing tools on the Score Editor toolbar:
Arrow Note Selection Tool



Used for note selection, moving, and editing note durations. It can be selected
with the keyboard shortcut Q.
Pencil Tool



Used for drawing new notes on the staff. It can be selected with the keyboard
shortcut W.
Eraser Tool



Clicking notes with the Eraser tool removes them from the staff. It can be
selected with the keyboard shortcut E.
 Note Duration Buttons

		
		
		
		
		

These work in conjunction with the pencil tool when drawing in new notes in
the grid. Choose whole-note, half-note, quarter-note, eighth-note, sixteenthnote, and thirty-second note values. You can also select the dotted and triplet
node modifiers for converting standard note values to dotted and triplet values,
respectively.

 Default Velocity
		 Specifies the velocity for new notes drawn in with the Pencil tool.
 Snap Value

		 Determines the minimum note value that notes will snap to when creating new
		 notes, moving pre-existing notes, and moving loop markers. Dependent upon
		 the current zoom view level, Snap To Grid setting automatically changes the
		 snap value to the current grid size. This setting works well in most situations.
		 If you’re working on a track with a three-count based time signature, use the
		Snap To Grid (Triplets) settings.
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 Tidy Notes

		

Since a performance won’t always present itself as
nicely as printed sheet music, Tidy Notes attempts to
clean up the display of recorded note data.

		 For example, if you played a quarter-note but shortened the note by a 32nd note
		 duration, the software would show a dotted 8th-note tied to a 32nd-note with a
		 32nd-note rest. Yikes... this would look like the following:
		

		

To remedy the situation, set the Tidy Note level to an
8th note or less.
		

		

After changing the Tidy Note level, the note appears
as a quarter-note.

The drawback is that 16th notes could potentially appear as 8th notes. Of course, you
can always set the Tidy Note level to 16th notes and edit any incorrect bars.
PRINTING

Once a clip is properly selected, click the Print... button on the Score toolbar or press
[CTRL]+P to print. To include the author and title in the printed version, enter the
appropriate text in the Author Information section of the Project tab.
CHANGING CLEFS

Right-click on a clef and choose from the following:


Treble & Bass



Treble



Bass

This changes the clef for the entire track.
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What’s the difference
between a Voice List
and a Drum Map?
Good question. A Voice
List is the list of notes
you see displayed
in the Step Editor.
Depending on how
you’ve configured it,
it will consist either
of boring MIDI note
names (i.e. C4, C#4, D5,
etc.) or slightly-moreexciting text names,
such as “kick drum”,
“snare”, “tambourine”,
etc. The important
thing to remember is
that the Voice List only
shows the voices you’ve
selected to display
(using the Add/Edit
button).
A Drum Map is a
small document
stored on your hard
drive containing a
list of names for each
instrument in (usually)
a multi-sampled
drum kit. The Voice
List may or may not
currently display all the
instrument names in
the Drum Map. When
a Drum Map is loaded,
you can add or hide
specific sounds using
the Add/Edit button.
If you’re computersavvy, you can create
your own custom drum
map templates. (See
Creating Custom
Drum Maps).

SOUND TAB
Click the Sound tab at the bottom left of the screen to edit and set parameters for
audio, MIDI, and video clips with greater precision. The sound tab will display
different parameters and graphics depending on what type of clip is currently selected.
Sound Tab Navigation Bar

The Sound Tab Navigation Bar allows clip previewing, vertical and horizontal zoom
in/out, and lets you hide or show the Sound Tab Parameter Editor. Its appearance and
operation are the same whether editing audio or MIDI notes.
Preview

The preview play button at the top of the Sound Tab Navigation Bar plays
back the currently selected clip.
Zoom Controls

The up/down magnifying glass and left/right arrow icons adjust the current
vertical and horizontal zoom view of the current audio clip. The zoom
controls have no effect on the sound.
Hide Sound Tab

The dual left arrows hide the sound tab parameters for increased
viewing size.
SOUND TAB (WITH AUDIO CLIP SELECTED)

Pitch, key, loop points, and time stretching can be set and edited in the Sound tab. The
Sound tab defaults to Mixcraft’s standard wave editing window view shown above.

88

INTEGRATED MELODYNE PITCH EDITING (MIXCRAFT PRO STUDIO 8 ONLY)

You can switch between standard wave editing and
Mixcraft’s integrated Melodyne functionality by clicking
the Editor and Melodyne buttons above the wave
display area. For a tutorial on how to use Melodyne, see Appendix 1: Using Melodyne
For Basic Vocal Tuning. Melodyne is an amazing vocal tuning (and creative) tool. It’s
worth the upgrade price to Mixcraft Pro Studio 8 on its own!
 Name Field

The name of the currently selected clip appears here. (“Crash” is the name of the
clip in the above screenshot.) To edit a clip name, click on the name text and type
a new name. Changing the name of audio clips from the Mixcraft library will not
affect the filename in Windows Explorer, only within the current project.
 Lock/Unlock

Clicking the Lock icon will prevent changes to the clip’s Loop Start, Loop End, and
Snap Point. Lock also prevent clips from being moved in the grid.
 Mute /Unmute

This is the circle-with-a-cross-through-it next to the Lock icon that mutes or
unmutes the clip. When muted, all instances of the clip will turn gray. The Mute
Sound button in the Sound tab is interchangeable with the Mute Sound button on
clip itself – you can mute or unmute with either button.
 Time Signature

This lets you set the time signature of an audio loop with individually settable
numerator (beats per bar) and denominator (note value constituting a beat). Keep
in mind that the time signature setting has no effect on the sound; it only changes
the placement of beats on the ruler above the waveform to simplify setting in/out
points and looping.
 Use Project Tempo/Time Stretch

Mixcraft plays audio clips in one of two time-domain modes:



Use Project Tempo
Time Stretch
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 Use Project Tempo

In this mode, Mixcraft adjusts sounds based on the difference between the project’s
tempo and the sound’s detected tempo. For example, if the project tempo was 120
BPM and the sound’s detected tempo was 60 BPM, it would time-stretch the sound
to be half as long, because it would be playing the sound back two times as fast.
However, a project’s tempo many not remain constant throughout. For example,
in a transition between two songs, you could slowly ramp the tempo up with
multiple tempo changes. In Use Project Tempo mode, Mixcraft dynamically adjusts
the playback rate of audio to maintain perfect synchronization based on the current
tempo. This offers lots of latitude to mix and match loops of various tempos.
To set the loop speed by tempo, click Use Project Tempo. The numeric display will
show the loop’s original tempo. Enter a tempo by clicking in the number field to the
right, or use the up/down arrows.
 Time Stretch

In this mode, the sound is simply time stretched by a fixed amount. The sound
will not adjust to the project tempo. You’ll most likely use Use Project Tempo mode
most of the time, but there are situations when automatic tempo change isn’t
desirable. For example, if you had a long drone with no inherent tempo, and you
didn’t want its length affected. Fortunately, Mixcraft’s audio playback mode is
settable on a per-sound basis, so you can mix and match modes as you please.
To set the loop speed by percentage, click the Time Stretch and enter a percentage
value by clicking in the field, or by using the up/down arrows.
 Double/Half-Speed

If the current clip is set to Use Project Tempo mode, clicking on the 2x button will
play loops at double speed. Clicking once will play the loop at half-speed, a second
click will play the loop at double-speed, and clicking a third time will return the
loop to standard playback speed.
Note: Loops can be slowed down or sped up by up to four times their normal
speed (i.e. 25% - 400% of normal playback speed). If values set are above or below
this, Mixcraft “maxes out” at 25% - 400% normal playback speed.
 Key/Pitch Adjustments

Mixcraft plays audio clips in one of three key/pitch modes:




Use Project Key
Transpose
No Pitch Adjustments
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Changing The Key Of
A Sound, aka Songs In
The Key of Right
Assuming that the key
of the sound is correct,
you can change the
key of a sound by
adding markers with
key changes and/or by
changing the project’s
key. You do not need to
change the key of the
sound on the Sound
tab. It’s recommended
to change the project
key or add key change
markers. In short, if
you want to change
the key of a sound,
change the project key.
(Changing the key of
a sound should only
be done if the detected
key is wrong!) If the
sound’s key is wrong,
you can adjust it with
the Original Clip Key
control.

 Use Project Key

Mixcraft adjusts the pitch of the sound based on the difference between the project’s
key and the sound’s key. (The project key can easily be seen and adjusted in the
transport bar display.) For example, if the project key was F# and the sound’s key
was F, it would adjust the pitch of the sound up by one semitone so that it was in
tune with F# instead of F.
However, you can have more than one key change in a project. A sound in Use
Project Key mode will adjust in real-time to the correct number of half steps in
order to play in the correct key based on the most recent key change. To continue
the example, if the sound was in F and there were two key changes to A and then G,
it would correspond to shifting the pitch of your sound by four semitones up to A
and then by two semitones up to G.
Mixcraft adjusts the pitch by the shortest distance between two keys. For example,
if the project key was G and the sound’s key was F, it will adjust it by +2 semitones,
instead of -10 semitones.
 Transpose

This gives manual control over the playback key of audio. It’s useful if you don’t want
audio to follow Mixcraft’s project key setting or obey key changes on the timeline.
You can type in a partial amount such as 1.26 semitones or use the up/down to
adjust pitch in semitones up to 24 semitones in either direction. You might use this
option to fix a slightly off key vocal performance or transpose a sound into a key
you are more familiar with.
 No Pitch Adjustments

If Use Project Key and Transpose are both deselected, No Pitch Adjustments appears
beneath the buttons and audio will play “as is” with no pitch transposition.
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SOUND TAB – TIME SUB TAB
These controls let you fine tune a clip’s
location in the Main Clip Grid as well
its length and looping parameters. If the
project is set to Beats mode in the top
toolbar (next to the handsome Mixcraft 8
logo) the edit boxes display in measures,
beats, and partial beats. If the project is
set to Time mode, the edit boxes display
positions in minutes, seconds, and
milliseconds.
Helpful Hint: You can use the mouse
scroll wheel to quickly set values by
clicking in the number fields and
spinning.

 Offset

The offset setting defines a clip’s location in the Main Clip Grid.
 Length

The length setting defines the size of the clip. If the length value setting is longer
than the entire audio clip, the clip will repeat until it reaches the set length value.
The clip will show “indentations” in the bottom where it repeats.
 Loop Start/End

Defines a clip’s playback start and end points. Example: say you like the second half
of a four-bar loop, but don’t like the first half. Changing the Loop Start setting from
1:1:0 to 3:1:0 will skip playback of the first half. Loop start and end points can be
set either by clicking in the number fields in the Sound>Time tab, or by moving
the Loop Start and Loop End markers in the audio waveform display. You can also
set a clip’s start and end points by grabbing and moving its start and end points in
the Main Clip Grid. Regardless of how a clip’s start and end points are set, all
displays will update.
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 # Loops

The number of times a loop will repeat. (This setting can potentially overlap with
the Length setting – changing one automatically updates the other.)
SOUND TAB – AUDIO SUB TAB
Here you’ll find some useful extra
parameters.

 Channels

If the audio clip is stereo, the pop-up menu selects regular stereo playback or left
or right channel only. If left or right channel is selected, playback becomes mono
and the channel pan slider will control panning. (If a clip is playing in stereo, the
pan slider acts as a balance control.)
 Phase

Normal plays in standard stereo; Invert Left, Invert Right, and Invert Both flips the
waveform phase 180 degrees of each respectively.
 Noise Reduction

Mixcraft features built-in noise reduction feature for audio clips. Noise may be
background hum, clicks and pops, or any other unwanted sound (not including
your band’s drummer). However, Mixcraft’s noise reduction works best on
steady-state noise such as fans, air conditioners, or other constant noises throughout
the recording.
93

To use Mixcraft’s noise reduction, highlight
the audio clip you’d like to remove the
noise from, then click the Sound tab on the
bottom. Now click the Noise Reduction
button next to the slider, and select a value
up to 100%. Once an amount is selected,
Mixcraft attempts to locate a good noise
sample. Mixcraft displays the noise sample
region between the Noise Start and Noise
End markers.

The image above shows an example of a good noise sample. The noise sample
region can be edited by clicking and dragging the Noise Start or Noise End controls.
To automatically locate the next best noise print, click the Find Next Noise Sample
button next to the Noise Reduction slider. (It’s the button with the green downward
arrow on a wee waveform.) This instructs Mixcraft to look for the next best noise
sample based on what it thinks might be noise.
 Finding A Noise Sample

The best candidate for noise reduction is a snippet of the noise by itself. For 		
example, if you had an air conditioner in the background and began recording,
there would likely be a second of the air conditioner by itself – this would make
an ideal noise sample. If you don’t have a good sample of the noise, you could
potentially record the noise by itself and then merge the clips together. Once you’ve
located a good noise sample, highlight it in the audio tab, then right-click and select
Set Noise Reduction From Selection.
 Normalize

Checking the Normalize check box automatically increases the peak level of an
audio waveform to full 100% scale while proportionally increasing the level of
the entire waveform. In this way, audio files will play back as loudly as possible
before clipping. Unlike a compressor or limiter, the dynamic range of a sound
is not altered; normalization simply makes the entire waveform proportionately
louder. Like most Mixcraft audio processes, normalization is non-destructive,
so unchecking the Normalize checkbox will return the waveform to its original
gain state.
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 Formant Preservation

The Formant Preservation checkbox allows Mixcraft
to maintain the harmonic “imprint” of a sound 			
when transposing pitch up or down. This is useful
for avoiding the “chipmunk” effect when transposing
vocals upward,and conversely, the “aging–born–			
under–a–bad–sign–bluesman” effect when 				
transposing downward.

Why Does Mixcraft Ask If I Want
To Change My Project’s Tempo?
If you’ve tried dragging loops from the library onto the
playback grid, you’ve probably seen this window. You may
have clicked Yes, not knowing exactly what it meant.
Understanding the relationship between project tempo
and the timing of clips used in a project is important, so
read on!

 File Path

Not really a parameter per se, but the actual file 			
name as displayed in Windows Explorer is shown 		
in yellow text for reference. Clicking the yellow 			
folder icon to the left of the filename opens the 			
enclosing Windows Explorer folder. This can be 		
time saver if you’re trying to determine where the 		
original file is located on your drive.
 Format

Again, not an adjustable parameter, this displays the
current audio clip’s format (e.g., WAV, Ogg, etc.), as
well its sample rate, bit depth, mono/stereo, etc.
SHOW/HIDE CONTROLS BUTTON
Click the [<<] Show/Hide Controls button to see
more sound data, instead of the controls. This toggles
between showing and hiding the controls. To show the
controls again, click the [>>] button.
WAVE SNAP POINT, AUDIBLE CLIP REGION,
LOOPING, AND PLAY HEAD
The looping and audible region of a sound has a
white background. The unused parts of the sound are
shown in green. If the clip is “closed down” smaller in
the Main Clip Grid than the entire looped region, the
unused section of the loop will have a gray background.
The adjustable points in the waveform display are as
follows:

When a new, empty Mixcraft project is opened, the project
tempo setting is displayed in the transport in beats per
minute. (If you want to get a feel for the tempo, click the
Metronome icon, then click the Play button.)
Most of Mixcraft’s included loops are beats or musical
phrases, and are precisely edited to be an even length to
ensure that they’ll loop smoothly. They contain embedded
information that “tells” Mixcraft their original key and
tempo. (You can see the original key and tempo when
browsing clips in the Library tab.)
For example, a new Mixcraft project and its tempo was
set to 100 BPM. If a 90 BPM loop is placed at at bar one,
it won’t play in time with the project tempo. It also won’t
line up to bars and beats very well. If we drop in a second
loop with a native tempo of 163 BPM at bar one and
play back, it’ll be a timing train wreck. This is where the
Use Best Sounding Project Tempo window comes
in. Clicking Yes when this window pops up automatically
changes the project’s tempo to match the first loop’s
native tempo. Additional clips dragged into a project are
automatically adjusted to match the project tempo. Now
everything plays in sync. Mixcraft works a similar kind of
magic with key signatures by transposing imported clips
to match the project key signature (which is displayed and
adjustable in the Transport Bar).
(Continued Next Page)
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(continued from
previous page)

 Snap Point Marker

Why Does Mixcraft
Ask If I Want
To Change My
Project’s Tempo?
You can set how
Mixcraft handles
matching the project’s
tempo and key to
imported sounds in the
Preferences>Project
menu.

The red vertical line defining the position a clip snaps to in the Main Clip Grid. Set
the Snap Point marker by clicking and sliding at the marker’s top or bottom (the
cursor will turn into left/right arrows), or by right-clicking and selecting Set As Start
Time. Right-clicking and selecting Reset Start Time will return the Snap Point
marker to its original position. Sometimes this guy likes to hide behind the Loop
Start marker, so if you don’t see it, try moving the Loop Start marker (just 		
remember to move it back where it needs to be).
 Loop Start

Defines the point where sound playback begins. To position Loop Start, click and
drag at the top of the marker (the cursor will turn into left/right arrows). You can
also set it by right-clicking in the waveform and selecting Set Loop Start.
 Loop End

Defines the point where sound playback ends, because all good loops must come
to an end. To position Loop End, click and drag at the top of the marker (the cursor
will turn into left/right arrows). You also set it by right-clicking in the waveform and
selecting Set Loop End.
Loop points can be returned to their original positions by right-clicking and
selecting Reset Loop Points.
96

If the “Change Project
Tempo and Key To
Match First Sound”
check box is checked,
Mixcraft will always
match the project
tempo and key
automatically for the
first imported sound.
If the “Ask To Change
Project Tempo and Key
To Match First Sound”
box is checked, Mixcraft
will politely ask first.
If neither box is
checked, Mixcraft won’t
ajust the project tempo
or key when the first
sound is imported, so
be careful! You can
also disable both check
boxes by clicking the
“Do Not Prompt Again”
check box in the “Use
Best Sounding Project
Tempo, Key & Time
Signature” window.

 Playhead

Just to keep things clear, that yellow line with the flag is the
same Playhead as the one in the Main Clip Grid. You’ll notice
that it moves in both windows simultaneously.

SOUND TAB TOOLBAR (WITH AUDIO CLIP SELECTED)
 Snap To Grid

This determines the snap value when selecting a waveform region, as well as
moving the play insert and loop start/end markers. When set to Grid, items will
snap to the ruler markings in the timeline, directly above the waveform.The ruler
markings vary in size depending upon horizontal zoom level. Grid (Triplets) is best
suited for music with a three feel, i.e. 3/4 or 6/8 time signatures.
 Copy Selection To

		

The Copy Selection To command
exports the currently highlighted audio
wave region to one of the following:

 Copy Selection To> Performance Panel

		
		

Places the selected region in the highlighted cell of the Performance Panel.
If no cell is currently selected, the sample will be placed at the first open location.

 Copy Selection To> Alpha Sampler
		 A new instrument track with an Alpha Sampler is created, and the selected

		

region will be loaded into Alpha Sampler.
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 Copy Selection To> Omni Sampler

		 If there are no instances of Omni Sampler in the current project, selecting
		Copy Selection To> Omni Sampler>New opens a new instrument track with
		 an Omni Sampler, and the sample is placed on the C4 sample pad. If Mixcraft
		 detects an existing Omni Sampler, this is displayed when Copy Selection To>
		 Omni Sampler is displayed. At this point you can export the audio region to an
		 existing Omni Sampler, or select New to create a new Omni Sampler instance on
		 a new track. Samples exported to an existing Omni Sampler instance will be
		 loaded into the first open cell above C4.
 Copy Selection To> Track

		
		
		
		
		

The selected region is imported to a track in the Main Clip Grid. The region is
placed at the current playhead location on the current audio track. If the 		
currently selected track isn’t an audio track, the region is placed on the first
audio track. (Be careful, the region can potentially land beneath existing audio–
you won’t see it unless you slide the existing audio up or down.)

 Slice To…
		 The Slice To… button cuts up audio regions and exports the “slices” to the

		
		
		
		
		

Performance Panel, Omni Sampler, or directly to a Mixcraft audio track.
Though the audio slices can be any length, you’d typically use this for cutting
up a section of loop or a song into smaller chunks allowing you to create new
beats or loops (using small slices), rearrange sections of a song (with larger slices),
or anything in between. Clicking the Slice To… button opens this window:

		

The Slice By pop-up menu selects from the following options that define how
the sound will be sliced ‘n’ diced:


			

Beats slices by the note value defined in the pop-up menu to the right.
This works well for slicing beats and loops into small “chunks.”
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		  Measures works the same as Beats, but is defined in number of measures in
			 the pop-up menu to the right, making it more appropriate for larger chunks
			of music.
		 
			
			
			

Transients slices according to audio transients detected by Mixcraft.
The sensitivity level is defined by the slider to the right according to the
amplitude level in percentage; the lower the slider setting, the more sensitive,
thus creating more slices.

		  Warp Markers slices according to the location of warp markers; you must
			 have warp markers already created in the audio region (see “Warp”).
 Limit To Selection

If a region of audio is currently selected, checking this box ensures that only audio
within the selected region is exported as slices.
 No Slices Before Measure 1

This prevents the export of slices before the first measure of a loop.
(Desirable if you’ve manually relocated a loop’s start point.)
 Confine To Loop Area

Checking this box ensures that slices are only exported from audio between
the Loop Start and Loop End markers of the current clip.
 Create MIDI Loop

This creates a MIDI clip of all slices, playing consecutively and places it on the
newly created Omni Sampler track at the current Carat location. Playing back this
clip will sound exactly the same as playing the entire source loop, but now you’ll
have the ability to edit each slice (or drum hit) in Mixcraft’s MIDI editors, opening
the door to all kinds of creativity such as changing sounds, varying drum patterns,
etc. If you like playing with beats, Create MIDI Loop is a powerful and fun feature.
 Send To

Selects the destination for exported slices.


		
		
		
		

Performance Panel exports slices to the Performance Panel. The first slice
appears in the currently highlighted grid location, and each additional slice
lands in the next grid location to the right. If you’d like slices to land in on a
particular track, it’s a good idea to highlight the desired grid location prior to
exporting slices.
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Omni Sampler exports slices to individual Omni Sampler cells. If the pop-up
menu to the right is set to New, Mixcraft creates a new track with a blank Omni
Sampler loaded. If there are existing instances of Omni Sampler, these can be
selected in the pop-up menu. To begin exporting, click OK. Exported slices
begin loading at the cell number selected in the Start At selector. If a cells
already contain samples, Mixcraft will skip them and continue loading at the
next open cell location.
Track exports slices to the currently selected audio track, beginning at the
current playhead location in the Main Clip Grid.

 Warp

Warping audio lets you adjust the timing of audio by detecting the locations of
transients or “hits,” then effectively time-stretching and -expanding small regions
between transients within an audio file. This offers powerful creative and corrective
options. Used on a smaller piece of audio, such as a drum loop, warping lets you
correct the timing of poor playing, or requantize audio for different rhythmic feels.
When applied to an entire song, warping makes it easy to lock up the tempos and
feels of songs, allowing easy mixing and creation of song “mash-ups.”
Mixcraft’s warping tools are easy to use; not only can Mixcraft interpret tempo,
time signature, and beat locations to assist in the placement of warp markers,
Mixcraft includes an Autowarp function that automatically locates warp information
and places warp markers.

HOW TO USE WARP

1. When Warp is clicked in the Sound Tab Toolbar, Mixcraft scans the currently
		 looped audio region and makes educated guesses as to tempo, time signature,
		 and beat locations.
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The blue lines shown display the predicted beat locations, and black lines show
transient hits. The blue and black lines have no effect on sound, but the
predicted beat locations are very helpful when placing warp markers as
described on the next page.

2. Once the predicted beat locations and transient hits are displayed, set the Audio
		 Tab’s snap setting to Snap To Grid. (This makes the Caret snap to predicted beat
		 and transient locations.) Now click on beats and transients to place the Caret,
		 and add red Warp Markers by clicking the Add Warp Marker button in the
		 toolbar (or right-click and select Add Warp Marker). If you don’t want
		 neighboring hits or audio areas to be affected, place “safety” Warp Markers
		 on hits before and after the hits or areas to be manipulated.
		

3.
		
		
		
		
		

Once Warp Markers are in place, they can be freely moved left and right to
squeeze and stretch audio in time. It’s easiest to hear the effects of warping by
pressing the green Sound tab play button and moving the Warp Markers in
real-time during playback. Feel free to experiment - like all Mixcraft audio
processes, warping is non-destructive, and its operation is easier to wrap your
head around when you’re actually using it!
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4. To remove a Warp Marker, right-click it and select Clear. To remove all Warp
		 Markers from a loop, click the Clear button in the Sound Tab Toolbar.
 Autowarp

Autowarp analyzes audio material and automatically places Warp Markers at
relevant points. It’s particularly useful for “mashup” mixes where two unrelated
songs are to be mixed together. There are four strength settings ranging from sloppy
to tight. Tighter settings add more Warp Markers and affect timing more strongly,
whereas looser settings add fewer Warp Markers and have less effect on the timing
of audio content. By all means, experiment, as different source material responds
better to different settings.
 Warp Quantize

Warp Quantize allows audio material to be quantized much like MIDI notes by
intelligently squashing and stretching rhythmic hits in source material.
 Note Type

		

This is the quantize value; transients will be moved to the closest note value.

 Sensitivity

		
		

The amplitude a transient must reach before Mixcraft considers it a “hit” to
quantize to.

 Strength

		
		
		

Regulates how close hits will be moved in time toward the quantize values. 0%
won’t move transients at all, whereas 100% would move transients all the way
to the quantize point.

 Swing

		
		
		
		

As stated on-screen, Swing value delays the start time of every other note.
Your ears will recognize this as the sound as the rhythmic feel of old blues
music, “Take The A Train,” or any Bobby Brown hit from the 80s. The 		
percentage sets howmuch every other note is delayed.
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 All/Selection

		
		

A setting of All applies Warp Quantization to the entire audio clip. Selection
quantizes only the highlighted region.

SOUND TAB WITH MIDI CLIP SELECTED
The Sound tab enables eding of a MIDI clip’s speed, pitch, key, grid placement, and
looping parameters.

 Name Field

The name of the currently selected clip appears here. To edit the name, click on
the name text and type a new name. Click outside of the name field when done.
 Lock/Unlock

Clicking the Lock icon prevents a clip from being moved in the grid. It also disables
cropping and resizing.
 Mute /Unmute

This silences the clip. All instances of the clip will turn gray. The Mute Sound
button in the Sound tab is interchangeable with the Mute Sound button on clip
itself – you can mute or unmute using either button.
 Time Signature

This lets you set the time signature of a MIDI clip with individually settable
numerator (beats per bar) and denominator (note value constituting a beat). Keep
in mind that the time signature setting has no effect on the sound; it simply
changes the placement of beats on the ruler in the selected MIDI editor to the right
of the Sound tab.
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 Setting MIDI Clip Playback Rate

Mixcraft plays MIDI clips in one of two time-domain modes:



Use Project Tempo
Time Stretch
			

 Use Project Tempo

MIDI clips will lock to the current project tempo. Original Clip Tempo is displayed
and can be altered by clicking the number field and entering a new temp, or by
using the up/down arrows.
 Time Stretch

To set the playback rate by percentage, select Time Stretch and enter a number
value by clicking in the field, or by using the up/down arrows.
 Key/Pitch Adjustments

Mixcraft plays MIDI clips in one of two key/pitch modes:



Use Project Key
Transpose

 Use Project Key

		

Mixcraft adjusts the pitch of the sound based on the
difference between the project’s key and the sound’s
key. (The project key can easily be seen and adjusted in
the transport bar display.) For example, if the project
key was F# and the sound’s key was F, it would adjust
the pitch of the sound up by one semitone so that it
was in tune with F# instead of F.

		
		
		
		
		
		

However, you can have more than one key change in a project. A sound in Use
Project Key mode will adjust in real-time to the correct number of half steps in
order to play in the correct key based on the most recent key change. To 		
continue the example, if the sound was in F and there were two key changes to
A and then G, it would correspond to shifting the pitch of your sound by four
semitones up to A and then by two semitones up to G.

		
		
		

Mixcraft adjusts the pitch by the shortest distance between two keys. For 		
example, if the project key was G and the sound’s key was F, it will adjust it by
+2 semitones, instead of -10 semitones.
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		The MAJ/MIN popup selector conforms notes to the correct major or minor
		 scale notes for the selected key signature. (It’s mainly there to ensure that the
		 correct key signature is displayed when using the Score editor.)
SOUND TAB> TIME SUB TAB
These controls let you fine tune a clip’s location in the Main Clip Grid as well its length
and looping parameters. If the project is set to ` mode in the top toolbar (next to the
handsome Mixcraft 8 logo) the edit boxes display in measures, beats, and partial beats.
If the project is set to Time mode in the top toolbar, the edit boxes display positions in
minutes, seconds, and milliseconds.
Helpful Hint: Use the mouse scroll wheel to quickly set values by clicking in the
number fields and spinning.

 Offset

The offset setting defines a clip’s location in the Main Clip Grid.
 Length

The length setting defines the size of the clip. If the length value setting is longer
than the entire audio clip, the clip will repeat until it reaches the set length value.
The clip will show “indentations” in the bottom where it repeats. If the sound is
made long enough, this will also cause it to loop.
 Loop Start/End

Defines a clip’s playback start and end points. Loop start and end points can be
set either by clicking in the number fields in the Sound>Time tab, or by moving
the Loop Start and Loop End markers in the Piano, Step, or Score editors. You can
also set a clip’s start and end points by grabbing and moving its start and end
points in the Main Clip Grid. Regardless of how a clip’s start and end points are set,
all displays will update.
 # Loops

The number of times a loop will repeat. (This setting can potentially overlap with
the Length setting – changing one automatically updates the other.)
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PROJECT TAB

The Project tab is primarily used for information and
notes about the project. All fields are can be clicked
and filled in with any text.
The only non-text field is the the folder icon. Clicking
this lets you change the default project save location.
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RECORDING MIDI TRACKS
Unlike an audio clip, which contains an actual recording of digitized sound data, a
MIDI Clip contains MIDI notes. Think of a MIDI clips as a sort of computerized player
piano ... a MIDI clip contains digital on/off messages saying, “hey computer instrument,
play these notes at this time please.” It can also contain fairly detailed information
about how to play said notes: loud or quiet, dark or bright, or perhaps with or without
vibrato.
There are a number of ways to create MIDI clips, but the most common way is to plug
in a USB MIDI controller keyboard, press the Record button, and tickle the ivories
(plastics?). If you have a USB MIDI controller, plug it into an available USB port on
your computer. If you don’t have a USB keyboard controller, you can input notes direct
from the computer’s keyboard using Mixcraft’s Musical Typing Keyboard. (for more
info, see “Musical Typing Keyboard (MTK)”).
SETTING UP A VIRTUAL INSTRUMENT FOR PLAYING AND RECORDING
A Virtual Instrument is like having keyboard instrument that lives inside the computer.
Mixcraft includes a bunch of them, so let’s open one up.
First, create a new virtual instrument track. Click the +Track button at the top left, and
select Insert Virtual Instrument Track. Now click the track’s piano keyboard icon. This
opens a dialog box where instruments can be selected:
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The list on the left side displays categories for quick access to various sound types. If
you’ve already installed third–party instruments, click the <VSTi> category and they’ll
show in the column on the right. Hardware MIDI instruments can be used by selecting
External MIDI Devices (like that DX7 that’s been collecting dust in your uncle’s closet
next to his MC Hammer pants). Otherwise, choose a sound/instrument from the right
hand column. When you’ve made your selection, click the X in the upper–right corner.
Before we record a MIDI performance, let’s turn on Mixcraft’s metronome.
This lets you play in time with the project’s tempo. To turn on the
metronome, click the metronome button in the middle of the transport:
The dialog below opens:

Check the Recording box. This means the metronome will click during recording.
Checking the Playback box makes it click during playback, but we can leave this off for
now. If it’s not already checked, check the Recording Count-In Measures box.
Upon pressing the Record button, this gives a “countdown” before recording begins.
The number selector lets you choose the length of the countdown. Unless your
computer and MIDI keyboard are really far away from each other, choosing 1 bar
should give you plenty of time to get those fingers poised. Hit OK when you’re done.
Once you’ve configured when the metronome plays, you can quickly toggle the
metronome on and off by pressing the M key on the computer keyboard.
We’re almost there! Let Mixcraft know where to begin recording by positioning the
Caret in the grid. This can be done by either clicking in the timeline at the top of the
main window, or by clicking anywhere in the Main Grid. We recommend positioning
the Caret exactly on a number (e.g., 1, 2, 3). To simplify
positioning the Caret, make sure Snap To Grid is selected
in the Snap To menu at the top of the screen.
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Make sure the track is armed for recording – if it’s not red, click on it. Now click the
red Record button in the transport (that’s the one with the red dot), wait four clicks for
recording to begin, and lay down some rock. When you’re done, click the Record
button again to stop (you’ll notice the red circle turns into a square while recording), or
just hit your computer’s space bar. You should have something like this:

To create more MIDI tracks, select empty tracks in the Track List on the left of the
screen and add more instruments as described above.
CHOOSING THE MIDI RECORD INPUT

By default, Mixcraft listens to all MIDI channels for each track, letting you record
multiple tracks of virtual instruments at the same time.
Clicking the down arrow next to the Arm button lets you specify the MIDI input and
MIDI channel the track listens to. For example, if you have two keyboards and want to
record each keyboard on a different track:
1. Set keyboard one to send on MIDI channel 1 and set keyboard two to send on
MIDI channel 2.
2. Click the Arm button on track 1 and select All Input Devices to Receive From
MIDI channel 1.
3. Click the Arm button on track 2 and select All Input Devices to Receive From
MIDI channel 2. You are ready for recording.
Alternatively, you could split one MIDI keyboard into two sections, sending the first
section or range of notes to MIDI channel 1 and the second range of notes to MIDI
channel 2. This would allow one keyboard to behave like two separate ones. (You may
need to check the keyboard’s owner’s manual to see if it’s capable of sending separately
channelized MIDI zones.)
RECORDING MULTIPLE TRACKS SIMULTANEOUSLY

Multiple virtual instrument MIDI tracks can be recorded simultaneously. Simply click
the arm button for each track to be recorded. To record from multiple sources or MIDI
channels, click the down arrow beside the Arm button, then choose the MIDI input
device and/or the MIDI channel you’d like the track to record from.
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AUTOMATIC QUANTIZATION

Quantization automatically “rounds off” the locations of MIDI notes on the grid in
order to clean up minor timing mistakes in performances (or major ones, but we won’t
tell anyone). This typically done after recording a MIDI performance, but Mixcraft also
lets you quantize “on the way in” as recordings are made by clicking the Arm button
down arrow and and selecting Automatic Quantization followed by a note value. 1/16
notes is usually a good place to start for most 4/4-based music.
The word Arm will turn yellow when Automatic Quantization is engaged.
If you’d rather quantize after recordings are made, right-click a MIDI clip and choose
MIDI Editing>Quantize...
LANES
Lanes allow multiple tracks of audio (or MIDI) to occur on the same channel, and are
created automatically when looping is enabled in Takes or Overdub recording mode.
ADDING LANES

Empty lanes can be manually added by right-clicking in the Main Clip Grid and
selecting Lanes>Add (or with the shortcut [ALT]+L). If multiple tracks are selected,
extra lanes will be added to all selected tracks.
DELETING LANES

A track’s bottom-most lane can be deleted by right–clicking and selecting Lanes>Delete.
To delete unused lanes, right–click and select Lanes>Delete Empty Lanes (or with the
shortcut [ALT]+K).
MUTING LANES

All clips on any lane can be muted or unmuted by right-clicking on an empty part of a
lane and clicking Lanes>Mute All or Lanes>Unmute All.
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LANE MIDI CHANNEL ASSIGNMENT

Separate MIDI channels can be assigned to individual lanes when using Virtual
Instruments. This is particularly useful with multi-timbral instruments. To assign MIDI
channels, right-click an empty part of a lane, select Lanes>MIDI Channel, followed by
the desired MIDI channel for the lane.
RECORDING MODE
There are three recording modes:


Takes



Overdub



Replace

To choose a recording mode, click the down arrow next to the track Arm button and
select Recording Mode:

Recording Mode can also be selected by right-clicking in the track header or by clicking
Track>Recording Mode in the Main Window menus. Recording Mode can be set
independently for each track in a project.
The default Recording Mode for audio and MIDI can be independently set in
Preferences>Recording in the Main Window menus.
 Takes

Takes mode is very useful for laying down multiple performances without starting
and stopping each time. It’s generally used in conjunction with Loop Mode wherein
a section is looped and each cycle records a new “take” (see Loop Recording below).
Mixcraft automatically creates recording Lanes to accommodate each pass.

As new takes are recorded, the clips of previous recording passes are automatically
muted. Take clips can freely be moved to their own instrument tracks.		
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When Takes mode is used in conjunction with
punch in/out, it creates a clip on a new lane in the
punch area, but only mutes the portion of the
audio clips in the punch area.
 Overdub

In this mode, all previous clips are heard during recording. Virtual Instrument
(MIDI) tracks default to Overdub mode. This works well for quickly stacking parts.
Each new recording is placed on a new lane. Overdub mode is the default Recording
Mode for MIDI tracks.
 Replace

Replace mode functions exactly the same as Takes mode when recording MIDI
tracks. (We chose this because actually replacing MIDI recording regions would
have made it very easy to unintentionally erase prior performances.)
 Loop Recording

Loop recording allows recording of multiple takes or overdubs without
stopping the transport.
To create a loop, click the Loops mode button in the Transport, then drag the Loop
Start and Loop End markers in the Timeline to set a loop area.
 Punch In/Out

Punch In/Out recording lets you place markers that define where to start
and end recording.
To mark a region for punch in/out recording, click the Punch In/Out button. Set the
Punch In and Punch Out handles in the Timeline.

After setting up a punch area, press record, and the new recordings will be created
inside the punch start and end.
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Be a Loop Mode Ninja
A faster way to set
loop points is to drag a
purple highlight area
either in the Timeline
or Main Clip Grid, then
click the Loop button.
This automatically sets
the in and out points to
the beginning and end
of the highlight region.
(You can also use the
L key shortcut to toggle
loop mode on and off.)
Remember that the
Snap setting affects
where the loop region
markers land; we
recommend setting
this to Snap To Grid
or Bar for more
congruent clips.

You can use the same technique described in the “Be A Loop Mode Ninja” sidebar
for setting Punch In/Out locations.
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RECORDING AUDIO
There are two main ways to hook up recording hardware to your computer.
 Analog Mixer With Sound Card

The outputs of an analog mixer can routed to a sound card’s stereo inputs. (This
may require specific audio cables and/or adapters.) Once a mixer is plugged into the
sound card, microphones and other audio inputs are plugged into the analog mixer.
 Audio Interface

Firewire or USB audio interfaces designed for music production are the best choice,
as they are designed to handle high-quality recording and playback of multiple
audio channels. Many audio interfaces include high-quality mic preamps and
instrument inputs. Some also include MIDI input and output.
CHOOSING AN AUDIO DRIVER
The audio driver is the “go-between” software that allows audio hardware to
communicate with Mixcraft. Mixcraft supports three types of audio drivers:




ASIO
WaveRT
Wave

If you are playing virtual instruments or want to live monitor, you’ll need to use a low
latency setting along with audio hardware and a computer that are up to the task. ASIO
drivers usually offer the best performance, followed by WaveRT. If no other drivers are
supported, choose Wave.
Learn more about setting up audio drivers in “Important Sound Setup Information
RECORD ARMING
Arming a track simply means you’re preparing it for recording. At this time, you’ll want
to make sure the correct audio hardware input is selected and recording level is
optimally set.

To arm a track, click its Arm button; the button will turn red letting you know that the
magic is about to happen. You can also arm the current track with the key shortcut
[CTRL]+B.
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Note: If you’re using Core Audio/Wave RT or Wave audio drivers, the track volume
fader will turn red as shown in the picture above. If you’re using the ASIO audio driver,
the track volume fader disappears. This is normal, and we’ll explain why a little later.
CHOOSING RECORDING INPUT
Mixcraft allows recording from multiple sound cards and different inputs simultaneously.
Many audio interfaces allow recording of multiple inputs simultaneously.
To select the hardware audio device input for recording, click the selector arrow on
the right side of the Arm button. You’ll see a list of all available inputs from your audio
device(s).
Select the device, followed by the input that you’d like to arm for recording.

If you’re recording a mono signal, click the sound device followed by Left or Right
depending on where you’ve plugged into your device. If you’re recording in stereo with
left and right inputs, select Stereo. Pay close attention to this setting, because it’s easy to
unnecessarily record mono input sources (e.g., lead vocals, bass guitar, etc.) as a stereo
file if you’ve set this incorrectly. It won’t hurt anything, but you’ll unnecessarily use
twice as much hard drive space.
After selecting the input, send some audio through the input to verify that the correct
input was chosen. You should see the meters moving on-screen in the recording track.
SETTING THE RECORD INPUT LEVEL
When a track is armed, the volume slider turns
into a red recording level adjuster. Move the slider
to adjust the recording input level. If peaks send
the meter into the red, back off the level. Ideally, the input signal should nominally sit
in the yellow area.
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Important Note: If you’re using an audio device with an ASIO driver (you can check

in File>Preferences>Sound Device), the volume slider will disappear when the track
is armed for recording. This is because ASIO recording drivers do not support input
level adjustment in software. To set the proper recording input level, you’ll need to use
either the input level on your audio hardware or if it doesn’t have one, the output level
control on an external preamp or channel strip. If you don’t have any of these, stand
further away from the microphone. (Just kidding!)
RECORDING MULTIPLE TRACKS SIMULTANEOUSLY
Multiple tracks can be armed simultaneously if your sound device supports it. In this
way, you can record an entire band in real-time, with each input recording to a separate
track, allowing far greater flexibility at mix time. Remember that you’ll need to set the
record input individually for each track.
In this example, we’re using a FireStudio Project audio interface and would like to
record one mono track through the left channel input. To choose an input, click the
Arm arrow for track 1. Click on the name of the audio interface; in our case that will be
FireStudio Project, and choose Left Channel.

On the second track, we’ll record the right channel input. Click the Arm arrow on track
2, followed by the name of the audio interface, then choose Right Channel.
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Both tracks are now armed for recording.
RECORD AN AUDIO CLIP
Once a track (or multiple tracks) is armed, you’re ready to record clips.
1. Position the Caret for recording by clicking on the track.
2. Click the Record button on the transport control to start recording.
3. To stop recording, click the Record button again, or press the [Space Bar].
MONITOR/HEAR YOURSELF
“I need more me!,” said the musician, to every sound engineer who ever lived.
Some sound devices let you listen to the input recording in real-time, or very
close to it, during recording. This is known as software monitoring. To
enable software monitoring for a track, click the arm button, then click the speaker
icon. The speaker icon will turn green to indicate that software monitoring is enabled
for the track.
We recommend using headphones in order to avoid feedback when recording with a
microphone. Closed-ear headphones also help to prevent the click track from bleeding
into mics during recording, and take it from they who know, there’s nothing worse than
the sound of “bleep-bleep-bleep” as the final chord of a flawlessly executed acoustic
guitar performance gently fades.
One caveat when using software monitoring is that audio hardware must be set to a
low latency, otherwise the monitored audio will have an audible delay. For the lowest
latency and best audio performance, use the ASIO audio driver if available. Check in
File>Preferences>Sound Device to see if ASIO is available; you may need to download
and install drivers from the manufacturer of your audio hardware. The downside to
reducing buffer size is, depending on your sound card and computer speed, you may
hear gaps or clicks in the audio. Learn more about setting up your sound device in
“Important Sound Setup Information.”
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HEARING EFFECTS DURING RECORDING

If effects are added, they’ll be audible when software monitoring is on. This is often
desirable, e.g., adding reverb when tracking a vocalist, or when tracking electric guitar
with Mixcraft’s Shred Amp Simulator. Though you’ll hear the effects during recording,
they will not be recorded into the track. In other words, Mixcraft always records dry.
LANES

Lanes allow multiple tracks of audio (or MIDI) to occur on the same channel, and are
created automatically when looping is enabled in Takes or Overdub recording mode.
ADDING LANES

Empty lanes can be manually added by right-clicking in the Main Clip Grid and
selecting Lanes>Add (or with the shortcut [ALT]+L). If multiple tracks are selected,
extra lanes will be added to all selected tracks.
DELETING LANES

A track’s bottom-most lane can be deleted by right–clicking and selecting Lanes>Delete.
To delete unused lanes, right–click and select Lanes>Delete Empty Lanes (or with the
shortcut [ALT]+K).
MUTING LANES

All clips on any lane can be muted or unmuted by right-clicking on an empty part of a
lane and clicking Lanes>Mute All or Lanes>Unmute All.
RECORDING MODE
There are three recording modes:


Takes



Overdub



Replace

To choose a recording mode, click the down arrow next to the track Arm button and
select Recording Mode:
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Saving Time With
a Multi-Input
Recording Template
A project with the
correct inputs and
armed tracks for
multiple-input
recording can be set up
and saved as a project
template. This is handy
if you’re recording an
entire band – the next
time you record the
band, simply load the
template and all inputs
will be ready to go!
(Provided all instruments
and inputs are plugged
into the same inputs…
keep notes!)

Recording Mode can also be selected by right-clicking in the track header or by clicking
Track>Recording Mode in the Main Window menus. Recording Mode can be set
independently for each track in a project.
The default Recording Mode for audio and MIDI can be independently set in
Preferences>Recording in the Main Window menus.
 Takes

Takes mode is very useful for laying down multiple performances without starting
and stopping each time. It’s generally used in conjunction with Loop Mode wherein
a section is looped and each cycle records a new “take” (see Loop Recording below).
Mixcraft automatically creates recording Lanes to accommodate each pass.
Be a Loop Mode Ninja

As new takes are recorded, the clips of previous recording passes are automatically
muted. Audio tracks default to Takes mode. The resulting Clips on Lanes can be
freely moved to their own audio tracks.
When Takes mode is used in conjunction with
punch in/out, it creates a clip on a new lane in
the punch area, but only mutes the portion of the
audio clips in the punch area.
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A faster way to set
loop points is to drag a
purple highlight area
either in the Timeline
or Main Clip Grid, then
click the Loop button.
This automatically sets
the in and out points to
the beginning and end
of the highlight region.
(You can also use the
L key shortcut to toggle
loop mode on and off.)
Remember that the
Snap setting affects
where the loop region
markers land; we
recommend setting
this to Snap To Grid
or Bar for more
congruent clips.

 Overdub

In this mode, all previous clips are heard during recording. This works well for
quickly stacking parts. Each new recording is placed on a new lane.

 Replace

In this mode, existing audio is replaced by new recordings. New lanes are not created.
 Loop Recording

Loop recording allows recording of multiple takes or overdubs without
stopping the transport.

To create a loop, click the Loop mode button in the Transport, then drag the Loop
Start and Loop End markers in the Timeline to set a loop area. Loop regions can also
be set by drawing a purple region in the Timeline or an empty area of the clip grid,
then double-clicking the Loop button. Be aware of the Snap setting when setting
Loop points– it’s usually a good idea to set Snap to the Grid setting.
 Punch In/Out

Punch In/Out recording lets you place markers that define where to start
and end recording.
To mark a region for punch in/out recording, click the Punch In/Out button. The
punch region can set by grabbing the Punch In and Punch Out handles in the 		
Timeline and moving them. A faster way to set the punch area is by dragging a
purple highlight region in the Timeline or an empty area of the Clip Grid and
double–clicking the Punch In/Out button.
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After setting up a punch area, press record, and the new recording will be created
within the punch start and end region.
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LOOP AND SOUND EFFECTS
LIBRARY
Mixcraft’s loop library contains a number of song kits and sound effects for royaltyfree use within your own projects! Feel free to mix, loop, and edit them to your heart’s
content. Mixcraft also offers direct browsing of Freesound.org’s massive online library
of samples.
The Library tab includes categories and an easy-to-use search function that filter which
sounds are currently displayed. This makes light work of navigating Mixcraft’s vast
sound library.
LIBRARY
The top level of the Library’s navigation are the
Category Selection buttons. Here’s what they do:
The Book icon accesses Mixcraft’s huge onboard library of loops, samples,
and sound effects. Book, library... get it?
The Folder icon lets you add Windows Explorer directories, for fast and
easy access to sound files for auditioning and adding to projects.
The Freesound icon allows online browsing of Freesound.org’s immense
(and free!) sample library.
Clicking on the Star next to any sound in the Library marks it as a favorite;
clicking the Star icon displays all favorited sounds.
MIXCRAFT SOUND LIBRARY
The Mixcraft Sound Library refers to all of the loops,
samples, sound effects included Mixcraft. These will
download as needed to your hard drive, but if you have
even a moderately fast Internet connection, downloading
will usually occur quickly enough that you won’t notice
it happening.
Click the Book icon to access the Mixcraft
Sound Library.
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LIBRARY

The Library pop–up menu displays the following choices:

 All

Mixcraft’s included library and user-imported sounds.
 Loops

Only musical and rhythmic loops are displayed. Useful if you’re creating a song by
assembling loops in the Main Clip Grid or Performance Panel.


Samples

The “one-shot” (i.e., not looped) acoustic and electronic drum samples included
with Mixcraft’s sound library. These are particularly suited for creating beats with
Omni Sampler.
 Sound Effects

Only sound effects are shown. These are “non-music” sounds and usually don’t loop
in a rhythmic fashion.
 Imported

Any user or third-party sounds added to Mixcraft’s library. Previously installed user
or third-party sound libraries may show as Library categories.
SORT BY

The Sort By drop-down menus allows filtering of sounds by category.
Choose from the following:





Tempo 			  Name
Key 			  Song Kit
Style 			  Date
Instrument		  Imported Date

The list beneath the Sort By filter changes dependent
upon the currently selected Sort By category.
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SOUND LIST

The Sound List on the right side shows all sounds meeting the current Library and Sort
By criteria. Remember that selecting Library>All shows everything, so we recommend
setting filters to simplify finding the right sound.
SEARCH FIELD

Searching lets you quickly locate specific sounds in the currently selected category and
library. You can search using multiple terms and excluding certain words. Search terms
display in yellow.
For example, if you searched “Drums” and there were too many results, you could
change the search to “Drums Snare.”
If you didn’t want to see a specific type of drum, you can add the exclusion “-” sign.
“Drums -Snare” would show all drum sounds without the word “Snare” in it.
To delete/erase the current search term, either remove it or click the X button next to
the Search box.
Following a search, Mixcraft displays how many items matched the search query.
AUDITIONING SOUNDS

Click the small green triangular Play button next to a sound to audition it. If the
project is currently playing, the invisible superfly DJ inside Mixcraft automatically beat
matches the previewed library sound to the current tempo.Use the scroll bar on the
right to move the Sound List up and down.
ADDING SOUNDS TO AN AUDIO TRACK

Add the last selected sound by clicking the blue + Add Sound button or drag the sound
onto an audio track.


[CTRL] key – hold down the [CTRL] key to select specific sounds.



[SHIFT] key – hold down the [SHIFT] key to select all sounds from the previous
selection to the recently clicked sound.
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SOUND LIST VIEW STYLE BUTTONS

The View Style buttons let you choose how to view sounds in the
Sound List.


Phone Button

Displays the sound name only (and the favorite star) with sound meta data in the
the far right column. Because of the lack of columns, you’ll be able to see a lot of
sounds simultaneously. Sounds can be previewed by clicking on them to start or stop
preview playback. Use the scroll bar on the bottom to view more sounds by moving
horizontally.


List Button

Displays sounds in a single-column list view. This shows far less sounds than the phone
button, but you’ll be able to see all meta data info columns for every sound.
SORTING AND COLUMNS

Sounds can be sorted according to particular column headers by clicking on the
headers. To reverse the sort order, click the column a second time (A–Z becomes Z–A,
for example). By default, Mixcraft the columns as shown above, but there are more
column categories available. and they can be rearranged or hidden. For a power-user
rundown of how to use columns and categories, see “A Sorted Affair: Using Sound List
Columns and Categories.”
FAVORITE

You can Favorite sounds by clicking on the Star next to
its Play button. This turns the Star orange and makes the
sound show up when the Favorites Library Mode button
is clicked (see “Favorites” for more on this).
ADDING SOUNDS TO THE MIXCRAFT LIBRARY

Sounds can be imported from your local hard drive, network locations, or loop CDs.
You can also import sounds from the workspace. Supported file formats include AIF,
MP3, OGG, WMA, and WAV.
To import sounds, click the +Import... button on the Library tab
toolbar. This opens the Import To Library window.
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Importing Sounds
To The Library vs.
Accessing From The
Folder Button
There are actually two
ways to make use of
your own sounds or
sound libraries within
Mixcraft. Sounds may
be imported into the
Mixcraft Library as
described in the Adding
Sounds To The Mixcraft
Library section, or
directories containing
sounds on your hard
drive can be added and
accessed via the Folder
button at the top left
when the Library tab is
clicked.
Importing sounds into
Mixcraft’s library is a
little more work, but
the advantage is that
you’ll be able to enter
information such as
name, length, format,
file type, etc. using the
Edit Library button. In
this way, you can take
advantage of Mixcraft’s
sound library search
criteria to simplify
locating user sounds.
We recommend adding
sounds this way if you
intend to repeatedly
use them in future
projects.

(continued from
previous page)
Conversely, adding
sound directories with
the Library Folder
button is really fast and
easy, but you won’t be
able to add extensive
searchable “meta data”
descriptions to sounds.
We recommend this
method if you suspect
you’ll only use these
sounds for a particular
project.
 Import From

Specifies the directory to import from. Type its name or click the Browse... button
to choose a folder.
 Import To

Choose or type in the Library name to import to. To create a new Library, type
in a name.
 Import Length

– Choose from criteria and a length in minutes. Choose a length
in the drop-down menu to the right.


Import All Sounds



Import Sounds More Than (x minutes)



Import Sounds Less Than (x minutes)

 File Types

This specifies which file types are to be imported.



AIF
WAV




MP3
WMA



OGG

 Default Song Kit

Select or type in a name for a song kit if the imported sounds are to be associated
with a specific Song Kit. This can be easily edited later if need be.
 Guess

If Mixcraft sees certain keywords within the file name, checking Guess criteria
checkboxes will help Mixcraft to automatically assign attributes. These are helpful
when searching for sounds in the Library tab.
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 Style

		
		

– If a keyword is found in the file called “lib-styles-for-import.txt” this will
be considered its style. For example, if a file has the word “Rock” in it, Mixcraft
will set the sound’s style to Rock.

 Tempo

		

– If a number in the range of 40-240 is found, Mixcraft will assume that
this is the tempo.

 Key

		

– If a key is found by itself, such as “Rock-G,” Mixcraft will assume that
“G” is the key of the sound.

 Instrument

		
		

– If a keyword is found in the file called “lib-insts-for-import.txt”,
Mixcraft will consider that word to be its instrument. For example, if a file has
the word “piano” in it, Mixcraft will set the sound’s instrument to “Piano.”

 Copy sounds to library folder

This creates a copy of the sound on the local hard drive under the folder
%programdata%\Acoustica\Mixcraft\UserLibrarySounds\. If importing from a CD,
this option is on by default and cannot be turned off.
 Preserve folder structure when copying

If this is checked, then the folders that contain the imported sounds will be
mirrored in the %programdata%\Acoustica\Mixcraft\UserLibrarySounds\ folder
if you are using the Copy sounds to library folder option. For example, if a sound is
found at C:\folder one\sub folder two\, then it will add the sound to
%programdata%\Acoustica\Mixcraft\UserLibrarySounds\LibName\folder one\sub
folder two\. If this is off, it will place all the imported sounds at the base level in the
user library directory.
 Import

This begins the import. While an import is happening, you are free to edit sounds
or use Mixcraft without interruption.
IMPORTING VIA DRAG AND DROP

To add a single audio file or folder, drag the files and/or folders into the Library
window from Windows Explorer. After dragging them in, the import window appears.
It’s identical to the Import To Library window described previously for the Import+
button, less the Import From, Import Length, and File Type parameters
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 Import To

Choose or type in the library name to import to. To create a new library,
type in a name.
 Guess

If Mixcraft sees certain keywords within the file name, checking Guess criteria
checkboxes will help Mixcraft to automatically assign attributes. These are helpful
when searching for sounds in the Library tab.
 Style

		
		

– If a keyword is found in the file called “lib-styles-for-import.txt” this will
be considered its style. For example, if a file has the word “Rock” in it, Mixcraft
will set the sound’s style to Rock.

 Tempo

		

– If a number in the range of 40-240 is found, Mixcraft will assume that
this is the tempo.

 Key

		

– If a key is found by itself, such as “Rock-G”, Mixcraft will assume that
“G” is the key of the sound.

 Instrument

		
		

– If a keyword is found in the file called “lib-insts-for-import.txt”,
Mixcraft will consider that word to be its instrument. For example, if a file has
the word “piano” in it, Mixcraft will set the sound’s instrument to “Piano.”

 Default Song Kit

Select or type in a name for a song kit if the imported sounds are to be associated
with a specific Song Kit. This can be easily edited later if need be.
 Copy sounds to library folder

This creates a copy of the sound on the local hard drive under the folder
%programdata%\Acoustica\Mixcraft\UserLibrarySounds\. If importing from a CD,
this option is on by default and cannot be turned off.
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 Preserve folder structure when copying

If this is checked, then the folders that contain the imported sounds will be
mirrored in the %programdata%\Acoustica\Mixcraft\UserLibrarySounds\ folder
if you are using the Copy sounds to library folder option. For example, if a sound
is found at C:\folder one\sub folder two\, then it will add the sound to
%programdata%\Acoustica\Mixcraft\UserLibrarySounds\LibName\folder one\sub
folder two\. If this is off, it will place all the imported sounds at the base level in
the user library directory.
 Import

This starts the import. While an import is happening, you are free to edit sounds
or use Mixcraft without interruption.
IMPORTING SOUNDS FROM THE CURRENT PROJECT

Any recording or sound in the current project can be added to the library. Right-click
on an audio clip in the project and select Add To Library. This opens the following dialog:

This works much the same as the prior import options but allows saving of sounds
with plug-in effects and clip envelope parameters.
 Import To

Choose or type in the library name to import to. To create a new library,
type in a name.
 Default Song Kit

Select or type in a name for a song kit if the imported sounds are to be associated
with a specific Song Kit. This can be easily edited later if need be.
 Apply track effects when adding to library

Track effects will be applied to the final library sound.
 Apply clip envelope when adding to library

Clip envelope adjustments will be applied to the final library sound.
 Add

This starts the import. While an import is happening, you are free to edit sounds
or use Mixcraft without interruption.
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DELETING SOUNDS

Simply select the sound or sounds. Right-click and select Delete or press the [DELETE]
button on the keyboard. Mixcraft’s built-in sound library sounds cannot be deleted.
DOWNLOADING SOUNDS

One great Mixcraft feature is that loop library sounds are downloaded on demand from
our servers. If you click the play or add icon, and the sound does not yet exist on your
computer, Mixcraft immediately downloads it from the Internet. (Of course you’ll need
to be online to receive new sounds.)

If you experience download problems, try switching default download servers from
File>Preferences>Library>Loop Library Download in the Main Window menus.
To download more than one sound at a time, right-click on the library and choose
Download All In View. This downloads all sounds in the current view. To cancel all
downloads, right-click and select Cancel Downloads.
SOUND LIST RIGHT-CLICK MENU

Right-clicking on a sound in the SoundList
opens the menu shown.

 Play

Previews the sample the mouse pointer is currently hovering on.
 Add

Places the sound on a new audio track at the current Caret location.
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 Open Containing Folder…

Displays the file and its containing directory in Windows Explorer.
 Add Song Kit To Performance Panel

This nifty command lets you add an entire preconfigured song kit to the 		
Performance Panel in a single mouse click. Make sure Library is set to Loops, and
Sort By is set to Song Kit.
Choose a song kit, right–click on one of its sounds in the Sound List, and choose
Add Song Kit To Performance Panel. An entire pre– arranged “song” is automatically
set up in the Performance Panel with tracks logically assigned by instrument type.
 Download

Initiates downloading of the sound to your hard drive if the sound hasn’t been
downloaded yet.
 Download All In View

Initiates downloading of all sounds currently in view in the Sound List if sounds
haven’t been downloaded yet. This is mainly useful if your Internet connection
is on the slow side; for users with a slow connection, this means you’ll only have to
wait once.
 Show Columns

Displays all available Sound List columns. Checking or unchecking columns will
hide and display them in the Sound List.
(See “A Sorted Affair: Using Sound List Columns and Categories” for more 		
information.)
 Select All

Selects all sounds in the current Sound List window.
FOLDER BUTTON
The Folder button lets you add existing
Windows Explorer directories. This offers
fast and easy access to sound files for auditioning and
adding to projects.
Most operations, such as searching, auditioning
sounds, adding sounds, favorites, etc. operate the same
as Mixcraft Sound Library mode with some minor
differences (see “Mixcraft Sound Library”). We’ll touch
on those in the following pages, but first we’ll show how
to add folders.
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To add a folder, click on the +Add Folder button.
At the risk of the stating the obvious,
make sure the folders you’re adding
contain sounds. Supported file formats
include AIF, MP3, OGG, WMA, and WAV.
Any folders you’ve added are permanently
added and will be visible in all projects.

 MAKE NEW FOLDER

		The Make New Folder button creates a new folder in Windows Explorer.
SOUND LIST

The Sound List is basically the same as when using the Mixcraft sound library, however
the column headers are slightly different; continue reading for more information.
SORTING AND COLUMNS

This operates the same as with the Mixcraft Library, but the column names (and
number of columns) are slightly different. This is because the sound data hasn’t been
imported as with Library sounds – Folder mode is essentially providing a “shortcut” to
Windows Explorer directories, resulting in less descriptive meta data being available for
sorting and categorization (and to be clear, when we say “sound data,” we’re referring
to data that describes the sound, not the sound itself).
For more information on using sorting and columns like a ninja, check out “A Sorted
Affair: Using Sound List Columns and Categories.”
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SOUND LIST RIGHT-CLICK MENU (FOLDER MODE)

Right-clicking on a sound in the Sound List
opens the menu shown. This is a little different
than the Sound Library Right–Click Menu.

 Play

Previews the sample the mouse pointer is currently hovering on.
 Add

Places the sound on a new audio track at the current Caret location.
 Open Containing Folder…

Displays the file and its containing directory in Windows Explorer.
 Show Columns

Displays all available Sound List columns. Checking or unchecking columns will
hide and display them in the Sound List.
(See “A Sorted Affair: Using Sound List Columns and Categories” for more 		
information on columns.)
 Select All

Selects all sounds in the current Sound List window.
FREESOUND.ORG ONLINE LIBRARY
Click this for direct browsing of Freesound.org’s immense (and free!) online
sample library (requires an Internet connection). Freesound.org is a
collaborative repository of Creative Commons licensed audio samples with more than
230,000 sounds and 4 million registered users (as of early 2015).
The sounds range from instrumental phrases and single-notes, to sound effects, field
recordings, synthesized sounds, and a heck of a lot more.
There are three different types of Creative Commons licenses which affect how
you’ll be able to use downloaded sounds. For the full legal lowdown, please see
“Appendix 4: Freesound.Org Creative Commons License Terms.”
Most operations, such as searching, auditioning sounds, adding sounds, favorites,
etc. operate the same as Mixcraft Sound Library mode with some minor differences
(see “Mixcraft Sound Library”). We’ll cover these in this section, but first let’s look at
Freesound.org’s online search features.
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SEARCH ONLINE

 Freesound.org Pop-up Menu

		
		

As of this writing, the only selection choice here is FreeSound.org, but Acoustica
may add other sample download sites in the future.

 License Types Pop-up Menu

		

		
		
		
		
		

As the name would imply, sounds on the Freesound.org are indeed free to
download, and use in your compositions. There are three different types of
Creative Commons licenses each with different limitations on how sounds
may be used. The License Types pop-up menu lets you filter sound searches by
license type.

 All License Types
			 Searches display all three license types; essentially this means License Type

			

filter is turned off.

 Public Domain

			 You’re free to use these samples in your compositions however you like,

			
			


totally free. Karmically speaking, you might want to keep track of the 		
creator’s name and credit them appropriately.
Attribution

			 No, this isn’t the name of a death metal band from Florida. You can use the
			 samples however you like, but you must give credit to its creator, indicate
			 if any changes were made to the samples, and include the following link
			 in the work:
			
			https://creativecommons.org/licenses/by/3.0/
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 Attribution Non-Commercial
			 You can use the samples however you like, but you must give credit to its

			 creator, indicate if any changes were made to the samples, and include
			 the following link in the work:
			
			https://creativecommons.org/licenses/by-nc/3.0/
 Downloaded
		 This button changes the Sound List view to display only samples you’ve already

		

downloaded from Freesound.org.

SOUND LIST

The Sound List is basically the same as when using the Mixcraft sound library, however
the column headers are slightly different; continue reading for more information.


License Diamond/License Column

The little red, green, or yellow diamond next to the Favorite column indicates the
type of license associated with a sound. This is only seen in the Freesound.org
Sound List. The diamonds are as follows:
Diamond Color

Meaning

Green

public domain

Yellow

attribution

Red

attribution non–commericial

Black Diamond is a wicked jam from the first Kiss record, but that’s not important
right now.
In the middle of the Sound List, you’ll see a License column that spells out each
license type. Remember when we said you’d need to include a link to the license
type for attribution and attribution non-commercial licenses? These are URL links
that open in a web browser when clicked.
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SORTING AND COLUMNS

This operates the same as with the Mixcraft Library, but the column names (and
number of columns) are slightly different. This is because the Freesound.org sounds
don’t have the extensive descriptive meta data as Mixcraft’s sound library. For more
information on using sorting and columns like a boss, check out “A Sorted Affair:
Using Sound List Columns and Categories.”
SOUND LIST RIGHT-CLICK MENU (FREESOUND.ORG MODE)

Right-clicking on a sound in the Sound List
opens this menu. This is a little different than
the Sound Library right-click menu.

 Play

Previews the sample the mouse pointer is currently hovering on.
 Add

Places the sound on a new audio track at the current Caret location.
 Open Containing Folder…

Displays the file and its containing directory in Windows Explorer.
 Download

Initiates downloading of the sound to your hard drive if the sound hasn’t been
downloaded yet.
 Show Columns

Displays all available Sound List columns. Checking or unchecking columns will
hide and display them in the Sound List.
(See “A Sorted Affair: Using Sound List Columns and Categories” for more 		
information on columns and sorting trickery.
 Select All

Selects all sounds in the current Sound List window.
FAVORITES
Clicking on the Star next to any sound in the Sound List marks it as a
favorite; click the Favorite icon to access all favorited sounds.
Most operations, such as searching, auditioning sounds, adding sounds, favorites, etc.
operate the same as Mixcraft Sound Library mode with some minor differences (see
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“Mixcraft Sound Library”). First, we’ll explain how the Favorites mode works.
FAVORITES SELECT

Use these buttons to narrow down which favorites are displayed in the Sound List.
 All

		

Displays all favorited sounds

 Library

		

Displays favorited sounds from the Mixcraft Sound Library.

 Folders

		

Displays favorited sounds added to Mixcraft using the Folders button.

 Online

		
		
		
		
		

Displays favorited Freesound.org sounds. These must be downloaded before
they can be favorited – the Star column won’t be visible for sounds that haven’t
yet been downloaded (The Online category name refers to sounds that 		
originated online, but once downloaded to your hard drive, they aren’t 		
technically “online.” Cut us some slack, sometimes it’s hard to name this stuff!)

SOUND LIST RIGHT-CLICK MENU (FAVORITES MODE)

Right-clicking on a sound in the Sound List
opens this menu.

 Play

Previews the sample the mouse pointer is currently hovering on.
 Add

Places the sound on a new audio track at the current Caret location.
 Open Containing Folder…

Displays the file and its containing directory in Windows Explorer.
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 Delete

Deletes the sound from your hard drive. Careful with this one!
 Download

Initiates downloading of the sound to your hard drive if the sound hasn’t been
downloaded yet.
 Show Columns

Displays all available Sound List columns. Checking or unchecking columns will
hide and display them in the Sound List. See “A Sorted Affair: Using Sound List
Columns and Categories” for more information.
 Select All

Selects all sounds in the current Sound List window.
A SORTED AFFAIR: USING SOUND LIST COLUMNS AND CATEGORIES
Sound List columns and categories offer a powerful way to search and sort sound
libraries.
Columns and categories are actually the same thing; we refer to them as “categories”
when editing which types will be displayed in the sound list. These appear in the
sound list as column headers; when displayed at the top of the Sound List, they’re
referred to as “columns,” so don’t let this throw you. They’re one and the same.
Whatever you want to call them, they display “meta” data about sounds, which is a
fancy way of saying, “descriptive information about sounds that helps to easily sort
them.”
Depending on which Category Selection mode button is currently active, the Sound
List shows a different default column set. This is because the meta data available for
sounds is different depending on how they are imported (or possibly not yet imported)
into Mixcraft.
The following meta data columns are available. As explained above, not all meta data
types can attached or edited to all sounds.


Name



Instrument



Imported Date



Tempo



Style



Length



Is Loop?



Song Kit



File Source



#Bars



Author



File Location



Signature



Keywords



Database



Key



Date



Sound ID
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Sound Format



Text Description



Composer



License Type
You’ll notice that all of these columns
aren’t visible in the sound list by default.
To customize which columns are visible,
right–click on a column header or right–
click on the sound view, choose Show
Columns, and check or uncheck the
columns you’d like to appear in the
Sound List.

To resize the width of columns, move the mouse over the
black separator lines. The cursor turns into a left/right arrow;
click and drag to resize column width. Double–clicking the black separator bar
automatically resizes the column to fit the largest text in the column.
EDIT LIBRARY

The sound library features editable parameters to assist with organization. Meta info
including keywords, tempos, keys, and time signatures can be attached to sound files.

To modify sound info, click Edit Library in the Library tab toolbar. To edit a field, click
it, and type in a new name or tempo. Mixcraft will auto-suggest based on previous
entries and values. To move the cursor, use the arrow keys. Press [ENTER] to start
editing a field. Standard copy [CTRL]+C and paste [CTRL]+V commands can be used
for text. Click Stop Editing when done.
LIBRARY FILE FORMAT (ADVANCED)
User library files are stored in %programdata%\Acoustica\Mixcraft\UserLibrarySounds\
as .mldb files. Mixcraft reads all .mldb files stored in this folder upon launch.
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These files may be edited. To edit a .mldb file, copy it, rename the copy, and make edits
to the newly copied version. If you’re not technically inclined, we recommend editing
the library using Mixcraft as the “front end” as described in the preceding section.
LIBRARY MLDB FILE FORMAT
This file a standard .CSV file, aka a comma delimited spreadsheet. Each text field is
quote (“) delimited. Each column is comma (,) delimited.
You can view the MLDB file in MS Excel, OpenOffice.org, or Google docs. Be sure to
choose the Separated by Comma option with a text delimiter of a quote (“). You may
need to change the file extension to .CSV prior to editing.
MLDB FIELDS
MLDB files contain a number of columns:
Field Name

Description

Valid Values

Genre

This is the genre

“Rock”, “Jazz”, etc.

Style

This is equivalent to the
Song Kit

“Blues Shuffle”,
“Death Metal Polka”, etc.

Final Loop File Name

The displayed loop name

“My Loop”

Instrument

Type of musical instrument

“Vocal”, “Bass”,
“Guitar”, etc.

Keywords

This helps it pop up
in the search results

Anything

IsLoop

A field to let the software
know if it is a loop

“Y” or null

Number of Bars

The length of the sound in bars

null, 1 or greater

Has Key (Y/N)

Denotes if the sound has a key.
For example, drum sounds
do not normally have a key

“Y” or “N”

Key (# for sharp)

The key, if applicable. The key
should only be a A-G with an
optional # for a sharp

“A-G” with an
optional “#”

IsMajor (Y/N)

Is the loop a major key?

“Y” or null for no.

Time Signature
Numerator

If the sound has a time
signature, this is the
numerator or top portion.

null, 2 or greater
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Field Name

Description

Valid Values

Time Signature
Denominator

If the sound has a time
signature, this is the
denominator or bottom
portion.

null, or a power of 2 >=
2, ie: 2, 4, 8, 16, etc...

Comments

Field for making notes.

text of your choice

Artist

The name of the musician,
creator, composer, etc.

John John Smallberries
The Great, or whatever
you want.

URL

This is the URL of the artist’s
web page.

A valid web page/address

Acoustica Sound ID

This is a special sound ID
used internally for Mixcraft
projects. It is a way of allowing
projects saved on any computer
to be loaded up without any
problems.

Tempo

The tempo of the loop if
applicable.

null or valid tempo
such as 120 or 141.23

Date

The date that the loop/sound
was created/added.

A valid date such as
01/03/12 or mm/dd/yy
format, where dd=the day,
mm=month and yy=year

FilePath

The path to the file. If
the path is relative to the
library folder, you can use
the variable %LIBRARY%
before any. filepath. The
%LIBRARY% variable maps to
%programdata%\Acoustica\
Mixcraft\

Costs Money

Not Used

Not Used
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Field Name

Description

Valid Values

Imported Date

The day and time when
the sound was imported.

A valid date time such as
mm/dd/yyyy hh:mm:ss
where mm=month,
dd=day, yyyy=4 digit year,
hh=hour in 24 format,
mm=minute
and ss=second.

Length

The length of the sound
in milliseconds.

null or the number
of milliseconds. For
example, 2 seconds =
2000 milliseconds.

Source

The place that the file was
imported from. If it was a CD,
a unique identifier will be at
the start. In this way, it does
not copy the same sounds
from the CD more than once.
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PERFORMANCE PANEL

Mixcraft’s Performance Panel allows fast and fun creation of entire tracks using MIDI
and audio clips. Though it can be “played” with a standard MIDI keyboard controller
(or no MIDI controller at all), it’s best suited to a grid-style MIDI controller such as the
Novation Launchpad. Don’t mistake it as a simple grid loop player; the Performance
Panel has some nifty tricks up its sleeve!
The Performance Panel can be thought of as a grid for simultaneous playback of
multiple MIDI or audio clips (since both behave mostly the same in the Performance
Panel, we’ll refer to both as “clips”). A project can have only one Performance Panel.
Clips in the grid work similarly to standard clip playback in the main clip grid in that
only one per audio track can play at any given time (i.e. horizontally). The track list
to the left of the Performance Panel functions exactly the same as for “normal” clips in
the Main Clip Grid: volume, pan, solo, mute, etc. all operate as usual. MIDI and audio
tracks work the same as well, so be aware of whether a track is a MIDI or audio track
when placing clips in the Performance Panel grid. It’s usually sensible to keep audio
and MIDI tracks grouped together to avoid confusion.
PERFORMANCE PANEL CONTROLS
Performance Button

Click the Performance button above the Track List to hide or
view the Performance Panel grid (or press the P key).
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Sets

A Set refers to a group of clips that play concurrently. Sets are arranged
horizontally across the grid with each set consisting of one or more loops
arranged vertically “on top of each other”. You can create as many sets as
you like – to add more empty sets, simply click the +add button above
the Performance Panel. To rename a Set, double-click on the text, type a
new name, and press return (or click outside of the text box area).

Performance Panel Grid

The grid where clips are dragged and dropped for
playback.

Grid Play and Stop Buttons

You’ll find numerous play (right-facing black arrow) and stop (small black
square) buttons along the top columns, left–side rows, in blank cells and in
the corners of clips. These toggle start and stop of playback of individual
clips, entire sets, or tracks.
Performance Panel Record Arm Button

When a track is Record Armed, square Performance Panel Record Arm buttons
appear in the row next to the grid. These prepare all grid locations in that row
for recording. If the track has more than one recording lane, you’ll see Performance
Panel Record Arm button for each lane.
Performance Panel Grid Record Button

When a track is Record Armed, tiny Record buttons appear in all empty grid
locations in the associated track row. If the track has more than one recording
lane, you’ll see Performance Panel Grid Record buttons in all empty grid locations in all
recording lanes.
+ Add

Don’t worry, this button won’t increase Attention Deficit Disorder, it simply
adds more blank set locations to the right of the last set. All set locations
may not be currently visible depending on the Performance Panel view width.
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To view all current sets, scroll sideways, or widen the Performance Panel view width.
To make the current view wider, position the cursor on the leftmost area of the main
clip grid (the grid on the right side of the screen where you usually play and record
clips, not the Performance Panel Grid); you’ll know you’re in the right place when
the cursor turns into left/right arrows. Hold the mouse button and drag left or right to
change the Performance Panel width.
Solo

The Performance Panel Solo button mutes all clips in the main grid during
playback. This allows you to use the only the Performance Panel for audio
and MIDI clip playback. This is very useful in live performance applications. When the
Solo button is clicked, all clips in the main clip grid will turn gray. To unmute them,
click the Solo button again.
Arm

Clicking the Arm button causes any playback of sets to record in the main
clip grid. This is a powerful tool for song creation, enabling continuous
recording of set group performances, including changing sets, muting and soloing of
clips and more. It’s especially fun and creative when using a hardware USB grid
controller. Keep in mind that Performance Panel “recordings” don’t actually create new
audio files on your hard drive, they only create new clips in the Main Clip Grid that
refer to existing audio files. This means you can go nuts creating songs without filling
your hard drive!
Cue

The Cue button defines how long Mixcraft will wait to switch
playback from one clip or set when play buttons are clicked
during playback. Select from the following note values:
At any setting other than Instant, Mixcraft always switches exactly
on the beat, which is tremendously helpful for keeping playback
on the beat and in sync. When Cue is set to any value other than
none, the clip’s Play arrow will flash indicating it will begin playing
following the length of time specified by the Cue setting. We
recommend beginning with 1 Bar or 2 Bar.

145

If Cue is set to Instant, clips and sets will switch immediately upon pressing the play
button. This isn’t usually desirable when switching loops, because loops can easily get
off time from the project metronome. There are times when you’ll want to set Cue to
trigger individual sounds in the grid immediately when clicked(for one-shot drums or
sound effects with an external pad controller, for example), but since the Cue button
affects all clips in the Performance Panel, it’s a better idea to set the Cue parameter
individually for specific grid locations; this overrides the global setting.
(See Performance Panel Sound Tab Parameters in the next section.)
Record

Defines the length of recordings when recording directly to
the Performance Panel.
PERFORMANCE PANEL SOUND TAB PARAMETERS
In addition to the Performance Panel controls
described above, most of which affect all clips
simultaneously, Mixcraft includes a number of
parameters that let you customize the behavior of
individual clips. To access these parameters, select a
clip (or clips) by double–clicking them, then click the
Perform tab, toward the bottom left of the screen.
(The first click selects the clip; the second opens the
Sound tab.)

Cue (Sound Tab)

This works just like the Cue pop-up menu described above in the
Performance Panel Controls section - it defines how long Mixcraft will
wait to switch playback from one clip to another when a play button is
clicked for a new clip in the same column, but it applies only to
individual clips. If the Sound tab Cue pop-up menu is set to Project,
then the clip will behave as selected in the pop-up menu at the top of
the Performance Panel controls (i.e. the clip won’t behave any different
than normal).
If the Sound tab Cue setting is set to any value other than Project, its
setting will override the global cue setting for individual clips. This
is pretty important, so let that sink in. In practical application, this
offers a lot of flexibility for customizing the behavior of individual clips. Note that clips
in the Performance Panel default to Project setting unless the setting is individually
“customized” in the Performance Panel Sound Tab.
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Loop

This determines the looping behavior for individual Performance
Panel clips.
Embedded Tempo
and Key Information

 One Shot

		
		
		
		
		

Clip plays one time only. This is useful for non-looping sound effects, drum
sounds, or orchestra hits, in case you’ve been transported through a time 		
machine to 1990. You’ll likely want to set the Cue value to Instant to ensure
that the sound triggers immediately (it’s a real buzzkill when that orchestra hit
triggers four bars after you hit the button).

 Normal

		

Clip playback will loop when the clip reaches its end.

 Note Values

		
		

The clip will loop when it reaches the selected bar value. This is relevant if the
clip’s total length is longer than the chosen value setting.

Trigger Mode

This lets you customize how loops trigger when their play
button is pressed.

 Retrigger

		
		
		
		

Clip will repeat from its start each time the play button is clicked.
If global or Sound Tab>Perform Tab>Cue is set to any value other than Instant,
Mixcraft waits until the set note value has elapsed, then retrigger in time with
the project metronome.

 Trigger Once

		 Once play has been initiated for a clip either with its own
		 play button or with the Set play button above, the clip continues to play until
		 it is stopped with one of the stop buttons in the same row, the master stop
		 button in the upper left corner, or Mixcraft’s transport stop button (or space
		bar). Trigger Once is a good option for “foundation” beats intended to play
		 continuously during performances.
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Most of the clips in
Mixcraft’s included
library contain
“built-in” tempo and
key information (the
exceptions would be
things like one-shot
sound effects that
don’t have discernible
rhythmic timing or a
musical key signature).
This is gives Mixcraft
a timing and key
“roadmap”, allowing
multiple clips to
automatically lock
in time and play in
musically relevant
keys without user
intervention – in other
words, they just work.
Yay for technology!

 Transition In Sync

		
		
		
		
		

Similar to Retrigger mode, but instead of starting at the beginning of the clip
when the play button is clicked (after the Cue value elapses), the newly selected
clip continues playing at the same position as the currently playing clip. In
other words, if the currently playing loop is at beat three at the transition point,
the new clip will play from beat three.

		
		
		

Transition In Sync works well in live performance, because it allows seamless
transitions between clips and prevents multiple clips from becoming “turned
around” in time from one another (i.e. the downbeat plays on the wrong count).

Performance Control

Specifies clip behavior when the mouse button is clicked or a
button is pressed on a hardware USB controller.

 Down

		 Clicking a clip play button will start playback. Dependent upon Trigger Mode
		 setting, the clip will continuously loop or play through one time. You can think
		of Down mode as similar to striking a note on a piano while holding down the
		 sustain pedal.
 Down/Up

		 Clips only play when the play button is held down – pressing down initiates
		 playback, letting up stops it. This works best with the Cue time set to Instant, for
		 example, for temporarily dropping a fragment of a loop or musical passage into
		 a mix. If Cue is set to any value other than Instant, you’ll need to hold the
		 play button until the Cue note value time elapses, then clip playback begins.
		
 Toggle

		
		
		
		
		

This works like an on/off switch: press play to start a clip, and press again to
stop it. Note that the Cue setting affects the clip’s start and end points - Mixcraft
waits for the Cue value to elapse before starting to play, and if the play button is
pressed again before the Cue value has elapsed, playback continues to play for
the duration of the Cue value.

MOVING, DUPLICATING, DELETING, AND MORE
IN THE PERFORMANCE PANEL
 Move clips

		
		
		

To move a clip or clips, simply click and drag to another grid location. To select
multiple clips, click and drag a box around the clips by starting in a blank area
of the grid (i.e. no clips in the grid).
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Instantly Add An
Entire Song Kit To The
Performance Panel
Here’s a super–neato
“hidden” right-click
command that lets
you add an entire preconfigured song kit to
the Performance Panel
in a single mouse click.
In the Library tab, make
sure “Library” is set
to “Loops”, and “Sort
By” is set to “Song Kit”.
Once you’ve selected
a song kit, right–click
on one of its sounds in
the right–side column
and choose “Add Song
Kit To Performance
Panel”. An entire pre–
arranged “song” is
automatically set up in
the Performance Panel
with tracks logically
assigned by instrument
type.

 Duplicate clips

		
		
		
		

To duplicate a clip or clips, simply click and drag to another grid location while
holding the [CTRL] modifier key. To duplicate select multiple clips, click and
drag a box around the clips by starting in a blank area of the grid and drag to
empty grid locations while holding the [CTRL] modifier key.

		Dragging clips to an occupied grid location overwrites the existing clip, so
		 careful, loopmaster!
 Selecting Sets

		
		

To select an entire set for editing, right-click in the set name area at the top of
the Performance Panel grid and click Select in the pop-up menu.

 Duplicating Sets

		
		
		
		
		
		

To duplicate a set, right-click in the set name area at the top of the Performance
Panel grid and click Duplicate. The entire set (i.e. all clips in the vertical 		
column) will be copied to the next column over to the set’s right. Duplicate
behaves as an “insert” function, so if there is a set (or sets) to the right of the one
being duplicated, existing sets will be shifted over one column, and Mixcraft
automatically creates new sets if necessary.

 Delete Set

		
		
		

Sets can be deleted by right-clicking in the set name area and selecting Delete in
the pop-up menu. Existing sets to the right of the deleted set will shift over. Just
like a spreadsheet, but more fun!

 Resizing the Performance Panel Grid
		 Column widths can be adjusted by hovering the cursor between the set names at

		
		

the top of the Performance Panel - when the cursor becomes left/right arrows,
simply hold down the mouse button and slide horizontally to resize.

		
		
		
		

Vertical grid size follows a track’s vertical sizing. You can resize tracks vertically
by hovering between track names in the track list; click and drag vertically when
the mouse becomes up/down arrows. To reset to default height, right-click a
track and select Properties>Height>Small/Normal/Large in the pop-up menu.

PLAYING AUDIO AND MIDI SOUND CLIPS
WITH THE PERFORMANCE PANEL
To use to the Performance Panel, simply drag clips into individual grid locations. You
can drag in loops from the Mixcraft loop library (click the Library tab at the bottom of
the screen to view and audition loops), the main playback grid, or even directly from
the Windows File Explorer. Loops from the Mixcraft loop library contain information
about the tempo and key of the sound embedded into the file – this means clips will
play back in perfect time with project tempo. (see sidebar: Embedded Tempo and Key
Information)
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Once you’ve dragged loops into the Performance Panel set, initiate playback by clicking
the playback arrow to the immediate left of the set number (i.e. Set 1, Set 2, etc.).
You’ll notice small playback heads – these move at different speeds dependent upon
the length of the loops. Though loops in a set do not need to be the same length, we
strongly recommend using even loops lengths in units of two or four. Mixcraft will play
back loops of any length in time, but repeat and cycles may become difficult to keep
track of.
(Actually, If a clip is a really odd size, Mixcraft rounds its length to the nearest quarternote and tacks a little silence on the end before looping back around. This happens
transparently, but trust us, unless you want your music to sound like a bag of rocks
poured down a steel slide, this “rounding off” helps to keep things sounding musical.)
You can switch which set of loops is playing by simply clicking another set or loop’s
play button while the current set or loops is playing. Dependent upon the Cue setting,
the Performance Panel will transition to the next set or loop either immediately, or
wait until the Cue setting note value elapses. Clips can be stopped by pressing a row’s
dedicated stop button located at the far left of the Performance Panel, or by pressing
the stop button in an empty cell in the same row. You can stop all clip playback either
by pressing the master stop button in the Performance Panel’s upper-left corner, or by
pressing the stop button in Mixcraft’s transport controls (or by pressing the space bar).
RECORDING AUDIO AND MIDI SOUND CLIPS
TO THE PERFORMANCE PANEL

In addition to just dragging existing clips into the Performance Panel gird, new clips
can be recorded directly to the Performance Panel. In other words, it’s not necessary to
record to the Main Clip grid first. This is super useful for instantly creating layered live
loop performances, initially made famous by English chanteuse, Imogen Heap (check
out her YouTube vids of “Just For Now” for a mindblowing demo).
Recording can be initiated when the Performance Panel is stopped, or “on-the-fly”
while a Performance Panel set is playing.
RECORDING CLIPS WITH THE PERFORMANCE PANEL STOPPED

1. Open the Performance Panel by clicking the Performance Panel button, or by
pressing P on your computer’s keyboard.
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2. Click the metronome button and check that Recording and Recording
Count-In Measures are enabled; you may want to change the number of
count-in measures while you’re here (you can skip this step if you already 		
have the metronome configured to your liking).
3. Select a track in the track list for recording by clicking on it. If you need to set the
Recording Mode, enable or disable Auto Quantization, or MIDI input settings, click
the down arrow next to the track’s Arm button.
4. Unlike standard recording, you’ll need to set the clip length
prior to recording. Use the record pop-up menu above the
Performance Panel to select a recording length.

5. Click the track’s Arm button to ready it for recording. If you’re recording
audio, now is a good time to check that you’re getting a solid input signal on
the track input meter.
6. Click the Performance Panel’s Mini Arm button. It’s the gray square on the
bottom of the column; it turns red to show the row is armed for recording. The
small Record buttons in the Performance Panel grid locations turn red as well.
Important: If the Mini Arm button is enabled on a track, standard recording for that
track (i.e. in the Main Clip Grid, not the Performance Panel) is disabled.
7. To begin recording, click on a Record button in the same row as the recordenabled track. Mixcraft will count in according to the Metronome Count-In
Measures setting.
A progress bar moves across the top of the grid location as the count-in
measures go by; when the progress bar gets all the way to the right,
recording begins.
Once recording, a clip appears in the grid, and a progress bar makes its
way across the bottom of the clip, showing the duration of recording.
When the progress bar arrives at the right of the clip, Mixcraft stops recording. The
newly created clip continues to loop, playing back the recorded passage.
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RECORDING CLIPS WHILE THE PERFORMANCE PANEL IS PLAYING

Here’s where things start getting wild. Mixcraft lets you easily record new clips while
the Performance Panel is playing. This opens up myriad possibilities for improvised (or
semi-improvised) live performances. Because recording automatically disengages at the
end of the selected recording length, newly recorded clips can rapidly be muted and
unmuted, moved or copied between sets, and more. Add in Performance Panel Lane
recording, and the possibilities rapidly get crazy!
Recording MIDI and audio clips during Performance Panel playback works almost
exactly as with the Performance Panel stopped, as described in the preceding
section, with one major difference:
If the Performance Panel is currently playing and a Record button is clicked,
Mixcraft ignores the Count-In Measures setting altogether and instead waits the
duration of the Performance Panel Cue setting before recording begins. This
makes sense because there’s no way to know what point in the loops’ cycles the user is
going to whack a Record button.
The “countdown to record” progress bar discussed in step 7 on the previous page is
displayed at the top of the selected grid location. This let you know when recording
will begin.
Note: Mixcraft does its best to intelligently determine the musician’s intentions, but
setting Cue to Instant can have some squirrely results, in terms of clip recording start
and end points. Though you won’t hurt anything, we recommend sticking with Cue
settings of standard note values for more predictable recording results.
LANE PLAYBACK AND RECORDING WITH THE PERFORMANCE PANEL

Multiple Lanes are available when playing and recording clips in the Performance Panel
as with the Main Clip Grid. Besides the added flexibility of playing back multiple clips
within a single track, using Lanes speeds up recording clips because the Mini Arm
button is global for each track. In other words, clicking the Mini Arm button for a track
arms recording for all Lanes in the track simultaneously.
 Adding Lanes

Empty lanes can be added by right-clicking on the Track Header or an empty cell in
the Performance Panel grid and selecting Lanes>Add (or with the shortcut [ALT]+L).
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 Deleting Lanes

Lanes can be deleted by right-clicking on the Track Header or an empty cell in the
Performance Panel grid and selecting Lanes>Delete. To delete unused lanes, rightclick and select Lanes>Delete Empty Lanes (or with the shortcut [ALT]+K).
 Muting and Unmuting Lanes

All clips on any lane can be muted or unmuted by right-clicking on the Track
Header or an empty cell in the Performance Panel grid and clicking Lanes>Mute All
or Lanes>Unmute All.
We’re not sure what Penny Lane is, but it’s located in your ears and in your eyes.
PERFORMANCE PANEL RIGHT-CLICK COMMANDS
Most audio clip right-click commands are the same as with audio clips in the Main Clip
Grid, but there are some are unique commands when they’re in Performance Panel grid
locations. (Right-click commands for MIDI clips are the same for clips in the Main Clip
Grid and Performance panel.)
Audio Clip Right-Click Commands

 Play

		

Begins clip playback.

 Edit Loop

		
		

Opens the clip in the Sound tab editor window. This is the same as doubleclicking a clip.

 Trigger Quantization

		 Sets a “custom” Cue value for individual clips that overrides the master Cue
		 setting at the top of the Performance Panel. This is the same parameter as Sound
		Tab>Perform>Cue.
 Trigger Mode

		
		

Defines how a clip behaves if it’s clicked while playing. setting in Sound 		
Tab>Perform. One Shot mode can also be enabled here.

 Performance Mode

		
		

Defines how the clip responds to mouse clicks or button presses on an external
control surface. Same parameter as Sound Tab>Perform>Performance Control.
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Empty Cell Right-Click Commands

 Remove Button

		
		
		
		
		

		
		

This guy’s real easy to miss. As explained earlier, if the track isn’t record armed,
the little black square in a cell’s top-left corner acts as a stop button for all clips
in the row. Remove button will get rid of a cell’s stop button. Right-clicking
again lets you bring back the button.
Consider the example on the left: We’ve removed the Stop
button in Set 2, row 2. If Set 1 is currently playing and we
click the Play button for Set 2, the lack of a Stop button
causes the Beat 1 clip in Set 1 to continue playing.

If a track is record armed, the Remove Button will also remove a cell’s Record
button, so be aware of this if your Record buttons are mysteriously disappearing.

USING THE PERFORMANCE PANEL WITH A NOVATION LAUNCHPAD
USB HARDWARE CONTROLLER
The Performance Panel can be used with a standard USB keyboard controller (see
“Using Generic MIDI Controllers and Control Surfaces”) or even just your computer’s
mouse or trackpad, but it really shines when paired with a Novation Launchpad USB
grid controller. Instead of controlling set and cell playback with individual mouse
clicks, the Launchpad features a multicolor 64-button grid for rapid control of cell
playback and recording, as well 16 additional buttons for controlling set playback
and navigation. Mixcraft includes some special features designed to specifically take
advantage of the Launchpad controller.
CONFIGURING THE LAUNCHPAD CONTROLLER

The Novation Launchpad doesn’t need any special drivers. Here’s how to get it up and
running in a jiffy:
1. Plug the small end of the included USB cable into the the Launchpad, and the
big end into an open USB port on your PC.
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2. Upon plugging in the Launchpad, Mixcraft will display the following window.
This simply acknowledges that you’ve plugged in a new piece of hardware. Click OK.
3. In the upper-left corner, click File>Preferences, then select Control Surfaces. In the
left column, choose Launchpad. In the Input and Output columns to the right,
select Launchpad in each of these. Click OK at the bottom of the Preferences
window and you’re ready for Launchpad rock!
LAUNCHPAD BUTTONS
 Main 8x8 Grid – The main 8x8 button grid functions just as the corresponding

onscreen set, clip, and grid play, stop, and record buttons. The table below 		
describes button color and states.
button color

state

cell activity

off

–

no clip present in cell*

amber

solid

clip present, not currently playing

green

solid

clip currently playing

green

flashing

clip plays following Cue duration

red

solid

track/lane is record armed, press to begin recording

red

dim

count-in measures or Cue duration currently elapsing

red

flashing

currently recording

* Pressing an unoccupied grid button during playback will stop playback for clips
in the same row, following the duration of the Cue setting (if any). The button
flashes red during the cue duration, indicating clips playing in this row will stop
following the cue duration.
 1 – 8 Buttons

These start and stop sets just like the play/stop buttons along the top of the 		
Mixcraft’s onscreen Performance Panel.
 A – D Buttons

Though there are Launchpad’s main grid buttons “only” comprise an 8x8 grid,
Mixcraft’s onscreen grid has no size/cell number limit. When Mixcraft detects a
Launchpad controller, a 8x8 cell blue box appears in the Performance Panel; this
surrounds the current corresponding cells represented on the Launchpad controller.
The 8x8 cell grid represented on the Launchpad can be shifted up and down
with the A and B buttons, and left and right with the C and D buttons. The blue
box surrounding the 8x8 grid moves accordingly.
(This only becomes relevant if the Performance Panel grid is larger than 8x8 cells.)
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 H Button

The H button in the bottom-right corner acts as a master stop button. It glows
solid red whether the Performance Panel is stopped or playing. If it’s pressed while
the Performance Panel is running, it flashes for the Cue setting duration, then all
currently playing clips are stopped. This is the same as clicking the onscreen stop
button in the upper-left corner of the Performance Panel.
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AUDIO MIXER

Send Me A Send
Track... Right Now

By now you’ve probably used the channel volume and pan controls in the track list.
Basic mixes can be created this way, but the Mixer window offers far more creative
options. All audio signals including audio, virtual instruments, and effects can be
precisely controlled in the mixer window.

Each track is represented by a vertical channel strip containing a volume slider, pan
control, EQ (low, mid, high), insert FX, record arm, solo, and mute buttons, plus an
optional Send knob and Instrument button (some controls vary depending upon the
track type). Keep in mind that tracks in the track list have a one-to-one correlation with
mixer channels; in other words, each newly created track adds a new track in the mixer.
VIEWING, HIDING, AND RESIZING THE MIXER
To open the mixer at the bottom of the workspace, click the Mixer tab at
the very bottom of the screen. To hide it, click the dash in the upperright corner of the mixer, next to the Undock button.
To open the mixer in a separate window, click the Undock button. This
is particularly useful if you’re using two displays (or one real big one).
The Dock button in the top corner will “re–attach” the mixer to the bottom of the main
Mixcraft window.
The overall height of the mixer can be adjusted by
positioning the mouse pointer beneath Mixcraft’s transport;
the cursor will become up/down arrows when it’s in the
right spot. Dragging up vertically will extend the length of
the channel faders. Dragging down will compress the size of
the faders; once they’re dragged down to their minimum size, a scroll bar appears on the
right side of the mixer allowing scrolling of the mixer view area. This lets you maintain
the size of the track display area without totally squashing the mixer faders.
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Send tracks are
independent channels
that allow multiple
mixer channels to send
signal to them. These
are frequently used for
time-domain effects,
such as reverbs, delays,
or other situations
where it’s desirable to
have the dry signal
at full volume while
adding an effect at a
lower level.
A good example would
be if you wanted to
add reverb to the
components of a drum
kit that was split out
over multiple audio
channels (kick drum
on one track, snare on
another, etc.). Not only
would using a send
track let you save CPU
power by using a single
instance of reverb, but
because each channel
has its own send knob,
you could feed a great
deal of snare drum
signal to the reverb for
dramatic impact, but
only a tiny big of the
kick drum (because kick
drums generally sound
like cannons gone awry
when over-reverbed).
[Cont. next page]

SHOW/HIDE TRACKS
The Show Tracks area to the left of the mixer hides or
displays individual mixer channels. This allows you to see
only the tracks you’re currently working with. Hiding or
showing tracks has no effect on audio; if you’re hearing a
track but can’t see it, make sure it’s not currently hidden.
Mixer tracks can be quickly hidden or displayed by clicking
and dragging across multiple check boxes.
ALL/NONE SELECT BUTTONS

Check All/Check None lets you rapidly show or hide all
mixer channels. Chekov, on the other hand, is that guy on
Star Trek.
MIXER PANEL PREFERENCES
Clicking the small gear icon next to the All and
None select buttons opens the Mixer Panel
Preferences menu. Mixer control sections can be
individual displayed or hidden using the check
boxes. You can also rearrange where each section is
displayed from top to bottom in a mixer channel by
clicking and dragging each section with the three
lines at the left or by grabbing the section names.
When you’re done arranging the mixer layout, click
the X at the top right or the OK button. The Default
button returns the channel strip components to their
default arrangement case things get really mucky.
Mixer Panel Preferences has no effect whatsoever on sound.
INSERT EFFECTS
Insert effects are effects that are placed into or “inserted” into the
signal path of a mixer channel. One or more insert effects can be
added in the main track window by clicking on a channel strip’s
fx button, or by clicking the +fx button in a mixer channel strip.
By default, mixer insert effects are located above the built-in
three-band EQ in the mixer. Clicking the +fx button opens a list of built-in and
third-party VST effects as well as any user-created effects collections. To add an effect,
simply scroll through the list and click on the desired effect. Additional effects can be
added by clicking again on a channel’s +fx button. The effects inserts displayed in the
mixer will always reflect the same effects list as when clicking a channel’s fx button.
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Send Me A Send
Track... Right Now
Send tracks are
independent channels
that allow multiple
mixer channels to send
signal to them. These
are frequently used for
time-domain effects,
such as reverbs, delays,
or other situations
where it’s desirable to
have the dry signal
at full volume while
adding an effect at a
lower level.
A good example would
be if you wanted to
add reverb to the
components of a drum
kit that was split out
over multiple audio
channels (kick drum
on one track, snare on
another, etc.). Not only
would using a send
track let you save CPU
power by using a single
instance of reverb, but
because each channel
has its own send knob,
you could feed a great
deal of snare drum
signal to the reverb for
dramatic impact, but
only a tiny big of the
kick drum (because kick
drums generally sound
like cannons gone awry
when over-reverbed).
[Cont. next page]

The nice thing about the mixer effects view is that all of a channel’s insert effects can be
seen at a glance.
EDITING, ARRANGING, AND MOVING INSERT EFFECTS
 Opening Effects Edit Windows

To open the edit window for an effect, click on it in the mixer. Effects edit windows
can be closed either by clicking the X in the upper corner, or by clicking a second
time on the insert effect in the mixer channel. You can open as many simultaneous
effects editing windows as you like.
 Rearranging Insert Effects

Audio signals flow from the top of the channel strip
downward through each insert effect. To change the
position of an effect in the chain, simply grab the
effect insert block and drag it up or down. But that’s
not all… insert effects can also be moved to different audio channels by dragging
sideways. Holding down the [ALT] key while dragging will make a copy of the
effect. This can be a major time saver. As an example, if you’ve layered numerous
vocal tracks, and you’d like to use the same compressor, EQ, or perhaps a GSnap
Pitch Corrector with the same settings, [ALT]-dragging allows easy duplication
of effects across multiple channels.
ADDITIONAL EFFECTS INSERT FUNCTIONS

Right-clicking an effects insert offers a few more options:
 Active

Right-clicking an effects insert and clicking Active
toggles the effect between active and bypass
modes. A check mark is displayed next to the
word Active when an insert effect is active. The
effects insert background turns dark gray when
an effect is in bypass mode.
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[cont from prev. page]
Another great way to
use Send Tracks is for
grouping related tracks,
such as backing vocals.
Not only does this let
you put numerous
related tracks under
one fader for easy
control, inserting effects
into a Send Track also
lets you add effects
to many channels
at once (for adding
compression and EQ to
all those backing vocals
in one fell swoop, for
example).

 Effects Chain

Right-clicking this opens the channel’s effects list; this is the same as clicking the
fx button in the channel strip or track list. Most insert effect-related tasks can be
accomplished directly from the mixer window, but the effect list allows you to open
and edit effects chains as well assign MIDI hardware controllers to effect parameters.
 Remove

Right-click and select Remove to delete an insert effect. So long!
 Remove All Effects

Right-clicking and selecting Remove All Effects deletes all current insert effects on
the channel.
MIXER SEND TRACK KNOBS
By default, send track knobs appear above the three-band EQ
section in the mixer when one or more send tracks have been
added to a project. The number of knobs corresponds to the
number of send tracks in a project, and the name shown next to
knob will be the same as the send track’s name in the track list.
The mixer displays a maximum of six send knobs in the mixer
interface; if more than six send tracks have been added, a scroll
bar appears next to the send knobs. Just slide that guy up and
down to view and adjust all 437 of your send tracks.
Due to space limitations in the mixer window, only the first nine characters and spaces
will be visible in the mixer knob label, so don’t give your send tracks names like
“Send 46 - Billy-Bob’s Sweet ‘Ol Gimungous Cavern O’ The Wee Depths O’ The Stone
Reverberation Chamber,” or something equally lofty. We do recommend that you retain
something like “Send 2” or similar at the beginning; this will simplify keeping track of
signal flow, especially with larger projects.
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MIXER SEND TRACK, OUTPUT BUS, AND MASTER TRACK DISPLAY

Send Tracks, Output Bus tracks, and the Master Track will always appear at the right
side of the mixer, regardless of their position in the track list. You’ll see a vertical
divider bar near the the middle of the mixer with audio, virtual instrument, video, and
submix tracks on the left, and send, output bus, and master tracks on the right side of
the divider. This makes it easier to visualize the mix signal flow. The vertical divider bar
automatically moves dependent upon how many send tracks and output bus tracks are
used in the project. (check out the image on the next page to see the vertical divider)
We like to put Send Tracks and Output Bus tracks at the bottom of the project track list
to maintain consistency between the track list and the mixer window, but Send Tracks
and Output Bus tracks can be placed anywhere in the track list.
MIXER CHANNEL STRIP CONTROLS
Following is a summary of all Mixer channel strip functions. Depending on the track
type, the channel strip may not contain all controls shown below.
Notes

Button

Selects the destination routing if the project contains
SubMix or Output Bus tracks. If no SubMix or Output Bus
tracks are present in the current project, track output defaults
to Main Mix and the Output flip menu is not displayed.
This tiny fader icon indicates the channel is active
for the current fader bank. This display is relevant
only when using a hardware fader controller.
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Notes

Button

Adjusts the amount of signal routed to the selected
Send Channel/Track. Only displayed if project has
one or more Send Tracks.
Opens the effect dialog for each track. If the track currently
has effects, the FX button turns green. Hovering over the
FX button displays the currently loaded effects.
Click to select and change Virtual Instruments.
(Virtual Instrument tracks only)
Arms the track for recording.
Solos the audio on the track and mutes other
non-soloed tracks.
Mutes the track’s audio.
Selects the channel input source for Audio tracks and Virtual
Instrument tracks. On an audio track, this lets you select the
audio source device (e.g., USB microphone, Line Input, etc.),
as well as the audio interface physical input channel.
On a Virtual Instrument track, this lets you select between
all MIDI devices and a specific MIDI device. Can also limit
the input to a specific MIDI channel.
Each track has built-in Hi, Mid, and Lo equalization
(EQ) knobs.

Panning control. For mono tracks, this shifts the sound left
or right in the stereo field. For stereo tracks, this affects the
balance between the left and right channel.
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Notes

Button

Track volume fader. A setting of 0 equals unity gain.

Tip: Double-clicking on any Mixer control will revert it back to its default.
This is particularly handy for returning pan controls to center position.
MIXER DELAY COMPENSATION
This doesn’t mean we’ll pay you for using delay effects in your projects… but like a
pile of cash, delay compensation is pretty nice to have around. Some plug-ins and
instruments can introduce delays as a result of the brief time it takes for them to
process sound. If this doesn’t get properly “reported” to the host app (i.e. Mixcraft),
some audio tracks or effects busses will play back later than others. In some cases, this
isn’t too noticeable (i.e. the wet signal of nine-second reverb on a Send Track), but in
other situations, it can reak havoc with the timing of your project (think 64th-notequantized castanets).
In the past, this might necessitate inserting VST delay compensation plug-ins at
various points in the mixer signal flow. As you might imagine, this could quickly get
confusing, but fortunately, Mixcraft 8’s mixing engine design automatically allows
for plug-in delay compensation on all mixer channels, including send knobs on
instrument output tracks, sidechaining, etc. In other words, you do nothing out of the
ordinary, and everything plays back in perfect time as it should. Hooray for mixer delay
compensation!
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VIDEO TRACKS AND EDITING

Mixcraft includes powerful video editing features that let you:


Add a musical soundtrack to a video.



Add sound effects to a video.



Create slideshows of still images.



Add titles, lyrics, or credits to your videos.



Sync video to sound with millisecond accuracy.



Export a project to video for burning DVDs or Internet upload.

VIDEO TRACK
A video track holds video clips, images, and text. A project can only have one video
track. To create a video track, click the +Track button and select Insert Video Track. You
can also insert a video track by right-clicking and selecting Insert Track, or accessing
from the Track> Insert Track menu at the top of the main page.
To toggle viewing of the video playback window, click the Show/Hide Video Window
button. A video preview window will open, and the Show/Hide Video Window button
will turn green.
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LOADING VIDEOS

Mixcraft supports AVI,WMV, and MP4 video formats. To load any other format, you’ll
need to convert it using a third-party video conversion app.
Note: MP4 format is only available with Windows 7 or higher.
To add a video, click Video>Add a Video File... in the Main Window menus and
navigate to the video to be loaded. The video will be placed at the current Caret
location. Videos can also be dragged and dropped into the Main Clip Grid from a
Windows directory. You don’t even need to create a Video Track; if the project doesn’t
have one, Mixcraft will create it.
VIDEO PREVIEW WINDOW

This Video Preview window displays the video at the
current playback position, including text and any
currently active effects. It can be toggled on and off by
clicking Show Video Window or Hide Video Window in
the Video Track. The Video Preview can be moved at will by grabbing and dragging its
title bar. This is especially handy if your computer setup has two displays.
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The Video Preview window can be resized by selecting Video>Set Preview Window Size
in the Main Window menus.
ADDING PHOTOS/IMAGES
Photos or images can be added by clicking Video>Add a Video File... in the Main
Window menus. This opens a file dialog which allows loading of an image or multiple
images. The images will be placed at the Caret location. Images can also be dragged
and dropped into the Main Clip Grid from a Windows directory.The following image
types are supported:


.JPG		



.PNG



.BMP		



.GIF

To add more than one image at a time, select
multiple photos or images when adding. The
images will be added to the video track; each
one will last five seconds and overlap the next
by one second.
Editing Photo Duration
The amount of time a photo is displayed can be altered
by moving the mouse to the left or right edge of the clip
and dragging horizontally to change the duration.
Entire clips can be moved by dragging the title bar. All standard edit commands apply
to images, such as copy, paste, linking, splitting, etc.
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As with audio clips, overlapping a video or image clip automatically creates a crossfade,
but in this case it will be a “visual” crossfade.
ALIGN VIDEO CLIPS
This allows easy tempo syncing of images or videos as well as precisely timed slide shows.

To align video clips, click Video>Align Clips in the Main Window menus. This opens
one of the following dialogs depending on whether Mixcraft is currently set to Time or
Beats mode.
In Time mode:

In Beats mode:
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DURATION

Sets the length of clips.
 Fitting To Audio Length

If you have a lot of audio, such as a song or several songs, and you’d like the images
to span the length of the audio, click Fit to Audio Length. This disables the duration
field, resizes, and aligns clips to create a slide show of all the images spaced over the
duration of the audio.
 Adjust Video Clip Lengths

If there are video clips in the project, their length will not be changed by default.
In order to crop the right hand side of video clips, make sure to check the 		
Adjust Video Clip Lengths checkbox.
 Start Time

Sets the start location of clip.
 Overlap

Causes clips to overlap and fade crossfade.
 All Clips/Selected Clips Only

Use these to select which clips are affected. All Clips applies alignment to all clips in
a project whereas Selected Clips Only affects only currently highlighted clips.
VIDEO EFFECTS
Video effects can be added to alter a video’s appearance over time. You can fade in and
out, add blur, transition to gray scale and much more. On the Video track, click the
automation button.
VIDEO EFFECTS AUTOMATION DISPLAY

Adding Mixcraft’s video effects is very similar to automating audio parameters. Multiple
video effects lanes can be displayed simultaneously. To view or hide video effects, click
the Video Track’s Toggle Automation button.
If a Video Track has no video effects, a single automation lane opens displaying the
Lightness effect. If a track has existing video effects, you’ll see all automation lanes with
views currently enabled (using the + and X buttons described below).
The Toggle Automation button only hides and displays the video effects
automation lanes, but has no affect on automation playback. In other words,
video effects are active even if the lanes are hidden with Toggle Automation button.
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ADD AUTOMATION LANE

Adds a new video effects automation lane to the track.
HIDE AUTOMATION LANE

Hides a video effects automation lane.
SELECTING A VIDEO EFFECT

To choose an effect, click on the drop-down menu in the
tracklist.

Video Effects List

Lightness

Blue Channel Strength

Lightness (High CPU)

Red Filter

Grayscale

Green Filter

Blur

Blue Filter

Posterize (High Pass)

Invert Red Channel

Low Pass

Invert Green Channel

Emboss

Invert Blue Channel

XOR (Invert/Negative)

XOR High Pass

Sepia

XOR Low Pass

Antique (Light)

Flip Horizontal

Antique (Heavy)

Kaleidoscope Right

Red Channel Strength

Kaleidoscope Left

Green Channel Strength
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ADDING AND EDITING VIDEO EFFECTS AUTOMATION

To add automation points, click on the automation line and drag the point up and
down. The position of newly created automation points will conform to the the current
Snap setting. The global snap value applies when adding and editing automation
points.

If you experience problems moving an envelope point to a specific location, remember
to change the Snap setting to Snap Off.
To move a horizontal section of the automation line, hold down the [SHIFT] key while
dragging. The cursor will turn into an up/down arrow.
Dragging an automation point over other automation points will cause them to be
“overrun” and deleted upon mouse release.
FINE TUNING AND DELETING AUTOMATION POINTS
 Edit Exact Value

To precisely set automation point values, right-click it
and choose Edit Exact Value. The dialog box below
opens and allows exact settings for automation points.

 Delete Point

To delete an automation point, right-click on and choose Delete Point.
CUTTING, COPYING, AND PASTING AUTOMATION DATA

As with audio automation, video effect automation data can be cut, copied, and pasted.
 Cut

To cut a section of Video Effect automation, highlight the section to be cut by clicking
and dragging over it. Now select [CTRL]+X either in Mixcraft’s file menu, or by right–
clicking the mouse. Paste the cut automation data to a new location by positioning the
Caret marker in the desired new location, then selecting [CTRL]+V either in Mixcraft’s
file menu, or by right–clicking.
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 Copy

To copy, highlight the section of Video Effect automation you’d like copied by clicking
and dragging over the area to be copied. Now select [CTRL]+C either in Mixcraft’s file
menu, or by right-clicking. Position the Caret marker in the desired copy location, and
paste by selecting [CTRL]+V either in Mixcraft’s file menu, or by right-clicking.
VIDEO TEXT TRACK

The text track contains text clips and is a child of the video track. It can be viewed by
clicking the + sign at the bottom–left corner of the video track.
There are two types of text clips:
 Normal
 Scrolling Text
Text tracks can contain multiple lanes and can be used for titles, lyrics, credits,
transitions, and more.
ADDING AND EDITING TEXT

Use the Text feature to add titles, lyrics, captions, and more.

To open the Edit Text window, click Video>Add Text… in the Main Window menus.
Opening the Edit Text window automatically creates a Text clip and places it in the
grid at the current Caret location. Text clips are placed on the Text track. This is a child
track of the Video track. To view or hide the Text track, click the + or - sign on the left
side of the Video track.
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The Text track also has a Mute button. This won’t make on-screen words any quieter,
but it disables the display of text in the project.
To edit a Text clip, double-click it, or right-click and choose Edit Text...
THE TEXT OBJECT

The Text Object is the field within the red rectangle where text is contained.
To resize the Text Object, click and drag on
the small red squares; the cursor turns into
arrows when in the correct position.

To move the entire Text Object, grab one of the red lines
(away from the red squares), click and drag. The cursor
turns into a hand when in position.

SETTING TEXT FONT, SIZE, AND COLOR

The font, size, and color settings can be set using the toolbar at the bottom of the Edit
Text window.
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The font, size, and color settings can be specified per character. In other words, every
letter or number in a title can have its own individual settings. Simply highlight the
characters you’d like to modify and make changes. (Go easy on this one - you can
make a real mess!)
Background Check

OPACITY TAB

The Opacity Tab changes the text, colors, background colors, and transparency level.
 Text/Background Opacity Sliders

		
		

Moving the Opacity sliders adjusts the text and background from transparent to
a solid color.

 Selecting a Text Color
		 To select text color, click the Text Color button and click a color 			

		 square. You can also click the mouse anywhere in the color spectrum display,
		 or if you’re familiar with RGB color numbering, numbers may be entered in the
		 RGB fields, then click OK. Custom colors can be saved for future use by clicking
		Add To Custom Colors.
 Selecting a Background Color
		 To select a color for the text background, click the Background Color button and

		

choose a color as specified above.

Note: The text color setting at the bottom of the toolbar and the Text Color… button
both perform the same function.
TEXT TAB

These parameters specify text placement within the Text Object as well as masking and
drop shadow options
 Orientation

		

Choose whether the text justifies left, center, or right, and top, center, or bottom.
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A text background
color can be very
helpful for making the
text easy to read on an
overly bright or dark
video images.

 Margins
		 Percentage setting for vertical and horizontal margins.
 Treat Text As Mask

		

		 Creates a solid color screen fill with the underlying video bleeding through the

		

text characters.

 Drop Shadow

		

		
		

Adds a black drop shadow to text characters with choices of small, medium,
and large.
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FADE TAB

Text can be faded in and out over time using the Fade tab. Check the Fade In or Fade
Out checkboxes, then set the desired fade duration. As a reference, one second = 1000
milliseconds.
MOTION TAB

The Motion tab provides intro and outro text animation.
TYPES OF ANIMATION

Adds movement to text. Start Animation and End Animation lets you specify separate
animation behavior for the start and end of Text Clips.
 None

		

Text does not animate. Not very exciting.

 Move

		
		
		

Choose whether text enters from left, right, top, or bottom of the frame as
specified by the Direction drop-down menu. Enter the animation length 		
using the Duration field.

 Reveal

		
		

Text characters reveal themselves in the specified according to the Direction
drop-down choice. Enter the animation length using the Duration field.

EDITING TEXT CLIP SIZE

Resizing a Text Clip alters how long the text is displayed. To change
the the size a text clip, click on the clip’s left or right edge and drag
horizontally. The cursor turns into left/right arrows when hovering
on the clip’s edge.
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ADDING AND EDITING SCROLLING TEXT

Scrolling Text functions much the same as regular text, but scrolling text automatically
moves from the bottom to the top of the screen (hence the clever name). Scrolling text
is ideal for creating credits.
To add Scrolling Text, click Video>Add Scrolling Text… in the Main Window menus.
Opening the Edit Text window automatically creates a Scrolling Text Clip and places it
in the grid at the current Caret location on the Video Track’s Text child track.

To edit a Scrolling Text Clip, double-click it, or right-click and choose Edit Text...
All editing functionality and tabs work the same as when editing static text, but
because Scrolling Text inherently moves from the bottom to the top of the screen, the
Motion tab is removed from the Edit Text window.
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ALTERING SCROLL SPEED

The scroll rate of Scrolling Text clips is automatically
adjusted dependent on the clip size. To slow down or
speed up the rate of scrolling, move the mouse over the
left or right edge of the clip and resize it horizontally. The
cursor will turn into left/right arrows when hovering on
the clip’s edge.
USING LANES WITH VIDEO AND TEXT TRACKS

As with Audio Tracks and Virtual Instrument Tracks, multiple lanes can be created for
Video and Text tracks. To create or delete lanes, highlight a Video Track or Text Track
and right-click and select Lanes>Add or Lanes>Delete. Lanes can also be added with
the key shortcut [ALT]+L.
Remember that only one video stream can play at any given time; if multiple video
lanes are used, the clip in the uppermost lane will have playback priority.
Text and Scrolling Text clips are not subject to “one-at-a-time” limitations. Text and
Scrolling Text clips in multiple lanes will all play simultaneously.
RENDERING EDITED VIDEOS
Once the editing of a video is completed, it needs to be output to a single file for
playback. Because videos typically contain a large amount of data representing moving
picture and audio, video is usually “compressed” as it renders for output using special
algorithms designed to reduce file size and required processor power for playback. This
compression process can take a while, dependent on your computer’s processor speed.
Mixcraft supports saving video in MP4, WMV, and AVI formats. AVI is an
uncompressed format, so the files it creates will be larger than files created using WMV
or MP4 format. If you’re uploading video to YouTube, you should choose WMV or MP4
format (to avoid potentially excessive upload times, dependent upon the speed of your
Internet connection).
Note: MP4 format is only available with Windows 7 or higher.
To save the current project as a video, click File>Mix Down To>, then select MP4,
WMV, or AVI.
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MP4 RENDER SETTINGS

To render a movie using the MP4 format, click File>Mix Down To>MP4 in the Main
Window menus.
To customize MP4 render settings, click the Edit Details button in
the file save window.

When creating a movie file, you’ll generally need to choose between quality and final
file size (i.e., a larger file size equals better quality). If you’re not a video compression
guru, simply choose the Preset Quality radio button and move the Quality slider left to
choose a preset resulting in a smaller file size at lower quality, or right to choose presets
with larger file sizes at higher quality.

If you’re a little more familiar with video compression and want to further customize
MP4 rendering parameters, choose the Specify Settings radio button and click the
Settings button. The available parameters are:
 Dimensions

		

Type the desired width and height in pixels, or set with the up/down arrows.

 Frame Rate

		
		

Set a frame rate in frames per second. We strongly recommend using a standard
FPS setting (such as 24 FPS, 25 FPS, 29.97 FPS “drop frame”, or 30 FPS).
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MP4 Compression
Settings In The
Modern World
Generally speaking,
saving every last bit
of file size is far less
important than it
was in the past due
to faster Internet
connections and larger
hard drives. If you’re
creating video content
for a video upload site
such as YouTube, keep
in mind that they will
compress the file size
(and therefore the
quality) on their end,
so it’s often a better
idea to render larger,
better quality videos to
maintain fidelity.

 Profile
		 Base, Main, or High settings are optimized for different final delivery platforms.
 Video Bit Rate

		 This influences how large the rendered file will be; additionally, larger files will
		 require a higher speed Internet connection for smooth streamed playback. A
		 higher bit rate will result in a larger file size, but better fidelity. Click the pop-up
		 menu to choose from standard rates, or set a custom bit rate by checking the
		Set a custom bit rate box and entering a bit rate in the box.
 Audio Settings

		 These determine audio quality. Like video settings, higher kbps settings result

		
		

in larger files but better fidelity. If the audio quality is non-critical (the audio
content is spoken word, for example), you can dial this back and save file size.

AVI RENDER SETTINGS

To render a movie using the AVI format, click File>Mix Down To>AVI in the Main
Window menus.
To customize AVI render settings, click the Edit Details button in
the file save window.
When creating a movie file, you’ll generally need to choose between quality and final
file size (i.e., a larger file size will be better quality). Following are the settings in the
AVI Render Details window:
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 Dimensions

The Dimensions drop-down menu allows selection of the most common standard
definition and high-def (HD) sizes. The Set Custom Dimensions checkbox allows a
custom video size to be specified.
 Frame Rate

The Frame Rate drop-down menu allows selection of the most common frame rates
used in video, film, and TV. The Set Custom Frame Rate checkbox allows a custom
frame rate to be used (careful, funky frame rates sometimes don’t play nice with
some playback platforms, usually showing up as oddball sync issues).
WMV RENDER SETTINGS

To render a movie using the WMV format, click File>Mix Down To>WMV.
To customize WMV render settings, click the Edit Details button in
the file save window. This lets you choose specific compression
settings when you’re rendering a video project to a WMV video.
If you’re not a video compression guru, select Preset Quality and adjust the slider for
the best compromise of file size vs. playback quality. Move it all the way to the left for
the smallest possible file size, or all the way to the right for highest quality video.
WMV ADVANCED SETTINGS DIALOG

For more detailed control over WMV compression characteristics, select Specify
Settings and click Settings... Now would be a good time to put on your propeller cap!
 Dimensions

Specifies the height and width of the video. It defaults to the same resolution as the
smallest video in the current project. The dimensions combo box holds a variety of
standard settings, or the Set Custom Dimensions box can be set to any desired size.
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A few things to remember when setting custom dimensions: height and width
must both be even multiples of four, or DirectShow will refuse to render. If the
dimensions you choose are too large, DirectShow may not have enough memory
to render the video. If the chosen dimensions are a different aspect ratio than the
original videos, the resulting video may look stretched or squashed.
 Frame Rate

Specifies how many frames per second the video contains. The frame rate defaults
to the highest frame rate found in the project’s video clips. (To find a video’s native
frame rate , right-click on the video clip and select Properties.) The Frame Rate
combo box contains a variety of standard frame rates, but if you don’t see the frame
rate needed, check the Set a custom frame rate box and type in a specific frame rate.
Should I change the default frame rate?
Probably not. Increasing the frame rate to one higher than any of the project’s video
clips won’t improve final video quality, while decreasing the frame rate will usually
lower the quality. Even if the primary concern is video size, changing the frame
rate is not necessarily useful; depending on the chosen encoding method, lowering
the frame rate can potentially increase the file size. If you’re trying to alter the frame
rate to produce smaller file sizes, you’ll need to experiment to find the best setting.
 Video Encoding

This setting specifies approximately how much bandwidth video playback will
require, in kilobits per second. It’s one of the primary factors affecting compression.
A higher bit rates mean larger files and higher quality, while lower bit rates result
in smaller, lower quality video files. The right bit rate to use will depend on the
dimensions and frame rate. A bit rate that produces a high quality 720 x 480 video
may result in a grainy, pixelated video at 1440 x 1080. Again, you’ll likely need to
experiment for best results.
Microsoft provides a handful of encoding methods for WMV creation. Which one
to use depends on your priorities (quality vs. file size) as well as the video content.
In practice, an encoding method that produces the best results for one video may
not produce the best results for another.
		 
			
			
			
			
			

Constant Bit Rate (One Pass)

This method was designed to handle live streaming video and will usually
produce the lowest quality results when rendering to a file. Because it’s a onepass method, though, it takes half as long to render to file as the two-pass
methods, so it might be the choice for you if the world’s ending in a few
minutes and you really want to be able to watch the video before it’s all over.
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Constant Bit Rate (Two Pass)

		 
			
			
			
			
			
			
			

Variable Bit Rate with Quality Setting

		 
			
			
			
			
			
			
			
			
			
			

Variable Bit Rate with Bit Rate Ceiling

This method will usually produce good quality video if you’ve set a 		
sufficiently high bit rate. Because it’s a two-pass method, it’ll take twice as
long to create the video as one-pass methods will. Since the bit rate will be
consistent for the entire video, it should work well for videos intended to
stream over a network or the Internet.
Using this encoding method with the quality slider at its highest setting
usually results in higher quality videos than the aforementioned encoding
methods. However, the resulting video files tend to be about three times
larger. Use this method if quality is the highest priority. This is a one-pass
encoding method, which means it will take roughly half as long to create
the video as with two-pass methods. (The number of passes refers only to the
creation of the video, and doesn’t affect the speed of video playback.)
This two-pass method uses a variable bit rate, which means that it’s likely
(but not guaranteed) to produce smaller file sizes than the constant bit-rate
methods. With variable bit rate encoding, the bit rate you choose will be
the average bit rate, but actual bit rate during playback may vary depending
on how complex the video is. (Sections of video with lots of motion will
probably have a higher bit rate, and sections with little motion will have
lower rates.) This method has a max rate ceiling, which means that it’ll keep
the highest bit rates from exceeding the average bit rate. Consequently, this
method is better suited to streaming than the Unconstrained Variable Bit Rate
method, but may not produce video of quite as high a quality.

		  VARIABLE BIT RATE (UNCONSTRAINED)
			 This method is similar to the VBR with Bit Rate Ceiling method but lacks

			
			
			
			
			
			

the bit rate ceiling. This means that, while your specified bit rate will be the
average bit rate for the video, the bit rate could reach infinitely high (or
at least really, really high) levels during short sections of the video. This
could cause choppy playback during these sections during streaming, but
can also result in higher quality for these sections, making it a better choice
for video to be played back from a hard drive.

 Audio Quality

This section lets you choose the quality sound. It will list all WMV-compatible
audio quality options installed on the computer. Audio almost always uses far
less disk space than video, so choosing a high audio quality setting will rarely have
much relative effect on overall video size. A setting of 128 kbps usually produces
acceptable audio quality.
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DIMENSION DEMENTIA...

You think audio has lots of format options? We music people have it easy. Video can
have a myriad of options with regard to size, frame rate, compression, and more. Just
to simplify things a bit, “dimensions” refers strictly to a movie’s size, vertically and
horizontally on the screen, expressed in pixels. Here’s a quick primer on sizes and their
typical application:
 320x240

Really small, from back when computers and Internet connections had a tough time
handling video content. Rarely used these days.
 640x480

This was the standard for full-screen video on computers for many years, but has
fallen by the wayside with faster processors and online connections.
 720x480 NTSC

Remember that big heavy thing with a glass screen that used to reside in your
living room? Me neither. Before high-def, 720x480 was the standard for televisions
in the US. NTSC is an acronym for, “bunch of guys who used to argue about 		
US analog TV standards and are probably now unemployed.” Actually, it stood for
“National Television System Committee.”
 720x576 PAL

The European equivalent of the NTSC, with slightly different dimensions and a
different number of resolution lines so you couldn’t play your Fellini and Truffaut
VHS tapes in the US.
 1280x720

Referred to as 720p, this is the smaller of high definition formats, generally seen in
the “first wave” of flat-panel LCD TV’s and digital cameras with video capabilities.
 1440x1080

Referred to as 1080p, this is super high-def, butterfly-wings-in-your-face-at-thestore resolution. The difference between 1080p and 1080i gets a little confusing,
but the basic idea is that the “p” stands for “progressive scan,” meaning that displays
are drawn one after the other for more realistic motion. Progressive scan presents
the most realistic motion.
 1920x1080

Referred to as 1080i, the difference between this and 1080p is that display line
drawing is “interlaced.” Content is broadcast at 30 frames per second, but it’s 		
displayed at 60 frames per second by drawing lines in two passes; one for even lines
and one for odd lines. This is done to reduce perceived flicker.
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OPTIMIZING VIDEO OUTPUT
If you’re using the WMV Compression Settings dialog, you’ll probably want to dig
in and read all the details, but here are a few quick answers to help assist with some
common goals:
How do I achieve the highest quality video?
Using the Variable Bit Rate with quality setting encoding option and then setting its
quality slider to the highest setting (by sliding it all the way to the right) will almost
always produce the highest quality results, but it will also produce files that are about
three times larger than other methods. If that’s too big, try reducing the quality slider
a bit or choosing a different encoding method. (That said, we don’t recommend the
Constant Bit Rate (1 pass) method, as it usually produces low-quality results.) Which
encoding method works best generally differs depending on the video content; you
might have to experiment with multiple methods.
Bit rate also has a large impact on video quality. Higher bit rates will result in higher
video quality, albeit with larger file sizes. There will usually be a point at which a higher
bit rate won’t have any noticeable effect, but raising the rate won’t hurt video quality.
How can I create the smallest video files?
Video dimensions and bit rate will usually impact file size the most, with smaller
dimensions and lower bit rates producing the smallest files. Encoding method can also
be important - don’t choose the Variable Bit Rate (unconstrained) method, and if you
choose the Variable Bit Rate with quality setting method, don’t set the quality slider to
its highest setting.
What video settings should I use for YouTube uploads?
YouTube recommends using the same resolution and frame rate as the original video.
Unless the file size exceeds YouTube’s limits, it’s best to use bit rates that err on the side
of quality rather than file size (in other words, higher bit rates), since YouTube can
compress video to produce smaller file sizes but can’t “re-add” quality removed by low
bit rates. To view the video clip’s original resolution and frame rate, right-click on the
clip and then select Properties.
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LOADING AND SAVING
PROJECTS
NEW PROJECT SETTINGS
The New Project Settings window is displayed when the Mixcraft program icon (or
a shortcut) is double-clicked. It lets you specify preset settings for new projects, or
open a default project file. You may also choose not to display the New Project Settings
window at startup, but we think you’ll leave it on, because the New Project Settings
window is pretty nifty!
All parameters in the New Project Settings window remember their current setting,
even when new projects are initiated. If you make a change to one of the settings,
Mixcraft remembers it the next time the New Project Settings window is opened.

SPECIFY SETTINGS

When the Specify Settings radio button is selected, you’re able to quickly and easily set
the most significant parameters when beginning a new project.
 Video Track

With this box checked, the first track in a project will be a video track (a project can
only have one video track).
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 Instrument Tracks

Defines the number of virtual instrument tracks automatically created by Mixcraft.
Either click the number and enter a number on the keyboard, or use the up/down
arrows to specify a number.
 Audio Tracks

Defines the number of audio tracks automatically created. Either click and enter a
number on the keyboard, or specify a number with the up/down arrows.
 Send Tracks

Defines the number of send tracks automatically created. Either click and enter a
number on the keyboard, or specify a number with the up/down arrows.
 Master Track

Checking this box will create a master track at the bottom of the track list.
 Performance Panel

Checking this box opens the Performance Panel in the new project. Use the Sets
box to define the number of empty Performance Panel sets.
 Snap Setting

This sets the Snap setting in the new project.
 Mode

Selects between Time and Beats mode in the timeline ruler and position displays.
 Tempo

Sets the tempo of the new project. Either click the tempo number and enter a
number on the keyboard, or use the up/down arrows to specify the tempo.
 Key

Click the letter C and enter the desired key signature or use the up/down arrows to
specify the project key.
 Time Signature

Click on the numerator or denominator and enter the desired numbers to specify
the time signature.
 Auto Beatmatch

Checking this box will automatically autowarp imported audio content over 30
seconds in length.
LOAD TEMPLATE

To load existing Mixcraft template files, click the Browse… button, navigate Windows
Explorer to the location of a Mixcraft template file, then double-click the template file
to open it.
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LOAD AN EXISTING PROJECT
Mixcraft can load Mixcraft project files (mx7, mx6, mx5, mx4, or mx3) by clicking
the File menu and choosing Open Project... ([CTRL]+O). Navigate to your project file,
select it and click Open. Alternatively, you can click the Load Project button on the
toolbar or click Browse... in the New Project Settings window.
You can also load Mixcraft 2 project files (MXC) and Mixcraft templates (mx7, mx6,
mx5, or mx4 Template files).
LOADING A STANDARD MIDI FILE

Mixcraft can also open Standard MIDI files. When Mixcraft creates a new track, it uses
the default General MIDI synthesizer as set in the MIDI preferences.
SHOW FOR NEW PROJECTS
The New Project Settings window display can be disabled by unchecking the Show For
New Projects box. If the box is unchecked, Mixcraft still defaults to the most recent
New Project Settings configuration, but skips displaying the New Project Settings
window. To re-enable display of the New Project Settings window, select File>Set New
Project Defaults to view the New Project Settings window, and check the Show For New
Projects checkbox.
SAVING A PROJECT
Select Save or Save As… from the File menu, navigate to the folder where you’d like
the current project’s folder to reside, type in a name and click the Save button. Mixcraft
automatically creates a folder with the name you typed. The Mixcraft project file and all
associated audio files will save to the project folder.
If the project has already been saved in an earlier version, the Save command will
simply overwrite the existing project file with the same file name. If you’d like to save
different iterations of a project, we recommend adding numbers or dates at the end of
the project file name.
Projects can also be saved by clicking the Save button on the toolbar - it’s the icon that
looks like a blue floppy disk. (Remember those? If you still have a box of them in the
closet, stop what you’re doing and go throw ‘em away. You’re never going to use them
again, really.)
Save your work often. You never know when the power might shut off!
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MIXING DOWN A PROJECT TO AN AUDIO FILE
To save the project as an MP3, WAV, OGG or WMA file, use the File>Mix Down To
Audio File command in the Main Window menus. For more information, see “Mixing
Down To Audio And Video Files.”
SAVING AS A MIDI FILE
If you want to export a project’s MIDI content to a Standard MIDI file, select File> Save
As MIDI File… from the Main Window menus. Alternatively, you can choose File>Save
As…., click the Type field and select MIDI File Type 1.
Audio tracks will be skipped, as they do not contain MIDI data.
BACKING UP PROJECTS
A backup of the project is made each time it is saved. Backup files are automatically
saved in the backup sub-folder located in the project folder.
PROJECT TEMPLATES
A template is a special project that stores track names, track images, volume settings,
armed states, and other track settings. Project templates can be a big time saver because
they let you set initial project parameters to your liking.
Mixcraft project templates are stored as .mx7template files.
To save a project template, select File>Save As… in the Main Window menus, then
select Mixcraft Template from the Save as type: drop-down menu. Type in a file name,
select a destination folder and click Save.
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Saving Projects With
Templates
If a new project is
started by loading a
template and you hit
the Save button (or the
File menu equivalent),
Mixcraft will save the
file as a new project - it
won’t overwrite your
template file.

COPY PROJECT FILES TO...

A project and all sounds, videos and/or recordings used within it can be easily saved to
a single folder or zip file. This is handy for organizing projects and backup as well as
sharing with other Mixcraft users.
To copy the project and its sounds, save the project, then click File>Copy Project Files
To... in the Main Window menus, followed by clicking Folder or Zip File.
COPY TO A FOLDER

Pick a folder to copy the project and files to and click OK. You can optionally create a
new folder by clicking the (you guessed it) New Folder button.
COPY TO A ZIP FILE

Enter a name for the zip file and click Save. All project files will be automatically added
to the compressed zip file. Audio and video files do not necessarily compress well (i.e.
they won’t be corrupted, but their file size won’t shrink much), but this is still a great
way to quickly create a single file for emailing or uploading.
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AUTOMATION AND
CONTROLLER MAPPING

AUTOMATED MIXING 101: INTRO TO AUTOMATION
If we might take a moment to pat ourselves on the back, we think you’ll find Mixcraft’s
automation features to be super–comprehensive while being easy to learn and use
(y’know, like the rest of Mixcraft). Though automation can be used for basic volume
and pan moves, we think once you dig in, you’ll find oodles of great ways to make use
of automation, resulting in pro-quality, “how’d they do that?” final mixes.
First we’ll explain Mixcraft’s two different types of automation, then later in the chapter
we’ll go over MIDI/USB hardware controller setup and mapping, as it’s closely tied
into recording automation moves. To save on valuable screen pixel resources, we’ll
abbreviate clip–based automation down to “clip automation,” and likewise with lanebased automation.
IMPORTANT DIFFERENCES BETWEEN CLIP AND TRACK AUTOMATION
Mixcraft features two different types of
automation: clip and track. As its name implies,
clip automation operates individually on each
clip. It allows automation of volume, pan, low
pass filter cutoff frequency and resonance, or high
pass filter cutoff frequency and resonance. It’s useful for automation moves that you’d
like to repeat for a number of clips or if you need to reduce or increase volume or
change panning on just a couple clips. As you’ll see, clip–based automation is fast and
easy and has many applications.
Track-based automation differs in a number of ways. Most significantly, track
automation functions independently of clips – it’s essentially “laid across” mulitple
clips that make up a project. Because it functions independently of clips, it’s possible
to create, for example, a slow volume fade spanning numerous clips. In fact, it doesn’t
even care if there is a clip beneath it, it just does its automatin’ thing. And instead
of being visually superimposed onto the clips themselves, lane-based automation is
displayed separately from the clips it affects in parallel horizontal “lanes” beneath clips.
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The other important difference is that
clip-based automation does not
affect control positions in the Mixer
– it simply adds or subtracts
parameters “on top” of the current
control positions. Conversely, if an
automation lane’s Lock button is
engaged, automation behaves like a
“third hand,” causing mixer controls to move. This makes it more suitable for use with
moving fader hardware control surfaces, as the onscreen controls and physical controls
will move together in lock step.
Finally, clip and lane automation can be used simultaneously, but be extra careful if
you’re using both types to control the same parameter (like volume), as things can
potentially get confusing.
CLIP AUTOMATION
Clip automation is initially displayed by a horizontal line that
appears when hovering over the bottom half of audio or MIDI
clips. The parameter currently shown is selected with the dropdown menu at the top of the screen in the main menu tool bar.
(Click the one that says Volume to view all the clip automation
parameters.) The drop-down menu parameter selection is global – in other words, if
you choose the Pan parameter, all clips in a project will display Pan automation.

Each audio clip has its own independent automation line for the following parameters:




Volume
Pan
High Pass Cutoff





Low Pass Cutoff
Low Pass Resonance
High Pass Resonance

All six parameters are simultaneously available for any clip.
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 Adjusting Clip Automation

To create and adjust clip automation points, hover the mouse
cursor over the lower section of a clip. The clip’s automation
line will appear, and the cursor will turn into crosshairs.
Click to create new points, and drag to position them.
Keyboard/Right–Click Modifiers

 Add Points:

		

Hold the [CTRL] key down and click to add points anywhere
on the sound.

 Move Line:

line
		

Hold the [SHIFT] key down and click down on an automation

to move the line up or down.

 Delete Points: Hold the [ALT] key down and click points to remove them or

		

right– click a point and select Delete Point.

 Setting Exact Value

Precise values can be set by right-clicking on the point and choosing Edit Exact
Value... This opens a dialog box where exact number values can be entered.
 Fades, Boosts, and Reductions

Though these sound like surgical for rich old ladies, these are actually convenient
shortcuts that add multiple envelope points at a time. Select an area of a sound
and choose one of the following predefined options from the Sound menu in the
Main Window:
		 
		 
		 
		 

Sound>Envelopes>Fade Out
Sound>Envelopes>Fade In
Sound>Envelopes>Reduce
Sound>Envelopes>Boost

 Clip Volume

Volume can be set to values from 0% to 200% (-Inf dB to +6 dB).
 Clip Pan
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Pan is the volume balance between the left and right channel (i.e. left and right
speaker). By automating pan settings, sounds can move from left to right or
vice-versa. Pan can be set to values from 100% left to 100% right.
CLIP AUTOMATION LOW AND HIGH PASS FILTERS

In addition to changing the volume and pan of a sound over time, clip automation
includes low pass and high pass filters that (you guessed it) allow filtering to change
over time.
What Is A Low Pass Filter?

A low pass filter is an audio filter that literally allows low frequencies to “pass” while
removing (or “filtering out”) high frequencies. A low pass filter has a cutoff value, such
that every frequency below the cutoff can be heard, and every frequency above the
cutoff is reduced or removed entirely from the audio. For example, if you use a low
pass filter with a cutoff frequency of 2000 Hz, every frequency below 2000 Hz will be
heard in full, but every frequency above 2000 Hz will be reduced or removed entirely.
The low pass filter in Mixcraft is a resonant filter. This means that in addition to the
cutoff value, there is also a value for the amount of resonance. Simply put, resonance
emphasizes frequencies in the vicinity or the cutoff point. If the cutoff frequency is
set to 2000 Hz along with a high resonance value, frequencies above 2000 Hz will be
removed, frequencies below 2000 Hz remain, and frequencies at and directly around
2000 Hz become louder. Resonance is a simple concept, but it can be a dramatic effect,
especially if resonance is high and the filter’s cutoff frequency is changing. This effect
is what’s known as a “filter sweep,” and results in the familiar “wah” sound often heard
in funky synth bass sounds. It’s also the basic concept behind the venerable wah-wah
pedal effect.
A clip’s low pass filter can be used as an EQ effect, reducing certain high frequencies,
such as acoustic guitar finger squeaks. You can also use them to create filter sweeps, by
adding resonance while the cutoff frequency moves up or down. The cutoff frequency
and resonance amount are each controlled via an envelope, and these values can
change over time, in the same way a volume or pan envelope can be used to change
volume and pan amount over time.
Editing A Low Pass Filter

To edit a sound’s low pass filter cutoff, go to the toolbar and
select Low Pass Cutoff. By default, all points on this envelope
are at 100%, meaning that all sounds below the cutoff (i.e.
everything) can be heard. Adding points lower than 100% will
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cause high frequencies to be removed from the audio.
To edit a sound’s low pass filter resonance, go to the toolbar and select Low Pass
Resonance. By default, all points on this envelope are at 0%, meaning that there is
no resonance/emphasis at the cutoff point. Adding points higher than 0% will cause
emphasis at the cutoff frequency, if any frequencies exist at and around that frequency.
What Is A High Pass Filter?

A high pass filter is the exact opposite of a low pass filter, meaning that high
frequencies above the cutoff point are allowed to pass, while frequencies below the
cutoff point are reduced, resulting in a thinning out of the sound. Mixcraft’s high pass
filter includes a resonance parameter like the low pass filter.
Editing A High Pass Filter

Editing the high pass filter parameters works exactly the same as the low pass filter, but
the cutoff parameter defaults to 0%, with low frequencies being gradually removed as
the automation line is raised in a clip. The resonance parameter works as in the low
pass filter.
TRACK AUTOMATION
Mixcraft’s track automation allows automation of volume, pan, and send tracks, as well
as all parameters of a track’s plug-ins and virtual instruments. You can view or hide as
many parameters as you like, with each parameter occupying its own “lane,” until you
run out of screen space. It’s also compatible with Mackie Control, TranzPort, and other
hardware control surfaces.
LANES EXPLAINED

Automation is displayed as a continuous jagged horizontal line (that’s a fabulous title
for an Alanis Morissette record). Since Mixcraft allows automation of multiple
simultaneous parameters, it would get confusing if the automation line were
superimposed directly atop audio and MIDI clips. Thus we give you... automation
lanes! Automation lanes are areas beneath a track’s clips where automation lines for the
track are displayed and edited. To make viewing and editing multiple parameters easy,
there’s no limite to the number of lanes that can be viewed simultaneously, but lanes
may also be hidden to conserve screen real estate.
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TRACK LIST AUTOMATION CONTROLS
 Track Automation Button

The Track Automation button displays and hides automation lanes for individual
tracks. If a track has no prior automation, a single automation lane opens displaying
volume automation when the button is clicked. If a track has existing automation,
you’ll see all automation lanes with views currently enabled (using the + and x
buttons described below). The track automation button colors change as follows:
Track Automation off, track contains no automation.

Track Automation present, automation lanes view hidden.

Track Automation present, automation lanes view displayed.

The Toggle Automation button only hides and displays the automation lanes, but
has no affect on automation playback. In other words, lane automation still happens
even if the lanes are hidden with Toggle Automation button.
You can view as many automation lanes for a single track, or tracks, as you like.
This makes it easy to edit numerous parameter simultaneously. To open additional
automation lanes for a track, click the + sign, then click the Automation Parameter
drop-down menu to select the desired parameter for editing. To hide an automation
lane, click the X sign. When an automation lane is hidden, the automation still
remains active – it’s simply hidden from view.
To simplify remembering which track parameters contain automation data, 		
the text for parameters containing automation data is displayed in blue in the
Automation Parameter drop-down submenu.
 (+) Button

Adds a new automation lane to the track.
 (X) Button

Hides the automation lane.
 Arm

This is the automation Arm button to the left of the lock icon in the
automation track header, not the record Arm button above it. Clicking
this allows recording of automation data either via the onscreen control associated
with the lane’s automation parameter, or by using a hardware controller assigned to
a parameter. (See “Recording Automation Using Hardware Controllers.”)
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 Lock Button

Synchronizes the movements of lane automation with onscreen displays
of channel volume and pan, as well as submix, send, output bus, and master
track volumes. As these parameters are being controlled by lane automation in lock
mode, the onscreen controls for these parameters will be disabled when in lock
mode – you’ll see them shrink slightly and “go dark.” Automation parameter lock is
especially useful when using hardware control surfaces with motorized faders, as it
keeps onscreen and hardware controls locked together at all times.
If an automation lane’s Lock button is not engaged, mixer controls will not move,
and their control positions act as “master” controls in addition to automation data.
In other words, if lane automation contains a volume curve, moving a channel fader
will cause the entire volume curve to become louder or quieter, but the automated
volume will still occur.
SELECTING PARAMETERS FOR AUTOMATION

This drop-down selects which parameter the
automation lane will control. These can be
Mixcraft mixer parameters such as channel
volume, pan, or send levels, or individual
parameters of a plugin or virtual instrument;
clicking the name of a plugin or virtual
instrument will display a drop-down submenu
displaying all automatable parameters for the
plug-in or instrument.
To select a parameter for automation, click a track’s Automation Parameter dropdown lane in the track list – by default it will say Track Volume. You can click it or the
downward facing arrow next to it.
ADDING AND EDITING AUTOMATION POINTS

To add automation points, simply click on an automation lane’s automation line
and drag the point up and down. The position of newly created automation points
conforms to the the current snap setting. In most situations, you won’t want
automation point positions to “quantize” to a note value, so it’s best to set the Snap
setting to Snap Off.
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To move a horizontal section of the automation line, hold down the [SHIFT] key while
dragging. The cursor turns into an up/down arrow and moves the entire line between
the two closest points. This is super handy for increasing or decreasing volume for a
word or group of words in a vocal track, a specific musical phrase, etc.
Dragging an automation point over other automation points will cause them to be
“overrun” and deleted upon mouse release.
FINE TUNING AND DELETING AUTOMATION POINTS

 Edit Exact Value

To precisely set automation point values, right-click it and choose Edit Exact Value.
The dialog box below opens and allows exact settings for automation points.
 Delete Point

To delete an automation point, right-click on and choose Delete Point.
CUTTING, COPYING, AND PASTING AUTOMATION DATA

Automation data can easily be cut, copied, and pasted.
 Cut

To Cut a section of automation, highlight the section of automation to be cut by
clicking and dragging over the area to be cut. Now select [CTRL]+X either in
Mixcraft’s file menu, or by right-clicking the mouse to copy.You can paste the cut
automation data to a new location by positioning the Caret marker in the desired new
location, then selecting [CTRL]+V either in Mixcraft’s file menu, or by right-clicking.
 Copy

To Copy, highlight the section of automation you’d like copied by clicking and
dragging over the area to be copied. Now select [CTRL]+C either in Mixcraft’s file
menu, or by right-clicking the mouse to copy. Position the Caret marker in the
desired copy location, and paste by selecting [CTRL]+V either in Mixcraft’s file
menu, or by right-clicking.
Automation data may be freely copied between tracks, and even to different parameter
lanes. You can also copy multiple automation lanes or automation lanes and clips
simultaneously. The only limitation is that Mixcraft will only copy automation data
to visible lanes, e.g., if volume and pan lanes are copied to track with only a volume
lane visible, only the volume controller data will be copied. This is done to prevent
automation data from copying to an “invisible” location and causing confusion.
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ADDITIONAL AUTOMATION PARAMETERS

Right-click in the track automation header to display additional parameters.
 Clear

Deletes automation data in the currently selected lane.
 Invert

Reverses the positions of automation data in the currently selected lane.
 Boost

Raises automation data value in the selected lane by 5%, 10%, 25%, or 50%.
 Reduce

Lowers the value of automation data in the currently selected lane by 5%, 10%,
25%, or 50%.
 Clear All Automation

Deletes all automation in all lanes for the current track. Be careful with this one!


Hide Automation Lane

Hides the current automation lane - the same as clicking the X in the lane’s header.
RECORDING REAL-TIME AUTOMATION
“Real-time automation” is a fancy way of saying that Mixcraft will record parameter
changes as you’re a moving a knob or slider, or pressing a button. Upon playback, all of
these automation “moves” will dutifully be recreated, as if a swarm magical elves were
obediently working inside Mixcraft (don’t worry, they don’t eat much).
You can record parameter changes using onscreen controls or with the physical
controls on a hardware MIDI/USB controller or dedicated control surface.
RECORDING AUTOMATION USING ONSCREEN CONTROLS

The most straightforward way to record automation moves is to use your mouse or
trackpad to move onscreen sliders and knobs. There a couple of ways to arm Mixcraft
for recording automation. We’ll start with the easiest way... which is super-duper easy!
 Global “Record All Effect and Instrument Automation”

This nifty command essentially tells Mixcraft to look out for any and all incoming
automation moves once the Record button has been pressed. All channel volume,
pan, or send knob moves are recorded, as well as knob or slider movements in
effects or Virtual Instruments.
1. In the Main Window menus, check mark Mix>Record All Effect and Instrument
		Automation.

198

Fading Out Again
To end a project
with an automated
fadeout, display the
Master Track and
select Master Volume
in the automation
drop-down. Scroll to
the end of the project
and add volume
automation points
to lower the volume
for the whole project.
Learn more in the
“Automation and
Controller Mapping”
section.

2.
		
		
		
		

To begin automation recording, place the Caret in the desired starting location,
and click Record. During automation recording, a new track automation lane for
the associated parameter is automatically created and displayed whenever a
knob or slider is moved. You can record as many separate controls as desired
during automation recording.

 Enabling Automation Recording for Specific Effects or Instruments

This is “Method #2.” Instead of globally enabling automation recording for all
possible Mixcraft automation parameters, here we’ll enable automation recording
for just one effect or instrument. We’ll demonstrate this with an effect plug-in, but
the procedure is the same whether you’re automating an effect or an instrument.
		
1. Click on the track you’d like to automate a
parameter on in the track list. Click on the
Automation button to open an automation lane.
2. Click on the automation parameter in the
track header next to the automation lane you
just opened (by default it will say Track
Volume). Scroll down to the name of the effect
or instrument and click Record All in the
submenu.
When recording is engaged, all automatable parameters for this effect or instrument
will be recorded. Control movements on all other effects or instruments are ignored.
Really Important Note: When you’ve finished recording automation for a particular
parameter, remember to click the Arm button to disable arming for the automation
lane, otherwise the automation will be overwritten (that’s a nice way of saying “erased”)
if automation recording of a different automation parameter is initiated in the same
section of the song. Along the same lines, be careful if Loop mode is engaged because
the automation moves you record may be instantly overwritten when Mixcraft “comes
back ‘round.”
 Enabling A Single Parameter For Automation Recording

aka, Keepin’ It Old School

The third method for recording automation is a holdover from older Mixcraft
versions and requires the most setup. It’s still pretty easy though!
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1. Click on the track you’d like to automate a parameter on in the track list.
		

2. Click the track’s automation button. The
automation button will turn green, and an
automation lane will open beneath it. The
default automation parameter will be Track
		Volume; to choose a different parameter for automation, click the down arrow
		 next to the default automation parameter. (When virtual instruments and 		
		 plug-ins in the list are clicked, submenus show automatable parameters.)
3. Once the appropriate parameter has been chosen, click the Arm button beneath
		 and to the left of the automation parameter display; this tells Mixcraft to record
		 controller data for selected parameter. (The track’s main Record Arm button does
		 not need to be armed; it can be, but now you will be recording automation data
		and audio or MIDI note data depending on track type.)
4. Position the playhead where you’d like automation recording to begin by 		
		 clicking in the ruler at top of the project.
5. Press Record. If you’re recording volume, pan, send level, or other parameters
		 with a parameter control on the main screen or in the Mixer tab, you can simply
		 move these onscreen controls, and Mixcraft records their movements. If you’re
		 recording automation for virtual instrument or plug-in parameters, make sure to
		 open up their interface prior to recording (right-click on the keyboard icon or
		the fx icon) for access to controls. Either way, newly recorded automation will
		 appear as it’s recording. Remember that you can add as many automation lanes
		 and parameters as desired.
Remember to hit the Stop button when you’re done, and be careful not to enable
Loop Mode, otherwise the movements you record may be instantly overwritten
when Mixcraft “comes back ‘round.”
TRACK AUTOMATION KNOB

This extra little doodad is easy to miss, but it’s really handy. If
an automation lane for a track is displayed and the currently
selected automation parameter is an instrument or effect
parameter, a knob will be displayed to the left of the
automation parameter pop-up menu. This knob can be used
during automation recording just like the control in an
instrument or plug-in. This may seem redundant, but there are a few good reasons to
use the track automation knob:


If you’re using a plug-in or instrument with a large user interface and your 		
computer has limited screen real estate, the plug-in interface can be closed and the
desired automation parameter can be manipulated using the track automation knob.
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If the plug-in or instrument’s onscreen control knob is tiny or awkward, thus 		
making it difficult to accurately control with a mouse or trackpad, the track 		
automation knob is easier to control.



If you’re using a plug-in or instrument with tons of controls jam-packed into its
user interface, and you’d like to quickly automate multiple parameters, it can be a
lot easier to wrap your brain (and eyeballs) around a couple of neatly arranged
knobs in the track list.

AUTOMATING EFFECTS ON NON-CLIP TRACKS

A non-clip track is any track that doesn’t have audio or MIDI clips associated with it.
The primary track does not have an X, because these tracks only display automation in
the main clip grip. However, if you choose to display additional parameters for a nonclip track (by clicking the + button), these will have an X allowing the extra parameters
to be displayed or hidden. The following track types are non-clip tracks:







SubMix
Send
Output
Master
Instrument Mix Output
ReWire

CONFIGURING A USB OR MIDI HARDWARE CONTROLLER
Before we can record automation using a hardware controller, we’ll need to
map the hardware controller’s knobs, sliders, or buttons to Mixcraft effect or
instrument parameters.
Any USB/MIDI controller or keyboard can be set up to control any effect or virtual
instrument parameter. The basic idea is that you’ll map buttons, knobs, or sliders
to specific parameters. This allows a whole new level of expressiveness with virtual
instruments, effects, and synthesizers.
MAPPING A HARDWARE CONTROLLER TO A PLUG-IN OR VIRTUAL INSTRUMENT
EFFECT PARAMETER

In this example we’ll assume that an effect has
already been inserted into the channel.
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Super Helpful
Shortcut
If a virtual instrument or
plug-in effect is already
loaded into a channel,
its user interface can
be accessed directly by
right-clicking on the
keyboard instrument
icon or FX button. This
is a useful shortcut,
and in this case, it will
immediately get you to
the “gear” icon for MIDI
mapping.

1. Click the FX button in the channel header to open the Effect
List, then click the gear icon next to the effect Edit button to open
the MIDI Mapping window. If you’re assigning a controller to a
virtual instrument, click on its keyboard icon in the track header.

If the effect or instrument controls window is already open, clicking on the gear next to
the preset name also opens the MIDI Mapping window.
If that’s not enough options, you can also open the MIDI Mapping window
by clicking a channel’s show automation button, followed by the channel
automation parameter drop-down menu, scrolling down to the effect, and selecting
MIDI/Audio Control which is faster than it sounds).

2. Under the Parameter heading, click <Add New> to see the automatable parameters
for the current effect or virtual instrument. Choose a parameter and click to select it.
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3. Click the MIDI Learn button. If a knob or fader is being assigned, move it back and
forth. If a button is being assigned, press it. The MIDI controller number will
showing the MIDI controller number (CC) column. Once the parameter is assigned,
click Stop Learning. If Mixcraft doesn’t successfully learn the MIDI controller,
double check that your device is plugged in correctly and that Mixcraft is receiving
MIDI data.
4. Click the X in the upper-right corner to close the MIDI Mapping window.
ADDITIONAL MIDI MAPPING WINDOW PARAMETERS
 Reverse

This reverses the effect of continuous controllers and buttons.
 Reset All

This button clears the current mapping
 Delete Current Mapping

Clicking the red X deletes the currently selected controller mapping.
LOADING AND SAVING EFFECT MAPPINGS

To save current mapping assignments, click the Save or Save As buttons. (You
may want to create a directory for these.) MIDI Mapping window assignments will
automatically be saved with the current project, but the ability to save mappings lets
you reuse settings in new projects.
RECORDING AUTOMATION USING HARDWARE CONTROLLERS
This works almost exactly as described in the “Recording Automation Using Onscreen
Controls” section but instead of moving or clicking the mouse on virtual on-screen
controllers, you’ll be able to record the movements of the knobs, sliders, or buttons on
a hardware controller, which is really fun and more impressive for studio bystanders.
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To record automation using a dedicated hardware controller such as the
Mackie MCU or Novation Launchpad, see “Using Natively Supported Hardware
Controllers.”
AUDIO CONTROL OF A PLUG-IN OR
VIRTUAL INSTRUMENT EFFECT PARAMETER
Instead of using a knob or slider on a MIDI hardware controller, Audio Control
maps the relative level of any Mixcraft audio channel to Virtual Instrument or effect
parameters. The source Audio Control track can be a standard audio track, a Virtual
Instrument track, or even live audio from an armed audio track. Best of all Audio
Control, is easy to use and super fun!
AUDIO CONTROL PARAMETERS

Open the Audio Control window by clicking the gear icon in the Effect List
window, Instrument Preset window, or at the top of an instrument or effect
controls window, then click the Audio tab at the top of the window (this
window defaults to the MIDI tab, so don’t forget to click Audio).

From left to right:
 Check Box

Check or unchecking this box enables or disables Audio Control of a parameter.
 Level Meters

These aren’t actually a control, but you’ll see them flash to indicate incoming Audio
Control signal level. Helpful for making sure everything’s working as it should.
 Source

Clicking this displays all tracks available as Audio Control signal sources. Hovering
over a source track opens a sub-menu with three options:
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Post-Fader- Audio Control signal is tapped after mixer fader level, channel EQ, and
insert effects.
Pre-Fader- Audio Control signal is tapped prior to fader level but after insert effects
and EQ. Fader level adjustments have no effect on control signal.
Dry- Audio Control signal is tapped prior to fader level, insert effects and EQ. Fader
level adjustments have no effect on control signal.
 Curve

Sets the “taper” of how audio level affects control amount.
Linear- An even one-to-one relationship between level and signal
modulation amount.
Logarithmic- Applies a greater amount of modulation as levels
go up (this works more like the hearing curve of the human ear. Science is rad.)
Curve is also a sweet English alternative electronica duo from the 90s.
 Value

Sets the initial parameter amount. This overrides the parameter control in the
instrument or effect; the effect parameter moves as you move the Value control.
 Change

Change affects the Audio Control depth; i.e., how much the audio signal changes
the parameter. Change can have positive or negative values; if Change is set at its
median setting of twelve o’ clock, Audio Control has no effect at all. Dialing the
Change control to the right adds to the initial Value setting, conversely, dialing
Change to the left subtracts from it.
 Attack

Much like the attack knob on a compressor, Attack slows down the effect a loud or
quick transient in the audio signal has on parameter control. Setting the Attack
knob at zero equates to instant effect on the control parameter; higher Attack 		
settings slow the effect of loud or fast transients.
 Release

When a loud signal quickly loses amplitude, Release slows down the effect it has
on parameter control. Setting the Release knob at zero equates to instant effect on
the control parameter; higher Release settings slow the effects of audio signals that
quickly get softer.
 X

Removes the currently selected Audio Control parameter routing.
 Reset All

Removes all current Audio Control routings.
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 Show Effect

This “shortcut” button opens the current effect (or instrument) user interface. It’s a
good idea to keep the user interface open because this allows you to see exactly how
control parameters are affected by Audio Control settings.
USING AUDIO CONTROL

The steps for setting up Audio Control are almost identical whether the destination is
an effect or a Virtual Instrument parameter. In this example, we’ll use the Acoustica
Distortion plug-in on a synth pad loop. The distortion amount will be controlled by a
drum loop.
v

1. Here we’ve set up two tracks; the first is a beat loop from the Mixcraft Library and
the second is an ambient synth pad. Any sounds can be used, but for the purpose of
this demo, it’s a good idea to use a drum loop as the “modulator” (mod source) and
a constant sound (like a pad) for the “carrier “ (sound that gets modified).

2. Click the pad channel’s fx button; choose Acoustica Distortion from the effect list.

3. Click the gear icon next to the Edit button in the effects list, then click the Audio tab
at the top of the MIDI/Audio Control Assign Window.
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4. It’s a good idea to loop the playback of the clips so they’ll play continuously while
you tweeze parameters. To loop playback, check that Snap is set to an even value
(Snap To Grid is fine), drag a highlight region over one or two bars in the ruler at
the top of the Main Window, then click the Loop button in the transport. Now
thwack the Play button, and we’ll get this Audio Control party started.
5. Going back to the MIDI/Audio Control Assign Window, choose the effect parameter
you’d like to Audio Control by clicking Add New in the Parameter column. All
parameters for the chosen effect will be displayed. Choose Distortion.

6. Now we’ll select the mod source - that’s fancy shorthand for “audio track that will
automatically vary the parameter.”
In the Source column, click Off (or the down arrow next to it). A list of all audio
tracks in the current project is displayed. In this simple example, the drum loop
track (“Beat”) is the only choice. Hovering the mouse over it displays a sub-menu
where you’ll select from Post-Fader, Pre-Fader, or Dry; click on Dry. If the project
is currently playing, you’ll see level meters that display the amplitude of the 		
incoming signal.
7. We recommend keeping the effect or instrument interface control panel open in
order to easily see the affect the Audio Control signal is having on the destination
parameter. If you don’t already have the effect or instrument control panel opened,
we’ve made this super easy - just click the Show Effect button.

8. The Value knob sets the initial parameter amount. This overrides the parameter
control in the instrument or effect itself; you’ll see the effect parameter moving as
you move the Value control.
For this example, you’ll want to turn Value control all the way down, because we’re
going to use Audio Control to crank it up and back down.
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9. Change affects the Audio Control depth; i.e., how much the audio signal changes
the parameter. Change can have positive or negative values; if Change is set at its
median setting of twelve o’ clock, Audio Control will have no effect at all. Dialing
the Change control to the right adds to the initial Value setting, conversely, dialing
Change to the left subtracts from it.
In this example, we’ve set the Value control all the way left (setting the initial 		
Distortion amount to zero), and the Change control all the way to the right (causing
the drum loop to dramatically increase the amount of distortion with every hit).
10. Similar to the controls on an audio compressor, Attack and Release knobs
regulate how quickly the parameter is changed. In this example, we’ve set both to
values of zero, equating to instant changes. Turning the attack up will slow down
the affects of transients in the controlling audio; conversely, turning up the release
slows the speed of parameter adjustment when the audio signal becomes quieter.
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MIXING DOWN TO AUDIO
AND VIDEO FILES
Projects can be mixed down to any of the following audio file types:




MP3
WAV
FLAC




WMA
OGG

Click the Mix Down button on the toolbar...

...or select File>Mix Down To from the Main Screen menus, followed by selecting the
format you’d like to mix down to. Alternatively, you can choose File>Save As… from
the Main Screen menus and then click the Save as type drop-down menu to select the
desired format.
Once you’re viewing the Mix Down Project window with the correct format, you’ll see
the following extra options:

FORMAT DETAILS

Displays current format details such as bit rate and number of audio channels (i.e.
mono or stereo).
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 Edit Details...

		
		
		
		
		
		

This opens a window where you can set the audio quality for MP3, WAV, and
OGG format files. Higher quality settings will create larger file sizes. Selecting
the Preset Quality radio button simplifies audio quality settings with a single
slider. If you’re knowledgeable about audio compression, the Specify Settings
radio button lets you set individual digital compression parameters for the
selected file type.

 Estimated Size

		 This shows the approximate size of the resulting mix down file in megabytes.
 Create A New File For Each CD Marker

		
		

If you’ve added CD markers to the project, this causes the mix down to create
multiple files, one for each CD marker encountered.

 Use Marker Titles

		
		

If you’ve chosen Create A New File For Each CD Marker, this option uses the
titles in the marker for the name of the file and tag.

 Use File/Tag Information

		
		
		

Choose this option if you want the audio file(s) to be tagged with the project’s
author information and CD track names (if set). Click Tag Info... to edit the
project’s author information.

 Use Selection

		

This lets you create a file from a selected region in a project.

 Mix Down To Video

		
		
		

Projects containing video can be mixed down to a new video file. Mixcraft
supports mixing down to AVI, WMV, and MP4 formats. (Shouldn’t they just call
it “MP4-mat?”

		 (For tons of information on how to render and mix down with video please see
		“Rendering Edited Videos.” )
MIX DOWN TO STEMS
Mix Down To Stems is similar to the standard Mix Down To Audio File function, but
instead of creating a single mix file, it creates separate audio files for each individual
track. This is useful if you’re handing off a project for mixing (or further composition)
to someone who isn’t using Mixcraft; they can simply import the individual audio files
into empty tracks in their DAW of choice. Mixing to individual stems can also be useful
if you’re producing music for TV or film, as some editors and audio producers prefer to
receive music and effects in a separated, unmixed state.
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You Down With OGG?
OGG is a lossy audio
compression format
that delivers better
sound quality than MP3
(we think, but this can
be debated on your
favorite audio forum)
and potentially saves
a lot of disk space. Its
full name is actually
“Ogg Vorbis”. We’re not
sure what that means,
but we’re pretty sure its
creators watched a lot
of Star Trek.

To use Mix Down To Stems, click the File menu in the top-left corner and select Mix
Down To Stems. Mixcraft will ask if you’d like to save any changes made to the current
project; it’s usually a good idea to do so. Next you’ll see the impressively thorough Mix
Down To Stems window.
CHOOSE TRACKS TO MIX

The top portion of the window displays all standard audio tracks, send tracks, submix
tracks, and virtual instrument tracks within the current project.
 Mix?

These checkboxes select which tracks will be output to new audio files.
 Track#

This column shows the track numbers in the same order as the tracks in Mixcraft’s
main track window.
 Name

Displays the track name.
 Destination File

This column displays where the mixed file will land as well as its full name, as specified
in the File Info section below. (the scroll bars at the bottom and right side of the Tracks
To MIx window will make it easier to see file names and info).
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 Check All

Use this button to quickly check all tracks in a project for export.
 Check None

Conversely, this button unchecks all tracks in a song. This is useful if the song contains
many tracks but you’d only like to export a couple of them.
AUDIO OPTIONS
 Mute Track Effects

Selecting this disables insert effects for all exported tracks. If you’re handing off
tracks for mixing, it’s good to find out what the mix engineer needs. Most often, mix
engineers won’t want compression or EQ types of effects “burned-in” to the files, but
they may want time-domain effects such as synchronized delays. As an alternative to
simply clicking the Mute Track Effects button, you can customize which tracks retain
their insert effects by clicking a track’s fx button and check boxing which effects to
engage or bypass.
 Set Track Volume To 0db

This automatically sets all fader volumes to 0db for more uniform levels in the resulting
files. Be careful though, because this can potentially create clipped files. Note that
Mixcraft’s onscreen faders won’t move; this only affects files as they’re being exported.
 Set Track Pan To Center

Like Set Track Volume To 0db, checking this pans mixer channels to center when
files are being created. This is useful in couple of ways depending on whether you’re
creating mono or stereo files.
Let’s say you have a mono tambourine that’s panned hard left. If you output a mono
file, the hard left panning could cause the overall mono level to be lower than if it were
panned to the center. If you’re outputting a stereo file, the tambourine would retain
its hard left orientation in the resulting file, which could potentially be bad for a mix
engineer. In a nutshell, Set Track Pan To Center is the safest choice if you’d like to leave
panning decisions to the recipient of the individual files.
 Ignore Automation

These checkboxes allow you to temporarily disable all volume, pan, or other track
automation, automation applied to effects parameters, or clip automation as applied to
individual clips. Again, this can be really important if you’re handing off a project for
someone else to mix - they’ll most certainly want automation disabled in order to create
their own.
FILE INFO

Here you’ll specify file formats, naming conventions, and the destination folder for
newly created files.
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 Format

Choose the audio file format here. Options include Wave, FLAC, mp3, OGG, and
WMA. For the greatest flexibility and fidelity, Wave is the best choice as it’s a full–
fidelity, uncompressed audio format, and can be read by almost any DAW software. But
Wave’s uncompressed nature can make for large file sizes, so be aware of this.
 Settings

Opens a window where format-specific preferences can be set. Most of these relate
to file size vs. audio fidelity (i.e., larger file sizes = better fidelity and vice-versa. It’s
always a tradeoff, right?). The good news is that unless the project is excessively large
(like, 100 tracks), uncompressed audio files aren’t considered all that large by today’s
standards, so it’s usually best to lean toward quality over compact file sizes.
 Stereo/Mono Radio Buttons

These buttons let you choose whether the outputted files will be mono or stereo.
 Filing Naming Convention

I attended the File Naming Convention in Davenport, Iowa back in ‘87, and boy could
those people party! Kidding aside, if you’ve ever had to rename dozens of files because
your dumb computer kept adding useless footers or characters, you’ll love this handy–
dandy feature.
It looks a little scary, but it’s actually pretty easy to use. You can type any text you like
into the white box. Characters inside the brackets will automatically be filled in with
the appropriate information as shown in the Tip guide beneath the window.

Let’s say we left the File Naming Convention settings as shown above, and our project
was called “Hokey Love Song”. If were to output the first four tracks, the file names
would be as follows:
Hokey Love Song render #1 [track 1] - drums
Hokey Love Song render #1 [track 2] - bass
Hokey Love Song render #1 [track 3] - Funk Clav 2
Hokey Love Song render #1 [track 4] - Acoustic Piano
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You can rearrange regular text or the location of the bracketed variables however you
like. You can also delete any of the bracketed variables, though we recommend keeping
at least one so you don’t end up with a bunch of files with the same name, potentially
inciting a Wargames/HAL 9000-level computer confusion calamity.
 Output Folder

Here’s where you’ll set the destination folder for mix stem files. If you’re one of those
whiz bang computer genius–types, you can manually type the file path in the field, or
if you’re like the rest of us, click on the ellipsis button to the right for a standard file
dialog where you can specify a destination directory or create a new one.
USE TIMELINE SELECTION

If you only need to output a section of a project, check the Use Timeline Selection box
and highlight a section by click-dragging in the clip area or the ruler above.
TIME TO MIX DOWN!

When you’ve set all the necessary
parameters, click the Mix button, and
soon you’ll see the Success! window
below. If you change your mind, you
can always click the Cancel button
prior to mix down.
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Too Much Time
On My Hands
By default, Mix Down
To Stems outputs all
selected audio files
beginning at bar
one, regardless of
clip locations. If a clip
doesn’t begin until a
later offset, Mixcraft
“fills in” the empty
space with silence.
If you’re handing off
files to someone using
a different DAW, this
greatly reduces the
possibility of timing
issues, because they’ll
be able to drop all the
files on bar number
one in their DAW, and
the files will play in
time (it’s a good idea
to let them know the
tempo, to insure that
bar lines and click
will work properly).
Because clip locations
aren’t stored with audio
files,if Mixcraft simply
output clips beginning
at their actual location
in a project (i.e. not at
bar one), the recipient
would have no way of
knowing the proper
locations of each file,
and the result would be
an out-of-time disaster..
I’m talking to you,
everybody-who-evergave-me-a-ProTools-file
to mix!

BURNING AUDIO CD’S
To burn an audio CD, click the Burn CD icon on the toolbar, or select File>Burn CD...
([CTRL]+B) from the Main Window menus.

Insert a blank CD and click the Start Burn button.

 Writer

		

Selects a CD burner if more than one is available.

 Speed

		
		
		
		

Choose a CD writing speed. In some cases, burning at a slower speed may
improve the success rate of burning and may be more compatible with older
CD players. If the CD writer features Burn Proof-type protection, you can burn
at maximum speed without worrying about a burn failure.

 Test Mode

		
		
		
		

In this mode, the CD writer will go through the process of transferring the
data to the CD without turning its laser on for writing. This lets check if 		
your computer can send data to the CD writer at the desired speed. If you’re
having problems burning a CD, see pg. 357, “Troubleshooting”.
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 Convert To WAV First
		 This converts the mix to one or more WAV files on your hard drive. CD-		

		 quality WAV files require around 8 MB for every minute of audio burned. 		
		 Therefore, a 74 minute mix will require about 650 MB of hard drive space. The
		 advantage to converting to WAV first is that it may help the success rate of burns
		 for some older CD recorders, especially if the CD writer does not have Burn
		Proof.
 Create CD-TEXT

		
		
		

If the CD writer supports CD-TEXT, you should be able to check the CD-TEXT
box. When the CD is played on a player that supports CD-TEXT, titles and
names of each track are visible. Sony CD players often support CD-TEXT.

		
		

You can enter a CD-TEXT title for the CD’s title. Track names will be derived
from CD track markers.

 Burn As One Track

		
		
		
		
		

This option essentially skips CD track markers created in the project and burns
the whole project as one track. If your burner is only supported in IMAPI mode
this is a good option for a seamless mix, because IMAPI mode places a twosecond gap between tracks. (The main drawback is that you can’t skip to specific
tracks when playing the CD.)

 Burn All Or Selection

		
		
		
		
		

Choose Burn All to burn up to 80 minutes of audio, depending on the blank
CD capacity. Choose Burn Selection to burn the current selection of audio. This
can be useful if the mix goes beyond 74 or 80 minutes and you want to burn
extended sections. (Note that it simply uses the selected area to define a time
range to burn.)
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PUBLISHING MIXCRAFT
PROJECTS ONLINE
OVERVIEW
Mixcraft’s Publish function lets you render, upload, and promote music and video
projects to social media sites (such as YouTube, Vimeo, Facebook, Soundcloud, and
Mixcloud) without ever leaving Mixcraft. Uploaded projects can also be promoted on
Facebook and Twitter directly from Mixcraft. The procedure for uploading songs or
videos is basically the same for each type of social media account with a few minor
differences. (See “Social Media Publishing Site Specifics” for details.)
UPLOADING TO SOCIAL MEDIA SITES
Choose the Publish function either by clicking File>Publish, or by clicking the Publish
shortcut button in the shortcuts section at the top of Mixcraft’s main window. The
Publish shortcut button looks like this:

Mixcraft opens a prompt window asking if you’d like to save prior to the publishing
process. Unless there’s a specific reason you don’t want to save the current version of a
project (or you’re Steven Tyler, livin’ on the edge), it’s a good idea to click Yes.

Log in to the desired social media accounts by clicking on the names of each social
media page you’d like to upload to. This opens a login window where you can enter
your username and password. Once you’re logged in, a green checkmark appears next
to the name of the site (you’ll need to individually log in to each social media site). You
can log out of sites by clicking Logout.
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Now that we’ve logged into social media sites, we need to add some information about
our project.
*TITLE (REQUIRED)

Enter a title such as, “My Ratchet Jam,” or perhaps something more esoteric like, “The
Wreck Of The Ella Fitzgerald.”
DESCRIPTION

Enter text here describing the project, crediting musicians (or discrediting them if they
played lousy), shout outs, tofu recipes, etc. This text appears in the description area of
the social media site you’ve chosen.
TAGS (COMMA SEPARATED)

Here you can add keywords allowing users to easily locate your song or video. Make
sure each tag is a single continuous word (e.g. “shoelaces”, not “shoe laces”), and
separate each tag word with a comma.
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PROMOTE ON

Here you can post a message and a link to your project on sites like Facebook and
Twitter. These messages will also include any tags you’ve entered in the Tag area.
The Promote On section works just like Upload To. Log into an account by clicking in
the appropriate row of the Promote On area (if you’ve already logged into a Facebook
account in the Upload To window, you don’t need to do it again).
Once you’re logged in to the site, type a message promoting your upload in the
Promotional Text box. Remember that Twitter will automatically truncate messages to
140 characters in length (including the URL link and any tags you’ve entered), so keep
this message short if you’re one of them Twittery types.

LINK TO

The Promote On function also automatically inserts a URL link in the Facebook or
Twitter message. You can select which social media site the link directs users to by
choosing from the Link To pop-up menu. Social media sites checkmarked in the
Upload To area will appear in the Link To pop-up menu.

219

STATUS

Here you’ll select privacy settings, letting you decide who can see and hear your
projects. These settings are global; in other words, you’ll choose one setting for each
project which applies to all social media sites the project is uploaded to. The Public,
Unlisted, and Private settings are based on YouTube’s options, but work a little
differently for each social media site. (see Social Media Publishing Site Specifics for
details, pg. 188)
UPLOAD IMAGE

If the uploaded project contains audio only, Upload Image adds either an included
Mixcraft still image or lets you select your own. This works on any social media upload
site, but is particularly important with video sites such as YouTube or Vimeo that don’t
allow audio-only file uploads. Mixcraft provides a couple of options:


		
		
		
		
		

Mixcraft Default Images:

In case you’re not graphically-inclined, we’ve provided some nifty Mixcraftcentric images whipped up by Alan, our in-house graphic wunderkind. You
can choose one by hovering over the image and clicking the left/right arrows.
You’ll see thumbnail versions in the Publisher window, but they’ll be full-		
size when viewed on the upload site.

 Custom User Images:

		
		
		
		

To upload your own image, click the downward 		
arrow next to Upload Image. This opens a standard Windows Explorer dialog
where you can navigate to a directory and choose an image. For information
on optimal image sizes for various sites, check out Social Media Publishing
Site Specifics, pg. 188.

RENDER QUALITY

This pop-up menu affects MP3 audio compression parameters (for audio) and frame
rate and compression quality (for video). Lower quality results in smaller file sizes;
higher quality settings result in larger file sizes. You may want to use lower render
quality settings if you have a slower Internet connection in order to optimize upload
times. To see exactly what effect the render quality settings have on video and audio
quality, don your propeller cap and check out the Render Quality tables on pg. 191.
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INCLUDE MIXCRAFT LOGO AND SOUNDS

Let the world know that you’re using Mixcraft to create your masterpieces with these
brief video clips. Checking the Before or After boxes automatically adds a cool threesecond (before) or six-second (after) “Made With Mixcraft” clip at the beginning and/or
end of your project upload.
TIME TO PUBLISH!
Once you’ve filled in the appropriate fields and chosen image and promotion
options, click the Publish! button. By checking multiple checkboxes, projects can be
simultaneously uploaded to multiple social media sites. You’ll see progress bars at
the bottom of the Publisher window. Once the upload is complete, Mixcraft displays
a window confirming upload (or promotion) to the selected social media sites. This
window also contains clickable URL links to all upload sites so you can check out your
handiwork, you multimedia mogul, you.

SOCIAL MEDIA PUBLISHING SITE SPECIFICS
YOUTUBE
 Status
		 As mentioned, the Publish window status settings directly correlate to YouTube’s

		

privacy settings:

		- Public: anyone on YouTube can view.
		- Unlisted: not visible on your YouTube page, but anyone with the URL (or a
		 link to it) can view.
		- Private: can only be viewed by users with YouTube accounts whom you have
		 invited. For the Howard Hughes-type artiste.
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 Upload Image
		 YouTube should accommodate any image dimensions by letterboxing the top

		
		
		

and bottom or sides, but if you want it to fit exactly, use an image with standard
16:9 HD proportions. If you don’t like doing fractional math, 1280x720 pixels
works well (or any multiples up or down thereof).

VIMEO

It takes minute or so for newly published videos to become live on Vimeo, so don’t
panic if you get a scary error message when you first click the URL link in the
Publishing Results window.
 Status
		 Vimeo refers actually refers to their privacy settings as status.

		- Public: anyone can view.
		- Unlisted: only the account owner can view (that’s you, bub).
		- Private: Same as above, only the account owner can view.
You can easily change a video’s privacy settings from your Vimeo account by going to
My Videos and clicking the gear in the video’s top-left corner.
 Upload Image / Custom User Images

		
		
		
		

Vimeo should accommodate any image dimensions by letterboxing the top and
bottom or sides, but if you want it to fit exactly, use an image with standard 16:9
HD proportions. If you don’t like doing fractions, 1280x720 pixels works well
(or any multiples up or down thereof).

FACEBOOK VIDEO
 Status

		 Facebook doesn’t allow Mixcraft to remotely change privacy settings at will, but
		 the first time you log in to Facebook from the Publisher window, you’ll be
		 prompted to set whether uploaded content is viewable by Public, Friends,
		or Only Me. You can change the default setting in the future (from your jet
		 hovercraft car), or from your Facebook page. Make sure you’re on the
		 standard “news feed” page by clicking the f button at the top (beside the 		
		Search Facebook box), and click Apps in the left-hand column. Now click the
		Settings button at the top of the page and click the Mixcraft app. Next to App
		Visibility and Post Audience you’ll see a pop-menu where you can choose who is
		 able to see and hear your sweet jams.
		
		
		

Alternatively, you can always change the viewing audience settings for individual
posts on your Facebook page. Do this by clicking on your name in Facebook (to
view your posts), then click the tiny lock icon in the text section of the entry.
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		  Upload Image / Custom User Images

			
			
			
			

Facebook should accommodate any image dimensions by letterboxing the
top and bottom or sides, but for a perfect fit, use an image with standard
16:9 HD proportions. If you don’t like doing fractional math, 1280x720
pixels will scale nicely (or any multiples up or down thereof).

 Tags (comma separated)

			
			

These appear as standard Facebook hashtags; Mixcraft automatically 		
adds # signs at the beginning of each hashtag word.

SOUNDCLOUD

Soundcloud is an audio-only site, so if you attempt to upload a project containing
video, Mixcraft only uploads the audio portion.
		  Status
			- Public: anyone on Soundcloud can listen.
			- Unlisted: only users who you’ve shared the song with can listen (click the
			Share button on your Soundcloud web page to see private sharing options).
			- Private: same as Unlisted
 Upload Image / Custom User Images

			
			

Soundcloud images are square in proportion; if you’re creating your own,
500x500 pixels is optimal.

MIXCLOUD

Mixcloud is an audio-only site, so if you attempt to upload a project containing video,
Mixcraft only uploads the audio portion. It’s also useful to know that Mixcloud is
oriented toward long-form content such as continuous mixes or full radio shows (all of
which you can create with Mixcraft!); you’ll get a message of mild admonishment for
attempting to upload content less than seven minutes in length.
		  Status
			 Mixcloud doesn’t have options for making uploads private (i.e., anyone can
			 listen to them), so Status pop-menu settings won’t have any effect.
		  Upload Image / Custom User Images Mixcloud images are square in
			 proportion; if you’re creating your own, 500x500 pixels is optimal.
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RENDER QUALITY
VIDEO QUALITY
Frame Rate

Resolution

Quality

High

60 fps max

1920x1080 max

VBR Quality 90

Medium

15 fps

848x480 max

VBR Quality 83

Low

10 fps

480x270 max

Video: CBR 2-pass
Still Images:
VBR Quality 70

AUDIO QUALITY
Sample Rate

Bit depth

Channels

Bit Rate

High

44100

16-bit

Stereo

256 kbps

Medium

44100

16-bit

Stereo

192 kbps

Low

44100

16-bit

Stereo

128 kbps
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MARKERS
Markers serve a variety of purposes. They can be
used simply for adding notes such as “Chorus
Here!” or “fix the guitar effects at mix time,” or they
can perform functions such as changing the project
tempo, key, or time signature. Markers are really
easy to use, so we encourage you to use them!
EDIT MARKER

To insert a Marker into the Timeline at the current Caret position, double-click in
the Timeline or right-click and select Add Marker. Markers can also be added by
selecting Mix>Markers>Add Marker or Mix>Markers>Add Tempo/Key Change from
the Main Screen menus. You can also add a Marker at the current Caret location with
the shortcut [CTRL]+ /... (that’s Control plus the slash key). Using the key shortcut is
especially handy, because markers can be added “on-the-fly” during playback.
If Snap is on, Marker placement will conform to the current Snap setting. (Remember
this if the Marker doesn’t seem to be landing where you want it.) Markers set to alter
the current time signature always snap to a measure, otherwise adding a time signature
change in the middle of a measure would wreak havoc with the project’s timing!
 Title

		

The Marker name. Use this for notes in the Timeline.
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Markers’ Effect On
Tempo, Key, and Time
Signature
Keep in mind that using
Markers to set tempo,
key, and time signature
always overrides any
settings made by
clicking these controls
in the transport display
window. If the tempo,
key, or time signature
remains constant for
the entire project, this
won’t matter, but if
you’re using markers
to change the project
tempo, key, or time
signature, setting them
in the transport display
window effectively only
functions from the first
(permanent) Marker
at the beginning of
the project until the
location of the second
“user-added” Marker.

 Offset

		
		
		

Defines the exact position of the Marker in the Timeline. Markers can be 		
repositioned by altering these numbers, either by clicking in the fields and
entering a number or by using the up/down arrows to change the numbers.

 Marker Play Arrow

		
		
		

Clicking the Marker Play Arrow begins playback of the project from the location
of the Marker. Clicking again stops playback and returns the playhead to the
Marker location.

 Color
		 This drop-down menu can be used to select a color for the Marker “flag.” One

		
		

useful application would be to use different colors to indicate song sections,
such as green for verse, red for choruses, etc.

 Tempo
		 Check this box to change tempos in a project. Tempo changes will affect the

		
		

metronome and cause any sounds set to Adjust To Project Tempo mode to 		
follow the new tempo.

		The Tap Tempo button lets you set a new tempo by clicking quarter-notes with
		 the mouse.
 Key

		 Check this box to change to change the project key signature. Any sounds set to

		

Adjust To Project Key mode will switch to the new key.

 Signature
		 Check this box to change the project time signature. The numerator and 		

		

denominator can be set using the up/down arrows.

		
		
		

Time signature changes will affect the metronome. This will also force the time
signature to have a tempo change, even if it’s the same tempo as the previous
tempo change.

 Create Track For CDs or Audio Files
		 Creates track numbers if the project is to be burned to an audio CD using

		Mixcraft’s Burn Audio CD function. A CD icon will appear on the timeline.
 ISRC
		 The International Standard Recording Code (ISRC) is an international standard

		
		
		

code for uniquely identifying sound recordings and music video recordings. If
you have an ISRC number for a CD track, check the box and add it here. (This
is only important if you intend to mass-produce a CD.)
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 Play Metronome Every X Beat
		 This lets you alter which beats sound the metronome click. When using 		

		
		
		
		
		
		

common time signatures such as 3/4 or 4/4, it’s usually desirable to hear a click
for every beat, but for time signatures with a large numerator (like 12/8, for
example), the incessant clicking might drive you mad (or sound like one of
those silly “Exotica Percussion” lounge records from the 60’s). Play Metronome
Every X Beat instructs Mixcraft to click on fewer beats. Set this using the up/
down arrows.

MOVING MARKERS

To move a marker, position the mouse over the Marker’s flag and click
and drag horizontally. You’ll see the cursor turn into a left/right arrow
when the mouse is in position. Markers can also be moved by doubleclicking the flag and entering a position with the number dialog in the
Edit Marker window.
DELETING A MARKER

To delete a Marker, right-click a Marker flag and select Delete.
Note: You cannot delete the first marker and may only edit it.
DELETE ALL MARKERS

Select Mix>Markers>Delete All Markers in the Main Window menus. This deletes all
Markers except the first one.
MARKER LIST
The Marker List window lets you conveniently
view and edit all markers in a project in one
place, as well as allowing a couple of nifty and
useful tricks. To open the Marker List, click
the View menu at the top of Mixcraft and
select Marker List. To hide the Marker List,
you can reselect it in the View menu but it’s
easiest to just click the X in the upper-right
corner.

You can set most of the same marker parameters as when clicking on individual marker
setting windows, but the Marker List window allows configuring markers for an entire
project with far less mouse clicking. Here are the available parameters for markers in
the Marker List window moving left to right, and top to bottom.
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 Marker Play

Clicking the Marker Play arrow begins playback of the project from the location
of the Marker. Clicking again stops playback and returns the playhead to the 		
Marker location.
 Color

This drop-down menu can be used to select a color for the Marker “flag.” One
useful application is to use different colors to indicate song sections, such as green
for verse, red for choruses, red, yellow, and green stripes for reggae, etc.
 Black Flag

Opens the parameter window for individual markers, in case you need to adjust
parameters not present in the Marker List. Will not make your music sound like
an angry 80’s punk rock band with Henry Rollins (you knew we’d make that joke).
 Title

The Marker name. Use this for notes in the Timeline.
 Offset

Defines the exact position of the Marker in the Timeline. Markers can be 		
repositioned by altering these numbers, either by clicking in the fields and entering
a number or by using the up/down arrows to change the numbers.
 Tempo

Check this box to change tempos in a project. Tempo changes will affect the 		
metronome and cause any sounds set to Adjust To Project Tempo mode to follow the
new tempo.
 Key

Check this box to change to change the project key signature. Any sounds set to
Adjust To Project Key mode will switch to the new key.
 Signature

Click these boxes to change the project time signature. The numerator and 		
denominator can be set using the up/down arrows. Note that time signature
changes can affect metronome clicking. This also forces a tempo change, even if it’s
the same tempo as the previous tempo change.
 X Button

Click X to delete the marker.

MIDI Control Tricks
With the Marker List
As you may already
know, Mixcraft lets you
assign a huge number
of its functions using
external MIDI hardware
devices with knobs,
buttons, and sliders.
One not-so-obvious
use is to assign MIDI
buttons or keyboard
keys to the Marker
Play arrow buttons in
the Marker List. This is
great for looping beats
or song sections in a
live setting. If you have
Loop Mode engaged,
Mixcraft automatically
loops playback between
the selected marker and
the following marker.
Along with the Marker
List’s tempo and time
signature settings,
this effectively puts
an infinite number
of beats and tempos
immediately under your
fingers.
Another use for
Marker Play button
controller assignment
would be for live
playback of stereo
mixes of entire songs
or backing tracks,
effectively turning your
computer into a very
fast and easy-to-control
iPod. Simply import
all songs for a live set,
create markers, then
[cont. next page]
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assign playback for
each to a MIDI key or
button control.
Here’s how to
assign controllers to
the Marker List. With
the Marker List window
open, click the MIDI
button in Mixcraft’s task
bar.

AUTOMATIC TRACK MARKER WIZARD

The automatic track marker wizard is a handy way to quickly add multiple track
markers. Markers may be added at specific time intervals, or in areas of silence - you
can even remove silence! This can be handy for breaking up the tracks of entire albums
recorded as a continuous audio file.
To use the Automatic Track Marker Wizard, select Mix>Markers>Automatic Marker
Wizard in the Main Window Menus.
 Automatically Create Track Markers: At Intervals Of

		
		
		

This creates Markers at the specified intervals. Select the number of minutes
between intervals with the At Intervals Of drop-down menu, and the total
duration over which Markers will be added with the For box drop-down menu.

 Automatically Create Track Markers: Based On Silence Of Sound

		Choose Based On Silence Of Sound to create markers based on silent gaps in
		 a recording. (Or choose Based On The Sounds of Silence if you want markers
		 arranged to sound like a Simon & Garfunkel classic.)
 Based On Silence Of Sound

		

This drop-down menu lets you choose from all audio clips in a Project.

 Must Be Silent For

		

Specifies the length of silence that must elapse before a new Marker is created.

 Silence is X% Or Less Of Full Volume
		 This lets you choose how low the volume of audio content must fall to be

		
		

considered “silence,” expressed in percentage (0% is full silence, 100% would
be full-scale volume). The default silence setting is 7% of full volume.
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All assignable
parameters will turn
purple. Click on a
Marker Play arrow in
the Marker List, then
press a button on your
MIDI controller. The
button is now assigned
to trigger the Marker
Play arrow. To assign
multiple buttons or
keys, simply leave
Mixcraft in MIDI Learn
mode. When you’re
done assigning buttons
or keys, click the MIDI
button in the task bar
again. To reassign to
a different hardware
button or key, click the
MIDI task bar button,
reselect the desired
Marker Play arrow, and
hit a different hardware
controller button or key.

 Must Be At Least X Minutes Between Markers
		 Set the minimum time between markers using the Must Be At Least X Minutes

		
		

Between Markers drop-down menu. This parameter helps prevent ending up
with an excessive number of markers.

 Remove and Trim Silence

		
		

This automatically cuts out silences between audio content. It’s good for getting
rid of long pauses in continuous recordings.

 Fade Edges By X Seconds

		
		

This adds a gentle fade-in and fade-out at the beginning and end of audio
sections when using the Remove and Trim Silence features.

 CD Track Markers

		
		
		
		

Adds CD Track Markers at each Marker. This is useful when converting existing
audio content to be burned to a CD with individual tracks. (Unless you want
to be like Prince’s “Black Album,” which was notoriously mastered as one 		
super–long purpley song.)
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EFFECTS
Mixcraft includes a large suite of real-time audio effects that can be applied to audio
clips or virtual instruments. These are usually referred to as “plug-ins.” Mixcraft also
supports user-installed third-party plug-ins in VST and VST3 formats.
ADDING EFFECTS
To add effects to any Audio Track or Virtual Instrument Track, click the FX
button to open the Effect List window.

Now click the <Select An Effect> drop-down menu and choose an effect. Once you’ve
selected an effect, the Effect List should look something like this:

 Active/Inactive Checkbox

		 Effects can be toggled on or off by clicking the green check mark to the left of
		 the effect name. The check mark next to Effect toggles all effects on and off. (See
		Effects Chains below.) This allows auditioning of effects without losing settings.
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 Effect Name

		Click <Select An Effect> to add new effects, or click an existing effects name to
		 replace an effect with a different one.
 Preset

		The Preset drop-down menu lets you select from included presets. These 		
		 are very handy for speedy mix setups (or if you’re not sure how to 		
		 operate a particular effect).
 Edit

		The Edit button opens the effect’s user interface for individual parameter 		
		tweaking.
 X

		

This removes an effect and returns its slot to the <Select An Effect> dialog.

 Use MIDI From Track

		

		The Use MIDI From Track pop-up menu lets you route the playback of MIDI
		 note data to a VST effect. This is most commonly used in conjunction with vocal
		 tuning plug-ins (like Mixcraft’s GSnap Pitch Correction) or vocoder plug-ins.
		 To choose a MIDI source track, click the pop-up menu and select the desired
		 MIDI track. The Use MIDI From Track setting applies to all effects in the track’s
		 effect chain, but plug-ins that don’t make use of MIDI data will simply ignore it.
ADDING EFFECTS USING THE +FX BUTTON
Effects can be added directly to tracks and mixer channels without opening the Effects
List window first.
ADDING EFFECTS TO MIXER CHANNEL EFFECTS SLOTS

Open the Mixer window by clicking on the Mixer tab at the bottom
of the screen. Click the +fx button and select an effect from the
pop-up window.
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ADDING EFFECTS DIRECTLY TO TRACK EFFECTS SLOTS

Hidden next to every channel in the Track List are effects slots just like the ones in the
Mixer view. These are essentially the same as the Mixer effect slots, i.e. any changes
made in the Mixer effects are reflected in the track effects slots and vice-versa.

The Track List effects slots are hidden by default; to view them, select Track>Show
Effects On Tracks from the Main Window menus or right-click on the track header. You
can also position the mouse cursor over the right edge of a track and slide the left/right
arrows to reveal or hide effects slots. Clicking +fx opens a pop-up menu where you’ll be
able to choose effects.
If more than two effects are added, the track’s vertical height increases to accommodate
additional effects (you can optionally reduce the track’s height, but effects slots may
become hidden).
EFFECTS SLOT RIGHT-CLICK FUNCTIONS

Oh, how we love to stash commands beneath your good
friend, the right-click button. These menus are the same
for the Mixer and Track List effects slots.

 Active

Use the check mark to bypass or engage an effect. Useful for A/B’ing purposes.
 Remove

Deletes the current effect from the list.
 Effect List Is Active

Just like the Active command, but this bypasses or engages all effects slots for the
current track.
 Edit Effects List...

Opens the track’s Effects List. Exactly the same as clicking the fx button in the track
header or mixer.
 Remove All Effects

Deletes all effects for the current track in one fell swoop.
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Display Virtual
Instruments and
Effects, Right Now!
Right-clicking a
channel’s FX button
instantly displays the
user interface for all
effects on a channel,
skipping the Effects
List Window. This is
really handy if you’ve
already decided on
which effects are to be
used and just want to
tweak their parameters.
This works exactly
the same for Virtual
Instruments by rightclicking a track’s Virtual
Instrument button.
To hide all effects or
Virtual Instruments for
a channel, press [CTRL]
+ right-click on the “fx”
button.

EDITING EFFECTS
To edit an effect’s individual parameters, click the Edit button to the right of the effect
name.

Every effect has a unique user interface and controls, but the top section will be the
same for all effects in Mixcraft. Let’s go over these:
		

 Level Meter

		
		
		

In the top-right corner of every VST Effect and Virtual Instrument is a stereo VU
meter. This is helpful when adjusting input and output levels, and in those
inevitable “what the heck?@#?” moments, it’ll let you know signal is present.

 Active Checkbox

		
		

Exactly the same as the Active/Inactive checkbox in the Effect List 		
window, just replicated in the effect interface for convenience.

 MIDI Map Parameters Gear

		
			

This opens the MIDI Mapping windows. This is used to assign hardware
controllers to plug-in parameters.
(See “Mapping A Hardware Controller To A Plug-In or Virtual
Instrument Effect Parameter”)

 Select Preset

		
		 Allows selection of Mixcraft and user presets. This is the same as the preset

		

selection menu in the Effect List window.

 Load VST Preset File (VSTi Plug-Ins only)

		

Some VST effect and instrument manufacturers distribute additional
sound banks in the form of .fxb files, replacing current presets with a
new presets.

 Save A New Preset

		

Saves the current plug-in settings to a new preset. You’ll be prompted to
enter a preset name. The preset will then appear in the preset list.
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 Remove A Selected Preset

		

Permanently removes the currently selected preset. Factory presets
cannot be deleted.

		
			

Note: If a track is frozen, its effects will not be editable until the track is
unfrozen. Objects in mirror are behind you.

EFFECTS CHAINS
A series of effects can be configured in the Effect List window by adding effects using
the <Select An Effect> dialog.
REARRANGE EFFECTS ORDER

To rearrange the order of effects in a chain, simply click on an
effect anywhere in the list and drag it to the desired location in the
chain. It’s easiest to do on the left side as the cursor will turn into
up/down arrows, and you won’t risk accidentally clicking
something else.
Mixcraft includes many useful effects chains
optimized for common applications. To load
an effects chain, click on the Effects Chain
drop-down menu at the top of the Effect List
window. To search for effects chains with a
particular term (“drums” for example),
simply type in a keyword next to the
magnifying glass icon. You can add as many
effects as desired to an Effects Chain.
The icons to the right of the Effects Chain drop-down menu perform the following
operations:
 Save A New Preset

		

Saves the current Effects Chain setup to a new preset. You’ll be
prompted to enter a preset name. The presets will then appear in the
Effects Chain presets.

 Remove A Selected Preset

		

Permanently removes the currently selected preset. Careful with this
guy! (You’ll get an, “Are you sure?” prompt.)

 New Preset

		

This clears all current effects if you’d like to start with a clean slate.
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MASTER EFFECTS

This is the effect insert on the Main Mix bus. Use this for adding master effects to be
applied to the entire mix such as bus compression, EQ, volume maximizers, etc.

Master Effects can be added either by clicking the FX button next to
the Master output slider in the Main Window, by clicking the Main Mix
FX button in the Main Mix channel, or by clicking the FX button in the
Master Track in the track list (if it’s currently displayed).

ADDING THIRD-PARTY VST EFFECTS
Mixcraft supports standard Windows VST as well as VST3 effects plug-ins. If you’ve
installed a third-party VST effect and you’re not seeing it in Mixcraft’s effects menu,
you’ll need to add the VST effect folder. There are two ways to accomplish this:
The super-duper easy way is to simply drag-and-drop its DLL file into Mixcraft’s main
window. Mixcraft automatically installs the file in the correct location and adds it to
the VST search path list (in other words, it’ll just work!). The alternative method is to
“manually” add VST effects to Mixcraft’s VST/VSTi folders.
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Select Preferences>Plug-Ins and click the Edit VST/VSTi Folders button.

Click the Add... button, navigate to the VST effect in Windows Explorer, and click OK.
If you’re not sure where the new VST plug-in is, click the Auto-Scan For VST/VSTi
Directories button for assistance finding VST plug-ins.
EFFECTS SIDECHAINING
Sidechaining allows an audio track to control parameters of a VST plug-in on a different
track. This may sound a bit esoteric and complex but once you wrap your head around
the concept, it’s easy to do and can be a real lifesaver.
Sidechaining is often used to “drive” a compressor. This is referred to as “ducking.” A
common trick in techno and EDM music is to insert a compressor into the master mix
bus and route the kick drum to the compressor’s sidechain input. This briefly reduces
the overall mix volume with every kick drum hit for a dramatic increase in perceived
impact.
A far more pedestrian, but equally useful application of ducking is to reduce the
volume of a background music track when an announcer speaks. The sidechained
compressor is inserted into the background music track while the sidechain input is
driven by the announcer’s voice. When the announcer is silent, the music plays at a
nominal level; when the announcer speaks, the music bed level is reduced. Unlike
our techno kick drum example, the compressor’s attack and release to slower settings
would be set to act slowly to prevent the music bed volume from rapidly jumping up
and down between words.
Sidechain inputs aren’t limited to just compressors. Expanders and gates (essentially
the opposite effect of a compressor) frequently feature sidechain inputs; these are
often used for stuttering synchronized gating effects (the rock band Garbage is fond of
applying this effect to guitars; check out the track “Vow”). Other VST effects that often
feature sidechain inputs include filters and vocoder plug-ins.
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Can I Sidechain Any VST Effect?
Unfortunately no, because only certain VST effects feature a sidechain input. If the
effect has this capability, you’ll see the Sidechain Source menu, plain-as-day on the
right side, at the top of its edit window.

As of this writing, Mixcraft 8 doesn’t include a sidechain-capable compressor*, but we
really dig Variety Of Sound’s Density mkIII. Not only does it sound great and have a
ton of cool features, it’s totally free, and who doesn’t love free?
* OK, that’s not 100% true: Mixcraft 8 Pro Studio includes the Sidekick Extended 6
compressor which allows sidechaining, but it doesn’t use the sidechaining routing
capabilities built-in into Mixcraft’s sound engine.
HOW TO USE THE EFFECTS SIDECHAIN INPUT

Since effects numerous effects types include sidechain inputs, the sidechain input can
influence effects parameters in varying ways, but sidechain routing operation is the
same regardless. In this example, we’ll insert a sidechained compressor into a MIDI
virtual instrument track playing sustained synth pads, and we’ll impart the rhythmic
groove of a drum pattern from a different track upon the synth pad by routing the
drum track audio into the compressor’s sidechain input.
The main track window looks like this:

Click the Synth Pad fx button in the track list, then click the <Select An Effect> down
arrow in the Effect List window. Select a sidechain-capable compressor (in this case,
we’ve used the aforementioned Density mkIII, which is not included with Mixcraft, but
it’s free to download it).
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Click the Edit button in the Effect List window, then click the Sidechain Source pop-up
menu. This is where you’ll choose an audio track to influence the VST effect. The list
will display all current tracks usable as sidechain audio sources, including standard
audio tracks and SubMix tracks. The current track with the sidechain effect inserted
will display Off in the Sidechain Source menu. When the mouse is positioned over a
track input selection, a submenu appears. Here are your options:
 Dry

As its name implies, the source track audio is sent into the effect’s sidechain 		
completely unadulterated. In other words, its current volume level, mixer EQ, and
insert effects are bypassed and have no effect on audio sent to the sidechain input.
 Pre-Fader

As with Dry, the channel’s current fader volume has no effect on the sidechain input
signal, but mixer settings and insert effects will be “in the chain.”
 Post-Fader

Post-Fader is just like Pre-Fader, with mixer EQ and insert effects active, but here
the current fader volume will affect the audio level sent to the sidechain input. This
can be useful, because some sidechain-enabled effects won’t have any provision for
adjusting the signal level entering the sidechain input.
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Let’s get back to our drums-adding-rhythmic-groove-to-constant-synth-pad
example... If you’re using the Density mklII compressor, you’ll need to set the SC (i.e.,
sidechain) switch to Ext. (Some VST effects will automatically respond to a sidechain
input signal, while others won’t.)
For our Sidechain Source, we’ve chosen the Drums track, set to Pre-Fader. Using the
Dry or Pre-Fader setting makes set up especially easy, because fader volume for the
sidechain source track can be set to zero, making it easier to hear how the sidechain
signal alters the sidechain-compressed track.
If you’re digging all the things you can do with compressor sidechaining, we think
you’ll love Mixcraft’s innovative Audio Control feature. It works in a somewhat similar
fashion, but instead of using audio to manipulate plug-ins with sidechain inputs,
Audio Control lets you use ANY audio track to control ANY MIDI-controllable plugin or instrument parameter. ‘Tis a barrel of monkeys! See “Using Audio Control” in
“Automation and Controller Mapping.”
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INCLUDED EFFECTS
Mixcraft includes tons of super awesome effects. These work alongside any userinstalled third-party VST or VST3 effects. The fancier editions of Mixcraft add more
included plug-ins.
All Mixcraft editions include the following effects:
ACOUSTICA CHORUS

Chorus is used to thicken up a sound, by adding tiny variations in pitch as well
as small amount of delay. It’s often used to give the impression of more than one
instrument or vocalist performing the same part.
ACOUSTICA COMPRESSOR

Compressors reduce the differences in volume between quiet sounds and loud sounds
in a recording. This effect is often used on vocals and drums, where some portions
of the sound are very quiet, and other portions are very loud. Reducing a recording’s
dynamic range makes mixing far easier and, dependent upon settings, can impart
“punch” and impact.
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ACOUSTICA DELAY

Also known as “echo,” delay is one of the oldest and simplest effects. Delay takes
incoming audio, waits a specified amount of time, and replays the audio, creating an
echo effect. The Feedback parameter allows a portion of the signal to be sent back into
the delay effect, creating additional repeats of the echo.
ACOUSTICA DISTORTION

Acoustica Distortion adds audio distortion similar to that used on electric guitars. This
effect can range from subtle grit to extreme destruction of the original audio. Note that
adding distortion can severely affect the volume of the recording. A little distortion
goes a long way, so experiment with very low settings to see how the audio is affected
and increase the amount gradually.
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ACOUSTICA EQ

Acoustica EQ is a ten-band graphic equalizer that allows boosting or cutting of audio
frequency regions. If a recording sounds thin, bass frequencies may be boosted. If
a recording sounds too bright, high frequencies can be reduced. The Output Gain
control is used to raise or lower overall volume after EQ processing.
ACOUSTICA FLANGER

Flangers delay the signal by a small amount while slowly varying the delay time,
producing a swept comb-filter effect, commonly referred to as a “jet swooshing” sound
(because of its similarity to the sound of a jet plane flyby).
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ACOUSTICA REVERB

Used to recreate the subtle echoes and reverberation of a natural room, reverb effects
are some of the most useful in music. A single violin or piano playing in a large church
or auditorium takes on new life when the last note bounces around the room and fades
away.
Acoustica Reverb effect can be used to recreate the ambience of many different
environments, ranging from small spaces to exceptionally large chambers. The decay
of high frequencies can be set High Frequency Damping control; carpeted rooms, for
example, absorb most high frequencies, but large empty houses with marble floors
sound extremely bright and echoey because high frequencies are not damped.
CLASSIC AUTO-FILTER
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Produces filtering effects that change over time, most commonly used for automated
“wah-wah” effects. However, Auto-Filter’s extensive parameters allow many more
musical variations including triggered effects (where the filter follows the dynamics of
a sound) or synced LFO effects (where the filter opens and closes at note values locked
to the project tempo).
CLASSIC CHORUS

Similar to the Acoustica Chorus effect, but with some additional features and a unique
sound.
CLASSIC COMPRESSOR

Similar to the Acoustica Compressor effect, but with additional parameters and a
different tonality. (There are many different compressor types in the software and
hardware world; pro audio engineers prefer different compressors for different source
material.)
CLASSIC DELAY

Like the Acoustica Delay effect, this offers echo and delay effects, but goes much
further with several outstanding features. Most exciting is Sync, which automatically
synchronizes delay times to note-values derived from the project tempo.
Synced delay effects are a fun and musically useful way to spice up parts. Classic
Delay’s Sound and Type parameters make it a great choice for replicating the sound of
vintage analog and tape delay effects.
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CLASSIC EQ

Similar to the Acoustica EQ effect, Classic EQ offers individual control of the left and
right channels. This can be used to create unique stereo effects or to correct audio
anomalies in one side of the stereo image.
CLASSIC FLANGER

Similar to Acoustica Flanger but with added controls and a unique tonality. The
modulation of the sweep can also be synced to the project tempo.
CLASSIC MASTER LIMITER

Similar to the Acoustica Compressor in function, the Classic Master Limiter is intended
to be used in the Master Effects bus to smooth out and increase overall project level for
a professional “sheen.”
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CLASSIC PHASER

Similar to a Flanger with a less metallic and more “swooshing” tonality, phasing is often
added to guitar and synth pad sounds, adding animation, depth, and character.
CLASSIC REVERB

Similar to the Acoustica Reverb effect, with some additional features and a unique
sound. Reverbs are another example of an effect where each brand and type has its own
unique audio “fingerprint,” so it’s often good to have a few different types for different
characters.
VOXENGO AMP SIMULATOR
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Voxengo Amp Simulator is a carefully modeled guitar amp simulator with extensive
boost and cut filtering, and numerous guitar cab and mic emulations.
VOXENGO SPECTRUM ANALYZER

Voxengo Spectrum Analyzer is a supremely powerful tool for viewing the frequency
spectrum of audio content. This is great for learning about audio frequencies and
refining mixes. (Voxengo Spectrum Analyzer needs to be currently viewed to use it, so
remember to click the Edit button in the Effects List or double-click the channel’s FX
button.)
EZQ EQUALIZER

There’s no easier way to EQ tracks! Instead of
adjusting numeric parameters or spinning virtual
knobs, EZQ lets you move a dot within a 2D
plane to quickly impart brighter, darker, warmer,
or tinnier sound characteristics.
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GTUNE GUITAR TUNER

GTune guitar tuner can be used for guitar and
bass tuning or for tuning other monophonic
instruments such as flutes, violins, and
synthesizers. This effect does not alter audio in
any way.

MIXCRAFT 8 RECORDING STUDIO ADDITIONAL PLUG-INS
Mixcraft 8 Recording Studio adds the following plug-ins:
VOCALZAP

VocalZap removes vocals and other center-panned content from stereo recordings. It’s
ideal for creating karaoke tracks.
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PULTRONIC TUBE EQ

G-Sonique’s Pultronic Tube EQ is a detailed recreation of a classic vintage vacuum-tube
based equalizer found in top studios throughout the world. Warm up tracks or add a
completely new character with the Pultronic Tube EQ’s array of tube models and
presets.
SHRED AMP SIMULATOR

Shred Amp Simulator by AcmeBarGig is a complete guitar amp and cabinet suite
including five classic amp heads, 17 cabinet models, and six powerful effects. Shred
faithfully models classic British and American tube heads, and includes powerful room
modeling technology.
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BROADCAST MULTIBAND COMPRESSOR

Broadcast Processor is a multiband compressor/limiter designed to impart maximum
overall volume to a mix by breaking up audio into separate frequency bands, and then
compressing these bands individually to make them louder or quieter. It can also lower
louder audio parts with downward compression for a more dynamically balanced mix.
This tool is essential for creating loud, dynamically balanced, professional mixes for
dance, electronica, pop, and other genres where “loud” mixes are needed.
GSNAP PITCH CORRECTION

GSnap is a state-of-the-art pitch correction plug-in that’s ideal for subtly (or not-sosubtly) tuning vocal performances in real-time (i.e. as they play back in a project). Note
choices may be limited to preset or user-specified scales, and the speed and amount of
pitch correction can be adjusted.
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EU PROMIXEQ-10A

EI PromixEQ-10A is a high quality five-band parametric EQ, optimized for final
mastering. Its straightforward interface and superb fidelity make it a natural for all
mastering applications.
DTC-1 DISCRETE ULTRA TRANSPARENT VCA BUS & TRACK COMPRESSOR

G-Sonique DTC-1 is modeled after a legendary analog VCA-based analog bus
compressors known for its transparency. It allows significant gain reduction (10dB or
more) without undesirable pumping, distortion, or compression artifacts. DTC-1 is
perfect for tracking/mixing and excels in mastering applications.
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ORB7000 OCTAVE REVERB

ORB7000 is a special, artistic and creative octave/pitch-shifting reverb system for
creating special sound and space effects, new sound colors and unique experimental
sounds. Using “particle-based pitch shifting,” ORB7000 splits the signal into three
signal paths: octave down, normal, and octave up, creating unique sounds including
classic “Eno shimmer” effects.
MIXCRAFT 8 PRO STUDIO ADDITIONAL PLUG-INS
Mixcraft 8 Pro Studio adds the following plug-ins:
ACOUSTICA 31 BAND EQ

Acoustica 31 Band EQ is a 1/3-octave graphic equalizer offering precise control over
frequency content. Slider range is adjustable from 6dB to 24dB of boost and cut, and
many presets are included to get you started.
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ACOUSTICA PRO STUDIO REVERB

Acoustica Pro Studio Reverb takes the lush, crystal-clear reverb used in our awardwinning Pianissimo grand piano virtual instrument and expands it into a greatsounding, flexible standalone effect.
CELEMONY MELODYNE ESSENTIAL

Melodyne is a vocal and audio tuning powerhouse that lets you move and edit notes
on a grid similar to the one used Mixcraft’s Piano Editor. It excels at fast and natural–
sounding vocal pitch correction. Melodyne is integrated into Mixcraft 8’s Sound edit
window, but we also include the standard plug-in for legacy projects. (Check out
“Appendix 1: Using Melodyne For Basic Vocal Tuning” for more info on Mixcraft’s
integrated Melodyne functionality.)
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DUBMASTER LIQUID DELAY

Dubmaster Liquid Delay combines tempo-synced rhythmic liquid delay with powerful
LFO-driven filtering and phase effects to add atmosphere and a unique sound to tracks
FAT+

FAT+ mixes all of the essential ingredients for truly huge sounds into one powerful
plug-in, combining analog warmth, vacuum-tube distortion, and tape saturation into a
single effect that’ll make your tracks sound enormous!
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FEROX TAPE EMULATOR

There’s something about the sound
of tape, and Ferox captures that
intangible “something.” The unique
combination of authentic tape hiss,
saturation, and compression brings
personality and classic feel to tracks.

FSQ1964 TRANSIENT VITALISER

This powerful mastering tools adds sweet high frequencies, analog colors, crystal and
transparent transients, and boldness to any mix.
GSXL4070 VINTAGE PARAMETRIC EQ

Four bands of parametric equalization plus a high pass filter emphasize the sizzle
and bass in tracks, cut out noise and mud from the mix, and dial in the perfect tone.
Inspired by the EQ section of one the world’s most coveted studio mixing consoles.
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IZOTOPE MASTERING ESSENTIALS

Mastering Essentials delivers Izotope’s world-class mastering tools to Mixcraft with a
gorgeous-sounding parametric EQ, spectrum analyzer, a phenomenal room simulation,
vacuum-tube compression, limiting, and saturation.
MID-SIDE ENVELOPE FOLLOWER+

An envelope follower using the dynamics and amplitude of the incoming audio to
modulate the cutoff frequency of a filter… the result is a funky, liquid filtering effect
that dynamically responds to music content. The signal is split into mono (Mid) and
stereo (Side) signals. Each part can be boosted or attenuated, enabling the creation of
panoramic 3D effects.
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MID-SIDE HARMONIC VITALISER

Mid-Side Harmonic Vitaliser+ is a stereo enhancer featuring a new technology for
vitalizing, coloring, controlling, adjusting, and widening stereo audio content (the Side
part of a signal), as well as adding space, width, and depth to mixes.
MID-SIDE STEREOPHASE FILTER+

Offers new, creative methods of modulating stereo sound by creating special 3D
modulation effects with phasing and filtering, and creates the illusion of effected sound
flying around your head, while the center audio content (Mid) remains untouched.
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TB GATE

A good gate effect is critical for removing noise and mud from a mix. Gates remove hiss
and noise from areas of a track containing no desirable sound, such as the hiss between
vocals or guitar passages.
TB PARAMETRIC EQUALIZER

The key to a good mix is proper EQ’ing, and this graphic parametric equalizer features
a gorgeous interface, six color-coded frequency bands, six filter types, spectrum
analysis, and the ability to independently EQ the mono (Mid) and stereo (Side)
portions of stereo material.
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TIMEMACHINE BIT CRUSHER
V

Recreate the sound of 8-bit video games, 12-bit samplers, or trash audio by
transforming it into 2-bit noise! TimeMachine simulates the effect of A/D and D/A
aliasing, re-sampling, and bit reduction (both linear and mu-Law quantization).
TWISTHEAD VS-206 PREAMP
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Adds subtle analog warmth or fierce overdriven tube grit to tracks. This vintage tube
preamp adds 1960’s charm and character to vocals, guitar, drums, and more.
XBASS 4000L BASS ENHANCER

XBass 4000L adds the warm, fat bass tone found in vintage tube circuits to your
projects. XBass 4000L combines two unique algorithms to enhance the bass spectrum
of tracks, adding emphasis to the audible bass content, enriching the bass and sub-bass
spectrum, and boosting higher harmonic frequencies.
DUBSHOX MULTI-BAND DISTORTION

DUBSHOX Multi-Band Distortion is a multi-band distortion and waveshaping unit
with over 40 types of distortion and shapers, from analog, transistor/diode and tube
distortions, to crazy digital waveshapers. Every band has a knob for drive and output
level for adding heavy distortion without excessive volume boost. DUBSHOX MultiBand Distortion is ideally suited to aggressive modern dance styles including Dubstep,
Drum and Bass, and EDM.
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POD4500 PARTICLE DELAY

The POD4500 Particle Delay expands upon standard beat-synced delays with wildly
unique “particles” that can be delayed, tuned up and down by octaves, filtered,
and modulated. A fantastic addition to any type of music, POD4500 Particle Delay
especially shines in experimental and dance music styles.
PSEQ-1 VACUUM TUBE PASSIVE EQ

The PSEQ-1 Vacuum Tube Passive EQ faithfully replicates the sweet and warm
“undoctored” tonality of passive EQ circuits. Even with large boosts at narrow-Q
settings, the PSEQ-1 Vacuum Tube Passive EQ avoids the harshness that often plagues
conventional active EQ topologies. The perfect EQ for individual channels or twochannel final mix busses.
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TREBLECREAM

TrebleCream is a unique new master bus plug-in intended to minimize the effect of
screaming or distorted mid-treble frequencies and transients resulting in more pleasing
final mixes.
TRW-1 VACUUM TUBE TRIODE WARMER

The TRW-1 Vacuum Tube Triode Warmer is a plug-in with an inner structure similar to
real blocks of vacuum tube studio devices, including emulation of physical phenomena
like small positive inner feedback, tube softening of transients, compression, and
generation of both odd and even harmonics.
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VBE-1 VACUUM TUBE BASS ENHANCER

VBE-1 Vacuum Tube Bass Enhancer is vacuum tube analog bass enhancer. When
standard equalization does not bring the massive fatness and warmth you’re seeking,
VBE-1 Vacuum Tube Bass Enhancer delivers real vacuum tube warmth, saturation, and
drive to bass lines and kick drums.
VTC-1 VACUUM TUBE COMPRESSOR

Pentode Audio VTC-1 Vacuum Tube Compressor is an analog-modeled virtual
VST compressor with a warm analog and transparent sound. Compared to modern
compressors, Pentode Audio VTC-1 operates differently: VTC-1 doesn’t have a
threshold knob; the amount of compression is set by increasing or decreasing input
level as with old analog tube compressors.The Compression amount knob is similar to
the ratio knob on modern compressors.
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ZENER LIMITER LM-2Z

The Zener Limiter LM-2Z models rare and unique compressors utilizing a zener-diode
as a gain-reduction element. Compared to classic digital brickwall limiters,the Zener
Limiter LM-2z offers a more transparent, liquid, and airy sound with significantly less
distortion and unwanted artifacts.
FUSION FIELD

Fusion Field is a smooth diffusion reverb that sits beautifully in a mix. Designed to
imitate complex, natural spaces, it’s also very easy to use. Using an innovative “cloud”
display to represent reverb spaces, Fusion Field offers powerful control with few
controls to hamper your creativity.
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SIDEKICK6

SideKick 6 Extended is the easiest, yet most comprehensive sidechain compressor
available. Sidechaining lets you compress one sound with another, most commonly
used to duck other sounds in the mix on each kick drum hit for maximum impact
when creating dance music. To use, simply open instances of Sidekick on both the
source and destination tracks, then set the send and receive channels for each instance.
STUDIO DEVIL VIRTUAL BASS AMP

Studio Devil Virtual Bass Amp is loaded with fantastic features for strikingly realistic
emulations of legendary bass amps including a vacuum-tube preamp, power amp drive
control, variable-knee limiter, seven-band EQ, two speaker cabinet emulations (plus
D.I.), and numerous presets.
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VTD-42 PSYCHEDELIC DELAY

VTD-42 Psychedelic Delay replicates the warm, smooth, trippy textures of early
tape-based delay systems without the hassle of cranky tape transports! With tape speed
and wow & flutter controls, you’ll get all the subtle (or not-so-subtle) pitch undulation
and tonality that only a tape delay can deliver, plus the rhythmic complexity of
multiple tape heads.
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VIRTUAL INSTRUMENTS

Virtual instruments are like having a keyboard instrument within Mixcraft that can be
played and recorded using a USB or MIDI keyboard controller. The Instrument Preset
Window offers powerful layering, splitting, and more (oh, how we love some “and
more”). Mixcraft supports VSTi and VST3 formats.
INSTRUMENT PRESET WINDOW
Click the piano keyboard icon in the track header to open the Instrument
Preset window.

This opens the Instrument Preset window. On the left side you’ll see numerous
categories. For now, we’ll leave this on the default <All> setting and explore some
Instrument Preset sounds.
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Instrument Presets

Click on a category on the left, then choose an Instrument Preset on the right.
The main default categories include:
Bass

Percussion

Brass

Reed

Combinations

Sound Effects

Ethnic

Strings

Guitar

Synth

Hits and Stabs

Voice

Keyboard

Wind

Click the X button at the top right of the window to close the instrument dialog.
Alternatively, click the instrument button on the track header to toggle viewing the
instrument preset window.
ADDITIONAL INSTRUMENT WINDOW CATEGORIES
There are five additional preset categories: <Favorites>, <VSTi Instruments>, <ReWire
Devices>, <Route To Track>, and <External MIDI Devices>. Here’s what they do:
 FAVORITES

Frequently used Instrument Presets can be tagged by clicking on the star next to an
Instrument Preset name. Choosing Favorites from the category displays all starred
selections in the Instrument Preset list.
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VSTI INSTRUMENTS

This shows all available virtual instruments including user-installed instruments.
(VSTi and VST3 are the the only supported third-party instrument formats. If you have
a Virtual Instrument that is not showing up, you may have to edit the plug-in folders in
Preferences>Plug-Ins>Edit VST/VSTi Folders.)
Clicking a Virtual Instrument expands the window downward (you can also expand
the view by clicking the Show Details button). Click the down arrow in the Preset
column to browse presets for the selected instrument.
REWIRE DEVICES

This section displays available ReWire applications. Selecting a ReWire application
automatically creates a ReWire track for that application. In the Show Details view,
available ReWire instrument sources can be selected (under Presets). Played or
recorded MIDI data from the Virtual Instrument track, will be routed to the ReWire
application. Audio generated by the application appears on the ReWire track in the
Main Window.
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ROUTE TO TRACK

Route To Track is a specialized instrument type that functions as a MIDI router.
Specifically, it lets you route MIDI from one Mixcraft track to another. That may not
sound like a big deal, but it’s super useful, particularly if you’d like to take advantage of
Virtual Instruments with multi-timbral capabilities. Here are some ways to make use of
Route To Track:
 Ex. 1: Play Multiple Instruments From A Single Track

		

1. Begin by setting up a couple of instruments on instrument tracks. Here we’ve set
		 up a piano on one track, and an organ on another.
		

2. Add a Virtual Instrument track (click +Track), then click the track’s keyboard
		 icon to open the Instrument Preset window. Select Route To Track from the
		 Category list. The track has been renamed MIDI Router.
		

3. The Instrument Preset list on the right shows all instrument tracks in the current
		 Project. In this example, these are the Piano and Organ instrument tracks. Click
		 on Piano in the Instrument Preset list.
271

		 If we click on the MIDI Router track to select it and play notes on a USB or MIDI
		 controller, the Piano track plays. If we click Organ in the Instrument Preset list,
		the Organ track gets played.
		
We can also play both instruments
simultaneously. Click on Select Synth in the
Instruments area below and scroll down to the
Route To Track section. Here you can choose
from any of the instrument tracks in the
current Project.
(You may have to scroll down a bit to see the
Route To Track section).
 Ex. 2: Play and Record Multi-Timbral Virtual Instruments On Separate Tracks

A multi-timbral virtual synth or sampler allows set up of different sounds on up to
16 MIDI channels within one instance. If you were to use “regular” instrument
tracks in Mixcraft, there would be no way to play each MIDI channel (i.e. each
instrumental sound) individually; there would also be no way to play or record
seperate MIDI clips for each MIDI channel.
We can get around this by creating a “master” multi-timbral instrument with 		
separate sounds on each MIDI channel, and then creating individual Virtual 		
Instrument tracks set to Route To Track. These all get routed to the master multitimbral instrument track, but we can separately play each of its sounds by setting
a different MIDI channel output for each of the Route To Track Virtual Instruments.
Here’s how:
		
v

1.
		
		
		

Create a Virtual Instrument track (+Track), open up a multi-timbral Virtual
Instrument, and set up multiple instruments on separate MIDI channels. In this
example, we’ve added Upright Bass on MIDI channel 1, a Jazz Organ on MIDI
channel 2, and a Mute Trumpet on MIDI channel 3.
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Super Quick Multi
Timbral Sub Track
Creation
Since the only
parameter that gets
changed is the MIDI
channel, one quick
way to create many
“sub” Route To Track
instrument tracks is to
create one and set it up
as described at left. Now
right-click the Route To
Track instrument track
and choose Duplicate.
Make additional
duplicates for as many
sub instruments as
needed. Now select
each track individually,
click the keyboard icon
in the track header,
and set the appropriate
MIDI channel in the
Preset column. Now
name each sub track as
needed.

		

2. Create new Virtual Instrument tracks for each instrument/MIDI channel you’d
		 like to use in the multi-timbral Virtual Instrument. We’ve named the newly
		 created Virtual Instrument tracks Upright Bass, Jazz Organ, and Mute Trumpet.
		
v

3. Now we’ll click the keyboard icon in the track header of the Upright Bass track
		 to open the Instrument Preset window. Select Route To Track from the Category
		 list. Click the name of the multi-timbral Virtual Instrument in the Instrument
		Preset list, which would be Kontakt 5 in our example.
		
v

4.
		
		
		
		
		

Here’s the important part: select the appropriate MIDI channel for the 		
instrument you’d like to hear in the Preset column of the Instruments section. (If
you don’t see the Instruments section, click the Show Details button.) Make sure
you don’t leave it on All Channels, or else all the multi-timbral instrument
channels will play at once, making your tune sound like a Michael Bolton ballad
from 1989, and no one wants that.

5. Repeat steps 3 and 4 for each separate multi-timbral instrument part. The only
		 setting that will be different will be the MIDI channel. You’ll now be able to play
		 and record clips of the individual “sub” instruments on each track.
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EXTERNAL MIDI DEVICES

This category displays all external MIDI outputs and sound card MIDI synthesizers.
Typically you’d use this send MIDI to hardware keyboards or sound modules, like that
DX7 that’s been collecting dust in Uncle Mike’s coat closet.
If an external synthesizer is connected via a MIDI interface, select the appropriate MIDI
output interface. Please note that you will not be able to render or burn the audio made
by external synthesizers unless they are first recorded to an audio track (because they
aren’t magically living inside Mr. Computer like Virtual Instruments).
EDITING VIRTUAL INSTRUMENT PRESETS
Custom Virtual Instrument presets featuring multiple layered synthesizers,
edited presets, custom key ranges and more can be created. Begin by clicking
a Virtual Instrument track’s Instrument icon.

This opens the Instrument Preset window shown above. Click the Show Details button
to extend the instrument window and display more details about the preset.
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You can either modify the current preset, or begin with a “blank slate” by clicking the
New Preset button. To add a virtual instrument, click <Select Synth> and choose a
synthesizer from the drop-down list.
After selecting an instrument, the following parameters can be set:
Parameter

Description

Preset

Selects a preset or patch from individual instruments.

Edit

If the synthesizer has an editable user interface, click
the Edit button to view and adjust its parameters.

Volume

Click on the Vol column and type in a value.

Pan

Click on the Pan column and type in a value from
-100% to 100%.

Range

The range of MIDI notes the synthesizer responds
to. Click and select a range of notes from the pop-up
keyboard. The synthesizer will respond only to notes
in the specified range.

Transpose

Type in a transposition value for this synthesizer. For
example, if transpose is set to 12, playing C4 will
actually sound C5.

Velocity

Type in a velocity range the synthesizer will respond
to including a low and high note limit, e.g.1127). Make sure to include a dash so the software
understands the range. For example, if you wanted
it to respond to velocities from 120 to 127, you
would type in 120-127.

Config

If the virtual instrument supports multiple output
channels, click the Config... button to configure
which output channels to use.
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ADDING EFFECTS TO INSTRUMENT PRESETS

To add effects to Instrument Presets, click <Select An Effect>.
Once an effect is chosen, an effects preset can be selected from the from the Preset
column. To customize effects settings, click the effects Edit button.
Effects chain can be created with as many effects as desired.
SETTING AN INSTRUMENT PRESET ICON

To add a custom icon to an Instrument Preset, click the Set
Icon button and select an icon (or add a custom icon using
the Add My Own Image File… button).

SAVING CUSTOM PRESET INSTRUMENT PRESETS

Custom Instrument Preset can easily be saved and recalled. This saves all parameters of
the Instrument Preset including effects.
Custom Instrument Presets can be saved by clicking the New
Preset button.
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Type a preset name and select a category from the Category drop-down menu. To save
the currently selected instrument icon, check the Embed Icon checkbox.
INSTRUMENT PRESET FILE LOCATION

Instrument Preset files are located in the Mixcraft folder in a directory called
InstPresets. Preset files have a .instrument extension and may be traded and sent
between computers and users. Please note that you’ll need the same VSTi’s and virtual
synths installed.
Custom presets will be saved under %appdata%\Acoustica\Mixcraft\InstPresets\
( %appdata% is a Window’s shell variable that is expanded to something like C:\Users\
UserName\AppData\Roaming\ )
EDITING INDIVIDUAL VIRTUAL INSTRUMENT PARAMETERS

Many Virtual Instruments feature extensively editable control panels. To access these
parameters, click the Edit button.
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On the preceding page is the Minimogue VA virtual instrument. Use the mouse to
create custom sounds by turning virtual knobs, switches, etc.
VIRTUAL INSTRUMENT PRESET MANAGEMENT

Though each Virtual Instrument will have a unique user interface, they share the same
controls on the top of the instrument window. These controls work exactly like the
ones for effects.
 Level Meter

		
		
		

In the top-right corner of every VST Effect and Virtual Instrument is a stereo VU
meter. This is helpful when adjusting input and output levels, and in those
inevitable “what the heck?@#?” moments, it’ll let you know signal is present.

 Active Checkbox

		
		

Exactly the same as the Active/Inactive checkbox in the Effect List 		
window, just replicated in the effect interface for convenience.

 MIDI Map Parameters Gear

		
This opens the MIDI Mapping window. This is used to assign hardware
			
controllers to plug-in parameters.
		(See “Mapping A Hardware Control To A Plug-In or Virtual Effects Parameter.”
 Select Preset

		
		 Allows selection of Mixcraft and user presets.
 Load VST Preset File

		

Some VST effect and instrument manufacturers distribute additional
sound banks in the form of .fxb files, replacing current presets with a
new presets.

 Save A New Preset

		

Saves the current instrument settings to a new preset. You’ll be
prompted to enter a preset name. The preset will then appear in the
preset list.

 Remove A Selected Preset

		

Permanently removes the currently selected preset. Factory presets
cannot be deleted.
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		Note: If a virtual instrument track is frozen, its controls will not be editable until
		 the track is unfrozen.
ADDING THIRD PARTY VIRTUAL INSTRUMENTS

If a VSTi instrument has been installed and it’s not visible in the Instrument List,
you’ll need to add the folder that stores the VST instrument.There are two ways to
accomplish this:
The simplest way is to drag-and-drop its DLL file into Mixcraft’s main window. Mixcraft
automatically installs the file in the correct location and adds it to the VSTi search path
list (in other words, it’ll just work!). The alternative method is to “manually” add VSTi
instruments to Mixcraft’s VST/VSTi folders.

Select File>Preferences>Plug-Ins from the Main Window menus., then click Edit VST/
VSTi Folders and navigate to the folder containing the Virtual Instrument.

Add the folder by clicking the Add… button. If you’re having trouble locating installed
Virtual Instruments, click Auto-Scan For VST/VSTi Directories. Mixcraft will attempt to
locate folders containing VSTi instruments.
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USING A THIRD-PARTY ARPEGGIATOR PLUG-IN
A number of third-pary software companies offer arpeggiator plug-ins that can be
used to “play” VST either Mixcraft’s included instruments or installed third-party VST
instruments.

To use an arpeggiator plug-in, open the Instrument Preset window and select the
arpeggiator as an instrument in a slot above the instrument you’d like it to control. No
other fancy setup necessary!
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INCLUDED VIRTUAL
INSTRUMENTS
The following virtual instruments are included with all versions of Mixcraft.
ACOUSTICA INSTRUMENTS

A huge library of carefully sampled orchestral instruments, drums, synthesizers, pianos,
organs, guitars, basses, and more, all mapped to the General MIDI specification.
IMPULSE

This polyphonic synthesizer is modeled after synthesizers of the early 80’s, and is
loaded with classic analog synthesizer tones.
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MESSIAH

This incredibly accurate recreation of the famous Sequential Circuits Prophet-5™
synthesizer takes the concept even further, with increased polyphony, added effects,
and more. This classic analog synthesizer dominated the music of the late 70s and
early 80s. These amazing instruments are difficult to find, highly collectible, and are
worth thousands of dollars, but Messiah nails the tone and experience of using a real
Prophet-5™.
MINIMOGUE VA
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The Moog Minimoog™ is the most famous analog monophonic synthesizer in history.
Invented by the late Dr. Robert Moog, this instrument took the intense sonic power of
a Moog™ modular synthesizer and put it in a portable instrument that revolutionized
music. The MinimogueVA is a detailed recreation of the Minimoog™ sound, complete
with huge bass sounds, powerful lead sounds, and a whole lot more.
VB3 ORGAN

The Hammond Organ™, invented by Laurens Hammond in the 1930s, has had a
major impact on nearly every popular music genre, from gospel and blues to rock and
pop. Paired with a Leslie™ speaker, there may be no more expressive and powerful
musical instrument in the world. The VB3 Organ recreates the sound and controls of
the famous Hammond B3™ organ, paired with a Leslie™ speaker.
MIXCRAFT 8 RECORDING STUDIO ADDITIONAL INSTRUMENTS
Mixcraft 8 Recording Studio adds the following instruments:
ACOUSTICA EXPANDED INSTRUMENTS

A rich addition to the Acoustic of deep synth pads, ethereal voices, haunting strings,
and more.
ACOUSTICA STUDIO DRUMS

A large collection of acoustic and electronic drum sounds, recorded professionally in a
world-class studio.
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ALIEN 303 BASS SYNTHESIZER

A deep, biting bass synthesizer inspired by the famous Roland TB-303™ bass
synthesizer. Ideal for authentic acid bass tones and other electronic dance music.

LOUNGE LIZARD ELECTRIC PIANO

The Rhodes™ and Wurlitzer™ electric pianos defined much of the sound of the
1970s. Featured in songs like Billy Joel’s “Just The Way You Are”, and Supertramp’s
“The Logical Song”, these electric pianos had a warm, unique sound that works as well
in jazz as it does in rock ‘n’ roll. These sounds are as popular today as ever, and Lounge
Lizard perfectly recreates the sound and nuance of these classic instruments, as well as
the effects they often were often paired with.
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COMBO ORGAN MODEL F

A spot-on recreation of the classic Farfisa™ transistor combo organ. Great for 60s rock,
surf rock, and more!
COMBO ORGAN MODEL V

A recreation of the classic Vox Continental™ transistor combo organ. Great for 60s
rock, surf rock, and more! (Especially famous for The Doors’ “Light My Fire.”)
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RENEGADE

Renegade combines the warm and organic sound of vintage analog synths with the
sharpness, toughness, and precision of modern digital synths. With a Supersaw
oscillator, vintage analog filters, and robust digital filters, Renegade provides tough,
well defined lead sounds, fat basses, and juicy organic analog sounds. The perfect synth
for aggressive Trance, Dance, Drum and Bass, Breakbeat, Electro, and more.
JOURNEYS

With A|A|S String Studio VS-2’s
sound engine running “under the
hood,” Journeys is master sound
designer Gregory Simpson’s
endeavor on sounds that evoke the
essence of other times, places, or
cultures. Indeed, this collection
will get you travelling from the
ancient centuries to modern times,
from Asia to Africa, and everything
in between. Truly inspiring and
totally unique!
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MIXCRAFT 8 PRO STUDIO ADDITIONAL INSTRUMENTS
Mixcraft 8 Pro Studio adds the following instruments.

ME80 VINTAGE ANALOG SYNTHESIZER

An incredibly realistic recreation of the Yamaha CS80 analog synthesizer, among the
most powerful and coveted analog synthesizers ever made. This amazing recreation
supports polyphonic aftertouch (just like the original) and has the same rich creamy
tone as the original.
MEMORYMOON ANALOG SYNTHESIZER

No synthesizer in history has ever sounded more massive than the legendary Moog
Memorymoog, and Memorymoon perfectly captures the enormous analog sound of
the classic original. Loaded with presets and knobs, this three-oscillator polyphonic
powerhouse will blow you away.
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ACOUSTICA PIANISSIMO VIRTUAL GRAND PIANO

High quality, award-winning grand piano featuring 250MB of Steinway Model D piano
samples combined with powerful piano modeling technology.
GLASS VIPER

Expanding on classic 80s and 90s digital synths such as the Yamaha DX7 and Roland
D-50, Glass Viper features unique waveform shaping, offering a deep and natural sense
of movement. Going beyond analog simulation into a truly organic sound, Glass Viper’s
tones span simple old synths, grungy filthy basses, delicate pianos, strange unnatural
film effects, and much more.
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ME80 VERSION 2

ME80 Version 2 is a fantastic update of the ME80 virtual analog polysynth. Now
with 64- and 32-bit modes, a gorgeous new updated user interface, and a whole new
sound engine, ME80 Version 2 is simply the most lush and realistic CS-80 polysynth
emulation available anywhere!
(Because ME-80 Version 1 user patches are not compatible, both versions are included
with Mixcraft 8 Pro Studio to maintain compatibility.)
KASTELHEIMER VELDBERG XD

Veldberg XD is new virtual analog synthesizer based on algorithms from hardware VA
synthesizers with immense programming possibilities. Including 137 preset sounds
ranging from classic massive analog to experimental and innovative digital sounds,
Veldberg XD is a world-class powersynth!
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ALPHA SAMPLER
v

Alpha Sampler is an easy-to-use basic sampler that’s fast and fun. It’s so easy, it almost
doesn’t need any instructions; just drag an audio clip into the sample display window
and play! Alpha Sampler lets you load one sound that can played up and down the
keyboard, but it’s polyphonic, so you you can play as many notes as you like. Alpha
Sampler is included with all versions of Mixcraft.
There are several ways to load a sound into Alpha Sampler:


Press the Load Sound button in the Sample Display window. This opens a standard
dialog box which can be navigated to any sound. Select the sound, then press the
Open button to load in the sound. Mixcraft 8 automatically saves sounds loaded
into Alpha Sampler in the current song project folder.



Drag and drop any audio clip from Mixcraft’s clip Library (click the Library tab
at the bottom of the Track View Window to select and preview clips) or directly
from the Track View window. Audio clips dragged in from the Track View window
retain their start and end points as set in the Track View window, allowing easy
editing of the sample’s start and end points.



Export a selected audio waveform region from the Sound tab by selecting a region,
clicking the Copy Selection To button in the Sound Tab toolbar and choosing Alpha
Sampler. (see “Copy Selection To> Alpha Sampler”)
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An entire clip can be added to Alpha Sampler by right-clicking and selecting 		
Copy To Alpha Sampler.

SAMPLE DISPLAY WINDOW

This displays the name of the currently loaded sample.
LOAD SOUND

Opens a dialog box for loading a sample. Since Alpha Sampler can only have one
sound loaded at a time, newly loaded sounds will erase previously loaded sounds. The
display beneath Load Sound displays the file name of the currently loaded sound.
MIDI ACTIVITY

On right side is a wee LED light that flashes when MIDI note info is received. This can
be helpful when tracking down a problem if Alpha Sampler isn’t making any sound. (A
likely scenario would be if you loaded an audio clip with silence at the beginning.)
VOLUME ENVELOPE
This is a simple attack/release envelope generator
affecting the sample’s volume.

ATTACK

Regulates the onset of a sound; at zero, the sound begins immediately, as the attack
setting is increased, the sound takes longer to reach maximum volume.
RELEASE

Affects the volume of the sample after the key is released. Set at zero, the sample will
stop as soon as the key is released. As the release setting is increased, the sample fades
away gradually. Higher settings increase the length of time.
While we’re talking about volume, we should mention that samples loaded into Alpha
Sampler are velocity-sensitive. In other words, play the keyboard softly and samples
will play quietly. Conversely, playing hard causes samples to play loudly.
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PITCH

FINE TUNE

Allows adjustment of the sample’s pitch + or - 100 cents. You can quickly restore the
Fine Tune control to zero by double-clicking the knob.
RUBBER

A fun and unique feature especially suited to drum loops or snippets of entire mixes.
When set to the middle position, the Rubber effect is off. Turning the knob to the left
of center will make the sample begin at a high speed and pitch, then slow down as it
plays. Turning the Rubber knob to the right of center position has the opposite effect:
samples will start at a low pitch and get faster (and higher) as they play.
FILTER
If you’ve ever played with filter controls on an
analog synthesizer, this should be familiar; Alpha
Sampler’s filter is a modeled classic lowpass filter.

CUTOFF

Sets the lowpass frequency of the filter. In other words, all frequencies beneath the
cutoff knob setting are allowed to pass through, but frequencies above it are blocked.
(Hence the name: low pass… get it?)
RESONANCE

Emphasizes frequencies close to the cutoff frequency. The higher the setting of the
Resonance knob, the greater the emphasis, resulting in the the familiar “ringing” and
(when the cutoff is modulated as described below), “wah-wah” sounds.
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MOD WHEEL
Consists of a low-frequency oscillator (LFO)
capable of controlling Alpha Sampler’s pitch or
filter cutoff frequency, resulting in vibrato, wah
wah effects, and more. One good way to think of a
modulation LFO is a “third hand” to automatically
turn controls up and down.

The amount of modulation (aka, “mod depth”) can be altered by using your controller’s
mod wheel (or another physical controller set to transmit MIDI controller #1).
SPEED

Adjusts the rate of the LFO.
FILTER AND PITCH BUTTONS

Selects the modulation destinations. Pressing Filter causes the LFO to modulate the
cutoff frequency of the filter. Pressing Pitch causes the LFO to modulate the pitch. Both
can be selected simultaneously if you really want to get crazy!
TRIANGLE/SQUARE SLIDE SWITCH

Selects between triangle and square LFO waves. The triangle waveform cycles up
and down in a smooth and uniform fashion, making it good for subtle vibrato or, at
extreme settings, swooping sirens or extreme wah effects (when modulating the filter).
The square waveform jumps back and forth abruptly, making it good for sirens with
alternating pitch, or when used with the Tempo Sync switch, “synchro-sonic” type
rhythmic effects.
TEMPO SYNC

Syncs the LFO rate to the tempo of the current project and causes the speed knob to
switch between musically relevant values, making the LFO modulate in “lock-step”
with the beat. The synced note values range from a whole-note to sixteenth-notes.
OUTPUT
The Output section contains a big stereo level meter. Like any meter,
you’ll want to make sure this isn’t slamming into the red, otherwise
you’ll get nasty digital clipping.
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VOLUME

Adjusts the master volume level of Alpha Sampler. Its middle setting represents unity,
i.e. Alpha Sampler isn’t adding or subtracting gain, but turning the master volume up
can add some juice to very quiet samples, and dialing back will prevent super loud
samples from distorting - this can be especially helpful when the filter’s resonance
control is cranked up.
LO-FI

Processes Alpha Sampler’s output down to an 8 kHz sample rate and eight-bit word
depth for a crunchy, aggressive sound similar to classic vintage 8–bit hardware
samplers and drum machines.
ADDITIONAL FUNCTIONS

MONOPHONIC

Limits Alpha Sampler to playing one note at a time. Mono mode is “last-note priority,”
i.e., If a new note is played while another is held, the most recently struck note will
sound and cut off the last one. Newly played notes will always retrigger the sample
from its beginning.
LOOP

Causes the sample to repeatedly loop back to its beginning if a key is held longer than
the entire duration of the sample.
REVERSE

Plays the sample backward, but be careful as you might invoke the spirits of sneaky
classic rock bands.
ROOT KEY

Adjusts the base note of the sample – think of this as the “home base” key where the
sample plays at standard pitch (i.e. not transposed). Adjusting the root key is useful for
transposing the range of samples.
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OMNI SAMPLER

Omni Sampler expands Alpha Sampler’s simple drag-and-drop concept to a familiar
16-pad drum machine grid sampler with easily switchable “grids,” allowing up to 128
simultaneously loaded samples. Better still, Omni Sampler features independent pitch,
filter, and envelope settings for each pad location. Mixcraft Pro Studio 8 also includes
Omni Sampler 8 Out, featuring up to eight individually assignable outputs for superior
mixing and effects flexibility.
SAMPLE PAD GRID
Omni Sampler can have up to 128 simultaneously loaded samples, with 16 sample
pads viewable at any time. The matrix grid on the left allows quick selection of which
16 sample pads are currently viewable in the 4x4 pad grid. The currently selected 4x4
pad grid is represented in the pad bank selector either by yellow squares indicating
pads with samples currently loaded, or gray pads indicating visible pads with no
sample currently loaded. To change which pads are currently visible in the 4x4 pad
grid, click within the pad bank selector. Keep in mind that sample pads always have
a one-to-one relationship with MIDI notes, and the MIDI note number of each pad is
fixed, starting at C-1 for the top left pad, going up to G9 for the bottom right pad.
If you’d like to play the same sample on separate pads, simply re-load the sample at a
different pad location. Be aware that Mixcraft 8 automatically saves sounds loaded into
Omni Sampler into the current song project folder, so you don’t need to worry about
sounds getting “lost” if you move or archive the project folder.
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PAD SELECTION
Pad locations can be selected for loading or deleting samples, or sound editing by
clicking on them. Empty or occupied pad locations will highlight in light gray when
selected. Multiple pads may be selected by clicking on them while holding the [CTRL]
key, or by clicking and dragging a rectangle over the desired pads. (Be sure to initially
click either outside the grid area or on one of the lines dividing the grid, not an actual
pad.) You can even select pads by dragging a rectangle over sections of the pad bank
selector on the left.
LOADING SOUNDS INTO OMNI SAMPLER
There are a couple of ways to load sounds in Omni Sampler:
 Method 1:

Select the destination pad in the 4x4 sample grid by clicking on it.
The pad will turn gray. Press the “Load Sound” button in the Sample Display
window. This opens a standard dialog box which can be navigated to any sound.
Select the sound, then press the Open button to load.

 Method 2:

Drag and drop any audio clip from Mixcraft’s clip Library (click the
Library tab at the bottom of the Track View Window to select and preview clips)
or from the Track View window directly to a pad in the 4x4 grid.

 Method 3:

Drag and drop any audio clip from Windows File Explorer to a pad in
the 4x4 grid.

Audio clips dragged in from the Track View window will retain their start and end
points as set in the Track View window, allowing easy editing of the sample’s start and
end points. This is handy if you’d like to use just a portion of one of Mixcraft’s included
loops or sound effects - first, drag the clip to an open audio track in the Track View
window, adjust the start and end points, then drag the clip into Omni Sampler.
Samples loaded into Omni Sampler are velocity-sensitive. In other words, play the
keyboard softly and samples will play quietly. Conversely, playing hard will cause
samples to play loudly.
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Beat Slicing Sounds
from the Sound Tab
with Omni Sampler
In addition to the
import methods shown
at left, any sound can
be imported into Omni
Sampler directly from
the Sound Tab window.
The simplest option
is the use the “Copy
Selection To” menu.
This adds the currently
selected wave region
to an existing or newly
created Alpha or Omni
Sampler.
The far more interesting
and flexible Sound Tab
import method is the
“Slice To…” menu. “Slice
to…” automatically
“cuts up” the sound
by beats, measures,
transients, or warp
markers. Each “slice”
is then automatically
imported to an Omni
Sampler pad location.
The “Create MIDI Loop”
check box will even
create a MIDI clip that
consecutively “plays”
each slice. This is
manna from heaven
for cutting up and
rearranging beats, and
with Mixcraft’s immense
beat loop collection,
there’s enough material
to keep beat fanatics
busy for years!

PERFORMANCE CONTROLS

Omni Sampler’s performance controls include Pitch, Filter, Envelope, and Output
settings and are set separately for each pad individually (it’s easy to remember because
“pad specific” controls have a gray background).
PITCH
FINE TUNE

Allows adjustment of the sample’s pitch + or - 100 cents. You can quickly restore the
Fine Tune control to zero by double-clicking the knob.
RUBBER

This is a fun and unique feature especially suited to drum loops or snippets of entire
mixes. When set to the middle position, the Rubber effect is off. Turning the knob to
the left of center will make the sample begin at a high speed and pitch then slow down
as it plays. Turning the Rubber knob to the right of center position has the opposite
effect: samples will start at a low pitch and get faster (and higher) as they play.
TRANSPOSE

Changes the pitch of samples in half-step increments with a maximum range of two
octaves, up or down. Click the up/down arrows to move pitch in half-step increments,
or click on the number to directly type a number value (add a “-” before the number
for downward transposition). After entering a number value, click again.
FILTER
Omni Sampler’s filter is a modeled classic low pass filter.
CUTOFF

Sets the lowpass frequency of the filter. In other words, all frequencies beneath the
cutoff knob setting are allowed to pass through, but frequencies above it are blocked.
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RESONANCE

Emphasizes frequencies close to the cutoff frequency. The higher the setting of the
Resonance knob, the greater the emphasis, resulting in the the familiar “ringing” and
(when the cutoff is modulated as described below), “wah-wah” sounds.
VOLUME ENVELOPE
This is a simple attack/release envelope generator affecting the sample’s volume.
ATTACK

Regulates the onset of a sound; at zero, the sound begins immediately, as the attack
setting is increased, the sound takes longer to reach maximum volume.
RELEASE

Affects the volume of the sample after the key is released. Set at zero, the sample will
stop as soon as the key is released. As the release setting is increased, the sample fades
away gradually. Higher settings increase the length of time.
OUTPUT
VOLUME

Adjusts level of each pad individually, letting you obtain an optimum mix. Its middle
setting represents unity; Omni Sampler won’t add or subtract gain, but turning the
master volume up make quiet samples louder, and dialing back will prevent super loud
samples from distorting, which can be helpful when the filter’s resonance control is
cranked up.
PAN

The pan control lets you set the position of each pad in the stereo field from left to
right. You sooo knew that already.
Output Channel Selector (Multi-Out version only)

This control is only visible if you’ve chosen the multi-out version when opening a new
instance of Omni Sampler. It allows each sample pad to route its audio to one of eight
stereo child track mixer channels. For more information, see “Omni Sampler 8 Out.”
You’ll notice a few extra buttons beneath the Sample Display window as well. Like
other performance parameters, these can be set individually for each sample pad.
 Loop

Makes the sample indefinitely loop back to its beginning if a key is held longer
than the entire duration of the sample.
 Reverse

Plays the sample backward in case you’re doing a dope cover of The Beastie Boys’
“Paul Revere.”
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 Lo-Fi

Processes samples down to an 8 kHz sample rate and eight-bit word depth for a
crunchy, aggressive sound similar to classic vintage 8–bit hardware samplers
and drum machines.
MASTER SECTION
The master section’s controls affect
all pads simultaneously – these
controls have a yellow background.

GLOBAL
The Global button makes the Performance Controls (Pitch, Filter,
Envelope, Output, Loop, Reverse, and Lo-Fi) affect all currently loaded
sounds simultaneously. This is handy when multiple loops or drum sounds are playing
and you want to modify everything at once (such as a filter sweep on everything).
Global mode is toggled on and off by clicking the button; when global mode is active,
the Performance Controls background turns yellow. When Global mode is switched off,
the background returns to gray and the Performance Controls become independently
settable for individual pad locations.
If you’ve already set Performance Control parameters for individual pads prior to
engaging Global mode, the settings for that parameter will remain until that parameter
is adjusted at which point it will affect all pads equally. For example, let’s say filter
cutoff is set to differing amounts for multiple pads, then the Global is engaged. The
individual filter cutoff settings for each pad will remain until the cutoff knob is adjusted.
At that point, all pads will jump to the current setting. Keep in mind that this becomes
the “current” knob position – changed knob positions won’t return to their old values if
the Global button is disengaged.
MODULATION
The Modulation section consists of a low-frequency oscillator (LFO) capable of
controlling Omni Sampler’s pitch or filter cutoff frequency, resulting in vibrato, wah
wah effects, and more. One good way to think of a modulation LFO is a “third hand” to
automatically turn controls up and down. Modulation amount is controlled using your
keyboard controller’s mod wheel (or any other physical controller set to transmit MIDI
controller #1).
SPEED

Adjusts the rate of the LFO.
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FILTER AND PITCH BUTTONS

These buttons select the modulation destination. Pressing Filter causes the LFO to
modulate the cutoff frequency of the filter. Pressing Pitch causes the LFO to modulate
the pitch for vibrato effects. Both can be selected simultaneously.
TRIANGLE/SQUARE WAVE SWITCH

Toggle between triangle and square LFO waves. The triangle waveform cycles up and
down in a smooth and uniform fashion, making it a good choice for subtle vibrato
or, at extreme settings, swooping sirens or extreme wah effects (when modulating
the filter). The square waveform jumps back and forth abruptly, good for sirens with
alternating pitch, or when used with the Tempo Sync switch, “synchro-sonic” type
rhythmic effects.
TEMPO SYNC

When the the Tempo Sync button is on, the LFO rate is synced to the tempo of the
current project and, now, the speed knob snaps to musically relevant values, making
the LFO modulate in lock-step with the beat. The synced note values range from a
whole note to sixteenth-notes.
MASTER VOLUME

Adjusts the volume level of all samples at once. Its middle setting represents unity. The
digital meter indicates relative level; for optimum gain, set it so that it stays strongly in
the green and doesn’t go into the red often.
MIDI

Though it’s not located in the yellow master section, you’ll see a MIDI
light to the left of the Sample Display window. This indicates incoming
MIDI data, and can be helpful in those inevitable, “why the heck isn’t
this making any noise?” situations.
WORKING WITH SAMPLES IN OMNI SAMPLER
Sample pads can be played and recorded in Omni Sampler by playing pads or keys on
a MIDI controller. Each sample pad also has three buttons across the top:
 Play Button

This is a handy way to preview a pad’s current sample. It will play the sample
as long as it’s held (or until the sample runs out).
 M (Mute) Button

This toggles muting for the selected pad. It’s handy if you’ve sequenced
a lot MIDI elements and would like to temporarily remove a sample.
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 S (Solo) Button

Opposite of muting above; it toggles all other pads off when pressed. Multiple
pads can be soloed as well. If you’re having a “why won’t this thing make any
noise?!?” moment, make sure none of the solo buttons are pressed.
MOVE A SAMPLE PAD

To move a sample from one pad to another, simply click and drag it.
DUPLICATING A SAMPLE PAD

To duplicate a sample to a different pad right-click and choose Duplicate Selected. A
copy of the sample will appear at the next available pad. You can also copy to another
pad by option-dragging the selected sample pad.
RENAMING A SAMPLE PAD

To rename a sample pad, right-click and choose Rename. The current name will be
highlighted; type a new name and hit the return key, or click anywhere outside the
current pad.
DELETING A SAMPLE PAD

To delete a sample, highlight a pad, right-click and choose Delete Selected, then click
Yes at the next dialog box. Don’t worry, this won’t actually erase the sample from your
hard drive, it just removes it from the Omni Sampler pad location.
OMNI SAMPLER 8 OUT

(MIXCRAFT PRO STUDIO 8 ONLY)

When opening a new instance of Omni Sampler, you’ll see two choices: Omni Sampler
– Stereo and Omni Sampler 8 Out. Like any other standard VST instrument, the stereo
version mixes all audio output to one stereo fader mixer channel. Omni Sampler 8 Out
is a multi–out version allowing routing of each pad to one of eight stereo child track
mixer channels.
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This is particularly useful for advanced mixing and effects processing. You could
accomplish the same thing by using multiple instances of Omni Sampler, but it’s often
easier to have samples “all in one place,” especially if the samples are related in some
way (they’re all used in one beat, for example).
To use a multi-out Omni Sampler, create a new track by clicking the +Track button,
then selecting Insert Virtual Instrument Track. Click the piano keyboard icon the track,
then click <VSTi Instruments> in the left column. In the right column, scroll down and
click Omni Sampler 8 Out).
A newly opened Omni Sampler 8 Out
defaults to standard stereo output.
Enable additional output pairs, by clicking on the Config button in the
Instrument Window.
This opens the Output Config window.
Here you can enable additional output
pairs by clicking the checkboxes on the
right. The All and None buttons will
enable or disable all additional outputs,
respectively. Automatically add all
instrument output tracks for Virtual
Instruments does just that... it enables all
outputs for newly added multi-out
capable instruments. If you’re only using
a few separate outs, child channels can
be disabled to save screen real estate.

Click the Edit button in the Instruments area next to Omni Sampler 8 Out to open its
controls. You can close Mixcraft’s instrument window by clicking the X in the upperright corner.
You’ll find the Output selector increment buttons beneath the Pan
control in the Output section in Omni Sampler’s controls. This lets you
choose from eight separate stereo “child” mixer channels for each pad. Nifty, eh? To see
these channels in the main arrange window, click the + sign directly to the right of the
instrument’s track icon. To hide child channels, click again on the – sign (that’s a dash).

302

To see the multi-out child
channels in the track list, click the
+ sign in the track.

To view the multi-out child
channels in the mixer window,
click the Mixer tab at the bottom
left of the screen. The child
output channels will be directly
to the right of the Omni Sampler
mixer channel.

Child channels (or any kind of mixer channels, for that matter) can also be hidden
from view in the Mixer window by clicking the green X’s before track names in the
Show Tracks column to the left of the mixer. This doesn’t disable the channels as above,
it only hides them from view in the mixer window.

303

PLUG-IN MANAGEMENT
Mixcraft lets you enable and disable virtual instruments and plug-ins, as well group
and sort plug-ins when loading using Collections.These are handy if you have a large
number of plug-ins; they can be used to create groups for most frequently used plugins, organize specific types of plug-ins, etc.
To access the Plug-In Management window, click on the Mixcraft File menu at the
top left and select Plug-In Management. You can also access the Plug-In Management
Window via File>Preferences>Plug-Ins>Manage Plug-Ins.
The Plug-Ins window on the right displays built-in and third-party installed virtual
instruments and effects plug-ins. The Categories window filters which plug-ins are
displayed. The green checkboxes next to each plug-in enable or disable individual
plug-ins. (For instance, you might want to disable older versions, plug-ins that are
causing issues, or plug-ins that you’re not currently using.)

CREATING PLUG-IN COLLECTIONS
To create a plug-in collection, click on the Mixcraft File menu at the top left and select
Plug-In Management. Choose an effect category to be displayed in the Plug-Ins list.
To create a new collection, click the + sign button, then type a name for the collection
and hit return. Now select a category above, and drag the effects you’d like in your
newly created collection onto the collection name in the Collections list.
304

You can drag as many plug-ins as you’d like into a collection. You can also mix virtual
instrument and effect plug-ins, but only the appropriate type of plug-ins will display
when viewing and loading plug-ins into a track. In other words, if you’ve clicked a
track’s keyboard icon to load a virtual instrument, only virtual instruments within a
collection will be displayed (or vice versa). You can place the same effect or instrument
into as many collections as desired.
DELETING PLUG-IN COLLECTIONS
To delete a collection, simply highlight it and click the X button.
SEARCHING FOR PLUG-INS
If you have a large number of plug-ins, you can use the search field next to the
magnifying glass icon to find effects by typing in the name of a particular plug-in (or
part of the name).
USING EFFECTS AND INSTRUMENT PLUG-IN COLLECTIONS

To access an effects plug-in collection, click the track’s fx button, then click <Select An
Effect>. Collections will appear at the top of the plug-ins list, and hovering over the
collection name will display the plug-in names; click on a plug-in’s name to open it.

To access an instrument collection, click the track’s piano keyboard icon, then click
<Select Synth>. Collections will appear at the top of the plug-ins list, and hovering over
the collection name will display the plug-in names; click on a plug-in’s name to open it
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REWIRE
ReWire is an audio and MIDI protocol developed by Propellerhead Software
allowing Mixcraft to access sounds, virtual instruments, and features of external
music programs.
Mixcraft acts as a host, also known as a ReWire Mixer, with other applications working
as “clients,” or ReWire Devices. External applications will synchronize their tempo,
loop points, and start and stop times with Mixcraft. MIDI data from Mixcraft can also
be routed to control virtual instruments inside other applications. Audio from these
other applications is routed to Mixcraft, where it can be mixed and affected.
There are two ways to add a ReWire track with Mixcraft.



Click the Mix>Add ReWire Application from the main screen menus and select the
desired Rewire application. This adds a ReWire track in Mixcraft and displays the
third-party program’s interface as a child window inside Mixcraft.



Click the keyboard icon on an Instrument Track and select <ReWire Devices> in
the category menu. Choose a ReWire application from the Instrument Preset menu.
A new ReWire track will be created for the application, if one doesn’t currently exist.

Once a ReWire track has been created, all transport controls, including play, rewind,
and stop, as well as tempo changes and loop points, will be sent to the Rewire
application, letting you use the application in conjunction with Mixcraft. Instrument
Tracks can also send live or recorded MIDI data to instrument tracks available in the
ReWire application.
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All audio generated by the ReWire application will play through to Mixcraft on the
ReWire track. As with other Mixcraft tracks, volume, pan, solo, and mute parameters
apply. Effects and automation can also be applied to ReWire tracks.

307

USING NATIVELY
SUPPORTED HARDWARE
CONTROLLERS
Mixcraft 8 features native support for numerous external hardware devices including
the Mackie Control Universal (formerly known as “Logic Control”), Frontier Design
Group Tranzport, and Novation Launchpad, as well as Acoustica’s own Mixcraft
Remote mobile app for smart phones and tablets (see “Configuring the Mixcraft Remote
Mobile App”). This means Mixcraft already “knows” how to interact with the knobs,
sliders, and switches for these hardware controllers. Once they’re plugged in and
enabled, no further assignment or MIDI mapping is needed. Hooray!
For a full list of supported devices, see “Appendix 5: Natively Supported Hardware
Controllers.”
CONFIGURING NATIVELY SUPPORTED USB AND MIDI CONTROLLERS
No special drivers are necessary to set up a Mackie Control Universal, Tranzport,
Launchpad, or the Mixcraft Remote mobile app to work in Mixcraft. Here’s how to add
them.
Plug it in. If you’re using a newer Mackie Control Universal, Tranzport, or
Launchpad, plug a USB cable into the control device on one side, and an open USB
port on the other. If you’re using an older Mackie Control with MIDI ports, plug these
into either a dedicated MIDI port on a USB MIDI interface, or use the MIDI in/out jacks
on your audio interface.


Upon plugging in the controller device, Depending on your preference settings,
you may see the dialog above acknowledging that you’ve plugged in a new piece of
hardware. Click OK.


In the upper left corner, click File>Preferences, then select Control Surfaces. In the
Type column at the left, click on Add New. When you see a the device in the dropdown menu, click to select it.
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If it’s a USB device, select it in the Input and Output columns to the right. If the
device is MIDI, select the name of the MIDI interface in the Input and Output columns.
If you’re using the MIDI I/O on your audio interface, select it by name in the Input and
Output columns.




Click OK at the bottom of the Preferences window and you’re set!

USING MACKIE CONTROL UNIVERSAL WITH MIXCRAFT

The Mackie Control Universal (aka MCU) is a full-featured mixer-style control surface
with channel strip and transport controls, a jog wheel, and numerous other controls.
Because it’s designed to work with numerous DAW programs, all of its controls may
not apply to Mixcraft, but we’ve implemented as many controls as possible in order
to best take advantage of MCU’s control interface. Following is a list of the currently
implemented controls:
MCU Control

Function

Rewind Transport Control

moves playhead back by 4x snap value

Fast-forward transport control

moves playhead forward by 4x snap value

Stop transport control

stops playback or recording

Play transport control

initiates playback

Record transport control

initiates recording

Master fader

sets master volume

Jog wheel

moves playhead forward or back by snap value

Flip button

reverses V-Pot pan and vol fader controls

Channel fader

sets track volume
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V-Pot rotate (channel strip)

above channel strips, sets pan

V-Pot push (channel strip)

resets panning to center

Rec/Ready (channel strip)

arms channel recording

Solo (channel strip)

solos the track

Mute (channel strip)

mutes the track

SELECTING THE CORRECT MACKIE CONTROL PROFILE
There are a couple of different Mackie Control variants. You’ll need to choose the
correct profile in File>Preferences>Control Surfaces for it to work correctly.
If you’re using an older Mackie Control and the large fluorescent display doesn’t work
properly, please choose Logic Control in the Type column; otherwise select Mackie
Control (this usually applies to units that say Logic Control on them).
If you’re using an original Mackie Control XT or a newer silver MCU Pro XT
“extender,” choose the appropriate XT version in preferences. For MCU Pro setups,
plug the main unit in with a USB cable, use a set of MIDI in/out jacks to connect the
extender unit, and choose the appropriate USB and MIDI connections in the Control
Surfaces preferences panel. Make sure to check the Link check boxes for all units if
you’re using one or more MCU extenders (this makes them behave as one big unit, as
opposed to multiple units controlling the same eight channels). The physical order of
units can be rearranged by grabbing the three lines at the left of the Preferences box
and moving them up and down. This insures that faders on multiple units will be in
the correct order in relation to the onscreen mixer.
MACKIE CONTROL DISPLAY

The Mackie Control display shows the following information for each of the current
tracks:


Track panning percentage, left or right



Track number



Track name (abbreviated to four characters)

310

OVERWRITE AND TOUCH FADER AUTOMATION MODES
When used in conjunction with a Mackie Control Universal, automation data can
be written in real time by moving the faders. There are two write modes regulating
how Mixcraft interprets fader movements and position. These can be set either in
Mix>Automation Recording Mode in the Main Window menus, or on the MCU in the
Automation section with the Write and Touch buttons.
OVERWRITE MODE
When a lane’s automation is armed and recording, Mixcraft continuously writes the
current fader or V-Pot position for the duration of recording. As a fader or V-Pot is
moved during recording, the current position is what gets written to Mixcraft. Bear in
mind that if you have automation already written, Mixcraft erases previous automation
and overwrites as it moves along.
TOUCH MODE
Mackie Control Universal and other MCU-compatible devices feature touch-sensitive
faders - they literally know if you’re touching them. This gives Mixcraft the ability
to write automation only while a fader is being touched. When an automation lane is
armed and recording, Mixcraft only writes (or overwrites) automation if a finger is
touching the fader. Mixcraft immediately stops writing as soon as the finger is released.
Next to all the faders automatically scurrying up and down on power-up, this is the
MCU’s most impressive party trick!
USING FRONTIER DESIGN GROUP TRANZPORT

Tranzport is a compact, wireless remote control surface featuring transport controls, a
jog wheel, and other button controls.
Here’s a list of Tranzport’s functions when used with Mixcraft:
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Tranzport Control

Function

Rewind Transport Control

moves playhead back by 4x snap value

Fast-forward transport control

moves playhead forward by 4x snap value

Stop transport control

stops playback or recording

Play transport control

initiates playback

Rewind Transport Control

moves playhead back by 4x snap value

Stop transport control

stops playback or recording

Play transport control

initiates playback

Record transport control

initiates recording

Jog wheel

moves playhead forward or back by snap value

Jog wheel+Shift button

adjusts volume of currently selected track

Track L/R

increments track selection up and down

Rec (small black button)

arms recording for currently selected track

Mute (channel strip)

mutes currently selected track

Solo (channel strip)

soloes currently selected track

Undo

cancels last action

Punch

toggles recording punch in/out

Loop

toggles loop mode on/off

Markers/Prev

moves playhead back to next earliest marker

Markers/Add

inserts a marker at current playhead location

Markers/Next

advances playhead to next marker
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TRANZPORT LCD DISPLAY

Tranzport’s display shows the following:


Track name (abbreviated to a maximum of six characters)



Track number



Fader volume level



Current playhead position (displayed in time or beats depending on current Time/
Beats setting).

CONFIGURING THE MIXCRAFT REMOTE MOBILE APP

Mixcraft Remote is a free mobile app for iOS and Android that lets you control the
transport and other functions wirelessly using an iPhone, iPad, or Android phones and
tablets. Android versions are downloadable via Google Play Store; iOS versions are
downloadable via the Apple App store. Here’s how to use it.


Download and install the Mixcraft Remote mobile app in your mobile device.



In your computer’s upper left corner, click File>Preferences, then select Control
Surfaces. In the Type column at the left, click on Add New. Select Mixcraft Remote
in the dropdown menu. (Unlike other external hardware controllers, you won’t
need to set the Input and Output drop-down menus.)



Click OK at the bottom of the Preferences window and you’re all set!
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Launch Mixcraft Remote on the mobile device; it will automatically locate and pair to
your computer.
USING THE MIXCRAFT REMOTE MOBILE APP
The following functions are controllable with the Mixcraft Remote app.
Mixcraft Remote Control

Function

Record transport Control

initiates recording

Return to beginning control

moves playhead to start of project

Rewind transport control

moves playhead back by 4x snap value

Play transport control

initiates playback

Fast-forward transport control

moves playhead forward by 4x snap value

Fast-forward to end transport
control

moves playhead to end of project

Undo

cancels last action

Redo

restores last action

Save

saves the current project

Master volume slider

adjusts project volume

Song position

touch the Beats/Time display, then slide the
pop-up bar to move the playhead to any
position in the current project
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USING GENERIC MIDI
CONTROLLERS AND
CONTROL SURFACES
A MIDI keyboard or other MIDI device with knobs, sliders, or buttons can be set up to
control Mixcraft functions such as starting and stopping playback, record, fast forward,
track arming, etc.
To configure a control surface, select Mix>MIDI Control Surfaces… from the Main
Window menus.

MIDI LEARN
Here you’ll be able to use a MIDI controller’s buttons, knobs , sliders, etc. to control
TONS functions and controls in Mixcraft. This is a super powerful and fun feature!


Click the MIDI Learn button. Alternatively, you can click the MIDI button
in the Main Window top toolbar.

Click on the command to learn. Command categories can be chosen using the
Category menu on the left side.


Move the knob, button, slider or push a key on your MIDI keyboard/controller that
you wish to trigger the command.


315



If you wish to learn another command, select it.

Alternatively, the Mixcraft interface will highlight buttons and sliders in purple. Simply
click on a button or control, then move the MIDI knob to assign it.
Once you’ve finished assigning controllers, click the Stop Learning button.
(Incidentally, this disproves the theory that you’re never too old to stop learning.)
SAVING AND LOADING CONTROL SURFACES ASSIGNMENTS
Control surfaces assignments can be saved and loaded if you have multiple keyboards
or want to reuse your settings for various projects. To save the current control surface
assignments, click the Save button. To delete the current control surface assignments,
click the Delete button.
Fields

Description

Command

This is the command being assigned or mapped

Type

Can be a CC, note-on, or note-off message

Val

The number of the CC or note-on

Ch#

MIDI channel of controller

Any (-), Dn,
Up

This field determines what type of CC data to respond to. Any or (-)
means it could be anything. “Dn” means that a CC button has been
pushed down. “Up” means that a CC button has been released.

X

Removes the current controller assignment

These files will be stored in %programdata%\Acoustica\Mixcraft\control-surfaces\ .
To load a previous control surface, click the Surfaces drop-down menu and choose one.
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CONTROL SURFACE COMMANDS LIST
The following commands can be assigned to MIDI control:
Main Transport Controls

Playback Toggle

Recording Metronome Toggle

Play

Count-In Metronome Toggle

Stop

Punch In/Out Toggle

Rewind a bit

Set Punch In To Current Position

Rewind to Start

Set Punch Out To Current Position

Fast forward a bit

Set Loop Start To Current Position

Fast forward to End

Set Loop End To Current Position

Record

Add Marker At Current Position

Adjust Master Volume

Play From Previous Marker

Loop Mode Toggle

Play From Next Marker

Playback Metronome Toggle
Selected Track Controls

Select Previous Track

Monitoring For Selected Track Toggle

Select Next Track

Guitar Tuner For Selected Track Toggle

Set Selected Track Volume

EQ High For Selected Track

Set Selected Track Pan

EQ Mid For Selected Track

Mute/Unmute Selected Track

EQ Low For Selected Track

Solo/Unsolo Selected Track

Send Adjustment For Selected Track

Arm/Disarm Selected Track
Other

Undo

Insert Virtual Instrument Track

Redo

Insert Audio Track

Save
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MUSICAL TYPING KEYBOARD
(MTK)
If you do not have a MIDI keyboard attached to your computer, you can use your
computer’s standard QWERTY keyboard to play notes.

OPENING THE MTK
Select View>Musical Typing, click the Musical Typing... button
in the Instrument Preset window, or use the keyboard shortcut
[CTRL]+[ALT]+K.
PLAYING AND RECORDING NOTES
The MTK has a 17-note range (1 ½ octaves), playable via the computer’s keyboard.
Add a Virtual Instrument track and choose a preset. Press the keyboard buttons on
the MTK to trigger notes. Press multiple keys to play chords. Press the [SHIFT] key to
sustain notes. Adjust the default velocity by clicking the velocity adjust keys < or >. To
bend pitch up or down, click the 1 or 2 keys while playing back notes. To adjust the
modulation amount, click keys 3 to 8 to choose from off to maximum modulation.
ADJUSTING THE PLAYABLE RANGE
The MTK may be transposed in steps or octaves. To transpose by an octave, press the Z
or X keys. To transpose in half-steps, press the C or V keys. Alternatively, you can click
a note on the smaller keyboard on the bottom to set the start key of the playable range.
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Need More
Keys, Please!

MUSICAL TYPING KEYBOARD SHORTCUTS
Keys

Function

A thru “

Mapped to playable notes (white keys)

Q thru {

Mapped to playable notes (black keys)

1, 2

Adjust the pitch bend

3-8

Adjust the modulation from “off” to “max”

[SHIFT]

Sustain the currently played notes, even if keys are released

Z, X

Transpose the playable range by +/- one octave

C, V

Transpose the playable range by +/- one note.

<, >

Adjust the default velocity for new notes.
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Musical Typing
functionality will
depend upon your
computer’s keyboard.
Many computer
keyboards do not
allow more than three
keys to be pushed
simultaneously.
Please keep in mind
that the MTK is supplied
as a way to make music
and is not necessarily
the best way to play a
keyboard! The good
news is that there are
many affordable “piano
keyboard” controllers
on the market... if even
those are beyond your
price range, there are
plenty of great deals
to be found on ebay or
Craigslist.

PREFERENCES
Preferences are options that are changed infrequently and allow you to
customize how the Mixcraft behaves. To open the Preferences, select
File>Preferences from the Main Window menus, or click the gear button in the top
toolbar. You can also access Preferences by pressing [CTRL]+[ALT]+P.
SOUND DEVICE

Choose settings for sound devices.
SETTINGS COMMON TO ALL SOUND DEVICES
 Driver

		 Select Wave, ASIO, or WaveRT audio drivers. This setting affects other options
		 on this page. The ASIO option will be unavailable if no ASIO drivers are found.
		(WaveRT mode is not available on Windows XP.)
 Force Single CPU

		
		
		
		

This will force the sound engine to use a single CPU for mixing audio. This is
only applicable to multiple-CPU machines, such as a dual-core or quad-core
computer. Single-CPU computers will not offer this option. This option may
offer better compatibility with older VST effects and virtual instruments.
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 Use High Priority Threads For Audio Engine

		
		

This will cause all audio mixing sound engine threads to mix at a high system
priority. By default, Mixcraft uses high priority.

 Default Settings

		
		

This button will reset the drivers and settings to defaults. This changes settings
to the Wave driver to 44,100 Hz, stereo, 16-bit (8 buffers @ 16384 bytes).

 Open Mixer...

		
		

This opens the Windows or ASIO mixer control panel, allowing you to change
some settings. This typically applies when using ASIO driver mode.

CORE AUDIO/WAVE RT-SPECIFIC SETTINGS

Adjust these settings when WaveRT mode is selected. WaveRT stands for “Wave Real
Time” and is the preferred driver. Make sure you’ve downloaded the latest drivers for
your sound device. Also, contact the sound device manufacturer to see if the drivers
support WaveRT.
Note: WaveRT is not available when using Windows XP.)
 Sample Rate
		 Choose a sample rate supported by the device. Higher sample rates provide

		

better audio quality but require more hard disk space and CPU resources.

 Bit Depth

		

Select the number of bits for one sample.

 Latency

		
		
		
		
		

Adjust the latency in milliseconds. Lower settings result in better performance you’ll hear less “slapback” delay when recording with software monitoring, and
Virtual Instruments will be more responsive when played live. The downside
is that lower latency settings increase the potential for audio gapping or noncontinuous audio (a.k.a. obnoxious crackling noises).

 Exclusive Mode

		 For Windows 7 and above, you have the option of running Mixcraft in Exclusive
		Mode. This will take over exclusive control of the sound device and allow 		
		 super-low latency settings down to three milliseconds! (You’ll also be welcome at
		 ritzy L.A. clubs and red carpet events.)
		 When using Exclusive Mode, other programs will not have access to the sound
		 device and will need to be restarted after Mixcraft is either shut down or out of
		Exclusive Mode.
ASIO-SPECIFIC PREFERENCES

Adjust these settings if ASIO mode is selected. ASIO is an alternative driver system
that allows for lower latency and improved synchronization between playback and
recording when using suitable audio hardware.
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It’s All About
The Drivers
Always make sure that
you’ve downloaded the
latest audio drivers for
your sound device or
audio system. Not only
are audio hardware
makers constantly
improving driver
performance, audio
issues are frequently
solved with a simple
driver update, so
head on over to the
manufacturer’s website
to check for updates!

 Default Input (Recording)

		
		

Choose the default audio interface physical input to record audio from. Make
sure the device is on and plugged in, otherwise it may not show up.

 Default Output (Playback)

		
		

Choose the default audio interface physical audio output. Make sure the device
is on and plugged in, otherwise it may not show up.

 ASIO Device

		
		

Choose the default ASIO Device to record from. ASIO only allows for one device
at a time.

 Open Mixer…

		
		
		
		

ASIO audio device drivers often have their own dedicated control panel 		
hardware where audio settings are configured. The Open Mixer… button 		
opens the ASIO device mixer control panel and allows you to select latency and
other advanced settings.

WAVE-SPECIFIC PREFERENCES

Adjust these settings when Wave mode is selected in the Sound Device Preferences. We
only recommend using Wave mode if nothing else is available. (No hard feelings, ok
Wave mode?)
 Default Input (Recording)

		
		

Selects the default sound device from which to record audio. Make sure the
device is on and plugged in, otherwise it may not show up.

 Default Output (Playback)

		
		

Selects the sound device from which to play audio. Make sure the device is on
and plugged in, otherwise it may not show up.

 Sample Rate

		
		
		

Choose a sample rate for both recording and playback. The default CD-quality
sample rate is 44.1 kHz. If your sound card (and hearing range!) supports it,
Mixcraft supports sample rates up to 192 kHz.

 Bit Depth

		
		
		

This is the number of bits per sample. 16-bit is the default for CD quality.
Mixcraft supports bit depths up to 24-bit for ultra high quality. Only use 8-bit if
you have no other option. (8-bit audio is very noisy)

 Number Of Buffers

		
		
		

This is the number of audio buffers to pre-mix before starting playback. The
number of buffers determines audio latency. More buffers result in higher 		
latency. Fewer buffers result in lower latency but possible audio gapping.
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 Buffer Size

		
		
		
		

The size of the buffer also determines audio latency. Larger buffers result in
higher latency. Smaller buffers result in lower latency but can cause audio 		
gapping. Buffer settings may require some trial-and-error to achieve the best
balance of latency vs. performance.

 Open Mixer...
		 This button opens the Windows mixer, allowing configuration of 		

		

inputs and recording levels for sound devices.

GENERAL

LANGUAGE

Choose a language to view Mixcraft in. You’ll need to restart Mixcraft for newly selected
languages to take effect.
PLAY EXPORTED FILES AFTER THEY’RE CREATED

After mixing down to an audio file, this option launches the associated player and
begins playback.
ASK ME PERIODICALLY TO CHECK FOR NEW SOFTWARE UPDATES

Allows Mixcraft to check online for new versions. A good idea!
TEMPORARY FILES DIRECTORY

Choose a directory to store any temporary files used by Mixcraft, such as peak data,
beat map data and other data Mixcraft temporarily stores while performing operations.
Click Browse... to select a new directory.
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DELETE TEMPORARY FILES

This deletes all temporary files and folders from the Temporary Files Directory above.
This includes all .tmp, .isk, .beatmap .isk, and .ipk files used in Mixcraft.
EXTERNAL WAVE EDITOR

Selects an external wave editing application to launch when Edit In External Editor is
used. Click Browse... to locate the the external audio editor application.
DISPLAY

DRAW AUDIO AND MIDI DATA ON CLIPS

Determines if audio wave or MIDI note data is displayed on the clips. Turning this off
could speed up your computer (but likely only if you have a really slow computer).
DRAW NOTE TEXT ON PIANO ROLL NOTES

Displays the text note on a note for easier recognition. For example, if the note is an A,
it will display an A on it.
CHANGE NOTE COLOR FOR PLAYING NOTES

This option makes it easier to see what notes are currently audibly playing.
ENABLE LOGGING FOR TROUBLESHOOTING

Logging can slow down some computers. However, this option should be left on for
support troubleshooting. (and to create jobs in the Pacific Northwest…)
LIMIT DRAWING DURING PLAYBACK

Allows limiting the maximum frame rate Mixcraft draws the screen at in order to
reduce CPU usage. By default, the screen will not draw more than 30 frames/second.
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DISPLAY VOLUME AS

Choose between Decibels or Percentage. This affects track volume sliders and editing of
volume envelope points on clips.
DEFAULT AUDIO TRACK COLOR

Choose a default track color. (Default color is green.)
DEFAULT INSTRUMENT TRACK COLOR

Choose a default track color. (Default color is blue.)
VISUAL THEME

Choose between MX_default (deep gray tones) or MX_light (it’s lighter, as its name
would imply).
INTERFACE

AUTO-SCROLL DURING PLAYBACK

This makes the Main Clip Grid scroll to automatically follow the Playhead.
 Keep The Playback Indicator Centered
		If Auto-Scroll During Playback is checked, this keeps the playback indicator
		 to be centered during playback. This auto-scrolls the project instead of moving
		 the playback indicator.

SET PLAYBACK INDICATOR WHEN CLICKING INSIDE SOUND WORKSPACE

This makes the Playhead jump to any position the mouse is clicked in the Main Clip
Grid. Also restarts playback from this location if the project is playing back.
AUTO-REWIND TO START POSITION WHEN PLAYBACK/RECORDING ENDS

After recording or playing, the Playhead rewinds to where it was prior to record or play.
MAKE CLIPS “STICKY” SO THAT THEY ARE HARDER TO MOVE

This helps to maintain the exact offset of notes or clips when dragging up or down. For
example, if you are zoomed way out and move a clip to a different track, it may change
the time offset ever so slightly causing the sound to go out of sync.
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ZOOM MODE

This customizes zoom behavior.

 Last Left Click & Caret

		
		

The center point of zoom in and out is the most recent left-click in the in the
Main Clip grid.

 Mouse Cursor

		

The center point of zoom in and out is the current mouse position.

 Caret

		

The center point of zoom in and out is the current caret position.

MOUSE WHEEL

These settings affect how the mouse wheel controls zooming and scrolling. Choose
combinations to customize mouse wheel behavior.
The default setting is:
Mouse wheel = Zoom
[CTRL] + Mouse wheel = Horizontal Scroll
[SHIFT] + Mouse wheel = Vertical Scroll
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PROJECT

AUTHOR

The default author will be filled into each new project’s author information.
COPYRIGHT

The default copyright information will automatically be filled into each new project’s
copyright information.
CHANGE PROJECT TEMPO AND KEY TO MATCH FIRST SOUND

When adding loops or sounds with a known key or tempo, the software will change
the master tempo and/or key so that it sounds good. For example, if a sound was
normally at 68 bpm and you tried to play it at 120 bpm, it would sound terrible. Time
stretching works best when the tempos are no more than 10 to 30% different. This
option conveniently sets the tempo or key of the project to match the sound’s tempo or
key signature.
ASK TO CHANGE PROJECT TEMPO AND KEY ON FIRST SOUND

This option causes the software to ask if you want to change the tempo or key for the
Change Project Tempo And Key To Match First Sound option above.
CREATE BACKUP FILE WHENEVER PROJECT IS SAVED

Every time you save, Mixcraft creates a backup file located in the project folder in a sub
folder called backup. MX7 backup file’s contain the date and time they are saved.
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RECORDING

DEFAULT PROJECT FOLDER

The default project folder is where recordings and other important files are placed.
Click Browse... to choose a new default project folder location.
DELETE UNUSED RECORDINGS DURING SAVE OR ON EXIT

If this option is checked, Mixcraft deletes any recordings made that are not currently on
any tracks during a project save or when the exiting the software. If recordings appear
to be disappearing from the recording folder, it may be because they weren’t part of the
project. To prevent these recordings from being deleted, uncheck this.
AUDIO TRACK DEFAULT RECORDING MODE

Choose from Takes, Overdub, or Replace mode.
INSTRUMENT TRACK DEFAULT RECORDING MODE

Choose from Takes, Overdub, or Replace mode.
For more information on Takes, Overdub, and Replace modes when recording MIDI
clips, see the Recording To MIDI Tracks “Recording Mode” section; for information
about recording modes with audio clips, see the Recording Audio “Recording Mode”
section
WHEN RECORDING INPUT IS USED ON MORE THAN ONE TRACK

This instructs the software on how to handle two different tracks set to use the same
recording input.
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The default is Do Not Allow Duplicate Recording Inputs. This routes the selected input
to the newly armed track and disarms previously armed tracks.
Allow Duplicate Recording Inputs allows any number of tracks to be armed; it’s possible
to accidentally record numerous independent tracks of the same thing, so be careful if
this option is chosen.
RECORDING FILE TYPE
 Uncompressed WAV File (.WAV)
		 WAV is the most common uncompressed Windows audio format. Because no

		
		

file compression occurs, it will have the best audio quality, but it also requires
the most hard disk space.

 Compressed OGG Vorbis File (.OGG)

		
		
		
		
		

OGG is very high quality compressed audio format. It’s a “lossy” format, that is,
it does get rid of some audio data in order to create smaller file sizes, but don’t
let that scare you; we’ve found OGG audio quality to be excellent, so we 		
recommend using it in most situations (that’s why we choose it as Mixcraft’s
default audio format).

		
		

OGG audio quality can be adjusted with the slider (lower quality = smaller file
sizes, higher quality = larger file sizes).

 Uncompressed FLAC File (.FLAC)

		
		
		
		
		
		

FLAC is another high-quality compressed audio format. It’s what’s referred to as
a “lossless” format, that is, it doesn’t get rid of any audio data. This results
in larger file sizes than OGG (but smaller than uncompressed WAV). Goldenear types love to argue about which format sounds better, and we’ve got better
things to do than bicker with those folks, but FLAC sounds great and it’s there if
you want it!

		
		

FLAC audio quality can be adjusted with the slider (lower quality = smaller file
sizes, higher quality = larger file sizes).
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METRONOME

Clicking the Browse buttons allows customization of metronome sounds at the
beginning of each measure and for individual beat clicks respectively. Default and user
metronome sounds reside in the Program Files>Mixcraft folder.
METRONOME SOUND FILE (MEASURE)

The default measure tone is HighTone.wav. Click Browse to replace this with a custom
user sound.
METRONOME SOUND FILE (BEAT)

The default measure tone is LowTone.wav. Click Browse to replace this with a custom
user sound.
METRONOME VOLUME

Adjust the metronome volume to desired level with the horizontal slider.
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MIDI

Set MIDI preferences here.
DEFAULT MIDI INPUT DEVICE

If you have MIDI interfaces or MIDI keyboards, choose the interface that you’d like to
play and record from. The default is All MIDI Devices.
“CHASE” UNFINISHED MIDI NOTES ON PLAYBACK AND LOOPING

MIDI is not actual sound, it’s a series of commands instructing the computer play (or
shut off) notes. With that in mind, what happens if you initiate playback in the middle
of a note? The Chase option tells Mixcraft to send a “note on” message even if the
playback start point is after the beginning of a note. This might not be significant if the
song contains quick, percussive sounds (like clavinet, or wood blocks), but if the song
has very long sustained pads, it’s likely that large musical elements will be missing if
playback isn’t started in the correct location. Chase helps alleviate this possibility.
RELEASE HOLD / SUSTAIN PEDAL (CC64) WHEN CLIP ENDS

Like the Chase situation above, this is another potential MIDI problem you might
consider until it occurs. If a sustain pedal isn’t released at the end of recording a
clip (or you trim the clip’s right edge so the sustain pedal off message no longer gets
transmitted), it’s possible to end up with notes that sustain forever and that’s a mighty
long time, but I’m here to tell you, there’s something else: Release Hold/Sustain Pedal
(CC64) When Clip Ends. This automatically sends a CC64 (the MIDI controller
number for a sustain pedal) message of 0 to prevent possible “forever” notes.
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RELEASE HOLD / SUSTAIN PEDAL (CC64) WHEN PLAYBACK ENDS

This performs the exact same function as Release Hold / Sustain Pedal (CC64) When
Clip Ends described above, but does so when playback is stopped.
REMOVE PROGRAM CHANGE MESSAGES FROM MIDI FILES

Embedded program changes in imported MIDI files (usually of the downloaded or
purchased General MIDI file variety) can cause things to go haywire with undesired
program changes. Remove Program Change Messages From MIDI Files strips the
annoying program changes from MusicBob’s standard MIDI file of “Total Eclipse Of The
Heart.”
DEFAULT MIDI SETTINGS

Reverts all settings on this page back to default settings.
CONTROL SURFACES

As of the initial release of Mixcraft 8, natively supported Control Surfaces include the
Novation Launchpad, Mackie Control (aka MCU, and previously, Logic Control) and
compatibles, Frontier Design Group TranzPort, and Acoustica’s own Mixcraft Remote
app for Android and iOS mobile devices.
Note: For more information on configuring Control Surfaces, see “Using Natively
Supported Hardware Controllers.”
TYPE

For Mixcraft to recognize any of these devices, plug in the device (or in the case of
Mixcraft Remote, makes sure your computer and mobile device are on the same
wireless network), click <Add New> and select the appropriate device. If you’re using
an older Emagic Logic Control, be sure to choose it (instead of Mackie Control) in the
Type list, otherwise all functions won’t work correctly.
INPUT

Specifies the input for the Control Surface. If it’s a MIDI device, choose the appropriate
MIDI interface. If it’s plugged into a USB port, choose the name of the Control Surface.
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OUTPUT

This is specifies the MIDI or USB output for the device and is set just like the input
setting. If it’s a MIDI device, choose the appropriate MIDI interface. If it’s plugged into a
USB port, choose the name of the Control Surface.
Note: The Mixcraft Remote mobile app does not require any Input or Output settings.
LINK

Linking two or more control surfaces (e.g. Mackie control surfaces), will cause them to
act as one large single control surface.
UP/DOWN ARROWS

If you’re using more than one of the same fader controller, these let you move devices
up and down in the list. This effectively lets you change the fader order of cascaded
units to align with their physical placement in your workspace.
X BUTTON

This deletes the currently selected Control Surface.
CD BURNING

BURNING ENGINE

Choose between Primo or IMAPI. Primo is the default and recommended CD burning
engine. It burns audio CD’s without gaps between tracks and supports CD-Text
burning.
IMAPI is Windows default audio CD burning method. The drawback is that when
burning more than one track, it inserts a two-second gap between tracks and
automatically converts to WAV prior to burning.
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LIBRARY

These are Mixcraft’s included sound library settings.
LOOP LIBRARY DIRECTORY

The folder where the loop library is stored. When new loops are downloaded, they are
saved in this directory. This folder is shared for all users on this computer.
If you’re using Mixcraft in Administrator mode, you can change this folder location. To
run Mixcraft in Administrator mode, browse to the Acoustica Mixcraft folder, rightclick Mixcraft7.exe and choose Run As Administrator...
Type in a new folder path or click Browse... to select a new folder.Schools or labs can
set the folder to reside on a server in order to save space on individual workstations.
LOOP LIBRARY DOWNLOAD

Select a Loop Library download site from the drop-down. If you experience problems
downloading sounds, please go to the “Troubleshooting” section.
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PLUG-INS

LOAD VST EFFECTS AND INSTRUMENTS (VST/VSTI)

Mixcraft loads VST effects and virtual instruments upon launch if this box is checked.
EDIT VST/VSTI FOLDERS

Click this button to add, edit, or delete folders Mixcraft scans to locate VST Plug-Ins.
RE-SCAN ALL VST PLUG-INS

Scans VST folders for new plug-ins. This is useful when installing new VST Plug-Ins.
(And also helps to thwart “lookin’ for plugs in all the wrong places.”)
AUTOMATICALLY ADD ALL INSTRUMENT OUTPUT TRACKS
FOR VIRTUAL INSTRUMENTS

This will add a child output channel track for each output channel in the VSTi. This is
only important for instrument plug-ins with multiple output channels. If this is off and
the instrument has multiple output channels, a single output track is created.
RESET PLUG-INS ON PLAYBACK AND MIX DOWN

If playback is stopped before a delay or reverb effect has faded out, the remaining
decay can get stuck in the audio buffers; this “stuck” audio can be heard the next
time playback is initiated. Checking Reset Plug-Ins On Playback And Mix Down
automatically clears Mixcraft’s audio buffers the next time play is pressed or when the
Mix Down To Audio File command is used, eliminating these annoying audio artifacts.
ENABLE REWIRE HOSTING

Toggle this option to enable or disable ReWire hosting. You’ll need to restart Mixcraft to
use newly added ReWire clients.
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DEFAULT VIRTUAL INSTRUMENT PRESET

Here you can define the instrument assigned to newly created Virtual Instrument
tracks. By default this is a piano sound, but it can be changed to whatever you like.
DEFAULT GENERAL MIDI (GM) INSTRUMENT

Here you can define the General MIDI sound set assigned to newly created General
MIDI files. This is set to Acoustica Instruments by default.
MANAGE PLUG-INS

A shortcut to the Manage Plug-Ins window (also accessible via File>Manage Plug-Ins).
This where plug-ins can be enabled and disabled from showing in the list of effects
shown in Mixcraft, and also where you can edit instrument and effects Collections (see
“Plug-In Management” for the full scoop).
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MAIN WINDOW MENUS
FILE MENU
NEW PROJECT [CTRL]+N

Creates a new project and shows the New Project Settings dialog.
OPEN PROJECT... [CTRL]+O

Opens or loads an existing project or template.
SAVE [CTRL]+S

Saves the current project
SAVE AS...

Saves the current project or mixes down to an audio file depending on Save As...
format selection.
COPY PROJECT FILES TO...

Copies all current project files to a folder or a new ZIP file. This is useful for backing
up projects (i.e. to CD), reorganizing project files, or collaboration with others.
MIX DOWN TO

Mixes the current project to an audio or video file format.
SAVE AS MIDI FILE...

Saves the MIDI data of the current project as a Type 1 Standard MIDI file.
BURN CD... [CTRL]+B

Burns an audio CD, compatible with any standard audio CD player.
LABEL CD...

This launches the optional Acoustica CD/DVD Label Maker application for printing CD
labels, etching a LightScribe disc, or printing on a direct-to-CD printer.
PRINT... [CTRL]+P

Prints the notation display, if currently selected.
PREFERENCES

Opens the Preferences dialog.
SET NEW PROJECT DEFAULTS

Opens the New Project Settings window.
MANAGE PLUG-INS…

Opens the Plug-In Management window.
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RECENT PROJECTS

Displays the ten most recently loaded or saved projects for quick access. To load a
recent project, click on it.
EXIT

This closes Mixcraft. Before exiting, it will prompt you to save unsaved changes.
EDIT MENU
UNDO [CTRL]+Z

This will undo any action up to the point of the last save, load, or new project.
REDO [CTRL]+Y

This will redo any “undone” action.
CUT [CTRL]+X

This cuts or removes any currently selected audio, MIDI data, or video (or parts
thereof). The cut operation also stores the cut sounds in the Clipboard for pasting if
desired.
COPY [CTRL]+C

This copies audio, MIDI data, or video currently selected or in the selection rectangle
to the Clipboard for pasting if desired.
PASTE [CTRL]+V

Pastes or inserts audio, MIDI data, or video currently stored in the Clipboard buffer
at the caret location. If necessary, new tracks are created if the Clipboard buffer stored
audio, MIDI data, or video spanning multiple tracks.
CROP [CTRL]+Q

The opposite of cut. Cropping something keeps what is selected and discard everything
else on the selected clips.
DELETE [DELETE]

This will remove any sounds or parts of sounds that are currently selected or in the
selection rectangle. Unlike, Cut, this will not store the deleted audio in the Clipboard.
SELECT ALL [CTRL]+A

This selects all clips in the project.
SPLIT [CTRL]+T

This splits selected clips at the current Caret location.
REMOVE SPACES BETWEEN CLIPS [CTRL]+J

Removing space between the clips eliminates gaps or silence between selected clips by
moving the selected clips together.
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MERGE TO NEW CLIPS [CTRL]+W

Merges the selected clips into a new clip. This functions on a per-track basis and does
not combine clips from different tracks.
LINK

The Link submenu allows clips to be linked or unlinked. When clips are linked, they
move together when dragging. Linked clips retain theirrelative offset to each other. The
submenu link options are:



Link Selected Clips
Unlink Selected Clips

Linked clips will have a button in the title bar. Click this button to unlink clips.

INSERT SELECTED TIME

When a purple selection region is made in the Timeline or Main Clip grid, this function
inserts additional time into the selected area. Any clips within the insert area are split
and the right halves are advanced. Automation data is also moved to maintain the
proper location.
REMOVE SELECTED TIME

When a purple selection region is made in the Timeline or Main Clip grid, this function
deletes the time in the selected area. Any clips (or parts of clips) within the area are
removed. Automation data in the selected area is also removed.
MIX MENU
PLAY/STOP PLAYBACK [SPACE BAR]

Starts and stops project playback at the Playback Indicator position.
PLAY FROM

Displays a menu allowing playback from project Markers.
REWIND TO START [HOME]

Moves the Playhead to the beginning of the project. If the project is currently playing,
the project starts playback from the beginning.
FAST FORWARD TO END [END]

Moves the Playhead to the end of the project. If the project is playing audio, playback
is stopped.
RECORD [CTRL]+R

Beings recording on any armed tracks.
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SET MASTER VOLUME

Sets the master volume to an exact amount or from 20% to 200%.
MIDI RESET!

Sends a panic message to all virtual synthesizers and external synthesizers instructing
them to stop playing any stuck notes. Use this if you can’t a sound to stop.
MIDI CONTROL SURFACE

Configures playback, recording, and other transport functions from a MIDI controller
or device.
EDIT MASTER EFFECTS

Opens the Master Effects window. Use to apply and edit effects on the Main Mix twotrack bus.
ADD REWIRE APPLICATION

Choose a ReWire application to control, if available.
ADD TEMPO/KEY CHANGE

Adds a marker at the current Playhead position and opens the Marker Edit window
where a tempo, key, or time signature change may be added.
MARKERS

Opens a submenu to add, edit, or delete Markers.
TRANSPOSE KEY CHANGES

Opens a submenu with Up or Down options for global transposition of a project,
including all Markers containing key changes.
METRONOME AND COUNT-IN SETTINGS [M], [SHIFT]+M

Toggles the metronome on and off independently for playback and recording, and
specifies the number of count-in measures prior to recording.
LOOP PLAYBACK MODE [L]

Loop playback of a selection or the entire project.
USE RECORDING TIMER

Sets the recording timer allowing recording to stop after a specified duration.
AUTOMATION RECORDING MODE

Selects the behavior of automation recording when using a control surface.
 Overwrite Mode

		
		

Continuously writes the current fader or V-Pot position for the duration of
recording, overwriting existing automation data as it records.
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 Touch Mode

		
		
		
		
		
		

When used with a control surface with touch-sensitive faders Touch Mode
overwrites automation data only when the fader is being touched. When used
with control surfaces with non touch-sensitive faders, recording of automation
initiates only after Mixcraft detects a fader has been moved. From this point on,
automation writing behaves the same as Overwrite Mode, overwriting as it goes
until Mixcraft is stopped.

TRACK MENU
ADD TRACK

Adds a new Audio Track [CTRL]+G,Virtual Instrument Track [CTRL]+E, Video Track,
Send Track, SubMix Track or Output Bus Track to the end of the project.
INSERT TRACK

Inserts a new Audio Track [CTRL]+G,Virtual Instrument Track [CTRL]+E, Video Track,
Send Track, SubMix Track, or Output Bus Track before the currently selected track.
DELETE TRACK [CTRL]+[SHIFT]+D

This deletes the currently selected track.
SHOW MASTER TRACK

Click to show or hide the Master Track.
PROPERTIES

These submenus contain numerous track options.
 Mute [CTRL]+M

		 Mutes or unmutes the selected track. A checkmark indicates that the track is
		muted.
 Solo [CTRL]+L

		

Solos or un-solos the selected track. A checkmark indicates the track is soloed.

 Set Volume

		 Sets the volume for the selected track to either an exact amount or from 20% to
		200%.
 Set Pan

		
		

Sets the pan position of the selected track. If the clip on the track is a stereo file,
pan will act as a left/right balance control.

 Track Color

		

Selects a color for the track and its clips.

 Track Height

		 Opens a submenu for setting the selected track height to Small, Normal, or
		Large.
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 Choose Image...
		 Opens the Track Image dialog allowing the use of custom track list images.

LANES

The Lanes submenu lets you add, delete, and mute clip lanes.
 Add [ALT]+L

		

Add a new lane to the currently selected track.

 Delete

		

Delete the currently selected lane and any clips on it.

 Delete Empty Lanes [ALT]+K

		

This removes unused lanes from the currently selected track.

 Mute All

		

Mutes all clips on the selected lane.

 Unmute All

		

Unmutes all clips on the selected lane.

 Select All

		

Select all clips on the selected lane.

ARM FOR RECORDING [CTRL]+B

Arms the selected track.
MONITOR

Allows you to hear audio as it records, including any effects on the recording track.
ARM RECORDING CHANNEL AND DEVICE

Selects the recording input source for an Audio Track, Virtual Instrument Track, or
MIDI Track.
RECORDING MODE

Selects Overdub, Takes, or Replace mode for the currently selected track.
GUITAR TUNER

Activates the Guitar Tuner on the current track [Audio Tracks only].
FX...

Displays the Effect List for the selected track.
SHOW/HIDE AUTOMATION LANE

Shows or hides automation lane[s] for the selected track.
MIX TO NEW AUDIO TRACK

Mixes the selected track to a new audio track with current effects applied. The original
track is retained and muted after the new audio track is created. This can be useful if
effects are using excessive CPU resources or RAM and compromising performance.
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DUPLICATE TRACK

This copies and pastes all clips and settings of the current track and and creates a new
track beneath the selected track with the same clips and settings. Useful if you’d like to
make serious edits but would like to maintain an “untouched” version.
FREEZE TRACK [CTRL]+[SHIFT]+F

Freezes the selected track. This is useful if the project is using too much CPU or RAM.
SELECT ALL CLIPS ON THIS TRACK [CTRL]+[SHIFT]+A

Selects all clips on the selected track.
SOUND MENU
ADD SOUND FILE... [CTRL]+H

Use for adding audio, MIDI data, or videos to the current project. New files will be
inserted at the current Caret location.
ADD INSTRUMENT CLIP

This will add a blank Virtual Instrument clip on the closest Virtual Instrument
Track. You can also double-click a Virtual Instrument track to create a blank Virtual
Instrument Clip.
MIDI EDITING

These submenus contain numerous MIDI editing options including Quantize,
Humanize, Transpose, Velocities, Offsets, Durations, Soloize, and Double.
[See “MIDI Editing: Clips” for full details.]
PROPERTIES

These submenus specify individual clip properties. See Using Clips and The Main Clip
Grid for full details.
 Mute

		

Mutes or unmutes the selected clip.

 Channels

		

Selects the active/audible channel for audio clips. (Audio clips only)

 Phase

		

Selects the phase of the audio clip. (Audio clips only)

 Normalize [CTRL]+K
		 This sets the volume of all selected sounds to the normalized level. Normalized

		

level is based on the loudest peak. Reselect to deactivate normalization.

 Lock

		 Locks or unlocks the selected clip(s) to prevent resizing, movement, or other
		modifications.
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ENVELOPES

Submenu for Envelopes, a.k.a. Clip Automation.
 Reset Envelope [CTRL]+[ALT]+T

		

Restores the current envelope to its default setting for all selected sounds.

 Invert Envelope [CTRL]+[ALT]+Y

		

Inverts or flips the current envelope vertically for all selected sounds.

 Fade Out

		
		
		
		

Displays pop-up menu with the following options: Fast, Medium, and Slow.
Each option adds a fade-out of the current envelope type to all selected sounds.
Note that the fade is applied to the selected area. If there is a selection rectangle,
the fade only occurs in the selection rectangle

 Fade In

		
		
		

Displays a pop-up menu with the following options: Fast, Medium, and Slow.
Each option adds a fade-in of the current envelope type to all selected sounds. If
there is a selection rectangle, the fade only occurs in the selection rectangle.

 Boost

		
		
		

Displays a pop-up menu to boost all selected sounds by a set percentage for
the current chosen envelope type. If there is a selection rectangle, the boost is
applied only to the selected area.

 Reduce

		
		
		

Displays a pop-up menu to reduce all selected sounds by a set percentage for
the current chosen envelope type. If there is a selection rectangle, the reduction
is applied only to the selected area.

LINK

The Link submenu allows clips to be linked or unlinked. When clips are linked, they
move together when dragging. Linked clip retain their relative offset to each other. The
submenu link options are:


Link Selected Clips



Unlink Selected Clips
Linked clips will have the button in the title bar. Clicking the button will
unlink clips.

SPLIT [CTRL]+T

This splits selected clips at the current Caret location.
REMOVE SPACES BETWEEN CLIPS [CTRL]+J

Removing space between the clips eliminates gaps or silence between selected clips by
moving the selected clips together.
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MERGE TO NEW CLIPS [CTRL]+W

This merges the selected clips into a new clip. This functions on a per-track basis and
does not combine clips from different tracks.
REVERSE

This makes audio clips play backwards, which is almost always awesome.
ADD TO LIBRARY

Adds the audio clip to the sound library, for easy future use.
SET LOOP TO CROP

Sets the loop point on a clip to its current crop. (Audio clips only)
TRIM SILENCE [CTRL]+I

This removes any silence from left and right edges of clips. (Audio clips only)
EDIT IN EXTERNAL EDITOR...

Opens the sound or a copy of the sound in an external third-party sound editor.
VIDEO MENU
ADD A VIDEO FILE...

Adds a video file to the project.
ADD STILL IMAGES...

Add image files to the video track. JPG, BMP, and PNG formats are supported.
ADD TEXT...

Adds text to the Text Video child track.
ADD SCROLLING TEXT...

Adds scrolling text to the Text Video child track.
ALIGN CLIPS...

Aligns image and video clips for creating slide shows or aligning them to the beat.
SET NON-CLIP BACKGROUND COLOR...

Sets the color of the background if no video or image clips are present.
SHOW/HIDE VIDEO WINDOW

Shows or hides the video playback window.
SET PREVIEW WINDOW SIZE

Selects standard video sizes for the Video Window.
LINK

The Link submenu allows clips to be linked or unlinked. When clips are linked, they
move together when dragging. Linked clips retain their relative offset to each other. The
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submenu link options are:


Link Selected Clips



Unlink Selected Clips

Linked clips will have a button in the title bar. Click this button to unlink clips.

VIEW MENU
ALL TRACKS HEIGHT

Opens a submenu for setting the selected track height to Small, Normal, or Large.
TIMELINE MODE

Selects Beats or Timeline viewing mode.
SNAP TO GRID

Disable Snap or choose a snap setting for the Timeline in the pop-up submenu.
SHOW/HIDE DETAILS AREA

Shows or hides the most recently selected details tab. (Project, Sound, Mixer, or
Library)
MUSICAL TYPING

Opens the Musical Typing keyboard. This allows MIDI note input using a standard
QWERTY computer keyboard.
PERFORMANCE PANEL

Toggles viewing and hiding of the Performance Panel.
ZOOM IN [+]

Zooms in to the project for a more detailed view.
ZOOM OUT [-]

Zooms out for a wider view.
ZOOM TO PROJECT [0]

Fits the entire project to the screen.
HELP MENU
HELP FILE...

Opens the Help File. (the thing you’re reading right now)
CHECK FOR UPDATE...

Checks the Internet for a newer or updated version of Mixcraft.
ENTER REGISTRATION CODE...
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If unregistered, use this to enter your registration code.
BUY NOW!

Displays a window with instructions on purchasing and registering the software.
(Unregistered versions only)
ABOUT MIXCRAFT...

Displays Mixcraft credits, copyrights, and thanks.
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KEYBOARD SHORTCUTS
NAVIGATION, PLAYBACK, AND RECORDING
Function

Keyboard Shortcut

Play / Stop

[SPACE]

Play Sound Tab
(not main transport)

[SHIFT]+[SPACE]

Play From Next Marker

[CTRL]+[SPACE]

Play From Previous Marker

[CTRL]+[SHIFT]+[SPACE]

Record

R or [CTRL]+R

Toggle Loop Mode

L

Toggle Playback Metronome

M

Toggle Recording Metronome

[SHIFT]+M

Move Clips

If Snap is on, the selected clips will move at the
current Snap setting.
[CTRL] + arrow keys moves +/- 20 milliseconds.
[CTRL] + [SHIFT] + arrow keys move +/- 1
millisecond.
If Snap is on, the selected clips will move at the
current Snap setting. [CTRL] + arrow keys moves
+/- 20 milliseconds. [CTRL] + [SHIFT] + arrow
keys move +/- 1 millisecond.
Up/down arrow keys move the selected clips to a
different track.
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Moving the Caret

If Snap is on, the caret will move at the current
Snap setting.

[CTRL]+arrow keys moves the caret +/- 20
milliseconds. [CTRL]+[SHIFT]+arrow keys move
the caret +/- 1 millisecond. Up/down arrow moves
the caret to a different track or lane.
Move Clip Without Changing
Time Offset

[SHIFT]+Drag

Resize Region While
Maintaining Initial Anchor
Point

[CTRL]+click near an edge of an existing region.
The region’s initial anchor point remains unaffected
as long as [CTRL] key is held.

Expand or Contract Region
Selection

[SHIFT]+click to expand or contract a selection to
the edge closest to the click point.

EDITING COMMANDS
Function

Keyboard Shortcut

Undo

[CTRL]+Z

Redo

[CTRL]+Y

Cut

[CTRL]+X

Copy

[CTRL]+C

Drag a Copy

[ALT]+drag

Drag Copy and Preserve Time
Offset

[SHIFT]+[ALT]+drag

Paste

[CTRL]+V

Delete

[DELETE]

Crop

[CTRL]+Q

Split

[CTRL]+T

Remove Spaces Between Clips

[CTRL]+J
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Merge To New Clip

[CTRL]+W

Trim Silence

[CTRL]+I

Add Marker at current Caret
position

[CTRL]+ / (slash key)

SNAP ADJUSTMENTS
Function

Keyboard Shortcut

Off

~

Grid

G

Measure

1

1/2 Notes

2

1/4 Notes

3

1/8 Notes

4

1/16 Notes

5

1/32 Notes

6

1/64 Notes

7

MIDI EDITING
Function

Keyboard Shortcut

Arrow Selection Tool

W

Eraser Tool

E

MIDI Reset/Panic

[CTRL]+[SHIFT]+M

Drag Copy

[ALT]+drag

Draw Selected Velocities Only

[SHIFT]+drag

Select Next Note

[TAB]

Select Previous Note

[SHIFT]+[TAB]

Select All Notes

[CTRL]+A

Unselect All Notes

[ESC]

Musical Typing Keyboard

[CTRL]+[ALT]+K

Move Note/Retain Offset

[SHIFT]+Drag
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SELECTING CLIPS
Function

Keyboard Shortcut

Select All

[CTRL]+A

Select All On Track

[CTRL]+[SHIFT]+A

Select All On Lane

[CTRL]+[SHIFT]+[ALT]+A

Select Next Clip

[TAB]

Select Previous Clip

[SHIFT]+[TAB]

Deselect All

[ESC]

Delete Selected Note(s)

[DELETE]

Drag Notes Vertical Only

[SHIFT]+ drag

TRACKS
Function

Keyboard Shortcut

Delete Track

[CTRL]+[SHIFT]+D

Add Audio Track

[CTRL]+G

Add Virtual Instrument Track
(MIDI)

[CTRL]+E

Arm Track Toggle

[CTRL]+B

Mute Track Toggle

[CTRL]+M

Unmute All Tracks

[CTRL]+click track Mute button

Solo Track Toggle

[CTRL]+L

Unsolo All Tracks

[CTRL]+click track Solo button

Move Track Down

[CTRL]+D

Move Track Up

[CTRL]+U

Freeze Track

[CTRL]+F

Add Lane

[ALT]+L

Delete Empty Lanes

[ALT]+K
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ZOOMING AND SCROLLING
Function

Keyboard Shortcut

Zoom To Project

0

Zoom In

-

Zoom Out

+

Scroll Up/Down

Mouse Wheel

Scroll Horizontal

[SHIFT]+Mouse Wheel

Scroll Vertical

[CTRL]+Mouse Wheel

Scroll Tracks Up

[PAGE UP]

Scroll Tracks Down

[PAGE DOWN]

MISCELLANEOUS
Function

Keyboard Shortcut

View/Hide Performance Panel

P

Add Sound File...

[CTRL]+H

Normalize Sound

[CTRL]+K

Adjust Volume Slider, Pan
Slider, EQ Knobs

[CTRL], [ALT] or [SHIFT] + click and drag

Reset MIDI Devices

[CTRL]+[ALT]+M

Print Virtual Instrument Clip

[CTRL]+P

Fade In Clip Fast

[ALT]+1

Fade Out Clip Fast

[ALT]+2

Fade In Clip Medium

[ALT]+3

Fade Out Clip Medium

[ALT]+4

Fade In Clip Slow

[ALT]+5

Fade Out Clip Slow

[ALT]+6

Boost Clip 1%

[ALT]+[CTRL]+Q

Reduce Clip 1%

[ALT]+[CTRL]+A
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Function

Keyboard Shortcut

Boost Clip 5%

[ALT]+[CTRL]+W

Reduce Clip 5%

[ALT]+[CTRL]+S

Boost Clip 25%

[ALT]+[CTRL]+E

Reduce Clip 25%

[ALT]+[CTRL]+D

Boost Clip 50%

[ALT]+[CTRL]+R

Reduce Clip 50%

[ALT]+[CTRL]+F
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CURSORS

ARROW

The default cursor.

ENVELOPE POINT EDIT

This cursor shows that an envelope point can be added or moved.

ERASER

This cursor shows that notes or controller data can be erased.

FLEXAUDIO™

By holding down the [CTRL] key and dragging, this allows visual time-stretching of
any audio clip.

I-BEAM

This cursor shows that a selection can be made on a sound.
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PENCIL

This cursor shows that new notes or controller data can be drawn.

PLAY SOUND

This cursor shows that a sound from the sound library can be played.

RESIZE INTERFACE

This cursor is shown when resizing the details area or resizing a track.

RESIZE OR LOOP SOUND

This cursor shows that a loop a sound can be resized from the left or right.

SCISSORS

Clips can be split by holding down the [CTRL]+[ALT] keys and clicking on the desired
split location - the cursor turns into the scissors icon while hovering over the clip. The
split occurs at the closest Snap setting increment. If you’d like to split a clip at the exact
cursor location, set the Snap setting to Off.

TRACK VOLUME

This cursor is used when changing the master volume or a track’s volume slider.
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FLAT TOOL

This cursor is used to lower a note or piano roll bar by one half step/semitone in
Notation View.

SHARP TOOL

This cursor is used to raise a note or piano roll bar by one half step/semitone in
Notation View. Always excercise caution when using a sharp tool.
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TROUBLESHOOTING
Here are some answers to common problems and issues. If you can’t find a solution in
this section, you’ll find numerous support options online at:
www.acoustica.com/product_support/


Playing



Recording



Files Not Loading



Effects & Plug-ins



CD Burning



Video



Loop Library



Control Surfaces

PLAYING AUDIO
SOUND DOES NOT PLAY

You’ve added sounds, but you can’t play anything... Here are a few things to check.


Are the speakers on and plugged in? (Sorry, management made us ask.)

Can you play a Wave file through Windows or another sound application? If you
can’t, there may be a problem with the sound card’s configuration or drivers. Refer to
your sound card documentation to track down the problem.


Load the volume control that came with your sound card and make sure that the
Wave device is turned up and not muted.


Another program may be using the sound card at the same time. (May happen with
older versions of Windows.)


Update or install your sound card’s drivers. Check the manufacturer’s website for
the latest drivers and documentation.


SOUND IS BREAKING UP, POPPING, OR CLICKING

When playing back a project, if the audio sounds like it is starting and stopping
quickly, it could be because the computer is over tasked due to other programs running
at the same time. Your computer may not be powerful enough to mix the audio in your
project. Here are some things to try:
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Always shut down as many unnecessary programs as possible. It may even be
advantageous to temporarily shut down virus software. (We don’t recommend doing
this unless you’ve done a full scan and are not connected to the Internet.)
Increase the audio device latency setting. (Go to the Preferences>Sound Device in the
Main Window menus.)
Freeze a track if there are many effects or compressed audio formats on the track.
(Frozen tracks use far less CPU resources.)
Turn off some display features. Go to the Preferences>Display and try limiting the frame
rate or not drawing audio and MIDI data. Turning off logging may also help.
Make sure that you have the latest drivers for your sound card. Visit your sound card
manufacturer’s website to check for updates.
Note the CPU meter in the lower right corner of Mixcraft; this indicates how much
CPU Mixcraft is using compared to the entire computer’s entire CPU usage.
Driver Type

Action

WaveRT

Go to the WaveRT preferences. Increase the latency time.

ASIO

Go to the ASIO preferences. Try a different ASIO driver,
download the latest ASIO driver or increase the latency
setting.

Wave

Go to the Wave preferences. Increase buffer size and/or
the number of buffers

SOUND IS DELAYED OR LAGGING (LATENCY)

The opposite of sound breaking up or gapping is an audible delay of sound playback
and/or latency from the time an edit is made to the time you hear it. For example, a
change is made to an envelope point during audio playback. If it takes several seconds
to hear the effect of the change, you’re experiencing latency. The solution depends on
the type of audio drivers being used.
Driver Type

Action

WaveRT

Choose a lower latency time.

ASIO

Go to the ASIO preferences and click the Open Mixer...
button. Use the ASIO driver control to configure the
latency. There will usually be a latency setting, displayed
in milliseconds. If possible, choose 10 milliseconds. 4080 milliseconds is also tolerable.
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Wave

Go to the Wave preferences. Reduce the number of
buffers and/or size. Try different settings to find a balance
between performance and smooth non-gapping audio.

Did we mention to make sure you have the latest drivers for your sound card? Of
course we did. Visit your sound card manufacturer’s website to check for updates.
NOTES WON’T STOP PLAYING!

Hey, this sounds like most of the lead guitarists we know. If you’re playing back Virtual
Instrument Clips and notes continue to play after stopping, this is referred to to as
“stuck” notes.
The solution is to click Mix>MIDI Reset! from the Main Window menus. This should
stop all Virtual Instrument stuck notes.
If this does not stop the notes, try saving your project and restarting Mixcraft. If
the stuck notes are coming from an external hardware synthesizer, try resetting or
restarting the external synthesizer.
If none of this works, beat your computer into oblivion with a twenty-pound
sledgehammer ‘til the racket ceases. (incidentally, this works for lead guitarists too)
ASIO IS NOT AVAILABLE

Make sure you’ve installed the latest drivers for your sound card. Go to the sound
device’s manufacturer website to download and install them.
SOUND PLAYS BACK TO SLOW OR FAST

If loaded sounds play back too fast or too slow, it’s most likely because the sound
is being tempo adjusted by Mixcraft. You can check this by clicking on the sound,
clicking the Sound tab, and clicking Time Stretch to hear the sound at its native tempo.
(Audio can sound odd if it’s being time stretched too drastically.)
RECORDING
RECORDING IS NOT WORKING!

You can play audio, but you can’t record anything! There can be many reasons why this
is not working. Here are a few:


Make sure audio hardware/microphone/guitar is properly plugged in!



Make sure the correct input/source is armed.



Make sure the recording level of the armed track is turned up.



Try recording using a different driver. Try ASIO, WaveRT, and Wave, in that order.

Make sure you have the latest drivers for your sound card. Visit your sound card
manufacturer’s website to check for updates.
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RECORDINGS DRIFTING AND/OR START AT THE WRONG TIME

If you notice that recordings are not lining up properly at the start, you’ll need to adjust
the offset or start time of the recorded sound. Make sure Snap is off and move the
sound so that it lines up properly. Zoom in for the best accuracy. Switching to an ASIO
driver or purchasing a better sound device may help.
If recordings are slowly drifting over time, the problem is due to an inaccurate clock
on your sound card or sound device. Each device is made with more or less accurate
clocks and not all devices have the same time as an atomic clock, for example.
If you have a Soundblaster LIVE, try recording in 48 kHz mode, by switching your
Sound Device preferences to the 48 kHz sample rate.
 Drift Work Around

		 Assuming the start of the sound is lined up properly, go to the end of the sound
		 and visually time stretch it with FlexAudio using the [CTRL] key so that it lines
		 up properly. Make sure to change the pitch shift mode to Do Not Fix Pitch.
		 Once you’ve lined up the end of the recording, you should be able to go to
		the Sound tab to view the time stretch percentage that was needed to get it in
		 sync. (Example percentages will be around 99.995% or 100.004%). Following
		 this, you can simply apply this drift percentage to all recordings. (Don’t forget to
		 change the pitch shift mode to Do Not Fix Pitch!)
If you’re constantly seeing Vin Diesel and Paul Walker spinning around in cars like
maniacs in Japan, this probably means you’re watching The Fast and The Furious:
Tokyo Drift.
RECORDINGS ARE NOT IN SYNC

There are a couple of possibilities:


Starting positions of recordings are wrong.
If the start offset of the recording is wrong, try the following:


Adjust the clips positions manually.



Update your sound card’s drivers if possible. Check the sound card 		
manufacturer’s website.

		


		

Get a more professional sound card designed for recording music, if possible.Try
switching to ASIO mode. or WaveRT mode for better synchronization.

 Recordings slowly losing synchronization over time.

If after 10 minutes or so, recordings are noticeably out of synchronization, you may
need to get a new sound device that won’t lose synchronization.
Always make sure that you have the latest drivers for your sound device. Visit your
sound device manufacturer’s website to see if there is an update. Pretty sure that’s
the seventh time we’ve said that... but it really makes a difference!
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I CAN’T HEAR MYSELF DURING RECORDING!

Some sound cards or USB devices have no provision for monitoring live recording. If
you can’t hear yourself or whatever you’re recording, you can use Mixcraft to play the
incoming audio by monitoring the track (by pressing the speaker icon when a track is
armed for recording). Always use headphones when monitoring to prevent audio bleed
from other tracks.
NEW TRACKS ARE RECORDING SOUND FROM OTHER TRACKS (BLEEDING OVER)

If newly recorded tracks are picking up parts of other tracks, your microphone or input
device is probably picking up the sound from your speakers.
Try using headphones- don’t forget to turn off your speakers. If the “full immersion” of
headphones is adversely affecting your pitch when singing, try pulling one side off your
ear. (added plus: you’ll look super cool like Kenny Loggins and Michael McDonald
during vocal tracking.)
If that doesn’t work, your sound device may have noisy circuitry. Go to the Windows
mixer recording settings and make sure that only the devices you are interested in
recording are heard. Mute any sources that are not being recorded (such as the CD
player or auxiliary). To open the sound card’s mixer click the Windows Start button,
and click Run... Type in sndvol or sndvol32 and press the ENTER key.
Also, make sure you’ve selected the correct recording source. If possible, it’s best
to choose a specific source, instead of something general like Stereo Mix, What You
Hear, or Digital Wave. For example, if the recording source is a microphone, choose
Microphone. If recording from your computer’s Line In input, choose that.
To choose a recording source, click on the small down arrow to the right of the Arm
button on the recording track. First, choose the sound device you want to use (you
may only have one choice), and you’ll see a submenu with a stereo source option.
Again, if you already have a specific source selected, your microphone could be picking
up the sound from your speakers. Try turning off your speakers and using headphones
to monitor the audio.
MY RECORDINGS ARE ONLY ON THE LEFT OR RIGHT CHANNEL!

This occurs when a mono input is plugged in to the left or right input of an audio
device, but you’ve selected stereo recording. To remedy this, be sure to arm a track for
the specific input you’d like to record from, either by input number, or by the channel
(left or right). If you wish to preserve stereo recordings, right-click on the clip, select
Properties>Channels, and select either the Left or Right channel. This will play only one
channel of a stereo recording.
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MY RECORDINGS ARE TOO LOUD AND ARE DISTORTING! WHAT DO I DO?

Distortion can ruin a good recording, and the worst part is, once distorted audio is
recorded, there’s no way to remove distortion. If the input signal is illuminating the
meters all the way and the peak indicators are lit, your incoming signal is too loud.
And if it’s too loud, you’re too old… ok, maybe that doesn’t apply here.
If you’re using Wave or WaveRT drivers and the track is armed, there should be a red
input level slider available on your track. You can use this to attenuate the input level
until the input source is no longer driving the meters into the red.
If you’re using an ASIO device or other external audio device, you won’t see an input
level slider on armed tracks (this inherent to ASIO audio devices, not Mixcraft). You’ll
need to lower the output level of the hardware preamp or audio device to reduce the
level being sent to Mixcraft.
FILES NOT LOADING
SOUND WON’T LOAD

There are many different types of sound file formats. Mixcraft currently supports Wave
(.WAV and .AIF), MP3, OGG, and WMA formats.
In addition, Mixcraft works with the Windows Audio Compression Manager (ACM) to
load compressed non-PCM Wave files.
If the audio file is a WMA file, make sure that WMA format support is installed and
that the file does not have Digital Rights Management (DRM) on it. The preceding
paragraphs might’ve set a record for acronyms... sorry about that.
WMA FILE SUPPORT

In order to load and save to WMA files, you must have support for Microsoft Windows
Media Format 7.1. If you are trying to load a WMA file or export to a WMA file and the
option is grayed out, you probably do not have this installed. To download and install
it, please visit http://www.acoustica.com/plug-ins/wma-install.htm. (It isn’t necessary to
restart your computer.)
If you’ve already installed WMA support, you may be trying to open a WMA with
Digital Rights Management (DRM). If the WMA file was created with Windows Media
Player, try recreating it with DRM disabled. To turn off DRM, run Windows Media
Player, choose Options from the Tool menu, click on Copy Music and ensure that Copy
Protect Music is unchecked.
CAN’T LOAD OR SEE VIDEO FILE

To load a video, select Video>Add Video File... from the Main Window menu. Navigate
to the folder containing the video.
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If the video is not in .AVI or .WMV format, you’ll need to switch the File Type dropdown from Default Video Files to All Files. Your video file should now be visible. Select
it to load it.
Proper video codecs may need to be installed in order to load a given video. See Video
Is Not Loading for more information.
If you’re still not seeing video, check to make sure your eyes are open, as closed eyelids
commonly cause video to be unviewable.
VIDEO IS NOT LOADING

If the video fails to load, it’s likely because you’re missing the correct DirectX video
codec. Do one of the following:
Install the software included with your video camera (or download the most current
version from the manufacturer’s website). It may also have come with a DirectX video
decoder that would allow other programs such as Windows Movie Maker or Windows
Media Player to play the files. (Assuming the file was created with a video camera that
you own.) Restart your computer after installing new video codecs.
Download and install a video file converter application to convert the video to AVI or
WMV. This is better than loading the original video format, as it will be faster.
Install a DirectX/DirectShow video codec for the video format you’re attempting to
load. Beware of many faulty/buggy/error prone decoders out there on the Internet! And
make sure to download and install the latest version of Windows Media Player.
EFFECTS AND PLUG-INS
HOW DO I ADD A PLUG-IN (VST OR VSTI)?

Mixcraft allows you to add your own VST or VSTi plug-ins. Plug-ins are usually .DLL
files. Download and install the plug-in file (.DLL) into your VST folder and restart
Mixcraft. The new VST plug-in should now be in the effect drop-down list or Virtual
Instrument list. Some plug-ins include their own installers. In that case, run the
installer and point the software to the appropriate folder.
If you don’t know where your VST folder is, you can create a new one and add it in the
Plug-Ins section. To add your own VST folder, go to Preferences>Plug-Ins in the Main
Window menus and click Edit VST/VSTi Folders. Click the Add button to add your
own folder, or click Auto-Scan For VST/VSTi Directories to locate one automatically.
Make sure to put the new VST plug-in (.DLL) into one of the folders in your VST folder
list and restart Mixcraft. The effect should appear in the effect drop-down or Virtual
Instrument lists, depending on the type of plug-in.
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HOW CAN I PREVENT CERTAIN PLUG-INS FROM LOADING?

Mixcraft has two files which may be edited to exclude plug-ins from loading. These
files are located in the %programdata%\Acoustica\Mixcraft\ folder.
VSTIgnore.ini - VST plug-in ignore list
Open or double-click the file, add the name of the effect, and set it to equal = 1.
For example, if you had an effect you didn’t want to load called “Digital Media
StudioDenoiser”, you would enter:
Digital Media StudioDenoiser=1
Save the ignore file, restart Mixcraft, and the effect will not be loaded. For VST plugins, you will need to use the name of the dll such as SuperDuperReverb.dll=1
HOW CAN I HEAR EFFECTS DURING RECORDING?

Some sound cards or USB devices have provisions for monitoring recording inputs
independently of Mixcraft. But if you’d like to hear the effects during recording, you’ll
need to disable the sound device’s monitoring and use Mixcraft’s monitoring system.
For example, if you are making a weird recording of your voice and would like to hear
the echo or delay while recording, you’ll need to turn on monitoring. You’ll need to
enable Mixcraft’s monitoring and disable any sound card’s built in monitoring.
CAN I USE 64 BIT PLUG-INS?

Yessirree you can, provided you’ve installed the 64-bit version of Mixcraft and are using
a 64-bit version of Windows.
The Mixcraft installer will install the 64-bit version on computers with 64-bit
Windows, and the 32-bit version on machines with a 32-bit version of Windows. You
can install both the 32-bit and 64-bit versions on a 64-bit computer, if desired.
If you don’t have a 64-bit version of Windows, or if you’re primarily using 32-bit
plugins, we recommend installing the 32-bit version as it will run faster. (Running 32bit plugins in 64-bit Mixcraft adds overhead and can be slower.)
CAN I USE 32-BIT PLUG-INS WITH THE 64-BIT VERSION OF MIXCRAFT?

Yes! Mixcraft allows 32- and 64-bit plug-ins to run simultaneously when using the 64bit Mixcraft version.
WILL 64-BIT PLUG-INS HAVE BETTER SOUND FIDELITY?

Actually, no. The primary advantage of running in 64-bit mode is that Mixcraft
(and other apps) are able to address more RAM. This is useful when using Virtual
Instruments that require large amounts of sample RAM (like that European megaorchestra you spent a week loading from 73 DVD’s).
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CDBURNING
Burning Engine
CD

Primo

Details

The default and preferred burning engine. Burns
on-the-fly, CD-Text, and supports gapless tracks.

MY CD/DVD RECORDER IS NOT SUPPORTED!

IMAPI supports two burning
Theengines:
drawback
to IMAPI
is that it adds two-second gaps
Mixcraft
Primo
and IMAPI.
between tracks.
I’M GETTING BURN FAILURES

Here are some suggestions if CD’s fail to burn properly:


Try a burn in Test Mode first.



Try a different blank CD (Make sure it’s not full or scratched).



Try a blank CD from a different manufacturer.



Shut down other programs and temporarily shut down your virus checker during a
burn. (Shutting down virus checker software should be done at your own risk.
Make sure you‘re not connected to the Internet and have recently done a full virus
scan.)



Try burning at a slower speed, especially if your CD recorder does not support
“Burn Proof” mode.



Try checking the option Convert To WAV First.



If you have more than one CD or DVD recorder, try burning with the other.



If you’re using Windows XP or Vista, try switching to IMAPI.



Try switching to a different burning engine.



Try burning a short sound just to verify that the CD recorder can burn and is not
defective.



Try burning with another program such as Windows Media Player to verify that
your CD recorder is not defective or having a system conflict.

GET RID OF THE TWO-SECOND GAP BETWEEN TRACKS

By default, audio CD’s burned in Primo mode will not have a two-second gap between
tracks. If burning in IMAPI mode, there will be a two-second gap between tracks.
There are two options:
• Click the Burn As One Track checkbox in the Burn CD window. The disadvantage is
that you’ll have to fast forward or rewind the CD to get to a specific part.
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Mix the project down to WAV files and then use a third-party burning program
that supports the CD- or DVD-burner. In the Mix Down dialog, make sure the
Create A New File For Each CD Marker option is selected. We recommend using
WAV files at CD quality for the mix down. Import the WAV files into the third-party
CD burning software, arrange them in the correct order and burn the CD.

BURNED CD WON’T PLAY IN MY CD PLAYER

Here are a few things to try:


Make sure that you actually burned the CD! Look at the back of the CD under a
light and look for differences between the burned area and blank section.



Make sure that there aren’t any scratches or smudges on the CD data surface.



Try a different burning engine. Primo is the latest and newest engine. Change the
engine in the CD Burning preferences.



Try burning using a blank CD from a different manufacturer. See if there is a 		
recommended type of CD for your CD player



Try burning at a slower speed. Older CD players are not as tolerant and if you burn
at a slower speed, it will burn with higher precision. Also, some blank CDs are not
rated for higher speeds. Check the information on the blank CD packaging for burn
speed rating.



If there is a paper sticker label on the CD, it could be interfering with the weight
balance or it may not be spinning at the correct speed. Try a CD without a label.



Check to see if the CD plays in other CD players or computers. (CD drives in
computers typically are less finicky about playing burned CD’s properly than 		
dedicated consumer audio CD players.)

VIDEO
VIDEO PLAYBACK PROBLEMS

If after loading a video, Mixcraft does one of the following:


Crashes with an error window



Freezes and stops responding



Mixcraft’s CPU usage goes way up to above 60% or so.



Video frames appear distorted

If one of the above is happening, it could be the DirectX video decoder. The best
solution is to convert the video file to AVI or WMV format. AVI and WMV are
compatible with Mixcraft. AVI files use less CPU power, as well.
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Search the Internet for “video converter software” that will convert to AVI and/or WMV.
DIRECTX ERRORS OR ERRORS LOADING VIDEO

Mixcraft uses Window’s DirectX layer to decode video, so video playback will be
governed by the codecs installed on your computer. Codecs are little pieces of software
that programs can use to decode special video file formats. Many codecs are poorly
written and may not work properly for video editing. If you’re having these types of
issues, try the following:


Download the latest Microsoft Windows Media Player.



Install the software included with your video camera or download and install the
latest version from the manufacturer’s website. It may also have include a DirectX
video decoder allowing other programs such as Windows Movie Maker or Windows
Media Player to play the files. (If the file was created with a video camera that you
own.) Make sure to restart the computer after installing.



Download a video file converter that will convert movies to AVI or WMV format.
This is better than loading the original video format, as it will be faster.

VIDEO FILE IS TOO BIG

If you want to send a video via email or upload it, you may find the file size to be
far too large. Uploading or sending huge files is impractical and slow. Here are some
suggestions:


To send via email, upload the video to a video hosting site such as Youtube or
Vimeo and send people a link to the video instead of sending the actual video file.



Adjust the video settings to a lower quality prior to rendering/mixdown. Lower
quality videos result in smaller file sizes. See the “Video Tracks and Editing” section
for more information.

LOOP LIBRARY
CAN’T DOWNLOAD SOUNDS

If you can’t download sounds from the library, check the following:
Make sure you’re connected to the good ol’ Internet. Try launching an Internet
browser and going to a news article or website you haven’t previously viewed. (This
verifies that you aren’t viewing previously cached content.)




Verify that security software or an Internet firewall isn’t blocking Mixcraft’s access
to the Internet. It may be necessary to reconfigure firewall or security software to
allow Internet access for Mixcraft. (Check your security or firewall’s documentation
for assistance.)
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Change Mixcraft’s Internet download server in Preferences>Library>Loop Library
Download in the Main Window menus.

CAN I ADD MY OWN SOUNDS?

Heck yeah, you can! See “Adding Sounds To The Mixcraft Library.” Supported sound
formats include AIF, WAV, OGG, MP3 and WMA.
CONTROL SURFACES
MIXCRAFT DOESN’T RECOGNIZE MY CONTROLLER.

If the devices is a natively recognized control surfaces, make sure you’ve added it in
Preferences>Control Surfaces in the Main Window menus. Natively recognized control
surfaces include Mackie Control (or others supporting the Mackie Control format),
Novation Launchpad, Frontier Design Group TranzPort, and the Acoustica Mixcraft
Remote mobile app.
If you’re using a generic MIDI control surface, go to the Control Surface Details dialog
box in Mix>MIDI Control Surface in the Main Window menus and make sure the
device is selected, or set the Surfaces drop-down menu to Any for Mixcraft to receive
control surface messages from all connected controller devices. If your device is not
listed in the Device drop-down, check that it’s plugged in and that the necessary drivers
have been installed. You may need to close and re-open the Control Surface Details
dialog to display new devices.
MIXCRAFT RECOGNIZES SOME KNOBS OR BUTTONS ON MY CONTROLLER, BUT
WON’T RESPOND TO OTHER KNOBS OR BUTTONS.

Mixcraft’s controls can be set to respond to MIDI Continuous Controller (CC) message,
or specific notes on your keyboard. Some controllers only send MIDI Machine Control
(MMC) or other types of system-exclusive data that Mixcraft does not respond to - just
because it has a bunch of sliders and a MIDI jack, that doesn’t necessarily mean it
transmits MIDI CC messages. (We’re lookin’ at you, vintage 90s Roland JD-800.) With
that said, most newer MIDI or USB devices with a bunch of knobs/sliders/buttons
usually do transmit MIDI CC data. (Check your controller’s manual.)
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GLOSSARY
ASIO

AVI

ASIO provides an interface between
the audio application and sound card.
It’s an acronym for Audio Stream
Input/Output. It was developed by
Steinberg Media Technologies and
helps manufacturers and developers
to create hardware and driver software
extending the personal computer’s
audio connectivity to meet the needs
of musicians and audio engineers.
ASIO offers a relatively simple way of
accessing multiple audio inputs and
outputs. The Audio Stream I/O API
addresses the areas of efficient audio
processing, high data throughput,
synchronization, low latency and
extensibility on the audio hardware side.
The interface is not bound to any fixed
number of input and output channels,
and provides a constant streaming
model.

AVI (Audio Video Interleave) is a
Microsoft video file format standard
for storing audio and video on PCs.
AVI files can contain compressed or
uncompressed video and audio.

ASPI

Buffer Under-run

ASPI stands for Advanced SCSI
Programming interface and standardizes
communication between a SCSI host
adapter and CD drives, hard drives and
other devices. (Most people can think
of it as a special driver to communicate
with your CD writer.)

This is when the computer cannot
deliver data fast enough to a CD writer.

CD-Quality

Audio Clips

Clipboard

Audio clips represent audio files that can
be stretched, edited, looped and played
in Mixcraft. Audio clips will usually
be in OGG, WAV, MP3, WMA or AIFF
format.

BPM
Beats per minute. The usual
measurement of tempo in music. In
Mixcraft, BPM means quarter notes /
minute.

Burn Proof
Burn Proof is a proprietary technology
for buffer under-run protection
developed by Plextor. Other buffer
under-run avoidance technologies are
called Safe Burn, Power Burn and Just
Speed. Most new drives have a buffer
under-run protection technology.

CD-Quality is the standard quality
used on audio CDs. Its audio specs are
44,100 Hz sample rate, 16-bit, stereo.

The clipboard is a buffer of sounds
that can be stored and pasted later.
Clipboard operations involving sound is
limited to Mixcraft and it will not share
audio data with other programs unless
you add the audio file directly.
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DAO

General MIDI

DAO stands for Disc-At-Once. During
the CD burning process, the entire CD
is written continuously without the
write laser being turned off. This results
in seamless, uninterrupted audio with
‘seek-able’ tracks.

General MIDI or GM is a standardized
mapping of patch numbers to specific
instruments. For example, patch 0 is
always ‘Acoustica Piano’. Each GM
standard synthesizer will have patch
0 mapped to “Acoustica Piano”. More
details can be found on Wikipedia.

Decibel
The decibel (dB) is a logarithmic unit of
relative measurement used to compare
the ratio of the intensities of two signals.
When an amplitude doubles, the
increase corresponds to 6 dB.

IMAPI

Decoder

ISRC

An algorithm or process for taking
compressed or encrypted data and
turning it into uncompressed or
unencrypted data.

ISRC stands for International Standard
Recording Code. If your intention is
to burn an audio CD for commercial
use, you will need to enter in your ISRC
codes for each track.

DRM
DRM stands for Digital Rights
Management. DRM provides a security
layer on software, audio or any type of
media to help ensure proper licensing
and use of the content. DRM on audio
files is constantly evolving and the “jury
is still out” as to whether it is effective.

Effects Chain
A group of multiple effects processing
audio, arranged in series (i.e., one after
the other). Audio is sent down the effect
chain list from top to bottom and the
final result is heard on your speakers.

IMAPI is the built in burning system
found in Windows. IMAPI stands
for Image Mastering Application
Programming Interface.

Key Signature
The key identifies the tonic triad, the
chord, major or minor, which represents
the final point of rest for a piece, or the
focal point of a section.

Latency
Latency is a delay between the time
something occurs and the time that you
sense the occurrence. In audio software,
this might be the difference from the
time audio is mixed and processed to
the time you hear it.

Encoder
An algorithm or process for taking
uncompressed data and turning it into
compressed or encrypted data.
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Megabyte

Multitrack

A megabyte is approximately one
million bytes ( 1024 X 1024 bytes ). A
typical hard drive stores around 40 GB
(gigabytes). A gigabyte is equivalent to
a billion bytes or 1024 X 1024 X 1024
bytes.

Multitrack recording (“multitracking”
or just “tracking” for short) is a method
of sound recording that allows separate
recording of multiple sound sources to
create a cohesive whole.

Metronome

Normalize

A metronome is a device or system that
produces a regulated pulse, usually
used to keep a beat steady in musical
compositions.

The process of raising the volume so
that the biggest volume in the sound is
increased to the maximum possible and
the rest of the sound is raised in volume
by the same percentage.

MIDI

OGG

MIDI is an acronym for Musical
Instrument Digital Interface. It is
the way that physical and virtual
synthesizers communicate with each
other. For example, when you press
middle C on your musical keyboard, it
sends a message says “Play Middle C”. It
is a small and compact series of codes.

Ogg is a patent-free, fully open,
and standardized multimedia bit
stream container format designed for
efficient streaming and manipulation
(concatenation and muxing) by the
Xiph.Org Foundation.

MP3
MPEG-1 Audio Layer 3, more
commonly referred to as MP3, is a
popular digital audio encoding, lossy
compression format, and algorithm,
designed to greatly reduce the amount
of data required to represent audio, yet
still sound like a faithful reproduction of
the original uncompressed audio to most
listeners.
option to upgrade to the full version of
Mixcraft allowing CD burning, MP3 file
creation, and unlimited tracks.

Overdub
Overdubbing (the process of making an
overdub, or overdubs) is a technique
used by recording studios to add a
supplementary recorded sound to a
previously recorded performance.

Pan
The balance or ratio between the left and
right speakers (channels).

Peaks
A visual display of a sound’s amplitude
over time. (Mixcraft displays one peak
per millisecond.)
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PCM

Semitone

Pulse-code modulation (PCM) is a
digital representation of an analog signal
where the magnitude of the signal is
sampled regularly at uniform intervals,
then quantized to a series of symbols in
a digital (usually binary) code. PCM has
been used in digital telephone systems
and is also the standard form for digital
audio in computers and the compact
disc red book format.

A semitone, or half-step is a musical
interval. It is the smallest interval
commonly used in Western music, and
is considered the most dissonant.

Primo

Tag

Primo is a CD burning engine created by
Primo Software. It is the default burning
engine.

A tag is extra ancillary information
stored inside of an audio file, which
includes things like artist, album, genre
and copyright.

Sample Bit Depth
In digital audio, bit depth describes
the amount of data contained in each
sample, using the unit bits (not to
be confused with bytes). Common
examples of bit depth include CD audio,
which is recorded at 16 bits, and DVDAudio which can support up to 24-bit
audio.

Sample Channels

Standard MIDI File
This is a standard file format that stores
multiple tracks of MIDI data. Most MIDI
software will read standard MIDI files
(.MID)

TAO
Track-At-Once or TAO is a recording
mode where the recording laser stops
after each track is finished and two runout blocks are written. One link block
and four run-in blocks are written when
the next track is recorded. TAO discs
can have both data and audio at the
same time.

Sample channels describes the number
of channels contained in each audio
sample. For example, CD audio has two
channels in each sample.

Tempo

Sample Rate

Time Signature

The sampling rate, sample rate, or
sampling frequency defines the number
of samples per second (or per other
unit) taken from a continuous signal to
make a discrete signal. For time-domain
signals, it can be measured in hertz (Hz).

The time signature (also known as
“meter signature”) is a notational
convention used in Western musical
notation to specify how many beats
are in each bar and what note value
constitutes one beat.

In musical terminology, tempo (Italian
for “time”, from Latin Tempus) is the
speed or pace of a given piece.
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Time Stretch

Waveform

Time stretching is the process of
changing the speed or duration of an
audio signal without affecting its pitch.

Waveform means the shape and form of
a signal, such as a wave moving across
the surface of water, or the vibration of a
plucked string.

Virtual Instrument Clips
A Virtual Instrument Clip contains
MIDI data which is a series of notes and
other events. To produce actual audio,
it sends the note data to the synthesizer
configured on a Virtual Instrument
Track.

Virtual Instrument Track
A Virtual Instrument Track is a track
that has a Virtual Instrument or external
synthesizer which it sends MIDI
information to.

Volume
The amplitude of sound. The minimum
is 0% and the maximum is 200%

VST Effects
Virtual Studio Technology and its
acronym VST refer to an interface
standard for connecting audio
synthesizer and effect plug ins to
audio editors and hard-disk recording
systems. VST and similar technologies
allow the replacement of traditional
recording studio hardware with software
counterparts.

WAV

WaveRT
This is the new low latency, high
performance audio driver system on
Windows Vista. It stands for Wave Real
Time.

WDM
WDM stands for Windows Driver
Model.

WMA
WMA stands for Windows Media Audio.
WMA files contain perceptually encoded
sound data.
The frequencies that humans cannot
perceive are removed, although some
audio purists say they can tell the
difference between a high bit-rate WMA
and a Wave file. A WMA file can be
as much as 20 times smaller than an
equivalent WAV file.

WMV
WMV (Windows Media Video) is a
Microsoft video file format for storing
and streaming audio and video on PCs.
WMV files contain compressed video
and audio.

WAV (or WAVE), short for Waveform
Audio Format, is a Microsoft and IBM
audio file format standard for storing
audio on PCs.
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APPENDIX 1:
USING MELODYNE FOR BASIC
VOCAL TUNING
MELODYNE, MEET MIXCRAFT – AN INTRODUCTION
Not only is Celemony’s awesome Melodyne tuning software included with Mixcraft Pro
Studio 8 (see the sidebar), but we’ve taken it one step further: instead of operating as
a standard VST plug-in, Melodyne functionality is integrated into the clip sound edit
window. This makes using it really easy (because that’s how we roll at Acoustica!).
When using the standard Melodyne plug-in version, it’s first necessary to transfer audio
into Melodyne in real-time (essentially playing back the audio material so Melodyne
can “record” it for editing), but Mixcraft 8’s built-in Melodyne architecture eliminates
this step for a much smoother workflow.
Note that the standard VST plug-in version of Melodyne Essential is included with
Mixcraft 8. This is primarily for folks who already have songs using the original plugin version, but under just about any other circumstance, using Mixcraft’s built-in
Melodyne functionality is the best choice.
WHAT DOES MELODYNE DO? IS IT HARD TO USE?

Melodyne might look a little intimidating when you first open it, but rest assured, basic
(and great-sounding) vocal tuning is easily accomplished. Before we get to the exciting
“do this, then do that…” section, it’s important to understand the underlying concept
of Melodyne.
Most vocal tuning plug-ins correct pitch in real-time, modifying the audio as it
plays back; in fact, this is how most VST effects plug-ins work. Melodyne operates
differently; audio material is loaded into Melodyne and analyzed prior to playback.
Mixcraft takes care of this task transparently and automatically when audio is selected
for editing. Once analyzed, Melodyne places the notes on a grid similar to Mixcraft’s
piano roll edit window. From here, you can freely move note “blobs” up or down to
change their pitch, left or right to move them in time, or even stretch or compress
individual notes. This offers amazing freedom not only for pitch and timing correction,
but also for creatively modifying and re-tooling performances.
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An Offer You Can’t
Refuse!
If you’re using the
standard version of
Mixcraft, it’s worth it
to upgrade to Mixcraft
Pro Studio 8 for the
addition Melodyne
alone. Upgrading from
standard Mixcraft to
Pro Studio is actually
less expensive than
buying Melodyne
Essential, AND you get
a metric ton of killler
instruments and effects.
Operators are standing
by! (get more info on
upgrading at www.
acoustica.com)

HOW TO TUNE A VOCAL TRACK, LICKETY–SPLIT
For this example we’ll assume you’ve already recorded a vocal take. In the basic project
shown below is a drum loop, a bass line, and lead vocal:

If the vocal track contains multiple clips, it’s helpful to merge the clips together into
one. You can do this by selecting all clips on the track then right-clicking and selecting
Merge. Now double-click the vocal clip to open it in the Sound editor, and click the
Melodyne button.

If you’re opening Melodyne for the first time, you’ll see a window linking to Celemony’s
First Steps instructional videos (feel free to check those out; there’s a wealth of
Melodyne info on Celemony’s website), but for now, click the Close button to skip it.
To disable this window popping up, uncheck the Show this window when Melodyne
starts check box.
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Super–duper note that will save you from emailing Acoustica tech support:
If the Close button isn’t visible at the bottom of the window, position the mouse cursor
just beneath Mixcraft’s transport controls, then click-drag vertically to increase the
height of the Sound edit window to reveal the Close button. (The cursor will change to
up/down arrows when it’s in the correct position.) It’s generally a good idea to open the
Sound edit area to a relatively large vertical size to simplify working with Melodyne.

If you know what key the song is in, now is a good time to set the key signature in
Melodyne. Remember that there is no correlation between Mixcraft’s project key setting
(the one you set in the transport section) and Melodyne’s key signature setting, so you’’
need to set the key in both places.
Being by making sure that Melodyne is set to Edit mode; that’s the icon that looks like
two little note blobs.

Now select the key signature by clicking on the list beneath Scale. More than likely
you’ll be looking at something like the image below where text is tiny and hard to read.
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This is easily remedied by selecting the magnifying glass tool from the Melodyne
toolbar and click-dragging vertically in Melodyne’s edit grid to increase its height. This
will make the key signature text larger and easier to read.

Now that we can easily read the key signatures, click the appropriate key to select it.
(See the sidebar Key Party!) If you’re not sure what key the melody is in (or the key is
frequently changing), you can leave the key signature setting as is.
Now we’re ready for Melodyne to do its magic. Click the Correct Pitch Macro button in
Melodyne’s top toolbar. It looks like this:

This opens up the Correct Pitch Macro window:

If you’ve set a key signature, check the Snap to <key here> checkbox to insure that
Melodyne snaps notes to that key and scale. If this box is left unchecked, Melodyne
will snap notes to chromatic half steps. If the vocalist is relatively on pitch, this usually
works fine; if they’re a little squirrely, you may need to move notes around on the grid,
but that’s fun and easy (we’ll get to that).
The Pitch Center slider moves notes up or down toward the next closest quantization
step - either the next closest note in the Snap to key setting, or the next closest half–
step if the Snap to box is left unchecked. The higher the Pitch Center percentage
setting, the closer the note “blobs” will move toward the target scale pitch - think of
Pitch Center as general tuning strength control.
The Pitch Drift slider affects fluctuations that happen during a single note’s duration.
A good example of this would be when a long, held note begins to go flat over time.
The higher the Pitch Drift percentage setting, the more Melodyne will “reel in” these
fluctuations and hold notes to correct pitch.
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Key Party!
When setting key
signatures, remember
that oftentimes a major
or minor melody line
will contain one or two
notes “outside” of the
standard major (aka
Ionian) or minor (aka
Aeolian) scale. Unless
you’re getting down
with some angular
Balinese or Hungarian
jams, more times
than not, the correct
melodic scale will be
the aforementioned
standard Ionian major
or Aeolian minor
but beginning on a
different note than the
key of the song. This
is the basic concept
behind scale modes. In
case you spent Music
Theory 101 rocking out
with Sammy Hagar on
your Walkman, you can
bypass all that smarty–
pants theory stuff and
determine the correct
scale notes by playing
all of the pitches of the
song’s melody on a
keyboard, and seeing
which standard major
or minor key scale
pattern the melody
notes “fit” into. Use this
key to set Melodyne’s
correction.

You’ll be able to see the note blobs and pitch line move as you slide the Pitch Center
and Pitch Drift sliders. Once you’ve got them set, click the OK button and you’re done.
You can listen to the results by hitting the play button in Mixcraft, or you can start and
stop playback of the soloed vocal within Melodyne by clicking in Melodyne’s ruler area.

CHANGING PITCHES OF INDIVIDUAL NOTES

You don’t have to tune all the notes in a clip simultaneously. You can highlight an
individual note or multiple notes for tuning either by dragging a box around note
blobs, shift-clicking to select sequential notes, or control-clicking to select nonsequential notes (or any combination thereof).
Occasionally Melodyne’s pitch detection algorithm will incorrectly detect note pitches,
causing it to correct to the wrong pitch. You can fix this by simply grabbing the
offending note blob and moving it up or down the grid to the correct pitch. First select
the Arrow Tool (aka the Main Tool, aka that pointer thingee).

Before you start moving note blobs, you’ll want to check the Pitch Grid setting. Click
Options>Pitch Grid. You’ll have three choices:

 No Snap

This allows notes to freely slide to any pitch. This can be useful for fixing up 		
oddball notes that aren’t sitting right, but it’s easy to get in trouble with No Snap.
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 Chromatic Snap

Notes move up or down in half step increments but maintain their “fine” position.
In other words, if the note has already been tuned, it will stay correctly tuned
relative to the scale when moved to a different note.
 Scale Snap

Notes move up or down in accord with the selected scale and key signature settings.
It should be easy to see how creating “customized” melodies is as simple as moving
MIDI notes around in Mixcraft’s Piano Roll edit window. You can even duplicate the
clip in the Mixcraft workspace, then move the notes in the secondary clip to create
harmonies. Things will start sounding funny if notes are moved too far away from the
original pitches, but hey, it worked for Art Of Noise and they had positively archaic
technology compared to the awesome sauce that is Mixcraft and Melodyne!
 Remove Melodyne

Clicking this removes all edits made with Melodyne, shuts off Melodyne for the
clip and switches the Sound tab editor back to the default wave editor.		

SOME CLOSING ADVICE ABOUR PITCH CORRECTION
Unless the performance is really amiss (we like to use the term “bad”), try to avoid
automatically cranking the Pitch Center and Pitch Drift sliders up to 100% in order to
maintain some human performance aspect. The best pitch correction happens when
you can’t tell it was used. At least we think so, but we don’t bu-leev in life after love,
after love, after love….
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APPENDIX 2:
BACKING UP MIXCRAFT
PROJECTS AND DATA
Since things are known to occasionally go horribly awry in the land of computer hard
drive storage, it’s prudent to back up your Mixcraft projects and their associated data.
Here we’ll detail how to archive projects so that you’ll have one less thing to worry
about should your computer spew flames.
FILES SAVED IN MY “DOCUMENTS: MIXCRAFT PROJECTS”

By default, Mixcraft projects save to the My Documents\Mixcraft Projects directory,
however, you can choose different folders anytime a project is saved. See the Saving A
Project (page 166) for more details.
FILES SAVED IN “APPDATA\ROAMING\ACOUSTICA\MIXCRAFT”

Mixcraft stores a variety of data in C:\users\[your user name]\AppData\Roaming\
Acoustica\Mixcraft, and we recommend backing up this entire folder regularly. Here’s a
breakdown of the data Mixcraft stores here:
AppData\Roaming\Acoustica\Mixcraft\collections: plug-in collections
AppData\Roaming\Acoustica\Mixcraft\favorites: instrument preset and VSTi preset
favorites
AppData\Roaming\Acoustica\Mixcraft\FX: user-created VST presets
AppData\Roaming\Acoustica\MixcraftIcons: user-created instrument preset icons
AppData\Roaming\Acoustica\Mixcraft\InstPresets: user-created instrument presets
If you’re copying a Mixcraft setup to a new computer and you copy collections,
favorites, or other presets that use non-Acoustica plug-ins, you’ll have to install those
plug-ins on the new computer. Mixcraft identifies plug-ins via VST unique IDs rather
than install folders, so they don’t have to be installed in the same folders as your
current computer. That said, you’ll need to go to Preferences/Plug-ins to tell Mixcraft
which folders to search in order to properly locate VST and VSTi plug-ins.
FILES SAVED IN “C:\PROGRAMDATA\ACOUSTICA\MIXCRAFT”

Mixcraft stores downloaded library loops here, and though you can always download
them again, there’s a variety of other data here that you’ll want to back up:
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ProgramData\Acoustica\Mixcraft\auto-mapping: user-created MIDI mapping presets
ProgramData\Acoustica\Mixcraft\MetaPresets7: Acoustica preset and user-created effect
chains stored here
ProgramData\Acoustica\Mixcraft\UserLibrarySounds: user-imported library loops and
audio files. Note that if you didn’t check the Copy Sounds To Library Folder box when
the audio files were originally imported, the audio files will be in their original folders
and not in UserLibrarySounds. If you’re copying a Mixcraft setup to a new machine,
you’ll need to manually copy those files to the same folder locations on the new
computer (or reimport them).
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APPENDIX 3:
NIFTY USES FOR OUTPUT
BUS TRACKS
CREATE OUTPUT BUS TRACKS FOR SIMPLIFIED MIXING

In the image below, we’ve created five Output BusTracks created for combining all
drums, bass, guitars, keyboards, and vocals. All of the drum tracks are routed to the
Drums Output Bus Track, all vocal tracks are routed to the Vocals Output Bus Track
and so on. This effectively places our entire mix under just five faders, making it super
easy to control the mix.

In this example, the Output Bus tracks are all routed to the standard stereo master
outs; we’re not routing any of the audio to separate audio interface physical outs. Also
remember that each Output Bus Track can have its own EQ, effects, and automation.

382

CREATE HEADPHONE CUE OR MONITOR MIXES

When recording or performing live, musicians appreciate having their own custom
monitor mix. The keyboard player may want to hear the drums, keyboards, and some
vocals, but maybe they don’t want to hear the guitarist. Meanwhile, the drummer
only wants to hear bass and vocals. And the vocalist will, of course, only want to hear
themself, at eardrum-searing volume.
If your audio hardware is equipped with multiple outputs, you can create a custom
headphone mixes for each whiny baby, I mean, band member (you may need to route
the audio output to some kind of headphone amp device). Here’s how to do it:


Create a Send Track for each individual performer’s mix. In the image below, third
from the right is a Send Track named Key Headphones. You’ll see a corresponding
red knob in each of the mixer channels.



Next, create an Output Bus Track for each performer’s mix. In the image above,
that’s the blue Key Phones Mix track.



Click the Output button on the Key Headphones Send Track, and select the Key
Phones Mix Output Bus track. This routes the Send Track to the Output bus track.



Click the Output button on the Key Phones Mix Output Bus Track and choose the
audio hardware physical output you’d like to route to.

You’re all set now – the level of the Send knobs on each track can be used to create a
custom monitor mix for the keyboard player. Repeat the steps to create as many mixes
as needed.
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USE HARDWARE EFFECTS IN A MIX

Using a multi-out audio interface and a little crafty routing, Mixcraft lets you use
hardware effect units in mixes. In the example below, a Send Track has been created to
make use of a vintage tape delay. The Send Track has been routed to an Output Track,
set to an output on the audio interface (make sure and use a physical output other than
the main stereo outs). This allows an external hardware effect to behave the same as a
Send Track with an onboard plug-in effect. Here’s how to set it up:

Create a Send Track (Send 1– Space Echo in the above shot) and an Output Bus
Track (Ext FX Send above).




Set the Send Track Output flip menu to the Output Bus track you just created.



Set the Output Bus Track Output flip menu to one of the physical outputs of your
audio hardware (or a pair of outs if you’re using an effect unit with stereo inputs).



Plug the selected audio interface physical output into the input of the effect unit.



Plug the output(s) of the effect unit into one of the inputs of the audio interface.



Turn up the red Send knob of the mixer channel you’d like to hear the effect on. In
our case, it’s the Vocal channel. Set the effect unit’s input level appropriately.
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Create a new Audio Track, and set its record input to the same one you plugged
the output of the effect unit into. Click the track’s Arm button (you might want to
initially turn the volume down in case there’s any feedback goblins lurking).

If software monitoring is activated on the audio track (by clicking the speaker icon with
the track armed), the effect output will be heard alongside all other mix elements. It’s a
good idea to record the effected signal (preferably set to 100% wet). Once you’ve done
this, the effected signal can be mixed as desired and you won’t need to worry about
having it set up when playing back the project in the future.
One thing to keep in mind is when routing external effects in this manner is that audio
latency settings can affect the timing of the returned effect signal when using software
monitoring at higher latency settings. If you’re using a time–domain effect such as a
delay or reverb, it’s unlikely you’ll hear any noticeable lagging (just make sure the effect
unit is set to 100% wet). You’re more likely to hear “comb filter” or flange-y artifacts
with “real-time” insert effects such as EQ’s or compressors. The easy workaround is to
record the effected audio into Mixcraft, then scoot the resulting audio clip back a tiny
amount in order to make up for the return-trip delay (turn Snap off and zoom in as
close as possible).
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APPENDIX 4:
FREESOUND.ORG CREATIVE
COMMONS LICENSE TERMS
Following are the legal descriptions of the Freesong.org library sound licenses:
PUBLIC DOMAIN
The person who associated a work with this deed has dedicated the work to the public
domain by waiving all of his or her rights to the work worldwide under copyright law,
including all related and neighboring rights, to the extent allowed by law. You can copy,
modify, distribute and perform the work, even for commercial purposes, all without
asking permission.
ATTRIBUTION
You are free to:
Share – copy and redistribute the material in any medium or formatAdapt –remix,
transform, and build upon the material for any purpose, even commercially.
The licensor cannot revoke these freedoms as long as you follow the license terms.
Under the following terms:
Attribution – You must give appropriate credit, provide a link to the license (https://
creativecommons.org/licenses/by/3.0/), and indicate if changes were made. You may
do so in any reasonable manner, but not in any way that suggests the licensor endorses
you or your use.
No additional restrictions – You may not apply legal terms or technological measures
that legally restrict others from doing anything the license permits.
ATTRIBUTION NON-COMMERCIAL
You are free to:
Share – copy and redistribute the material in any medium or format
Adapt – remix, transform, and build upon the material
The licensor cannot revoke these freedoms as long as you follow the license terms.
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Under the following terms:
Attribution – You must give appropriate credit, provide a link to the license (https://
creativecommons.org/licenses/by-nc/3.0/), and indicate if changes were made. You may
do so in any reasonable manner, but not in any way that suggests the licensor endorses
you or your use.
NonCommercial – You may not use the material for commercial purposes.
No additional restrictions – You may not apply legal terms or technological measures
that legally restrict others from doing anything the license permits.
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APPENDIX 5: NATIVELY
SUPPORTED HARDWARE
CONTROLLERS
The table below lists all natively supported hardware controllers as of January 2017,
but we’re adding support for newer hardware all the time. If you don’t see your unit
listed (or you’re in the market for one), make sure you’re using the latest version of
Mixcraft, then have a look at the supported control surfaces menu by going to the Main
Window menus and choosing File>Preferences>Control Surfaces. Click the down arrow
under the the Type column to see the list of currently supported hardware controllers.
manufacturer

model

Acoustica

Mixcraft Remote

Akai

APC Mini

Arturia

Beatstep

Behringer

CMD LC-1

Behringer

CMD Touch

Frontier Design Group

TranzPort

Keith McMillen Instruments

QuNeo

Livid Instruments

OhmRGB

Mackie

Logic Control/Logic Control XT

Mackie

Mackie Control/Mackie Control XT

Mackie

Mackie Control Universal Pro
Mackie Control Universal Pro XT

MIDI Fighter

3D

Novation

Launchkey 49 mk2

Novation

Launchkey Mini

Novation

Launchkey mk2

Novation

Launchpad/Launchpad mk2

Novation

Launchpad Pro

Numark

Orbit
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APPENDIX 6:
COPYRIGHTS AND
TRADEMARKS
Mixcraft™ and FlexAudio™ are registered trademarks of Acoustica™, Inc.
This software is provided by the copyright holders and contributors “as is” and any
express or implied warranties, including, but not limited to, the implied warranties of
merchantability and fitness for a particular purpose are disclaimed. In no event shall
the foundation or contributors be liable for any direct, indirect, incidental, special,
exemplary, or consequential damages (including, but not limited to, procurement
of substitute goods or services; loss of use, data, or profits; or business interruption)
however caused and on any theory of liability, whether in contract, strict liability,
or tort (including negligence or otherwise) arising in any way out of the use of this
software, even if advised of the possibility of such damage.
ROYALTY-FREE LOOPS POLICY

All included loops, sound effects, and samples are © their respective owners.
Providing that you legally own a Mixcraft license, you may redistribute new works of
art, podcasts or other sounds created using Mixcraft’s loops royalty-free for any and all
commercial and non-commercial uses, but you cannot redistribute the individual loops
by themselves in any format, medium or recording.
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
This product utilizes PrimoBurner™ Technology.
© 2003-2012 Primo Software Corporation http://www.primoburner.com
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
Copula time/pitch stretching technology by QuikQuak
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
aufTAKT, tONaRT, and z.reverb by zplane.development
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
Microsoft Windows Media Format © 2012 Microsoft Corporation. All rights reserved.
Many thanks to the LAME team for their work on the LAME encoder. See their website
at mp3dev.org/mp3/
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
MPEG patent technology licensed by Thomson @ www.mp3licensing.com
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––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
MP3 Encoder written by Patrick Dehne and Thomas Orgis
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
ReWire™ technology by Propellerhead
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
OGG Vorbis © 2012, Xiph.Org Foundation
• Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
• Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.
• Neither the name of the Xiph.org Foundation nor the names of its contributors may
be used to endorse or promote products derived from this software without specific
prior written permission.
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
Twitterizer Library © 2010, Patrick “Ricky” Smith. All rights reserved.
• Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
• Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
• Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.
• Neither the name Twitterizer nor the names of its contributors may be used to
endorse or promote products derived from this software without obtaining specific
prior written permission.
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
Newtonsoft.Json © 2007 James Newton-King
• Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
• The above copyright notice and this permission notice shall be included in all copies
or substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
Vimeo-Dot-Net Library
The MIT License (MIT)
© 2014 Stephen Commisso
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Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
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